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By Jeff Nott

Copyright © Jeff Nott 2013
This is a free ebook and you may distribute this free ebook freely.

In the spirit of Gimp, this book is free. If you had to pay for it you were cheated.

Distributors: You shall not charge a fee for this ebook nor charge a fee for
bundled offers in which this ebook is included.

Quick and Easy Tutorials that enable you to discover the magic of the Layers dialog
in GIMP.

The Layer lessons are designed to be read just like a normal book. They follow a
sequence which may be useful to you as a photographer.

Have Gimp and this book open together, on your desktop, and jump between the
two to practice the simple lessons and commit the skills to your memory.

Alternatively, you can print the entire book, 77 pages, or print just those pages
that you need.

Have fun and enjoy your voyage of discovery.

Download more Pdf ebooks and practice photos from:
http://www.gimp2tutorials.info/downloads.htm

Pdf ebook created with Serif PagePlus X4

http://www.gimp2tutorials.com/downloads.htm
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GIMP has many tools for quick and easy photo transformation. Even a
mundane photograph can be transformed to a beautiful and striking image.

It is designed to be upgraded with plugins and extensions to do just about
anything.

This advanced program allows you easily to perform everything from the
simplest task to the most complex image transformation techniques.

GIMP Layers Dialog

The Layers dialog panel is where you give GIMP the
instructions it needs to create incredible photos by
building an image, of your choice, layer by layer.

Imagine each layer as a clear sheet of glass. On each
sheet you place part of your final image. This means
you can make changes to each layer without altering
the layers above or below the layer you are working
on.

You'll soon become familiar with the Layers dialog as
you work through the tutorials.

Like most GIMP tools, the Layers dialog has options,
which means that you may set the tool up to perform
in a specific way.

You'll discover how to use the magic of these settings
as you progress through the tutorials.

Don't think of it as difficult – it's easy!

The GIMP Photo Editing: Layers

If you don’t have GIMP on your computer, or you have an earlier version of the program,
you need to download the latest version of the program, Gimp 2.8.4 or later. This is a
considerable upgrade from earlier editions.

The link is: http://www.gimp.org/downloads/
This is the Windows XP (SP3), 2000, Vista, and 7 update.

Mac users have their own program available here:
http://www.macupdate.com/app/mac/14597/gimp
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GIMP Layer Dialog

Layers Tab:  Use to click and drag the Layers Dialog around the work area (Interface).

Layers Mode:  A menu of options to change the appearance of a selected layer.

Opacity:   A slider to change the transparency of a selected layer, 0= totally
     transparent - 100= no transparency.

Lock Pixels:  Prevents painting on a layer when switched on. Click to toggle.

Lock Alpha
Channel: Click this option and the transparent areas of the layer will be kept.

Layers panel: All layers are displayed here. The active layer briefly turns blue when activated.

Eyes:    By clicking on a layer’s eye the layer image, on the canvas, will disappear along
     with the eye. Click where the eye should be and the layer image reappears.

Duplicate
Layer Icon:  Click on a layer to activate it and click the Duplicate Layer icon to create an
     identical layer. This action may be repeated to produce more identical layers.

Anchor
Layer Icon:  Click this icon to merge the active layer with the layer below it only.

Delete
Layer Icon:  Click on a layer to activate it and click the Delete icon to delete the layer.

Move Layer
Arrows   Click on a layer to activate it and click on an arrow to move the activated
     layer up or down the stack of layers.
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Layer Dialog - Right Click Menu

Load any photo into GIMP. Go to the Layers panel and right click; here’s the drop-down
menu, above, that you will see. I don’t want to bombard you with more information on
this menu. the details you need will be provided in each tutorial. All you need to know is
this menu really works for you with layers.

Mode Menu (AKA Blending Modes)

Load any photo into GIMP. Go to the Layers dialog and
click on the little down arrow to launch the ‘Mode’ menu.

You’ll see that the menu is divided into six sections. The
first section is ‘Normal’, this means nothing much happens
here. This is your normal photo. The Dissolve option: a
black layer under it  enables you to see the effect.

The second section: Lighten only: This section makes your
photo lighter. ‘Screen’ boost light; ‘Dodge’ makes brighter
and is funky; Addition is seriously bright. Screen is best.

Third section: Darken only. That’s right this section makes
your images darker. ‘Multiply’ darkens but often preserves
detail in the highlights. Burn darkens more but highlights
can burn out. Multiply is the favorite.

The fourth section: Overlay. No difference between
Overlay & Soft light. ‘Soft light’ adds a little soft brightness
plus a little contrast. ‘Hard light’ brighter and adds hard
contrast. Soft light is the most popular tool in this section.

As a photographer you may have little interest in the other
options. Well maybe if you are into weird stuff, otherwise
don’t worry about them. Try them for fun.
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Here's how to rescue a photograph that is dark (under-exposed). To lighten the image:

1. Load the 'Dark Sunset' photo into GIMP. Duplicate the background layer. (Click on the
tiny blue screen icon.) Click the top layer of the stack.

Rescue an Under-Exposed Photo With Layers

2. Set the Mode menu to 'Screen'.

3. Duplicate the duplicate layer, in ‘Screen’ mode, 5 times. Each layer gets brighter.
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3. Go to 'Colors' menu. Select 'Levels'. Drag the White slider to edge of histogram (black
line).

Move the Gray center slider to improve image. Examine the photo for 'Banding'. Move the
gray center slider back towards its original position until the banding disappears.
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4. Click on the 'Curves' bar in 'Levels Dialog'. Click on 'Channel' and select the dominant
color (red), in the photograph, from the Channel menu. Adjust preferred color curve to
improve image. Test other Channel colors for effect. Click OK. (If no red, blue, or green
dominant color select: Value.)

5. Right Click in 'Layers' panel. Select 'Merge Visible Layers'. (Bottom of menu.)

6. Go to 'Filters' menu. Hover over 'Enhance'. Select 'Wavelet-denoise'. (Bottom of menu.)
Click on the 'All' button. Channel select: Y. Color Model: Ycbcr(A.  Set: 'Channel
Thresholds: 1000; Detail: 1. Click 'OK'. You may adjust ‘Amount’ as required. Job done.
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Rescue an Over-Exposed Photo With Layers

Over-Exposed Image

Here's how to rescue a photograph that is too bright (over-exposed).

To rescue the image:

1.Load the ‘mom and baby' photo into GIMP. Duplicate the background layer. (Click on the
tiny blue screen on the bottom bar.) Click on the top layer of stack.

2. Set the Mode menu to 'Multiply'. Duplicate the image 3 times. (You’ll duplicate as many
times as necessary with your own photographs.)

You’ll notice that the child’s hand is becoming too red. Zoom in on the hand. Click the
‘Scissors’ tool and make a selection around the child’s forearm and hand. Click on ‘Feather
edges’. Set to 10 (Default). Don’t worry about each individual finger, make the selection
from finger tip to finger tip.

Go to the ‘Select’ menu and click ‘Invert’. The baby’s hand is now protected while you
work on the rest of the image. Zoom out to 100%.
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3. Go to 'Colors' menu. Select 'Levels'. Drag the Black slider to the somewhere around the
center of the dialog. If you go to the edge of the histogram the image will be corrupted.
Drag the White slider to edge of histogram (if not in that position). Move the gray center
slider to improve image. Examine the photo for 'Banding' (if any). If necessary, move the
gray center slider back towards its original position until the banding disappears.

4. Click on the 'Curves' bar in 'Levels Dialog'. Click on 'Channel'. There is no clear
dominant color in the photograph, Adjust by selecting each color curve in turn to improve
image. Click OK. Go to ‘Select’ menu, click ‘None’.
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5. Right Click in 'Layers' panel. Select 'Merge Visible Layers'. (Bottom of menu.) Click
‘Expand as necessary’. Click OK.

6. The baby’s arm may show color distortion where the selection was used. Make a
selection around the baby’s hand and arm, up to the sleeve, with the Lasso tool. Click on
the black ‘Dodge/Burn’ tool. Soft brush size of your choice. Click ‘Dodge’, ‘Smooth’, and
‘Mid tones’ buttons. Paint away any imperfections. Go to ‘Select’ menu. Click ‘None’.

7. Go to 'Filters' menu. Hover over 'Enhance'. Select 'Wavelet-denoise'. (Bottom of menu.)
Click on the 'All' button. Set: 'Threshold' to 2.00. Set 'Softness' to 0.00. Click 'OK'.

8. Soft focus often creates a more atmospheric image with babies and mothers with
babies. There are soft focus plugins, which you can download; you need to experiment
with them. In this instance we’ll go for ‘Gaussian’ blur. (Pronounced: gow-see-an.)

Go to Filters menu, hover over ‘Blur’, select ‘Gaussian Blur’. Set as shown. Go to the
Filters menu and repeat ‘Gaussian Blur’ at top of menu to see the effect. (Ctrl+Z will take
you back one step.)

10. Save image in format of your choice.

Job done.
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This is a way of blending family pictures or portraits, plus pets, flowers or whatever you
choose.

It was very popular with professional photographers back in the days of film and
darkrooms. It's simple and quick and gives very pleasing results with little practice.

1. Load GIMP. Go to Windows menu and click 'Single Window Mode'. Go to 'File' menu,
click 'Open' and select three of your own photos. (Do not not 'Open as layers'.) There are
three practice pictures in the Layers/Blend 3 photos folder if you require them.

2. In the Toolbox, set the foreground/background colors to black on top and white at the
bottom. We want a white background. If you want a black background reverse the colors.
You may also set the background color to whatever you choose.

3. Go to the 'File' menu, click 'New'. A box 'Create New Image' will open. Set the width to:
1200. The height to: '800'. A canvas with a white background will open.

Note: This canvas is approximately 16.5 inches X 11 inches. This gives you plenty of room
to work with the images. However, when you create something for yourself you may
desire something bigger. Click on the down arrow and set the measurements to what you
want.

Blend 3 Photos With Layers & Oval Feathering

This is the type of family vignette you’ll be creating by blending layers

4. Click on the first image, as shown below. Go to the layers dialog panel and you'll see
your new layer. Right click on the layer and select 'Add Alpha Channel'.

5. Select the 'Elipse Select Tool'. Click on 'Feather Edges'. Draw around the family as
shown. Click in the center of the selection to create the marching ants (Or hit the 'Enter'
key).
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Create a New Image
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6. Go to the 'Select' menu and click on 'Feather'. Set the feather to: 10.

7. Right click on the photo and hover over 'Edit' and select 'Copy Visible'.

8. Click on the white background to make it appear. Right click on the background, hover
over 'Edit' and 'Past As', select 'New Layer'. Your cutout from your photo will appear on
the white background.

9. Select the 'Move' tool, click and drag the family oval to the right.

10. Select the next photo and repeat steps 5, 6, 7, 8 and 9. Do not add an Alpha channel
for each photo as GIMP will do this automatically after the first image.

11. Now you have three images on one background. Use the 'Move' tool to move the
images to where you want them.

12. Your images may be different sizes. Go to the layers panel and click on one of the
layers with a transparent background. It will be outlined on the photo with a yellow dotted
line. To resize the image select the 'Scale' tool from the Toolbox. Click on the image and a
grid will appear over the active image. Click and drag from any corner to resize the image.
When you are happy with the size, click on the 'Scale' button in the box. Go the the layers
panel, click on any other image which requires resizing. Resize as explained.

13. To line up your images, select the 'Move' Tool. Click and drag on the top ruler. A
horizontal blue line will be dragged onto your background. Click on each image in turn and
drag the bottom of the image to the blue line. Space the images apart or overlap as you
require.

14. You may need to bring some images (or just one image) forward or back to create the
best layout for a pleasing result. Go to the layers panel. Click on the layer of the image
you need to come forward and on top of the others. Go to the up green arrow at the
bottom of the layers panel and click until that layer is at the top. The corresponding image
will be on top in your new photo layout. To move an image back (behind another image)
click on the layer and use the down green arrow to send the layer down the stack. The
corresponding image will move behind other images. Do not go below the white
background layer.

15. When you are pleased with your new picture, Go to the layers panel. Check all 'eyes'
are open. Right click in the layers panel. Select: 'Merge Visible Layers'. Click 'Expand as
Necessary' . Click 'Merge' again.

16. Click and drag the blue line up to the ruler. It will disappear. Crop to remove the
unwanted canvas.

17. Go to the 'Filters' menu. Hover over 'Decor' and select 'Add Border'. When the box
opens set both X and Y to: 10. Choose a border color. (Medium blue is good.) Click OK.

18. Again, go to the 'Filters' menu. Hover over 'Decor' and select 'Add Border'. When the
box opens set both X and Y to: 15. Choose a dark border color. (A deep yellow works with
blue.) Click OK.

17. Save and/or Export in the format of your choice.

Job done.
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Scale & Merge 3 Photo Layers & Correct Colors

Let's Get Started with Layers:

1. Place your three pictures inside a new folder: Bald Eagle, Diffords Tower, and
Mountains. Close the folder.

2. Start GIMP and go to 'File' menu. Select 'Open as Layers'. A box opens. Navigate to
your folder. Hold down the Ctrl key and select each photo in turn. Click on the 'Open'
button. Your three photos will open as illustrated.

Tip
When you have many layers you’ll find it useful to change the name of a layer
for quick identification. Double click on a layer and the ‘Edit Layer Attributes’
box will open. Enter the name you need and click OK. Alternatively, right click
on the layer and select ‘Edit Layer Attributes’ from the menu.
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3. Click on the 'Scale Tool', click on the 'Mountains' photo. A box will open and a grid will
appear over the mountains image. Drag the grid by the corners to fit exactly over the
'Bald Eagle' photo. Click the 'Scale' button as shown. The image will scale to fit.

4. In the 'Layers-Brushes' floating panel click on the 'bald eagle' layer to activate it. Click
the 'Green Arrow', pointing up, until the eagle is at the top of the pane. The eagle is now
the picture you are looking at. Click the 'Magic Wand' tool. Set the 'Threshold' to 33. Click
anywhere on the purple color. The eagle has been surrounded by marching ants. Zoom in
to the bottom wing, spaces between the feathers have not been selected. Click on the
'Magic Wand' tool again and add (hold down shift key) those isolated areas. With the add
key held down look for other little marching ants that need to be gathered in with + sign.

5. Go to the 'Select' menu and click 'Invert'. Hold down the shift key and press Q. An old
friend (Quick Mask) will flood across the picture. You'll notice that some red has flowed
onto the eagles head. Zoom into the head, check that white is the top color on the
Foreground/Background colors. Select the paintbrush and paint away the red. Zoom out
and close the 'Quick Mask' with the red square. Go to the 'Select' menu and click 'Invert'.

6. Check that Black is the bottom color on the Foreground/Background colors. Click on the
black and change the color to yellow. Click OK. Select the 'Eraser' tool and boldly paint all
over the picture, including the eagle, until the picture is yellow to every edge. Of course
the eagle won't be covered because it is protected by the selection (marching ants).
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7. Click on the 'Eagle' layer in the layer panel to activate it. Now right click and select 'Add
Alpha Channel'. The 'Eraser' tool should still be selected. Paint over the picture again.
Wow! All the background to the eagle disappears.

8. We need to clean up the eagle. Go to the 'Select' menu and click 'Shrink'. A box will
appear. Set the pixels to 2. Click OK. Back to the 'Eraser' tool and paint over the eagle
again. The shrinking will expose the flaws and the Eraser will clean up the colors we don't
want on the the eagle. That's the eagle taken care of . . . . for now.
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9. Go to the Layers floating panel. All three layers each have an 'eye' symbol. Click on any
one of the layers to activate it. Click the eye on and off in that layer. The layer will appear
or vanish to exspose what is underneath it. However, much depends on the position of the
layer in the pane. Move a layer to the top and it will appear. Move it to the bottom of the
pane and it will disappear no matter if you turn the 'eye' on or off. I know it's a bit weird
but it's useful as you'll see in a later lesson. Try it with each layer in turn.

10. Click on the 'Tower' layer and move it to the top with the green arrow. Click on the
eagle layer and move it to the bottom of the pane. (We are going to do a repeat of what
we did with the eagle.)

11. Click on the Tower layer to activate it. You should see the tower over the background,
both layers visible. (Click the 'eye' if one of them has vanished.) The Tower is now the
picture you are looking at. Drag the Tower to the bottom right of your background. Click
the 'Magic Wand' tool. Set the 'Threshold' to 33. Click anywhere on the blue sky. The
tower has been surrounded by marching ants. Zoom in to the Tower, areas of the sky may
not be completely selected. Click on the 'Magic Wand' tool again and add (hold down shift
key) those areas. With the add key held down look for other little marching ants that need
to be gathered in with + sign.

12. Check that yellow is the bottom color on the Foreground/Background colors. Select
the 'Eraser' tool and boldly paint all over the picture, including the Tower, until the picture
is yellow to every edge. Of course the Tower and grass won't be covered because it is
protected by the selection (marching ants).

13. Click on the 'Tower' layer in the layer panel to activate it. Now right click and select
'Add Alpha Channel'. The 'Eraser' tool should still be selected. Paint over the yellow color
again. All the blue sky disappears. Click on the tower again to keep it selected (blue).
Right click and select 'Alpha to Selection' (that's our selection protected. Go to the Select
menu. Click the shrink tool. Shrink your selection by 5 pixels. Click OK. Go to the 'Select'
menu and click 'Invert'. Click the 'Eraser' tool and paint over the outline of the tower
layer. If the tower is cut, Ctrl+Z followed by Ctrl+I. Paint over the tower outline again.
That's fine for the tower. Now we want to move the tower and grass behind the black
ridge on the background (Mountains layer).
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14. Move the Mountains layer to the top. Click on the 'Magic Wand' tool and select the
black area at lower right of the mountains. Use the add function to collect any stray pixels.
You only need enough room for the Tower layer, don't worry about the extreme left of the
mountains. (You could, of course, paint this selection black if you wish,)

15. Go to the 'Select' menu and click 'Grow'. A box will appear. Set to 2 pixels click OK.
We now have a clean edge to our black selection. Click on the 'Tower' layer and activate it.
Move it to the top of the pane. If you can't see the Tower click on the layer eye. Select the
'Eraser' tool and carefully go over the black selection area. Now your tower is behind the
ridge.

16. Click on the eagle layer and move it to the top. Let's say you think the eagle is too big
and it's in the wrong place. Click the eagle layer to activate it. Right click on the eagle
layer in the pane. Select 'Scale Layer'. Set the 'Width' to 2000. Click OK. The image will
resize keeping it's proportions. Select the 'Move' tool and drag the eagle to the top left
'Rule of Thirds' position (approx) as shown. When you are happy with that, go to the
'Select' Menu and click 'None.

17. Our problem now is the tower which looks out of place in such a bright color. Click on
the 'Tower' layer. Move it to the top of the pane. Activate the 'Tower' layer. Go to the
'Colors' menu and slect 'Curves'. The box will open. The 'Channel' option should be set to
'Value' (default). Click and drag the black button (center of the curve) to the position
shown. Our tower now looks more like its surroundings.

18. Click on the 'Channel' options menu, you'll see: Red, Green, Blue, and Alpha. Ignore
'Alpha' but click on red to activate the red channel only. Drag the red line around to see
how the color of the tower changes. Repeat with green and blue, just for fun. When you
are satisfied with your tower click OK.
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19. The eagle is too dark, let's change that. Click on the 'Eagle' layer. Move it to the top of
the pane. Activate the 'Eagle' layer. Go to the Colors' menu and slect 'Curves'. The box will
open. The 'Channel' option should be set to 'Value' (default). Click and drag the black
button (center of the curve) to the position shown. Our eagle now looks more dramatic but
not so light that it looks unrealistic.
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20. Click on the top layer. The layers should be in the following sequence: Eagle, Tower,
Mountains. This means the layers will correspond with the scene. Move them into
sequence with the green arrows. Get them out of sequence and you could be unhappy
with your photograph. You may need to examine your photo for flaws, clean up with your
clone or heal tool.

21. The final photo is very sharp, you may prefer a softer version because in real life the
light would be fading and objects would naturally be less sharp. This is subjective of
course, it's your opinion that matters. Save your original as an .xcf file (File menu, click
'Save').

You can add soft focus by going to a plugin at the Script-Fu menu. You may not have this
plugin. You'll find it at: http://registry.gimp.org/node/5322

Note: I got the bulk of this tutorial from this video website:
http://www.cgdudes.com/gimp-2-8-layering-and-color-correction/
I made some changes to the method in the video to keep it in line with what you know.
Please take a look at the video because the guy does other stuff which you'll find
interesting. He also supplied the images we used with free distribution for anyone to
enjoy. An all round good guy with GIMP.
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We'll be using skills you now have plus new skills in this tutorial.

1. Do not open GIMP yet. We are first going to a reputable website to download and install
a set of 'Cloud' brushes. These brushes allow you to paint clouds on a sky or produce mist
in a atmospheric landscape or waterscape. Colors add atmophere: black, grey, or white.
Go to this website: http://thegimp.ca/gimp-cloud-brushes-by-gimp-bc/

Download the zip file. Open it and highlight all the brushes (Ctrl=A). Copy the brushes
(Ctrl+C). Brushes go in a 'Brushes' folder. Install the brushes just as you did with plugins
and scripts, but brushes go in their own folder 'Brushes'. (You guessed that. Right?) The
folder you need is at the top after you open the folder.

2. Now you can open GIMP. Look in the Brushes floating panel and you should see little
cloud brushes at the top of the panel. You click or paint these brushes onto your image by
using the 'Paintbrush' tool and setting the size you require: go big with the size, 400 to
500 is normal, it all depends on the size of your base image. If you don't see the brushes
go to the 'Filters' menu and click 'Reset all Filters'. If your brushes are not in the brushes
panel you have installed them in the wrong folder. Try again. When you paint clouds onto
your picture use a selection of cloud brushes, each one a different shape, to create the
effect you want. Don't click on the same spot too many times, with the same brush, or
you'll have a white blob - totally unconvincing. Ctrl+Z will take you back as normal.

3. We'll bring images into GIMP. Go to the File menu and click 'Open as Layers'. Navigate
to your GIMP tutorials folder and load: Bald Eagle and the Mountains photos. Scale the
mountains to cover the eagle. Move 'Mountains' layer to the top of the layers panel.

4. Click on the 'Scissors' tool. Create a selection around the mountains as shown. Join up
your selection and hit the 'Enter' key. But creating your selection outside the frame, to of
image, you'll now see march ants following the shape of the mountains and tight to the
top edges of the sky.

Layers, Brushes & Other Magic Stuff
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5. Go to the 'Colors' menu and click on 'Curves'. The box opens. Find 'Channel' open the
menu and select a color. Use the curve to change the color of the sky: you may choose to
have a darker red, or turn it blue, or use a mixture of color channels to create something
abstract.
When you are happy with your sky, hold down the Ctrl key and press I. (invert selection).

6. Your selection is now the landscape. We want to blue mountains, not too blue, but
something you would see in the distance. (Often seen in the hour after dawn or the hour
before sunset.) You may need two or three blue curves in the 'Curves' dialog: one to
darken the mountains and the second and third to add the blue tint. Experiment and you'll
find something you like.

7. When you are happy with your landscape, go the the 'Select' menu and click 'None'.

8. This is when you add your clouds. Select a cloud brush, Select the 'Paintbrush' tool. Set
the size of your cloud. Experiment with different clouds and try over-lying clouds to create
a realistic picture. Include a little mist or cloud between the mountains. Play with the
clouds until you are happy. Save the result as an .xcf file: File/Save: call it 'cloud-
landscape.xcf'. You have finished with the mountains layer for the moment.

9. Move the eagle layer to the top on the panel. In the 'Layers-Brushes' floating panel click
on the 'bald eagle' layer to activate it. The eagle is now the picture you are looking at.
Click the 'Magic Wand' tool. Set the 'Threshold' to 40. Click anywhere on the purple color.
The eagle has been surrounded by marching ants. Zoom in to 200% to the bottom wing,
spaces between the feathers have not been selected. Click on the 'Magic Wand' tool again,
set the 'Threshold' to 40, (hold down shift key) add those isolated areas. With the add key
held down look for other little marching ants that need to be gathered in with + sign.

10. Ctrl+I to invert the selection. Zoom back to 100%. Hold down the shift key and press
Q. An old friend (Quick Mask) will flood across the picture. You'll notice that some red has
flowed onto the eagles head. Zoom into the head, check that white is the top color on the
Foreground/Background colors. Select the paintbrush and paint away the red. Zoom out
and close the 'Quick Mask' with the red square.

11. Check that Black is the bottom color on the Foreground/Background colors. Click on
the black and change the color to yellow. Click OK. Select the 'Eraser' tool and boldly paint
all over the picture, including the eagle, until the picture is yellow to every edge. Of course
the eagle won't be covered because it is protected by the selection (marching ants).

12. Click on the 'Eagle' layer in the layer panel to activate it. Now right click and select
'Add Alpha Channel'. The 'Eraser' tool should still be selected. Paint over the picture again.
The background to the eagle disappears.

13. We need to clean up the eagle. Go to the 'Select' menu and click 'Shrink'. A box will
appear. Set the pixels to 2. Click OK. Back to the 'Eraser' tool and paint over the eagle
again. The shrinking will expose the flaws and the Eraser will clean up the colors we don't
want on the the eagle. Finished? Go to Select menu and select 'None' If the selection has
changed (you lost part of the eagle) Press Ctrl+Z followed by Ctrl+I.

14 Click on the eagle layer at the top of the Layers panel. Right click on the layer, select
'Scale Layer'. Set Scale to width 2300. Click 'Scale'. The eagle should still be selected. Go
to 'Layer' menu. Click on Transform. Select 'Arbitrary Rotation'. Rotate the eagle to any
position you choose. (-40 is good if you are wondering). Click 'Rotate'. Move the eagle
layer to the bottom the stack.
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15. Click on 'Mountains' layer. Move to the top of the stack. Right click and click 'Scale
Layer'. Set layer to width 800. Click 'Scale'. Zoom in.
Right click in the layers panel and select 'New Layer'. Set to: Layer Name - 'Canvas';
Width - 1200; Height - 1000; Click foreground color (should be set to white on the
Foreground/Background tool). Click OK.

16. Adjust zoom. Move mountains layer to the top of the stack, Click the 'Move' tool. Drag
the mountains to the center of the 'Canvas' layer. Turn off the 'eye' in the eagle layer. On
the Mountains layer and the Canvas layer there is a chain next to the 'Eyes'. Click on the
'Chain' in each layer. The Mountains and the Canvas are now locked together. Move tool.
Drag both to the center of the screen. Click both chains, this will unlock the layers.

17. Eagle layer to the top of stack. Drag the eagle (Move tool) to your preferred position.
Move the eagle layer to the bottom of the stack.

18. Move the Mountain layer to the top of the stack. Click on the 'Rectangle Select tool'
(Top left in the tool box). Drag the tool to cover the mountains scene. Click in the center
of the selection (or hit 'Enter' key).
Go to the Select menu, click 'Border'. Set the Border to 20 pixels. Click 'Lock border to
images edges'. Click OK.

19. Move the 'Canvas' layer to the top of the stack. Close the 'eyes' of the other two
layers. Click on the border. Select the 'Fill' tool. Click on the Foreground color and change
it to a color you chose for the border. Click the 'Bucket' inside the 'Border'. The border will
fill with a color of your choice. Open all 'eyes'.

Sort your stack layers to: Eagle, Mountains, Canvas. Right click in the panel. Select:
'Merge Visible Layers'. Click Merge. Crop as required. Go to File menu. Click 'Save As'
eagle-frame.xcf. Export as .jpg file.
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In this tutorial we'll discover how to create 'Out of Bounds' images,

Here we go:
1. Load 'little girl.jpg' photo into GIMP. Zoom in to her eyes.

2. Select the 'Elipse Select Tool' from the top of the toolbox. Draw a small elipse around
one of her eyes (Not the white of the eye).

3. Go to the 'Colors' menu. Select 'Colorize'. Set to: Hue: 250; Saturation: 50; Lightness:
15. Click OK.

4. Go to the 'Filters' menu. Hover over 'Ehance'. Select 'Unsharp Mask'. Set to: Radius:
5.0; Amount: 0.50; Threshold: 0. Click OK. Go to the 'Select' menu. Click 'None'. (If a
Selection Tool outline does not disappear when you click 'None' it will do so when you click
a new tool.)

Out of Bounds with Layers
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5. Repeat Colorize and Sharpening with the othe eye as above. (Paras 2, 3 and 4.)

6. Go to 'Layer' menu and select 'New Layer'. Name the Layer 'Transparency'. Click the
Transparency button. Click OK. Zoom back to 100%.

7. Select 'Rectangle Select Tool' from toolbox. Drag over the girl as shown.

8. Select 'Bucket' tool from toolbox. Set the F/B colors as White on top, black below. Fill
the 'Rectangle Selection Tool' with color white.

9. Go to the 'Select' menu and click 'Shrink. Set to 30 pixels. Click OK.

10. Go to the 'Edit' menu and click 'Cut' (Ctrl+X). You can see the little girl in your white
frame.

11. Go to the 'Select' menu and click 'Border'. Set the border to 10 pixels.

12. Select 'Bucket' tool from toolbox. The F/B colors are White on top, black below.
Change the White to a strong 'Pink'. Fill the inside 'Border' with color: Pink.
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13. Click the rectangle selection tool. Draw a new selection around the outside edge of the
white frame.

14. Select the 'Perspective' tool from the Toolbox. Drag the bottom left corner of the
frame as shown. Check that the vertical lines are vertical. Click 'Transform'.

15. Look at the Layers panel. At the top of the stack you can see a 'Floating Selection
Layer'. Go to the bottom of the pane and find the 'Anchor'. (It's on the same bar as the
green arrows). Click on the Anchor to 'Anchor the Floating Layer'. The 'Perspective Tool'
creates the floating layer which you have now anchored to the 'little girl' photo.

16. Look for the 'Opacity Slider' above the Layers pane. Set the 'Opacity' to 65 or 70
(approx).

17. Change the pink back to white. Select the 'Eraser' tool, color 'White'. Hard Brush. Set
the size to: 40. Carefully paint away the frame around the little girl as shown. Reset the
'Opacity' to 100.
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18. Go to the 'Layer' menu and click 'Merge Down'.

19. Select the 'Scissors' tool. Create a selection around the frame and the little girl as
shown. Complete the selection and hit the 'Enter' key.
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20. Right click, click 'Select' and click 'Invert'.

21. Right click, Select 'Edit' and click 'Cut'.

22. Now you have a transparent background to be filled with color. Click on the 'Bucket'
tool, you need pale pink foreground color. Click the bucket in the transparent area. It will
fill with pale pink. Go to the 'Select' menu. Click 'None'. Reset the foreground color to
white.

23. Select the 'Lasso' tool ('Free Select Tool' at the top of the toolbox). Click around the
little girl's arm only. Start just inside the frame and continue around the girl's arm until
you are back inside the frame again. Click on the spot where you started. Your selection
be automatically created.

24. Go to the 'Filters' menu. Hover over 'Light and Shadow'. Click on 'Drop Shadow'. Set
both Offsets and Blur radius to: 20. Set 'Opacity' to: 70. Set color to: Black. Click OK.
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25. Right click in the layers pane. Select 'Merge Visible Layers'.

26. Look at lower white frame. There is a shadow. Think about it and create your own
shadow.

27. Clean up the little girl's hair with your paint brush. Use the 'Eye Dropper' tool to set
the pink color. (Select 'Eye Dropper' from the toolbox and click on the pink area in the
photo. The foreground color will change to the exact shade of pink you need.) Select a
soft brush to paint around the hair for a softer more natural appearance. Set your own
brush size. Clean the rest of your image with your 'Clone' tool and/or 'Heal' tool, if
required.

28. Crop as required.

29. Save and/or Export in the file of your choice.

Job done.

Now that you understand the technique for creating ‘Out of Bounds’ images, indulge
yourself and create something dramatic with sports, trains, ships, aircraft, or any dynamic
subject that takes your fancy.
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Layers Panel: Right Click Menu Options
There are many options in the ‘Right click menu’ which is available from the Layers panel.
Lots of these options are self evident but others require some explanation:

Layers option: 'Merge Down'.

The Merge Down command merges the active layer with the layer just below it in the
stack.

The 'Merge down' command will combine the two layers into one. The modifications in the
top layer will be apparent but without changing the other aspects of the image: size,
objects, scene, etc.

Layers option: 'Merge Visible Layers'.

The 'Merge Visible Layers' command merges the layers which are visible into a single
layer. 'Visible layers' are the layers that are marked with an “eye” icon in the Layers
dialog.

You may have a mix of layers which may have different images and/or effects. There is no
limit to the number of layers in the stack.

Obviously, this is the command you'll most often use. When you click 'Merge Visible
Layers' a box opens offering you a number of options:

'Expanded as necessary': The final layer is large enough to contain all of the merged
layers. Please note that a layer in GIMP can be larger than the image. (You'll remember
that from the eagle and tower tutorial.)

'Clipped to image': The final layer is the same size as the image. Remember that layers
in GIMP can be larger than the image itself. Any layers in the image that are larger than
the image are cropped by this option. (Think carefully before you select this option.)

'Clipped to bottom layer': The final compressed layer will be the same size as the
bottom layer. If the bottom layer is smaller than some of the visible layers, the other
layers are clipped and trimmed to the size and position of the bottom layer.

(You'll recall that we stacked our layers in sequence in the first eagle and tower tutorial.
The background was the lowest layer and the biggest.)

(Tip. The 'Expand as neccessary' button will keep you out of trouble.)

Layers option: 'Flatten Image'.

The 'Flatten Image' command merges all of the layers of the image into a single layer with
no alpha channel. The difference is that all of the image contents are in a single layer
without transparency.

It is normally only necessary when you would like to save an image in a format which
does not support levels or transparency (an alpha channel). This means that if you start
with a base image, create a duplicate, change the mode, and then create multiple
duplicates of the same image, the 'Flatten Image' command is for you.
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1. Load the work photo 'dark-tree', from the Fill-Flash folder, into GIMP.

2. Make a duplicate copy.

3. Click on the top layer in the layer panel.

4. Change mode to 'Screen'.

5. Go to 'Colors' menu. Select ‘Brightness-Contrast’. Set to: Brightness: (minus figures)
-20; Contrast: -5. Click OK.

6. Right click on Layers panel. Select: Merge down.

7. Go to 'Colors' menu. Select ‘Curves’; make a further adjustment with 'Curves' as you
see below.

8. Go to 'Filters' menu. Select 'Unsharp Mask'. Set to: Radius - 2.00; Amount - 0.50,
Threshold - 0. Click OK.

9. Save the photo in the format of your choice.

Note: Monitors vary in color reproduction, you may need to change my settings for
'Brightness and Contrast' (Or any other 'Colors' menu setting I give you.) to get the best
possible picture on your screen.

Fill-Flash Effect: Using Layers for Best Results
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Lighten Shadows with Layers
Here’s a quick and easy way to lighten shadows that spoil an otherwise good image. This
technique is known as a Contrast Mask. There are many tutorials online which tell you
more about the Contrast Mask but, to my knowledge, this is the best GIMP 2 method.

1. Load the image into GIMP.

2. Go to the Layers panel; duplicate the first layer.

3. Go to the Colors menu and select ‘Desaturate’. A box will appear, click on ‘Luminosity’,
click OK. Your colors are replaced by a black and white image.

4. Go to the Colors menu again and select ‘Invert’. Now your photo looks like a negative.

5. Go back to the Layers panel. Click on the Mode menu and select ‘Overlay. Your colors
have returned and the shadows are lighter. Lighten further with Colors/Levels.

6. Go to the Filters menu, hover over blur, and select ‘Gaussian blur’. A box will appear. In
the preview box you’ll see the negative image. Accept the default settings and click OK.
Your image will sharpen but maybe not enough, if your image needs further sharpening go
to the top of the Filters menu and click ‘Repeat Gaussian blur’. If this is too sharp hit the
Ctrl+Z keys to go back one step.

7. Right click in the Layers panel and click ‘Flatten Image’ (at the bottom of the menu).

8. If step 6 did not work for you, zoom in to 100% and check your photo’s sharpness. If it
requires sharpening, go to the Filters menu, hover over ‘Enhance’ and select ‘Unsharp
Mask’. Accept the default settings and click OK. If your image needs further sharpening go
to the top of the Filters menu and click ‘Repeat Unsharp Mask’. If this is too sharp hit the
Ctrl+Z keys to go back one step.

9. Save and/or Export to your file format.

Job done.

Before and After
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Blend 2 Photos With Layers & Paint Away Image

This blend technique looks wonderful when done well, great for family photos, weddings,
etc. It's truly easy but practice will astonish you. For this tutorial you have two photos of
the same height. When you use two of your own photos, if they are not of the same
height, ensure that one is re-sized to match the height of the other.

2. Start GIMP. Go to Windows menu and click 'Single Window Mode'.

3. Go to 'File' and select 'Open'. Navigate to your photos and click 'Open'. (Do not select
'Open as Layers')

4. Go to the image tabs and select your first photo.

5. You need a bigger canvas to accommdate both photos. Go to the 'Image' menu. Click
on 'Canvas Size'. When the box opens check that the chain next to the width and height
settings is broken. Set the width to 1200. Change no other settings. Click 'Resize' button.
Click 'Resize' button again in the next box.

6. Your photo should be on the left of the extended canvas. As below.

7. Go to the image tabs and select your second photo. The photo will appear, right click on
the photo, hover over 'Edit' and click 'Copy Visible'.

8. Go to the image tabs and select the new photo with extra canvas. Right click on the
photo, hover over 'Edit', hover over 'Paste As', and select 'New Layer'.

9. Select the 'Move' tool from your Toolbox. Click and Drag your second photo to the right
and release as shown below. You may also use the four way keys on your keyboard to
align the images perfectly, but only when the 'Move' tool has been selected.

(Tip: You are now working on layers. Ensure that the photo you are working on is
activated in the layer panel.)
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10. Select the 'Eraser' tool from the Toolbox. Setup the eraser as shown below. Be sure to
use a soft brush to avoid hard edges when blending the photos.
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11. Activate the second photo layer in the Layers pane. Go back to your image. Start at
the top, where the photos overlap, and carefully paint away the edge of the second picture
to expose the image below. Avoid cutting away heads. If you paint in small amounts you
can recover mistakes with Ctrl+Z.

12. When you are happy with the result, change to the 'Move' tool in the tool box. This is
to avoid accidents with the 'Eraser' tool. Check that your images are perfectly aligned at
top and bottom.

13. Go to the 'Layers' pane. Check that both layer 'eyes' are open. Right click and select:
'Merge Visible Layers'.

14. Crop to remove the unwanted canvas.

15. Go to the 'Filters' menu. Hover over 'Decor' and select 'Add Border'. When the box
opens set both X and Y to: 10. Choose a light border color. (Gold is good.) Click OK.

16. Again, go to the 'Filters' menu. Hover over 'Decor' and select 'Add Border'. When the
box opens set both X and Y to: 15. Choose a dark border color. (I went for chocolate.)
Click OK.

17. Save and/or Export in the format of your choice.

Job done.

Note: This plugin is supplied with GIMP plus others. Read about them here:
http://gimp.open-source-solution.org/manual/filters-decor.html Just follow the arrows.
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Q. What is an Alpha Channel in layers and why do we use it?

A. The GIMP separates color images into three (red, green, blue) single-color channels
that blend to create the full range of colors and shades in your photo or image. Plus, GIMP
uses an extra channel, the 'Alpha channel'. This channel has no effect on the three color
channels.

The 'Alpha channel' supplies transparency within an image. Areas of the Alpha channel are
represented by black, or checkerboard, to show where transparency appears in the image.
Your use of the Alpha channel allows you to employ: transparency, partial transparency,
or fading effects.

Load any image into GIMP (without the Alpha channel) and make a selection with the
'Rectangle' selection tool. Click delete and you'll see a white space where your selection
was. Ctrl+Z and get your complete image back. Now add an Alpha channel. (Right click in
the 'Layer' pane and select: 'Add Alpha Channel'.) Repeat the cut out with your selection
tool. You'll see a checkerboard effect; that's your transparent Alpha channel.

If your image is just one background layer, an alpha channel has to be added manually.
An Alpha channel is created automatically when you create an additional new layer in an
image.

When you save an image, and wish to keep the transparent 'Alpha channel' visible, use
the .png file format. Almost all other formats will delete the transparency and the
transparent areas will adopt the background color (probably white).

In the image below the Alpha Channel effect is greatly exaggerated.

What is an Alpha Channel?
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Use Layers to Strengthen Colors
In this tutorial you’ll discover how to strengthen colors in your images by using Layers.
You’ll be using the color yellow with one new layer and blue with the second to achieve the
result we want. You may use any color you desire, buts it’s a good idea to have a reason
for selecting a particular color

For example in the image below the colors are not as I remember them. The purpose is to
give me the colors I want, the house should be more of a honey to cream color. This
building was made with Cotswold stone, which varies from pale yellow to cream when the
sun is on it. It’s the stone of choice for builders in the Cotswold area of England. The sky I
remember was clear and very blue, I want it that way in the picture. Here’s our first image
that’s not quite right.

1. Go to the ‘Layers Strengthen Colors’ folder and open dial-house.jpg and load it into
GIMP.

2. Duplicate the first layer.

3. Right click in the Layers Panel and select ‘New layer’. Name the new layer ‘Yellow’ and
under ‘Layer Fill Type’ click on ‘White’. Click OK. A white canvas will appear over your
image.

4. Go to the Toolbox and click on the foreground color. Select a yellow color, HTML
notation f6ee15. Click OK. The yellow color will appear as the FG color.
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5. Click on the ‘Bucket Fill Tool’ and left click on your white canvas. The white will turn
yellow.

6. Go to the Layers Dialog and click on the ‘Mode’ menu. From the menu select ‘Overlay’.
Your image will appear but the yellow color may look too strong, don’t be concerned we’ll
talk about that later.

7. Click on the yellow layer. Right click in the Layers panel and select ‘Merge down’. The
yellow layer will merge with the layer immediately below it.

8. Click on the merged layer and duplicate it.

9. Right click in the Layers Panel and select ‘New layer’. Name the new layer ‘Blue’ and
under ‘Layer Fill Type’ click on ‘White’. Click OK. A white canvas will appear over your
image.

10. Go to the Toolbox and click on the foreground color. Select a blue color, HTML notation
0e2ad5. Click OK. The blue color will appear as the FG color.

11. Click on the ‘Bucket Fill Tool’ and left click on your white canvas. The white will turn
blue.

12. Go to the Layers Dialog and click on the ‘Mode’ menu. From the menu select ‘Overlay’.
Your image will appear but the yellow color has been toned down by the blue.

13. Click on the blue layer at the top. Right click in the Layers panel and select ‘Merge
Down’. The blue layer merges with the layer immediately below.

14. Click on the center layer, right click and select ‘Delete Layer’.

15. You now have two layers, click on the ‘eye’ of the top layer. What you can see is the
original photograph. Click where the eye should be on the top layer. You can now see the
improved layer. Click on and off to compare the images.

16. Right click in the Layers panel and select ‘Merge Down’.
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17. Optional: You may desire that you sky be more blue, if so, go to the Toolbox and click
on the ‘Select by Color tool’. Set the ‘Threshold’ to 40. Hold down the shift key and click
on the blue sky until you have marching ants surrounding the sky.

18. Go to the ‘Colors’ menu and select ‘Curves’. When the Curves dialog (box) opens,
change the ‘Channel’ to Blue. Push the line up to improve your blue sky. Click OK.

19. Go to the “Filters’ menu, hover ‘Enhance’, click on ‘Wavelet Denoise’. When the box
opens click ‘All’; set ‘Amount’ to: 950; Detail: 1.00. Click OK. If you don’t have this plugin
go to: http://registry.gimp.org/node/4235. Scroll down the page to find the windows
version: wavelet-denoise-0.2-win.zip.

19. Sharpen your image if required. Save and/or Export to your preferred file type.

20. As you have seen, by layering colors you often degrade the color you chose. This
means that you need to select a darker shade of your preferred color to get close to the
color you desire.

21. You may have to experiment with a photo until the color selection you need becomes
apparent. It’s all about practice and experience. Have fun!

Job done.

Your improved image

http://registry.gimp.org/node/4235
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In this tutorial we aim to do the very opposite of the previous tutorial. In the former
lesson we strengthened colors, in this session we'll dilute the colors. The image we are
using is of Ville-France a little town on the south coast of France. It's old, quaint, the
haunt of local artists, and a port-of-call for yachts of all shapes and sizes. At the end of
WW2, some admiral choose Ville-France as the base for the American Mediterranian fleet.
The only indication of that is a big iron bouy where a battleship tied up. Here's the photo
you'll work with, you can see why the admiral chose this spot.

Use Layers to Dilute Colors

1. Load the ville-france.jpg photo into GIMP and duplicate the image.

2. Click on the top layer until it turns blue. Go to the 'Colors' menu and select
'Desaturate'. A Destaturate box opens, click on 'Luminosity', click OK. The image changes
to grayscale.

3. Right click in the Layers panel and click on 'New Layer'. Select 'White' from the list.

4. Go to the Foreground/Background tool in the Toolbox and change the FG to blue, HTML
notation 3c61d9. Click OK. Use the Bucket Fill Tool from the Toolbox to fill the new layer.

5. Go to the Layers dialog, click on the 'Mode' menu and select 'Overlay'. Your image is
now blue.
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6. Right click on the blue layer and select 'Merge Down'. The blue layer merges with the layer below it.

7. Click on the original layer (at the bottom of the stack) and Duplicate again. Move the new duplicate
to the top of the stack (click and drag or use the green arrow).

8. Right click in the Layers panel and click on 'New Layer'. Select 'White' from the list.

9. Go to the Foreground/Background tool in the Toolbox and change the FG to orange, HTML notation
d79812. Click OK. Use the Bucket Fill Tool from the Toolbox to fill the new layer.

10. Go to the Layers dialog, click on the 'Mode' menu and select 'Overlay'. Your image is now orange.

11. Right click on the orange layer and select 'Merge Down'. The orange layer merges with the layer
below it.

12. You now have three layers: orange, blue, and original.

13. Click on the top layer, right click and select 'Add Layer Mask'. Click 'Grayscale copy of
layer' (if not pre-selected as default). Check that the box 'Invert Mask' has not been
ticked. Click 'Add'.

14. Click on the second layer, right click and select 'Add Layer Mask'. Click 'Grayscale copy
of layer' (if not pre-selected as default). Check that the box 'Invert Mask' has been
ticked. Click 'Add'.

15. You have the option of clicking on each of the top two layers and adjusting the opacity
to increase the level of the colors coming through from the image below. Try adjusting the
opacity of the orange and blue layers to see the effect. Opacity is critical to your final
image.

16. When you have practiced this, right click and select 'Merge Visible Layers' from the
bottom of the menu.

17. With this method you have total control over the process. This means you can choose
by how much you wish to degrade the colors.

The question is why would you bother degrading colors? It may be that you have a
colorful background that competes with the main subject for attention. You can do
something about that. You may have an image in which the colors are too strong, instead
of reshooting you may tone it down. Try it with any over-intensified HDR image.
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Add Layer Mask Options When There are Multiple layers
White (full opacity)

The layer mask will make all of the layer fully opaque. You will see a white rectangle on
the layer beside the photo icon. You can paint over your photo with the Bucket tool (or a
hard Paint brush for areas) to change the layer with any color except white. The color you
chose will change the shades of color on that layer but the image remains the same. Each
color has a different effect on your photo layer, with some colors the change is slight with
others the change is more discernable. The color Black makes the layer totally transparent
to expose the layer under the active layer (no color changes occur). The white rectangle
will change from gray to black as you paint away the layer mask.

Black (full transparency)

The layer mask will make the entire layer transparent. You can see the layer below the
active layer. You will see a black rectangle on the layer beside the photo icon. You can
paint over your photo make any part of the active layer visible. You may paint with any
color except 'Black'. Each color has a different effect on your photo layer, with some colors
the change is slight with others the change is more discernable.

Grayscale copy of layer

This option converts the layer itself into a layer mask. It is particularly useful when you
plan to add new contents to the layer afterwards. The colors become a little darker but do
not become black and white as may be expected.

Invert Mask

If you click on the Invert Mask box at the bottom of the dialog, the resulting mask is
inverted, so that transparent areas become opaque and vice versa.

Here’s the image with diluted colors.  It’s not as good as the original but it does show you
what the subject looks like after you have reduced the colors in the photograph.



45
Click Here for Index

A Layer mask is not difficult to understand or use. I want to get that idea understood
before we start. Why? Because so many tutorials make it seem difficult when it is not.

What is a Layer Mask?

This little explanation will make the layer mask concept easy to understand. In years gone
by, masked balls where very popular among the wealthy. A mask was worn to hide the
identity of the wearer or to achieve an attractive effect.

That's what a GIMP layer mask does; It hides (makes invisible) parts of the image, plus it
helps you to create an attractive effect. This means that the image is there but some of it
is invisible.

Now you understand what a layer mask does.

1. Start up GIMP and 'Open as Layers' both the 'red-planet.jpg' picture and the 'little-
girl.jpg' photo.

2. Click on the 'red-planet' layer and send to the top of the stack by using the green arrow
(at the bottom of the Layers pane). Right click in the Layers pane, select 'Add Layer Mask'.
A box will appear, select 'White Full Opacity'. Click the 'Add' button.

How to Use a Layer Mask



46
Click Here for Index

4. Move the 'little-girl' image to the top of the Layers pane. Right click in the Layers pane,
select 'Add Layer Mask'. A box will appear, select 'White Full Opacity'. Click the 'Add'
button.

5. Click on the 'Layer Mask' beside the mini image of the little girl to ensure it is activated.
We'll be working on the 'layer Mask' and not on the image of the little girl (although it will
look that way).

6. Select the 'Scissors' tool to make a selection around the little girl, as shown. Click inside
the selection to see the marching ants.

7. You want your cutout of the little girl to be smooth and feathered to make it more
attractive and to enable it to blend with the starry sky. This is easy to do: Go to the
'Select' menu and click on 'Feather'. A box appears, set the pixels to: 5. Click OK. Go to
the 'Select' menu again and click 'Invert'.

8. Click on the 'Layer Mask' only, of the 'Little-girl' layer, in the Layers pane. The layer
must turn blue.

9. Select the 'Bucket Fill Tool' from the Toolbox. Ensure that the foreground color is black.

The color 'Black' paints away the Layer Mask to expose the next image below in the layers
pane.

10. Stay outside of the marching ants around the little girl and left click the bucket tool on
the picture. Everything except your selection should disappear.
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11. To be sure of a clean image select the 'Paint Brush' from the Toolbox. Use a large hard
brush. Check the foreground color is still black. Paint all over the picture to clean up stray
fragments. The little girl will be protected by the marching ants. You can see the red
planet photo beneath the cutout of the girl, it will not be affected by the paint brush.

12. Click on the 'Move' tool in the Toolbox. The little girl is much too big. We are working
with a layer not a photo. We need to go to the Layer pane, right click and select 'Scale
Layer'. A box will open. Change the Pixels to Percent (%) by clicking where shown.
Change the Width and Height to 25.00 as shown. Click the 'Scale' button.
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13. Right click, hover over 'Select' and click 'None'. Go to the Layers pane. Click on the
mini 'Little girl' image to activate the layer. The 'litle-girl' mini image must be surrounded
by a white border. The Layer Mask is still there but it is not activated. (Do not delete the
Layer Mask, it is part of your complete image.)

14. Check that you have selected the 'Move' tool. Drag the image of the little girl to the
top of the planet. Her right elbow should just touch the edge of the red planet. She should
look as if she is resting on the planet.

15. When you are happy with the result, go to the Layers pane, right click and select
'Merge Down'.

16. Save and/or Export in the format of your choice.

Job done.
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Simple Composite Photograph Tutorial #1.

A composite photograph is simply an image made by combining two or more separate
photographs. There are various ways to create a composite image, we’ll start with one
simple technique and expand on the basic method.

I would guess that you are now saying “We did that before with the little girl and the red
planet”. That is true but this tutorial is different, we are aiming to build our knowledge,
layer by layer, (sorry about the pun) to create something much more ambitious. Plus
you’ll understand what you are doing and why.

Below is the image you’ll be creating. Take a look at how the guys overlap one another.
Many composite photos avoid overlapping images because it can create problems and the
whole scene appears unrealistic. You’ll discover how to avoid that kind of trouble. You can
check this for yourself by examining other composite images online; the figures may be
close together but often they do not overlap.

Composite Photograph with Overlapping Layers #1

You’ll find the two images you need in the following folders:
Layers/Simple Composite 1/ nailer-1-625.jpg and nailer-2-625.jpg
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Let’s get started. To follow along set GIMP to ‘Single-Window Mode’ (Windows menu,
select ‘Single-Window Mode’). Load the two work photos ‘Nailer-1.jpg’ and ‘Nailer-2.jpg’
into GIMP. (Do not load as layers.)

1. Click on the image tab of ‘Nailer-2.jpg’ and the image appears on your canvas.

2. Select the ‘Color Picker’ from the Toolbox. Click on the white area surrounding the man
with the hammer. (I like to choose the color from the image; in this tutorial what looks
white may be off-white when compared to a true white background.)

3. Go to the FG/BG colors in the toolbox, click on the bent arrow to change your selected
color to the background.

4. Go to the ‘File’ menu; select ‘New’, the ‘Create New Image’ box will appear. Set the
‘Width’ to: 1200. The height will be: 675, accept this setting. Click OK. The background
color is selected as default.

5. A new image tab will appear, this is your background for your composite photo.

6. Click on the ‘Nailer-2’ image tab and your image will appear on the canvas.

7. Select the ‘Fuzzy Select Tool’ (Magic Wand) from the Toolbox. In the Tool Options click
on ‘Replace the current selection’; click to activate ‘Antiailiasing’ to smooth any jagged
edges; clear the other boxes; set the ‘Threshold’ to: 25; select by: ‘Composite’.

8. Using the Magic Wand tool click on the background area (white) surrounding the figure.
You’ll see that the white area between the guy’s hand and shoulder has not been selected.
Hold down the shift key and click on this stray area. Now you have the entire background
surrounded by marching ants.

9. You are now going to copy the figure but it’s the background that has been selected. On
your keyboard hit Ctrl+I to invert the selection.

10. Now hit Ctrl+C to copy the guy without the background.

11. Click on the background image tab. The background you made is now on your canvas.
Hit Ctrl+V to paste your image onto the new background.

12. Look at your layers panel; you’ll see a layer for your background plus a greyish layer
named ‘Floating Selection (Pasted Layer)’. This is not yet a true layer. You have to do a
simple conversion job. Click on this layer.

13. Right click in the Layers panel and select ‘To New Layer’. The purpose of this
command is to convert pasted images, made with a selection, into a layer with a
transparent background. Look at your new layer and you’ll see a tiny image on a
transparent background. The name of the layer changes to ‘Pasted Layer’.

14. Go to the Toolbox and click on the ‘Move’ tool. You can now click and drag the guy’s
image around the canvas.

15. Click on the ‘Nailer-1’ image tab and your image will appear on the canvas.

16. Repeat what you did in paragraphs 7 to 14 inclusive to place the new image layer on
the background. There is an area between the guy’s hand and his hammer that may not
be selected. Check that you have added that area to your Magic Wand selection.

17. Move this new layer to the right edge of the background.
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18. Obviously, this new image is too big. Go to the Toolbox and select the ‘Scale’ tool.
Click on the new guy, a grid will appear along with the Scale dialog box. In the box, click
on the chain, next to the Width and height settings, to close the links and maintain the
aspect ratio. Click and drag on the corners to shrink the image to fit within the canvas.

19. Go to the layers panel; the latest layer has been named ‘Pasted Layer #1’. Click on
this layer. Duplicate the layer (right click and select ‘Duplicate layer’ or click the duplicate
icon at the bottom of the layers panel).

20. Go to the Toolbox and select the ‘Move’ tool. Click and drag the duplicate image to the
left of the canvas.

21. Go to the layers panel. Click on the layer named ‘Pasted Layer #2’. Go to the Toolbox
and select the ‘Flip Tool’. Click on the image and it will flip horizontally. The guy should
now be hammering a nail facing left on the background.

22. In this next task the ‘Background’ layer must always remain at the bottom of the stack
of layers. Change the position of the other three layers in the stack. The active image will
have a yellow dotted line around it. You’ll see that the top layer shows up as the front
image in the composite photograph. Now move the layers around to juggle the position of
the guys in the photo. Click on a layer and use the Move tool to locate one guy exactly
where you want him.

23. Repeat until you are happy with your composite image, complete with overlaps.

24. Right click in the layers panel and select ‘Flatten Image’. This will merge all the images
into the background and remove the transparent areas. Crop as required.

25. Save and/or Export to a format of your choice.

Job done.
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This tutorial follows the basic method in the first composite tutorial. This time we have a
dark background with three young women. We’ll advance our composite knowledge by
showing the problems three elements create in this type of composite. Here are the
elements to watch out for: jagged edges are easily seen when light colored images are
pasted onto a dark background; any flaws on a woman’s skin shows up clearly; the
outside edge of the hair often appears too sharp (or jagged) to be flattering.

Below is the image you’ll be creating. Take a look at how the girls overlap one another.
You’ll recreate this image with improvements. Note the jagged edges to fingers and hair.
You’ll discover how to eliminate this problem. Zoom in to 150% and you’ll see the
problems clearly. You'll see the flaws mentioned if you zoom in.

Composite Photograph with Overlapping Layers #2

Let’s get started. To follow along set GIMP to ‘Single-Window Mode’ (Windows menu,
select ‘Single-Window Mode’). Load the two work photos ‘woman-1.jpg’, ‘woman-2.jpg’
and ‘woman-3’.jpg into GIMP. (Do not load as layers.)

1. Click on the image tab of ‘woman-1.jpg’ and the image appears on your canvas. (You
can check the name on the blue bar at the top of GIMP.)

2. Select the ‘Color Picker’ from the Toolbox. Click on the dark area surrounding the
woman with the lipstick.

3. Go to the FG/BG colors in the toolbox, click on the bent arrow to change your selected
color to the background.

You’ll find the three images you need in the following folders:
Layers/Simple Composite 2/ woman-1-625.jpg, woman-2-625.jpg,
woman-3-625.jpg and a copy of the finished image for comparison:
3_girls_comp.jpg
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4. Go to the ‘File’ menu; select ‘New’, the ‘Create New Image’ box will appear. Set the
‘Width’ to: 2000. The height will be: 800, accept this setting. Click OK. The background
color is selected as default.

5. A new image tab will appear, this is your background for your composite photo.

6. Click on the ‘Woman-1’ image tab and your image will appear on the canvas.

7. Select the ‘Fuzzy Select Tool’ (Magic Wand) in the Toolbox. In the Tool Options click on
‘Replace the current selection’; click to activate ‘Antiailiasing’ to smooth any jagged edges;
click ‘Feather Edges’; Set the ‘Radius’ to: 10; clear the other boxes; set the ‘Threshold’ to:
25; select by: ‘Composite’.

8. Using the Magic Wand tool click on the background area (Dark) surrounding the figure.
You’ll see that the dark area between the woman’s hand and hair has not been selected.
Hold down the shift key and click on this stray area. Now you have the entire background
surrounded by marching ants.

9. NEW. On your keyboard hit Ctrl+I to invert your selection. (Now you are working with
the young woman and not the dark background.) Go to the Select menu and click on
‘Shrink’. The ‘Shrink Selection’ box will open; set for 2 pixels and click OK.

10. Hit Ctrl+I to invert your selection again. (You are back working with the background.)
Go to the ‘Filters’ menu and hover over ‘Blur’; click on “Gaussian Blur’, accept the default
settings and click OK.

11. Hit Ctrl+I to invert your selection yet again. (You are back working on the young
woman.) Go to the Select menu and click on ‘Grow’. The ‘Grow Selection’ box will open;
set for 2 pixels and click OK.

12. Explanation of new information: You have just created a 2 pixel blurred fringe around
the hair and figure of the young woman. This technique generates a stronger feather
effect than simply clicking the ‘Feather’ button. This is not always necessary but now you
know how to do it.

13. Now hit Ctrl+C to copy the young woman without the background.

14. Click on the background image tab. The background you made is now on your canvas.
Hit Ctrl+V to paste your image onto the new background.

15. Look at your layers pane; you’ll see a layer for your background plus a greyish layer
named ‘Floating Selection (Pasted Layer)’. This is not yet a true layer. You have to do a
simple conversion job.

16. Right click in the Layers pane and select ‘To New Layer’. The purpose of this command
is to convert pasted images, made with a selection, into a layer with a transparent
background. Look at your new layer and you’ll see a tiny image on a transparent
background. The name of the layer changes to ‘Pasted Layer’.

17. Go to the Toolbox and click on the ‘Move’ tool. You can now click and drag the young
woman’s image around the canvas.

18. Go to the layers pane. Click on the layer named ‘Pasted Layer’. Go to the Toolbox and
select the ‘Flip Tool’. Click on the image and it will flip horizontally. The woman should now
be facing left on the background. Drag the figure to the right of the background and lined
up with the bottom edge. (You can use the four way arrows on your keyboard for precise
alignment.)
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19. Click on the ‘Woman-2’ image tab and your image will appear on the canvas.

20. Repeat what you did in paragraphs 7 to 18 inclusive to place the new image layer on
the background. There is an area between the woman’s hand and her hair that may not be
selected. Check that you have added that area to your Magic Wand selection.

21. Move this new layer to the center of the background.

22. Obviously, this new image is too small. Go to the Toolbox and select the ‘Scale’ tool.
Click on the new woman, a grid will appear along with the Scale dialog box. In the box,
click on the chain, next to the Width and height settings, to close the links and maintain
the aspect ratio. Click and drag on the corners to enlarge the image to fit within the
canvas. Click the 'Scale' button to fix your enlargement.

23. Go to the layers pane; the latest layer has been named ‘Pasted Layer #1’. Click on this
layer. Go to the Toolbox and select the ‘Move’ tool. Click and drag the image to the right
until the new woman’s wrist covers the sharp line separating the first figure from the
background. Do not hide too much of the lipstick.

24. Click on the ‘Woman-3’ image tab and your image will appear on the canvas.

25. Repeat what you did in paragraphs 7 to 18 inclusive to place the new image layer on
the background.

26. Go to the layers pane; the latest layer has been named ‘Pasted Layer #2’. Click on this
layer. Go to the Toolbox and select the ‘Move’ tool. Click and drag the image to the left
until her shoulder is at the edge of the background. This will make her match up with the
girl on the right.

27. Go to the layers pane, click on ‘Pasted Layer #1 and move it to the top of the stack.
The center woman’s hair should now be resting on the arm of the figure behind her. It
looks ugly.

28. Go to the Toolbox and select the ‘Eraser’ tool. Opacity: 100; Very soft brush, size: 150
(approx).

29. Go to the layers pane, click on ‘Pasted Layer #1. (The center figure must be
surrounded by a dotted yellow line.) Click on the edge of the unsightly hair and brush
gently and carefully to give it a natural smooth edge. (The figure behind is protected
because it is on a different layer.)

30. In this next task the ‘Background’ layer must always remain at the bottom of the stack
of layers. Change the position of the other three layers in the stack. The active image will
have a yellow dotted line around it. You’ll see that the top layer shows up as the front
image in the composite photograph. Now move the layers around to juggle the position of
the women in the photo. Click on a layer and use the Move tool to locate one woman
exactly where you want her.

31. Repeat until you are happy with your composite image, complete with overlaps.

32. Right click in the layers pane and select ‘Flatten Image’. This will merge all the images
into the background and remove the transparent areas. Crop as required.

33. Your image is probably a little soft; scaling can soften an image. Go to the ‘Filters’
menu, hover over ‘Enhance’ and select ‘Unsharp Mask’. The default of 5 may be too
strong, set it to 3 in ‘Radius’.
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34. Set up the Smudge tool. Opacity 30; Soft brush and size it for the task. Large areas =
large brush, small areas = small brush. Zoom in to 150% (approx).

35. Paint over the large areas of their faces and bodies with a big brush, smooth strokes.

Reduce the size of your brush for the nose and around the eyes. Do not paint away all
their features; natural is better than plastic looking skin. Do not smudge their eyebrows,
Ctrl+Z for recovery.

36. Zoom back to 100% to check your work. Zoom back further if you have a small
screen.

37. When you are happy, ‘Save’ and/or ‘Export’ to a format of your choice.

Note: If you compare your finished image with the original, in the folder, you’ll see that
you have a strong feather around the fingers (no jaggies) and a better more attractive
composite. Naturally you can tone down the feather by selecting just one pixel rather than
two and/or reducing the amount of Gaussian blur.
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You can create an advanced sharpening brush using the Clone tool.

1. Load girl-pink1a.jpg' into Gimp.

2. Go to the 'Layers' panel, duplicate the first layer.

3. Double Click on the top layer and name it 'Duplicate. Click OK.

4. Click on the duplicate layer. Go to the 'Filters' menu, hover over 'Enhance, select
 'Unsharp Mask'. Accept the default settings and click OK.

5. Click on the 'Clone tool' in the Toolbox (Shortcut: C).

6. In the 'Tool Options' set Source to 'Image source' plus 'Alignment'’ mode to 'Registered'.

7. Set the brush Opacity to 20; Hard brush; Brush size: 20.

8. The duplicate layer should still be the active layer. Ctrl-click on girl's eye to make it the
 sharpened source image.

9. Go back to the Layers pane and close the 'eye' of the top layer. Click on the bottom
 layer to activate it.

10. With the 'Clone tool' still selected, paint over the girl's eyes and lips only on the photo.
 You will sharpen the eyes and lips. (In effect you are mixing the sharpened duplicate
 layer with the original unsharpened layer.) If the sharpening effect is not strong enough
 increase the brush opacity, all the way to 100% if necessary.

11. When you are happy with the bottom layer move it to the top of the stack.

12.  Open both layer 'eyes'. Right click, select 'Merge Visible Layers'.

That's your alternative sharpening method for anyl area.

Sharpen Areas of Your Photo with Layers
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HDR and Gimp

First the bad news: there is no way to produce HDR images in the basic GIMP program.

Now the good news: there are plugins and standalone programs that will enable you to
produce quality HDR images.

First we'll take a look at what can be done with a GIMP plugin to fake an HDR image and
make it good enough to pass for the real thing.

First you need to download the plugin: dodge-burn.scm from
http://registry.gimp.org/node/5574

Install it in the GIMP 2 / Scripts folder.

Here's your work image (you need a well exposed image to convert to HDR) Italy-
square.jpg

How to Fake HDR with Layers

http://registry.gimp.org/node/5574
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Here's how to get it done: Load the image into GIMP.

1. In the Layers pane, Duplicate image.

2. Go to the Colors menu, click 'Desaturate'. Select: Average, Click OK;

3. Go to the Colors menu, click Invert (changes to negative).

4. Go to the Filters menu, hover over 'Artistic', select 'Soft Glow'. Accept default settings.
Click OK.

5. Go to the layers panel. Click Layer Mode: select 'Soft Light', set 'Opacity' to: 50.

6. Go to the layers panel. Duplicate the 50 Opacity layer: Set opacity to: 75%.

7. Go to the layers pane. Duplicate the Background layer. Move the new Background layer
to top of layers pane.

8. Go to Colors Menu, select 'Levels': Set Left slider to 100 to darken image. Click OK.
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9. Check that you have 4 layers, duplicate of bottom layer should now be at the top of the
stack.

10. Go to the layers pane. Click Layers mode: select 'Darken only', turn opacity down to:
45.

11. Go to the layers pane. Right Click: Merge Visible Layers. Click 'Expand as Necessary'.
Click Merge.

12. Go to the Script-Fu menu: hover over Enhance, select Dodge-Burn: Set Thin to 10.
Click OK.

13. Go to the layers pane. Click Background layer. Go to Colors menu, select Hue and
Saturation: set Saturation to around 50% (approx), your choice of how vivid you want
your photo.

14. Go to the layers pane. Right Click: Merge Visible Layers.

If you are not happy try this: Go to the Colors menu. Hover over Auto, select 'White
Balance'.

15. Go to Filters menu, hover over 'Enhance', select: Unsharp Mask. Accept default
settings. Click OK.

16. Save and/or Export in your preferred format.
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Note: Every photograph is different, the sharper the original image the better the result.
The same rule goes for exposure, if you have a good wide histogram you can probably get
a good HDR image.

Also note that there are plugins available for working with three images: under exposed,
well exposed, and over exposed. Below are the links. You'll have to experiment to discover
which plugin you prefer.

Best simple HDR technique I have seen:
http://www.halley.cc/photo/multexp/gimp.multexp.5.html

An interesting site with GIMP tutorials for HDR type results.
http://photoluminary.com/2011/03/gimp-hdr-tutorial/

HDR Plugins, that use 3 photos, which may be useful:

http://registry.gimp.org/node/25056

http://registry.gimp.org/node/6708

http://registry.gimp.org/node/24500

http://registry.gimp.org/node/5980 Not HDR but Advanced Tone Mapping, very useful
when preparing a photo you intend to convert to HDR.

http://www.halley.cc/photo/multexp/gimp.multexp.5.html 
http://photoluminary.com/2011/03/gimp-hdr-tutorial/
http://registry.gimp.org/node/25056
http://registry.gimp.org/node/6708
http://registry.gimp.org/node/24500
http://registry.gimp.org/node/5980
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Cut Out Flying Hair & Paste to New Background
Flyaway hair can look very attractive but cutting it out from a photo often seems
frustrating. With GIMP it's very easy.

To help you learn this technique there are two photos available in the Layers/Cut out Hair/
folder: Hair-in-Wind.jpg and background.jpg. The Hair-in-Wind.jpg has been supplied by
Petr Kratochvil http://www.publicdomainpictures.net/view
image.php?image=4435&picture=hair-in-wind

The background.jpg has been blurred with GIMP's Gaussian Blur plugin to provide a
blurred background for the sharp focus of the girl and give you an almost 3D image.

1. Start up GIMP. Go to the File menu and select 'Open as Layers'. Navigate to the 'Cut
Out Hair' folder supplied, hold down the Ctrl key, and click on the two images. Click the
open button and your images will appear in the Layers panel. You need the Hair-in-wind
layer on top with the background layer below it. The girl will appear in your work area.

2. Go to the Layers panel, right click on the top layer and select 'Add Alpha Channel' from
the drop down menu.

3. Click on the blue icon at the bottom of the Layers panel to 'Duplicate' the top layer.

4. Click on the top layer to activate it. Go to the Colors menu, select 'Desaturate'.  A box
will open, select ‘Lumonosity, click OK. Your photo will become Black and White.

5. Go to the Colors menu again and click 'Brightness-Contrast'. Move the 'Brightness'
slider up to 50 approx. Move the 'Contrast' slider to 65 approx. Click OK.

6. Go to the Colors menu yet again , select 'Invert'. The black and white colors are
reversed and the photo looks like a negative. The girl is difficult to see. Go to the Opacity
slider and move it until it reads: 60 (approx). You should now be able to see the girl's
clothing more clearly.
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7. In this next step anything black will become transparent and disappear from the photo.
Everything that is white will appear in the final photo. Go to the Toolbox and click on the
Paintbrush tool. Check that the foreground colour is 'White'. Set your preferred brush size.
Now paint over the area you wish to keep: the girl's body and face. Often you don't need
to paint the hair because it is already white. In this photo however there are dark areas in
the hair that you'll need to paint white.

8. When you have finished this task set the Opacity back to 100. Don't miss this step, it is
important.
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9. Click on the top layer to be sure it is activated. Go to the Edit menu and select 'Copy' to
copy the active layer. (Ctrl+C the regular keyboard shortcut works fine.)

10. You have finished with this layer. Click on the bin (bottom right of the Layers panel) to
delete the active layer.

11. Go to Layer menu. Click on 'Mask' and a sub-menu will appear. Select 'Add Layer
Mask'. A box will appear (named: Add a Mask to the Layer.) The default setting is 'White
(full Opacity)'. This is the option you need. Click OK.

Opacity Slider Reset to 100



64
Click Here for Index

12. Go to the Edit menu and click 'Paste'. (Ctrl+V.) Your blended images will appear in the
work area. The Paste action places the Black & White layer you copied into the Layer
panel. The new layer is gray and named 'Floating Selection (Pasted Layer)'. This layer has
to be anchored to the 'Layer Mask'. Simply click the Anchor icon at the bottom of the
Layers panel.

13. Go to what is now the top layer. Right click on the top Layer, a menu will appear, click
'Merge Visible Layers', which is at the bottom of the menu. A box will appear, select
'Expand as Necessary'. Click OK.

14. If you are pleased with the result, Save and/or Export to a folder of your chice.

Note:

In your future photos you may have an area, behind your subject, which is cluttered
with objects that appear in white when you get to the negative (Invert) stage. To make
this clutter of unwanted subjects disappear all you need to do is paint over the clutter
with the color black. Be sure to follow all other instructions in this tutorial to create a
successful cutout.

To practice this skill go to the Layers/Cut out Hair folders and ‘Open as Layers’:
Girl_at_Bologna.jpg and background.jpg. Here you’ll have plenty of clutter to paint out.
This exercise will give you the practice you need to cut out any subject from a
background.

Girl_at_Bologna.jpg by: By Andrea Pavanello, Milano (Own work) [CC-BY-SA-3.0-it
(http://creativecommons.org/licenses/by-sa/3.0/it/deed.en)], via Wikimedia Commons.
http://upload.wikimedia.org/wikipedia/commons/6/69/%22_12_-_ITALY_-_FIAT_-
_Girls_at_Bologna_Motorshow_2012_06.jpg

http://upload.wikimedia.org/wikipedia/commons/6/69/%22_12_-_ITALY_-_FIAT_-_Girls_at_Bologna_Motorshow_2012_06.jpg
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How to Make Eyes More Glamorous
A woman’s eyes can make or break a glamour photograph. Consequently there are
many tutorials online that tell you how to change the color of a model’s eyes but not so
much on how to increase the natural loveliness of her eyes.

In this tutorial you’ll discover how easy it is to enhance the eyes with GIMP. However,
you have a choice: you may heighten the natural look or go for a more striking
appearance without making the model look weird. (You can do weird if you want.)

Go to the Layers/Glamorous Eyes folder and load ‘Girl_at_Bologna_2a.jpg’ into GIMP.

1. Click on the blue icon at the bottom of the Layers panel to 'Duplicate' the top layer.

2. Go to the Toolbox and select the ‘Zoom’ tool (Magnifying glass). Click on the girl’s
left eye and zoom in, click by click, to 550%.

3. Go to the Toolbox and select the ‘Ellipse Selection’ tool. Set up the Ellipse tool as
shown below.

4. Create an ellipse over the eyeball. If you include eyelashes that won’t matter but do
not capture too much skin. Click in the center of the ellipse to see the marching ants.
Only the area inside the marching ants will be affected by the changes you make. The
rest of the photo is protected.
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5. Go to the Toolbox and select the ‘Dodge/Burn’ tool. Set up the Dodge/Burn tool as
shown below.

6. Place the Dodge brush outline over the left edge of the marching ants until it touches
the iris of the eye. Click around the iris to lighten the color. Don’t try to turn the eye
white because it will look as if it is popping out of her face. What we call the ‘white of
the eye’ is not white, it ranges from pale gray to pale blue. You get red eyes, bloodshot
eyes and black eyes, but white . . . . . Never.

7. When you have a lighter color around the iris zoom out (hold down the Ctrl key and
click) to 100%. Check your work and see how it looks. When you are happy with the
right side zoom back in and add few few click with the Dodge tool at the right edge of
the marching ants. If you make a mistake, hit the Ctrl+Z keys to delete the last few
Dodge tool clicks.

8. Go to the ‘Select’ menu and click ‘None’. Your marching ants vanish. Zoom out and
see how that eye looks now.

9. Go to the toolbox and select the Zoom tool. Click on the right eye and zoon in to
550%. Repeat what you did in paragraphs 6 to 8 above to the right eye. The Dodge
tool will still be set up as you left it.

10. Now you should have natural looking whites in both of her eyes. This is better but
her hazel eyes are a little dull, we’ll add some ‘wow’ to her lackluster eyes.
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11. Go to the Toolbox and select the ‘Ellipse Selection’ tool. Set up the Ellipse tool as
shown before.

12. Go to the Toolbox and select the ‘Zoom’ tool (Magnifying glass). Click on the girl’s
left eye and zoom in, click by click, to 550%.

13. Create an ellipse over the iris of the eye only (see below). If you include eyelashes
that won’t matter but do not capture too much skin. Click in the center of the ellipse to
see the marching ants. Only the area inside the marching ants will be affected by the
changes you make. The rest of the photo is protected.

14. Go to the ‘Colors’ menu and select ‘Curves’. The ‘Adjust Color Curves’ box will open,
the default setting in the Channels menu is ‘Value’. We don’t need the Value channel.
Hit the little down arrow to open the menu and select ‘Green’. Click in the center of the
green diagonal line and push it up around half one of the squares (see below). You’ll
see the eye turn green.

15. Go to the channels menu again and select ‘Blue’. A blue diagonal line will appear.
Click in the center of the blue diagonal line and pull it down one full square (see below).
You’ll see the yellow and brown flecks in the eye appear. Zoom out to 100%. Go to the
Select menu and click ‘None’.

16. Repeat paragraphs 11 to 15 with the right eye. The Ellipse tool will still be set up as
you left it.
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17. Now I want you to check the before and after photographs. Zoom out until you can
see the whole picture on your screen, you may have to go down to 50% on a laptop.

18. Go to the Layers panel and click on the eye in the top layer. You now see the
bottom layer, your original photo, on your GIMP work area. The eyes are dull. Go to the
layer panel again and click on the spot where the layer eye is to be found. Your new
image reappears and the impact of the models eyes are obvious. Click on and off and
look at the image you have created. What impact!

Job done.

Note:

As you will have guessed I got carried away with the white and green in her eyes; I
liked it. I should have been less enthusiastic with the Dodge tool; and less green would
have made the eyes more natural hazel.

If you had wanted the eyes to be brighter you could have used the ‘Value’ channel in
the Curves dialog. Click on the black diagonal line and push it up towards the top left
corner and you can have brighter eyes.

Of course, to change the color of the eyes you could use the ‘Colorize’ tool in the Colors
menu, or perhaps play around with color combinations in the Curves and channels
dialog. Have fun!
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How to Make a Magic Blend/Composite Photo
I’m sure you have seen photographs, as below, where the same person appears in the
photo multiple times. In some photo editors the process can be a little complicated. In
GIMP the technique is so easy you’ll be creating magic blends in no time at all.

You can use any type of digital camera from a simple fully automatic point and shoot to
the latest DSLR. As with most techniques there are tips to ensure a successful outcome.

1. Mount your camera on a tripod to prevent any movement. The slightest movement
of the camera can spoil the picture. If you don’t have a tripod mount your camera on a
flat, solid surface: a wall, a table, a mantle, window sill, or whatever. If necessary pack
something around your camera to prevent it moving. You can buy very small tripods
with bendy legs at a very low price.

2. Find a background that does not include a bright sky. Cameras set on auto will often
expose for the sky and your subject will be under-exposed.

3. For an outdoor shoot, you need a day when the light is unchanging. Many tutorials
recommend an overcast sky. The above image was made from photos taken on a sunlit
but cold day. You don’t want clouds moving across the sun and varying the light
conditions.

4. You may take photos of yourself by using the self-timer on your camera. Set the
camera for around 10 seconds to give yourself time to get into position. Using a self-
timer will also give the camera time to stop vibrating if you have a heavy finger on the
button.
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5. Rehearse with your model where and how you want them to pose for each separate
photo. For this tutorial I have used four photos but there is no limit to the number of
times your model (or you) can be photographed to appear in the final image.

6. Ensure that the images do not overlap. This means there must be space between the
model’s last position and the next. (See the photo above.)

7. If you are taking your photos indoors under artificial lighting (your regular electric
lights) check that your camera’s white balance has been set for artificial light. If you
are not sure about this look in your camera handbook for ‘White balance’. If you don’t
set the white balance you photos will have a color cast, anything from yellow to orange.

8. All you need to do now is take a series of photographs similar to those shown below.
You pose your model any way you want. Old guys do not make the best subjects.

Upload your photos into your computer, be sure you now where they are located and
start GIMP. Do not crop your photos yet because that leads to all kinds of problems.

1. Go to the File menu and select ‘Open as layers’. Navigate to your photos and hold
down the Ctrl key on your keyboard as you click on each one. Click the Open button to
load your pictures as layers. You’ll see icons of your images on the layers in the Layers
panel. Your work photos are in the folder: Layers/Magic Blend.

2. The order of the layers in the stack should be magic-4 at the top, 3, 2, and magic-1
at the bottom.
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3. Click on the top layer, now right click and select ‘Add Layer Mask’ from the menu. A
box named ‘Add Mask to the Layer’ will open. Select the button ‘Black (Full
Transparency)’. Click the ‘Add’ button. A black box will appear on the layer next to the
icon of your photo.

4. Repeat ‘Add Layer Mask’ with every layer except the last layer.

5. Click on the top layer and you’ll see a white border surrounding the black box (Layer
Mask). The mask is active and you’ll be working on the mask, not the photograph. If
that sounds weird just take my word for it. All will become clear when you have
practiced this technique a few times.

6. Look at the icon next to the active Layer Mask. You can see where the figure will be
that you are about to expose. (See below)

7. Look at the big picture in your work area and note the position of the model in the
icon.

8. Go to the Toolbox and select the ‘Eraser’ tool. Select a soft brush. Set the brush size
to: 120. The brush size may need to change for your own photos. Check that the
Foreground/Background colors are black over white. (See above.)

9. Now paint over the area where you believe your model to be. Get it right and the
subject will be revealed; if it has a shadow paint that in too. If you paint over a figure
that is already there it may disappear. Hit Ctrl+Z and the figure will reappear.

10. Click on the next layer down. Check that the Layer Mask is activated. Note the
location of your model and paint the figure to make it appear.

11. Repeat paragraph 10 with the third Layer Mask.

12. All four figures should now be visible. Go to the Toolbox and select the ‘Crop’ tool.
Draw the Crop tool around the figures and adjust it to your satisfaction. Hit the ‘Enter’
key to complete the crop. If everything looks right you could say ‘Job done’ but not yet.
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13. Click on the top layer (you can do this with any layer) and go to the ‘Opacity Slider’
at the top of the Layers panel. Set the Opacity to: 65 (approx). You’ll see that the
figure for that layer has become transparent and ghost like. The Layer Mask makes this
possible with individual layers. Now you know how to put a ghost in your photos.

14. Return the Opacity Slider to 100%.

15. Click on the Layer Mask, in the top layer, to ensure it is activated. Go to the
Toolbox and select the ‘Paintbrush’ tool. Check that Black is the top color on the FG/BG
colors. Now paint away the figure on the extreme left. Change the FG/BG colors and
have White on top. You can restore the figure you painted out by painting with white.

That’s all you need to know - Job Done
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1. Go the the 'File' menu and click on 'Open as Layers. When the "open image' box
appears navigate to the 'Layers' folder and hold down the Ctrl key as you select the three
images: beer-can.jpg, jungle.jpg and tiger-roaring.jpg. Click on the 'Open' button. The
three images will load and appear in the Layers panel and on your work area (interface).

2. In the Layers panel, click and drag the layers until they are in the following order:
tiger-roaring at the top, beer-can, jungle.

3. In the Layers panel, click on the eye next to beer-can and jungle. These images will
disappear from your interface and you will see the small image of the tiger's mouth on a
transparent background.

4. Go to the 'Zoom' tool in the Toolbox and zoom in on the image of the tiger's mouth,
zoom to 150%.

5. Go to the Toolbox again and select the 'Lasso' tool (Free Select Tool). Click on the
'Antialiasing' box and the 'Feather Edges' box (Radius 10). Draw around the tiger's mouth
as shown below to create a selection.

Here’s How To Build a Beer Tiger
This is a fun tutorial which will extend your skill with layers and reinforce your knowledge of
layers by repeating skills you have practiced previously.

Enjoy this tutorial, it will give you ideas for wonderful and wacky images.
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6. Hit the keys 'Shift+Q' to flood the image with the red 'Quick Mask'. Your selected area
will not be red but the edges of the selection are too sharp for our purposes.

7. Go to the Toolbox and select the 'Paintbrush' tool. Check that the
Foreground/Background colors are set to White over Black. White paints the red away.
Black paints the red over the image.

8. Select a very soft brush, size 40, click on the 'Apply Jitter' and 'Smooth Stroke' boxes.
Accept the default settings for Jitter and Smooth Stroke. Your Paintbrush tool setup should
be as shown below.

9. Paint around the mouth, tongue and teeth with the edge of the brush until you have
smooth, soft edges. Alternate between the black and white colors until you have the
selection you need.

10. Go to the Toolbox and select the 'Move Tool'. This will prevent tool errors while
checking your work. Hit the 'Shift+Q' button to remove the Quick Mask to check your
selection. If it is not to your liking hit the Shift+Q keys again to restore the Quick Mask
and continue working. Return to the Paintbrush tool.

11. Remove the Quick Mask when your are satisfied with your selection.
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12. Right click on your selection, click on 'Edit' from the submenu select 'Copy Visible'.

13. Go to the Layers Panel and click on the beer-can layer. Click where the layer eye
should be and the beer can image will appear in your work space. Click on the layer eye of
the tiger-roaring layer and the photo of the tiger's mouth will disappear from your
interface.

14. On the beer can you'll see the outline of your tiger selection. You don't need that. Go
to the 'Select' menu and click 'None'.

15. Zoom out to 50%. Now you can see all of the can.

16. Right click on the can click 'Edit' from the submenu select 'Paste as' and from the new
menu select 'New Layer'. Now you can see your selection in the top left corner of the beer
can image.

17. You don't need the tiger-roaring layer any longer. Click on that layer, probably at the
top of the stack, and click on the bin at the bottom right of the layers panel. The tiger-
roaring layer has been deleted. If you deleted the wrong layer hit Ctrl+Z and try again.

18. Check that the Move tool is still active. Click and drag your selection to the center of
the beer can. Zoom in to 100%.

19. Select the 'Rotate' tool from the Toolbox. Set to 'Normal (Forward)' if not selected.
Accept the default for the other settings. Drag from the top corner of the grid or use the
slider to aline the mouth to the correct angle. Click the 'Rotate' button to accept your new
angle.
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20. Click on the Move tool. Drag the mouth to the edge of the can where it looks about
right as a mouth. Get the top and bottom of the mouth in position. Don't worry about the
area of the can between the teeth, you'll get rid of that next.

21. Go to the Layers Panel and click on the beer-can.jpg layer. Now the beer can is active
and you will work on it.

22. Go to the Toolbox and select the 'Eraser' tool. Select a hard brush, set the size to
around 80. Check that Black is the top color on the FG/BG setting. Now erase the area of
can between the tiger's teeth. Also erase any stray marks on the white area outside of the
can.

23. Go to the Layers Panel and click on the top layer (Clipboard) to activate it. Right click
on the Clipboard layer and select 'Merge down'. The mouth is now embedded in the beer
can.

24. Zoom out to 50%. Go to the Toolbox and select the "Magic Wand' (Fuzzy Select) tool.
Set the Threshold to 5. Click in the white area around the can. The marching ants will
surround the can. But of course we want the can and not the white area.

25. Go to the 'Select' menu and click on 'Invert'. Now your can and mouth are the
selection. You are now about to repeat what you did before. Right click on the can and
click on 'Edit' select 'Copy Visible' from the sub-menu.

26. Go to the Layers Panel and click on the Jungle.jpg layer to activate it. Click where the
eye should be and the jungle photo will appear on your interface. You can't see it? Close
the eye on the beer-can layer.

27. You can see the beer can selection. You don't need that. Go to the Select menu and
click on 'None'.

28. Right click on the jungle photo click 'Edit' from the submenu select 'Paste as' and from
the new menu select 'New Layer'. Now you can see your selection in the top left corner of
the jungle image.

29. You don't need the beer-can layer any longer. Click on that layer, probably at the top
of the stack, and click on the bin at the bottom right of the layers panel. The beer-can
layer has been deleted. If you deleted the wrong layer hit Ctrl+Z and try again.

30. Go to the Toolbox and select the Move tool again. Drag the tiger-beer can to the
center of the jungle. Right click on the top layer and select 'Merge down'. Your images
have been bonded together. You can see a yellow dotted line around your image, this is a
transparent area left over from your earlier work. Select the 'Crop' tool from the tool box,
adjust the size as required and crop away the unwanted area. Click in the center of the
photo to confirm your crop.

31. Save and or Export in the format of your choice. Job done.

Note. Give some thought to the images you could create with this technique: teeth on the
front of a car, on a train, on an angry friend? A little thought and you'll come up with all
kinds of ideas for wacky combinations, not just teeth.
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If the plugin ends in .scm, put it in the scripts folder.
If the plugin ends in .exe, put it in the plugins folder.

Note: Some .exe plugins are self-installing when you double click on them. The
instructions (Read Me file) will tell you what to do with your .exe plugin.

How to Install in Windows 7: (This may also work in other Windows operating systems.)

1. Click “Start” and click your user name at the top right corner of the Start menu.

2. Double-click the '.gimp-2.8' folder in the open folder.

3. Look for the 'Scripts' folder. Double-click the 'Scripts'.

4. Drag and drop (or copy + paste) the GIMP scripts ('.SCM') files into the Scripts folder.

5. Open your GIMP program. Click the “Filters” menu in GIMP, select 'Refresh Scripts'.
GIMP adds scripts to the 'Script-Fu' menu. If you don't see your plugin listed under any of
the Script-Fu sub-headings, close GIMP and restart GIMP.

If your plugin is an .exe file, which must be installed manually, follow the same sequence
as above but look for the 'Plugins' folder and place the .exe file there.

Here’s How To Install Plugins and Scripts
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Tips & Warnings.

GIMP is a 32bit program, please do not download 64bit plugins (even if your Windows 7 is
64 bit.) as 64bit plugins will not function correctly in Gimp 2.8.Plus.

Not all plugins will run in Windows 7 if the OS is 64bit. If the plugin does not work delete it
from its folder. You don't want it to hog space in GIMP.

You can download scripts from the official (GIMP 2.8.) Plugin Registry website at
http://www.registry.gimp.org.

Do not download plugins that are not on the the GIMP official site. Some plugins are
recommended by GIMP but have to be downloaded on other websites.

When downloading scripts (.scm files) left click on the script name, a box will open, select
save file, click OK, and the file will download.

Many plugins arrive in a zip file. Extract the zip file by double clicking. Most Windows
operating systems can open zip files automatically when you double click on them.

GIMP scripts are bundled together occasionally and circulated in 'archive' files. You may
need a file-archiving program to extract the script’s .scm file from the archive before
installing it. Here's a good and simple to use program: http://www.7-zip.org/

Some Photoshop plugins can be used in GIMP, you need a file installed in the plugins
folder to enable such plugins: PSPI (Photoshop Plugins Interface). Download PSPI here:
http://tml.pp.fi/gimp/pspi.html Select the 'Windows 32 gimp-pspi-1.0.7.win32.zip'. Then
search for 'Photoshop plugins for GIMP' online.
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Photoshop plugins for GIMP are in the .8bf format. (For example: fuzzypicture.8bf)

Only 32bit plugins work with GIMP. Avoid all 64bit plugins.

Download the PSPI plugin from the website link: http://tml.pp.fi/gimp/pspi.html. The
download links are at the bottom of the page. When the download is complete, double
click on the zip to open it.

Navigate to the plugins folder as shown in the graphic on installing plugins (above).
Double click on the plug-ins folder and drag or copy the 'pspi.exe' file that you
downloaded into the folder.

You have to tell GIMP where it will find the Photoshop plugins you intend to use.

Now open GIMP. Go to the 'Filters' menu, at the bottom of the menu you'll see:
'Photoshop Plug-in Settings'.

Double click on that name. A box will open. Click the 'New' button, on the left. Now click
the 'Folder' button on the right.

Navigate to the folder for plugins and select it: for example: username/gimp-2.8/plugins .
When you start GIMP it will look in this folder for plugins, adding them to the Filters menu.

How To Make GIMP Work with Photoshop Plugins

http://tml.pp.fi/gimp/pspi.html
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As we discussed, Photoshop plugins may come with an installer; with these, you just
identify your plugins folder as the install location. Installers ask you to browse to the
destination folder. Don't miss this option or your installation will get lost.

Regular Photoshop plugins, which don't have an installer, need to be dragged (or copy and
paste) to your plugins folder.

You need to know that some Photoshop plugins do not function correctly in GIMP. Note the
name and delete it from your plugins folder.

Your Photoshop plugins will be displayed at the bottom of the Filters menu. They are often
listed under the makers name. For example: 'Fotomatic'. By hovering over the name a full
list of filter effects is displayed. Clicking on a filter should apply that effect. If you get a
warning box, or nothing happens, delete that file from the plugins folder.

There are many Photoshop plugins available, install only those you have a use for. Or
download one package, load and try them in GIMP, and keep only those you really like.
Then try another plugin or set of plugins. Have fun.
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Below is a list of websites where you'll find free recommended plugins for GIMP.
Obviously, you will not need them all, and the same plugins show up on a number of sites,
but not all. Download and install the plugins that interest you for future use.

The safe place to download plugins (including scripts) is gimp.org. When you see a plugin
on another site, note the name and format (pictureperfect.exe, or pictureperfect.scm, or
pictureperfect.8bf). Go to: http://registry.gimp.org/ and search for that plugin name. If a
download page comes up, you can download it from there. No problems. However, you
may get a discussion page where other GIMP owners talk the the plugin and give their
opinions.

Many web sites give explanations of the purpose the each plugin, you decide if the plugin
meets your needs.

When you have downloaded and installed your plugin you'll want to know if GIMP
recognizes the plugin. Go to the 'Help' menu and select 'Plugin Browser'. All the plugins,
correctly installed, and accepted by GIMP are listed. Check the list by scrolling down. If
your plugin is not shown it was either not installed correctly or it does not work in GIMP.

Links:

http://registry.gimp.org/popular

http://registry.gimp.org/node/22018

http://registry.gimp.org/node/23203

http://registry.gimp.org/node/11776

http://www.lightstalking.com/gimp-plugins

http://davidwoodfx.blogspot.co.uk/2010/04/127-useful-gimp-scripts-and-plugins.html

http://www.techzilo.com/download-free-gimp-plugins/

http://www.brighthub.com/multimedia/photography/articles/16924.aspx

http://plugintop.com/category/design/gimp/

http://www.allisnow.com/bwn4/blog/graphic-design/gimp-plugins-photography-photo-
retouchin...

http://arshamshirvani.blogspot.co.uk/2010/02/top-40-gimp-plugins.html

http://www.gimphelp.org/script24.shtml

http://www.xero-graphics.co.uk/freeware.htm

Recommended Plugins & Scripts for GIMP


