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Note for Mac users

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux. 
The table below gives some common substitutions for the instructions in this chapter. For a more 
detailed list, see the application Help.

Windows or Linux Mac equivalent Effect

Tools > Options 
menu selection

Apache OpenOffice > 
Preferences

Access setup options

Right-click Control+click Opens a context menu

Ctrl (Control) z (Command) Used with other keys

F5 Shift+z+F5 Opens the Navigator

F11 z+T Opens the Styles and Formatting window
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Choosing options for all of Apache OpenOffice

This section covers some of the settings that apply to all the components of Apache OpenOffice. 
For information on settings not discussed here, see the online help.

Click Tools > Options. The list in the left-hand box of the Options – OpenOffice.org dialog varies 
depending on which component is open. The illustrations in this chapter show the list as it appears 
when a Writer document is open.

Click the marker (+ or triangle) by OpenOffice.org on the left-hand side. A list of pages drops down. 
Selecting an item in the list causes the right-hand side of the dialog to display the relevant page.

Figure 1: OpenOffice.org options

Note
The Back button has the same effect on all pages of the Options dialog. It 
resets the options to the values that were in place when you opened 
OpenOffice.org.

User Data options
Because the name or initials stored in the OpenOffice.org – User Data page are used for several 
things, including document properties (created by and last edited by information) and the name of 
the author of notes and changes, you should ensure that the correct information appears here. Fill 
in the form (shown in Figure 2), or amend or delete any existing incorrect information.
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Figure 2: Filling in user data

General options
The options on the OpenOffice.org – General page are described below.

Figure 3: Setting general options for OpenOffice.org

Help - Tips
When Tips is active, one or two words will appear when you hold the mouse pointer over an 
icon or field, without clicking.

Help - Extended tips
When Extended tips is active, a brief description of the function of a particular icon or menu 
command or a field on a dialog appears when you hold the mouse pointer over that item.

Help Agent
To turn off the Help Agent (similar to Microsoft’s Office Assistant), deselect this option. To 
restore the default behavior, click Reset Help Agent.
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Help formatting
High contrast is an operating system setting that changes the system color scheme to improve 
readability. To display Help in high contrast (if your computer’s operating system supports this), 
choose one of the high-contrast style sheets from the pull-down list.

High-contrast style Visual effect

Default Black text on white background

High Contrast #1 Yellow text on black background

High Contrast #2 Green text on black background

High Contrast Black White text on black background

High Contrast White Black text on white background

Open/Save dialogs
To use the standard Open and Save dialogs for your operating system, deselect the Use 
OpenOffice.org dialogs option. When this option is selected, the Open and Save dialogs 
supplied with OpenOffice.org will be used. See Chapter 1 (Introducing Apache OpenOffice) for 
more about the AOO Open and Save dialogs. This book uses the AOO Open and Save dialogs 
in illustrations.

Print dialogs – Use OpenOffice.org dialogs
(Mac OS X only) To use the standard Print dialogs for your operating system, deselect the Use 
OpenOffice.org dialogs option. When this option is selected, the Print dialogs supplied with 
OpenOffice.org will be used. This book uses the AOO Print dialogs in illustrations.

Document status
If this option is selected, then the next time you close the document after printing, the print date 
is recorded in the document properties as a change and you will be prompted to save the 
document again, even if you did not make any other changes.

Year (two digits)
Specifies how two-digit years are interpreted. For example, if the two-digit year is set to 1930, 
and you enter a date of 1/1/30 or later into your document, the date is interpreted as 1/1/1930 
or later. An “earlier” date is interpreted as being in the following century; that is, 1/1/20 is 
interpreted as 1/1/2020.
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Memory options
In the Options dialog, click OpenOffice.org > Memory.

Figure 4: Choosing Memory options for the OpenOffice.org applications
 

These options control how the program uses your computer’s memory and how much memory it 
requires. Before changing them, you may wish to consider the following points:

• More memory can make AOO faster and more convenient (for example, more undo steps 
require more memory); but the trade-off is less memory available for other applications and 
you could run out of memory altogether.

• If your documents contain a lot of objects such as images, or the objects are large, AOO’s 
performance may improve if you increase the memory for AOO or the memory per object. If 
you find that objects seem to disappear from a document that contains a lot of them, 
increase the number of objects in the cache. (The objects are still in the file even if you 
cannot see them on screen.)

• To load the Quickstarter (an icon on the desktop or in the system tray) when you start your 
computer, select the option near the bottom of the dialog. This makes AOO start faster; the 
trade-off is AOO uses some memory even when not being used. This option (sometimes 
called Enable systray quickstarter) is not available on all operating systems.
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View options
The options on the OpenOffice.org – View page affect the way the document window looks and 
behaves. Some of these options are described below. Set them to suit your personal preferences.

Figure 5: Choosing View options for AOO applications  

User Interface – Scaling
If the text in the help files or on the menus of the AOO user interface is too small or too large, 
you can change it by specifying a scaling factor. Sometimes a change here can have 
unexpected results, depending on the screen fonts available on your system. However, it does 
not affect the actual font size of the text in your documents.

User Interface – Icon size and style
The first box specifies the display size of toolbar icons (Automatic, Small, or Large). The 
Automatic icon size option uses the setting for your operating system. The second box 
specifies the icon style (theme); here the Automatic option uses an icon set compatible with 
your operating system and choice of desktop: for example, KDE or Gnome on Linux.

User Interface – Use system font for user interface
If you prefer to use the system font (the default font for your computer and operating system) 
instead of the font provided by AOO for the user interface, select this option.

User interface – Screen font anti-aliasing
(Not available in Windows; not shown in Figure 5.) Select this option to smooth the screen 
appearance of text. Enter the smallest font size to apply anti-aliasing.

Menu – icons in menus
Causes icons as well as words to be visible in menus.

Font Lists - Show preview of fonts
Causes the font list to look like Figure 6, Left, with the font names shown as an example of the 
font; with the option deselected, the font list shows only the font names, not their formatting 
(Figure 6, Right). The fonts you will see listed are those that are installed on your system.
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Figure 6. Font list (Left) With preview; (Right) Without preview

Font Lists - Show font history
Causes the last five fonts you have assigned to the current document are displayed at the top 
of the font list. Otherwise fonts are shown in alphabetical order.

Graphics output – Use hardware acceleration
Directly accesses hardware features of the graphical display adapter to improve the screen 
display. Not supported on all operating systems and AOO distributions.

Graphics output – Use anti-aliasing
Enables and disables anti-aliasing, which makes the display of most graphical objects look 
smoother and with fewer artifacts. Not supported on all operating systems and AOO 
distributions.

Tip Press Shift+Control+R to restore or refresh the view of the current document.

Mouse positioning
Specifies if and how the mouse pointer will be positioned in newly opened dialogs.

Middle mouse button
Defines the function of the middle mouse button.

• Automatic scrolling – dragging while pressing the middle mouse button shifts the view.

• Paste clipboard – pressing the middle mouse button inserts the contents of the “Selection 
clipboard” at the cursor position.

The “Selection clipboard” is independent of the normal clipboard that you use by Edit > 
Copy/Cut/Paste or their respective keyboard shortcuts. Clipboard and “Selection clipboard” 
can contain different contents at the same time.

Function Clipboard Selection clipboard

Copy content Edit > Copy Control+C Select text, table, or object.

Paste content Edit > Paste Control+V 
pastes at the cursor position.

Clicking the middle mouse button 
pastes at the mouse pointer position.

Pasting into another 
document

No effect on the clipboard 
contents.

The last marked selection is the 
content of the selection clipboard.

Selection – Transparency
Determines the appearance of selected text or graphics, which appear on a shaded 
background. To make the shaded background more or less dark, increase or decrease the 
Transparency setting.
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If you prefer selected material to appear in reversed color (typically white text on a black 
background), deselect this option.

Print options
On the OpenOffice.org – Print page, set the print options to suit your default printer and your most 
common printing method.

In the Printer warnings section near the bottom of the page, you can choose whether to be warned 
if the paper size or orientation specified in your document does not match the paper size or 
orientation available for your printer. Having these warnings turned on can be quite helpful, 
particularly if you work with documents produced by people in other countries where the standard 
paper size is different from yours.

Tip
If your printouts are incorrectly placed on the page or chopped off at the top, 
bottom, or sides, or the printer is refusing to print, the most likely cause is page 
size incompatibility.

Figure 7: Choosing general printing options to apply to all AOO components

Path options
On the OpenOffice.org – Paths page, you can change the location of files associated with, or used 
by, OpenOffice.org to suit your working situation. In a Windows system, for example, you might 
want to store documents by default somewhere other than My Documents.

To make changes, select an item in the list shown in Figure 8 and click Edit. On the Select Path 
dialog (not shown; may also be titled Edit Paths), add or delete folders as required, and then click 
OK to return to the Options dialog. Note that some items can have at least two paths listed: one to 
a shared folder (which might be on a network) and one to a user-specific folder (normally on the 
user’s personal computer).
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Tip
You can use the entries in the OpenOffice.org – Paths dialog to compile a list of 
files, such as those containing AutoText, that you need to back up or copy to 
another computer.

Figure 8: Viewing the paths of files used by OpenOffice.org  

Color options
On the OpenOffice.org – Colors page, you can specify colors to use in AOO documents. You can 
select a color from a color table, edit an existing color, and define new colors. These colors are 
stored in your color palette and are then available in all components of AOO.

Figure 9: Defining colors to use in color palettes in AOO
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To modify a color:

1) Select the color to modify from the list or the color table.

2) Enter the new values that define the color. If necessary, change the settings from RGB 
(Red, Green, Blue) to CMYK (Cyan, Magenta, Yellow, Black) or vice versa. The changed 
color appears in the lower of the two color preview boxes at the top.

3) Modify the Name as required.

4) Click the Modify button. The newly defined color is now listed in the Color table.

Alternatively, click the Edit button to open the Color Picker dialog, shown in Figure 10. Here you 
can select a color from the color window on the left; or you can enter values in the boxes on the 
right, using your choice of RGB, CMYK, or HSB (Hue, Saturation and Brightness) values.

The color window is linked directly with the color input fields on the right; as you choose a color in 
the window, the numbers change accordingly. The lower color field on the left shows the value of 
the selected color on the left and the currently set value from the color value fields on the right.

Modify the color components as required and click OK to exit the dialog. The newly defined color 
now appears in the lower of the color preview boxes shown in Figure 9. Type a name for this color 
in the Name box, then click the Add button. A small box showing the new color is added to the 
Color table.

Figure 10: Choosing colors
 

Another way to define or alter colors is through the Colors page of the Area dialog, where you can 
also save and load palettes, a feature that is not possible here. In Calc, draw a temporary draw 
object and use the context menu of this object to open the Area dialog. If you load a palette in one 
component of AOO, it is only active in that component; the other components keep their own 
palettes.
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Font options
You can define replacements for any fonts that might appear in your documents. If you receive 
from someone else a document containing fonts that you do not have on your system, 
OpenOffice.org will substitute fonts for those it does not find. You might prefer to specify a different 
font from the one the program chooses.

Figure 11: Defining a font to be substituted for another font  

On the OpenOffice.org – Fonts page:

1) Select the Apply Replacement Table option.

2) Select or type the name of the font to be replaced in the Font box. (If you do not have this 
font on your system, it will not appear in the drop-down list in this box, so you need to type 
it in.)

3) In the Replace with box, select a suitable font from the drop-down list of fonts installed on 
your computer.

4) The checkmark to the right of the Replace with box turns green. Click on this checkmark. 
A row of information now appears in the larger box below the input boxes. Select the 
options under Always and Screen.

5) In the bottom section of the page, you can change the typeface and size of the font used to 
display source code such as HTML and Basic (in macros).

Security options
Use the OpenOffice.org – Security page (Figure 12) to choose security options for saving 
documents and for opening documents that contain macros.

Security options and warnings
If you record changes, save multiple versions, or include hidden information or notes in your 
documents, and you do not want some of the recipients to see that information, you can set 
warnings to remind you to remove it, or you can have AOO remove some of it automatically. 
Note that (unless removed) much of this information is retained in a file whether the file is in 
AOO’s default OpenDocument format, or has been saved to other formats, including PDF.
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Figure 12: Choosing security options for opening and saving documents  

Click the Options button to open a separate dialog with specific choices (Figure 13).

Macro security
Click the Macro Security button to open the Macro Security dialog (not shown here), where 
you can adjust the security level for executing macros and specify trusted sources.

Security options and warnings
The following options are on the Security options and warnings dialog (Figure 13).

Figure 13: Security options and warnings dialog

 

Remove personal information on saving
Select this option to always remove user data from the file properties when saving the file. To 
manually remove personal information from specific documents, deselect this option and then 
use the Delete button under File > Properties > General.
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Ctrl-click required to follow hyperlinks
In older versions of AOO, clicking on a hyperlink in a document opened the linked document. 
Now you can choose whether to keep this behavior (by unchecking this box). Many people find 
creation and editing of documents easier when accidental clicks on links do not activate the 
links.

The other options on this dialog should be self-explanatory.

Appearance options
Writing, editing, and (especially) page layout are often easier when you can see the page margins 
(text boundaries), the boundaries of tables and sections (in Writer documents), page breaks in 
Calc, grid lines in Draw or Writer, and other features. In addition, you might prefer to use colors that 
are different from AOO’s defaults for such items as note indicators or field shadings.

On the OpenOffice.org – Appearance page, you can specify which items are visible and the colors 
used to display various items.

Figure 14: Showing or hiding text, object, and table boundaries
 

• To show or hide items such as text boundaries, select or deselect the options next to the 
names of the items.

• To change the default colors for items, click the down-arrow in the Color Setting column by 
the name of the item and select a color from the pop-up box.

• To save your color changes as a color scheme, click Save, type a name in the Scheme 
box; then click OK.

Accessibility options
Accessibility options include whether to allow animated graphics or text, how long help tips remain 
showing, some options for high contrast display, and a way to change the font for the user interface 
of the OpenOffice.org program.

Accessibility support relies on Sun Microsystems Java technology for communications with 
assistive technology tools. See “Java options“ below. The Support assistive technology tools option 

16 Setting up OpenOffice.org



is not shown on all AOO installations. See Assistive Tools in OpenOffice.org in the Help for other 
requirements and information.

Select or deselect the options as required.

Figure 15: Choosing accessibility options  

Java options
If you install or update a Java Runtime Environment (JRE) after you install OpenOffice.org, or if 
you have more than one JRE installed on your computer, you can use the OpenOffice.org – Java 
options page to choose the JRE for AOO to use.

If you are a system administrator, programmer, or other person who customizes JRE installations, 
you can use the Parameters and Class Path pages (reached from the Java page) to specify this 
information.

If you do not see anything listed in the middle of the page, wait a few minutes while AOO searches 
for JREs on the hard disk.

If AOO finds one or more JREs, it will display them there. You can then select the Use a Java 
runtime environment option and (if necessary) choose one of the JREs listed.

Figure 16: Choosing a Java runtime environment
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Online Update options
On the OpenOffice.org – Online Update page, you can choose whether and how often to have 
AOO check the AOO website for program updates. If the Check for updates automatically option 
is selected, an icon appears at the right-hand end of the menu bar when an update is available. 
Click this icon to open a dialog where you can choose to download the update.

Figure 17: Configuring Online Update
 

If the Download updates automatically option is selected, the download starts when you click the 
icon. To change the download destination, click the Change button and select the required folder in 
the file browser window.

Choosing options for loading and saving documents

You can set the Load/Save options to suit the way you work.

If the Options dialog is not already open, click Tools > Options. Click the expansion symbol (+ or 
triangle) to the left of Load/Save.

Figure 18: Load/Save options

General Load/Save options
Most of the choices on the Load/Save – General page are familiar to users of other office suites. 
Some items of interest are described below.
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Figure 19: Choosing Load and Save options  

Load user-specific settings with the document
When you save a document, certain settings are saved with it. Some settings (printer name, 
data source linked to the document) are always loaded with a document, whether or not this 
option is selected. If you select this option, these document settings are overruled by the user-
specific settings of the person who opens it. If you deselect this option, the user’s personal 
settings do not overrule the settings in the document. For example, your choice (in the options 
for AOO Writer) of how to update links is affected by the Load user-specific settings option.

Load printer settings with the document
If this option is not selected, the printer settings that are stored with the document are ignored 
when you print it using the Print File Directly icon. The default printer in your system will be 
used instead.

Edit document properties before saving
If you select this option, the Document Properties dialog pops up to prompt you to enter 
relevant information the first time you save a new document (or whenever you use Save As).

Save AutoRecovery information every
Choose whether to enable AutoRecovery and how often to save the information used by the 
AutoRecovery process.

AutoRecovery in AOO overwrites the original file. If you also choose Always create backup 
copy, the original file then overwrites the backup copy.  If you have this set, recovering your 
document after a system crash will be easier; but recovering an earlier version of the document 
may be harder.

Save URLs relative to file system / internet
Relative addressing to a file system is only possible if the source document and the referenced 
document are both on the same drive. A relative address always starts from the directory in 
which the current document is located. It is recommended to save relatively if you want to 
create a directory structure on an Internet server.
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Default file format and ODF settings
ODF format version. AOO by default saves documents in OpenDocument Format (ODF) 
version 1.2 Extended. While this allows for improved functionality, there may be backwards 
compatibility issues. When a file saved in ODF 1.2 Extended is opened in an earlier version of 
OpenOffice.org (using ODF 1.0/1.1), some of the advanced features may be lost. Two notable 
examples are cross-references to headings and the formatting of numbered lists. If you plan to 
share documents with people who are still using older versions of OpenOffice.org, save the 
document using ODF version 1.0/1.1.

Size optimization for ODF format. OpenOffice.org documents are XML files. When you select 
this option, AOO writes the XML data without indents and line breaks. If you want to be able to 
read the XML files in a text editor in a structured form, deselect this option.

Document type. If you routinely share documents with users of Microsoft Office, you might 
want to change the Always save as attribute for documents to one of the Microsoft Office 
formats.

Note
Although AOO can open files in the .docx, .xlsx, and .pptx formats produced 
by Microsoft Office 2007, it cannot save in those formats. This capability is 
planned for a future release.

VBA Properties Load/Save options
On the Load/Save – VBA Properties page, you can choose whether to keep any macros in 
Microsoft Office documents that are opened in OpenOffice.org.

Figure 20: Choosing Load/Save VBA Properties

• If you choose Save original Basic code, the macros will not work in AOO but are retained 
if you save the file into Microsoft Office format.

• If you choose Load Basic code to edit, the changed code is saved in an AOO document 
but is not retained if you save into a Microsoft Office format.

• If you are importing a Microsoft Excel file containing VBA code, you can select the option 
Executable code. Whereas normally the code is preserved but rendered inactive (if you 
inspect it with the StarBasic IDE you will notice that it is all commented), with this option the 
code is ready to be executed.
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Microsoft Office Load/Save options
On the Load/Save – Microsoft Office page, you can choose what to do when importing and 
exporting Microsoft Office OLE objects (linked or embedded objects or documents such as 
spreadsheets or equations).

Select the [L] options to convert Microsoft OLE objects into the corresponding OpenOffice.org OLE 
objects when a Microsoft document is loaded into AOO (mnemonic: “L” for “load”).

Select the [S] options to convert OpenOffice.org OLE objects into the corresponding Microsoft OLE 
objects when a document is saved in a Microsoft format (mnemonic: “S” for “save”).

Figure 21: Choosing Load/Save Microsoft Office options  

HTML compatibility Load/Save options
Choices made on the Load/Save – HTML Compatibility page affect HTML pages imported into 
OpenOffice.org and those exported from AOO. See HTML documents; importing/exporting in the 
Help for more information.

Figure 22. Choosing HTML compatibility options
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Font sizes
Use these fields to define the respective font sizes for the HTML <font size=1> to <font size=7> 
tags, if they are used in the HTML pages. (Many pages no longer use these tags.)

Import – Use 'English (USA)' locale for numbers
When importing numbers from an HTML page, the decimal and thousands separator 
characters differ according to the locale of the HTML page. The clipboard, however, contains 
no information about the locale. If this option is not selected, numbers will be interpreted 
according to the Language - Locale setting in Tools > Options > Language Settings > 
Languages (see page 23). If this option is selected, numbers will be interpreted as for the 
English (USA) locale.

Import – Import unknown HTML tags as fields
Select this option if you want tags that are not recognized by AOO to be imported as fields. For 
an opening tag, an HTML_ON field will be created with the value of the tag name. For a closing 
tag, an HTML_OFF will be created. These fields will be converted to tags in the HTML export.

Import – Ignore font settings
Select this option to have AOO ignore all font settings when importing. The fonts that were 
defined in the HTML Page Style will be used.

Export
To optimize the HTML export, select a browser or HTML standard from the Export box. If 
OpenOffice.org Writer is selected, specific OpenOffice.org Writer instructions are exported.

Export – OpenOffice.org Basic
Select this option to include AOO Basic macros (scripts) when exporting to HTML format. You 
must activate this option before you create the OpenOffice.org Basic macro; otherwise the 
script will not be inserted. OpenOffice.org Basic macros must be located in the header of the 
HTML document. Once you have created the macro in the OpenOffice.org Basic IDE, it 
appears in the source text of the HTML document in the header.

If you want the macro to run automatically when the HTML document is opened, choose Tools 
> Customize > Events. See Chapter 13 (Getting Started with Macros) for more information.

Export – Display warning
When the OpenOffice.org Basic option (see above) is not selected, the Display warning 
option becomes available. If the Display warning option is selected, then when exporting to 
HTML a warning is shown that OpenOffice.org Basic macros will be lost.

Export – Print layout
Select this option to export the print layout of the current document as well. The HTML filter 
supports CSS2 (Cascading Style Sheets Level 2) for printing documents. These capabilities 
are only effective if print layout export is activated.

Export – Copy local graphics to Internet
Select this option to automatically upload the embedded pictures to the Internet server when 
uploading using FTP.

Export – Character set
Select the appropriate character set for the export.
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Choosing language settings

You may need to do several things to set the language settings to what you want:

• Install the required dictionaries

• Change some locale and language settings

• Choose spelling options

Install the required dictionaries
AOO automatically installs several dictionaries with the program. To add other dictionaries, be sure 
you are connected to the Internet, and then use Tools > Language > More Dictionaries Online. 
AOO will open your default web browser to a page containing links to additional dictionaries that 
you can install. Follow the prompts to select and install the ones you want.

Change locale and language settings
You can change some details of the locale and language settings that AOO uses for all documents, 
or for specific documents.

In the Options dialog, click Language Settings > Languages.

Figure 23: Language Setting Options

On the right-hand side of the Language Settings – Languages page (Figure 25), change the User 
interface, Locale setting, Default currency, and Default languages for documents as required. In 
the example, English (UK) has been chosen for all the appropriate settings.

If you want the language (dictionary) setting to apply to the current document only, instead of being 
the default for all new documents, select the option labelled For the current document only.

If necessary, select the options to enable support for Asian languages (Chinese, Japanese, 
Korean) and support for CTL (complex text layout) languages such as Urdu, Thai, Hebrew, and 
Arabic. If you choose either of these options, the next time you open this dialog, you will see some 
extra choices under Language Settings, as shown in Figure 24. These choices (Searching in 
Japanese, Asian Layout, and Complex Text Layout) are not discussed here.

Figure 24: Extra pages available when enhanced language support options are selected
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Figure 25: Choosing language options

Choose spelling options
To choose the options for checking spelling, click Language Settings > Writing Aids. In the 
Options section of the page (Figure 26), choose the settings that are useful for you.

Figure 26: Choosing languages, dictionaries, and options for checking spelling

Some considerations:
• If you do not want spelling checked while you type, deselect Check spelling as you type 

and select Do not mark errors. (To find the second item, scroll down in the Options list.)
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• If you use a custom dictionary that includes words in all upper case and words with 
numbers (for example, AS/400), select Check uppercase words and Check words with 
numbers.

• Check special regions includes headers, footers, frames, and tables when checking 
spelling.

Here you can also check which user-defined (custom) dictionaries are active by default, and add or 
remove dictionaries, by clicking the New or Delete buttons.

Note
OpenOffice.org does not have a grammar checker, but you can install a grammar 
checker extension such as Language Tool and access that tool from Tools > 
Spelling and Grammar. See “Adding functionality with extensions” on page 35 
for more information.

Choosing Internet options

Use the Internet Options pages to define search engines and save proxy settings for use with 
OpenOffice.org.

If you are using a Netscape or Mozilla browser (such as Firefox), you can enable the Browser 
Plug-in so you can open AOO files in your browser, print them, save them, and work with them in 
other ways.

If you are using a Unix- or Linux-based operating system (including Mac OS X), an additional page 
of E-mail options is available, where you can specify the e-mail program to use when you send the 
current document as e-mail. Under Windows the operating system’s default e-mail program is 
always used.

Figure 27: Internet options, showing E-mail page available to Linux and Mac OS X users.

Controlling AOO’s AutoCorrect functions

Some people find some or all of the items in AOO’s AutoCorrect function annoying because they 
change what you type when you do not want it changed. Many people find some of the 
AutoCorrect functions quite helpful; if you do, then select the relevant options. But if you find 
unexplained changes appearing in your document, this is a good place to look to find the cause.

To open the AutoCorrect dialog, click Tools > AutoCorrect Options. (You need to have a 
document open for this menu item to appear.)

In Writer, this dialog has five tabs, as shown in Figure 28. In other components of AOO, the dialog 
has only four tabs.
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Figure 28: The AutoCorrect dialog in Writer, showing the five tabs and some of 
the choices

Customizing Apache OpenOffice

You can customize menus, toolbars, and keyboard shortcuts in OpenOffice.org, add new menus 
and toolbars, and assign macros to events. However, you cannot customize context (right-click) 
menus.

Other customizations are made easy by extensions that you can install from the OpenOffice.org 
website or from other providers.

Note
Customizations to menus and toolbars can be saved in a template. To do so, first 
save them in a document and then save the document as a template as 
described in Chapter 2 (Styles and Templates).

Customizing menus
You can add and rearrange items on the menu bar, add items to menus, and make other changes.

To customize menus:

1) Choose Tools > Customize.

2) On the Customize dialog, go to the Menus page.

3) In the Save In drop-down list, choose whether to save this changed menu for the 
application (for example, OpenOffice.org Writer) or for a selected document (for example, 
MyDoc.odt).
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Figure 29. The Menus page of the Customize dialog

4) In the section OpenOffice.org [name of the program (example: Writer)] Menus, select 
from the Menu drop-down list the menu that you want to customize. The list includes all the 
main menus as well as submenus (menus that are contained under another menu). For 
example, in addition to File, Edit, View, and so on, there is File | Send and File |Templates. 
The commands available for the selected menu are shown in the central part of the dialog.

5) To customize the selected menu, click on the Menu or Modify buttons. You can also add 
commands to a menu by clicking on the Add button. These actions are described in the 
following sections. Use the up and down arrows next to the Entries list to move the 
selected menu item to a different position.

6) When you have finished making all your changes, click OK (not shown in illustration) to 
save them.

Creating a new menu
In the Customize dialog, click New to display the dialog shown in Figure 29.

1) Type a name for your new menu in the Menu name box.

2) Use the up and down arrow buttons to move the new menu into the required position on 
the menu bar.

3) Click OK to save.

The new menu now appears on the list of menus in the Customize dialog. (It will appear on the 
menu bar itself after you save your customizations.)

After creating a new menu, you need to add some commands to it, as described in “Adding a 
command to a menu” on page 29.
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Figure 30: Adding a new menu

Modifying existing menus
To modify an existing menu, select it in the Menu list and click the Menu button to drop down a list 
of modifications: Move, Rename, Delete. Not all of these modifications can be applied to all the 
entries in the Menu list. For example, Rename and Delete are not available for the menus supplied 
by AOO.

To move a menu (such as File), choose Menu > Move. A dialog similar to the one shown in Figure 
29 (but without the Menu name box) opens. Use the up and down arrow buttons to move the 
menu into the required position.

To move submenus (such as File | Send), select the main menu (File) in the Menu list and then, in 
the Menu Content section of the dialog, select the submenu (Send) in the Entries list and use the 
arrow keys to move it up or down in the sequence.

In addition to renaming, you can specify a keyboard shortcut that allows you to select a menu 
command when you press Alt+ an underlined letter in a menu command.

1) Select a menu entry.

2) Click the Modify button and select Rename.

3) Add a tilde (~) in front of the letter that you want to use as an accelerator. For example, to 
select the Save All command by pressing Alt+V (after opening the File menu using Alt+F), 
enter Sa~ve All.

Caution Be careful when using these shortcuts. In the example above, if the File menu 
is not already open, then pressing Alt+V opens the View menu; if some other 
menu is open, Alt+V might activate some other command.
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Adding a command to a menu
You can add commands to the supplied menus and to menus you have created. On the Customize 
dialog, select the menu in the Menu list and click the Add button in the Menu Content section of 
the dialog.

On the Add Commands dialog (Figure 31), select a category and then the command, and click 
Add. The dialog remains open, so you can select several commands. When you have finished 
adding commands, click Close. Back on the Customize dialog, you can use the up and down 
arrow buttons to arrange the commands in your preferred sequence.

Figure 31: Adding a command to a menu

Modifying menu entries
In addition to changing the sequence of entries on a menu or submenu, you can add submenus, 
rename or delete the entries, and add group separators.

To begin, select the menu or submenu in the Menu list near the top of the Customize page, then 
select the entry in the Entries list under Menu Content. Click the Modify button and choose the 
required action from the drop-down list of actions.

Most of the actions should be self-explanatory. Begin a group adds a separator line after the 
highlighted entry.

Customizing toolbars
You can customize toolbars in several ways, including choosing which icons are visible and locking 
the position of a docked toolbar, as described in Chapter 1 (Introducing OpenOffice.org). This 
section describes how to create new toolbars and add other icons (commands) to the list of those 
available on a toolbar.
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To get to the toolbar customization dialog, do any of the following:

• On the toolbar, click the arrow at the end of the toolbar and choose Customize Toolbar.

• Choose View > Toolbars > Customize from the menu bar.

• Choose Tools > Customize from the menu bar and pick the Toolbars page (Figure 32).

To customize toolbars:

1) In the Save In drop-down list, choose whether to save this changed toolbar for the 
application (for example, Writer) or for a selected document.

2) In the section OpenOffice.org <name of the program (example: Writer)> Toolbars, 
select from the Toolbar drop-down list the toolbar that you want to customize.

3) You can create a new toolbar by clicking on the New button, or customize existing toolbars 
by clicking on the Toolbar or Modify buttons, and add commands to a toolbar by clicking 
on the Add button. These actions are described below.

4) When you have finished making all your changes, click OK to save them.

Figure 32. The Toolbars page of the Customize dialog

Creating a new toolbar
To create a new toolbar:

1) Choose Tools > Customize > Toolbars from the menu bar.

2) Click New. On the Name dialog, type the new toolbar's name and choose from the Save In 
drop-down list where to save this changed menu: for the application (for example, Writer) or 
for a selected document.

The new toolbar now appears on the list of toolbars in the Customize dialog. After creating a new 
toolbar, you need to add some commands to it, as described below.
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Adding a command to a toolbar
If the list of available buttons for a toolbar does not include all the commands you want on that 
toolbar, you can add commands. When you create a new toolbar, you need to add commands to it.

1) On the Toolbars page of the Customize dialog, select the toolbar in the Toolbar list and click 
the Add button in the Toolbar Content section of the dialog.

2) The Add Commands dialog is the same as for adding commands to menus (Figure 31). 
Select a category and then the command, and click Add. The dialog remains open, so you 
can select several commands. When you have finished adding commands, click Close. If 
you insert an item which does not have an associated icon, the toolbar will display the full 
name of the item: the next section describes how to choose an icon for a toolbar command.

3) Back on the Customize dialog, you can use the up and down arrow buttons to arrange the 
commands in your preferred sequence.

4) When you are done making changes, click OK to save.

Choosing icons for toolbar commands
Toolbar buttons usually have icons, not words, on them, but not all of the commands have 
associated icons.

To choose an icon for a command, select the command and click Modify > Change icon. On the 
Change Icon dialog, you can scroll through the available icons, select one, and click OK to assign 
it to the command.

Figure 33: Change Icon dialog
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To use a custom icon, create it in a graphics program and import it into AOO by clicking the Import 
button on the Change Icon dialog. Custom icons must be 16 x 16 or 26 x 26 pixels in size and 
cannot contain more than 256 colors.

Example: Adding a Fax icon to a toolbar
You can customize OpenOffice.org so that a single click on an icon automatically sends the current 
document as a fax.

1) Be sure the fax driver is installed. Consult the documentation for your fax modem for more 
information.

2) Choose Tools > Options > OpenOffice.org Writer > Print. The dialog shown in Figure 34 
opens.

3) Select the fax driver from the Fax list and click OK.

Figure 34: Setting up AOO for sending faxes

4) Click the arrow icon at the end of the Standard toolbar. In the drop-down menu, choose 
Customize Toolbar. The Toolbars page of the Customize dialog appears (Figure 32). Click
Add.

5) On the Add Commands dialog (Figure 35), select Documents in the Category list, then 
select Send Default Fax in the Commands list. Click Add. Now you can see the new icon in 
the Commands list.

6) In the Commands list, click the up or down arrow button to position the new icon where you 
want it. Click OK and then click Close. 

Your toolbar now has a new icon to send the current document as a fax.
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Figure 35: Adding a Send Fax command to a toolbar

Assigning shortcut keys
In addition to using the built-in keyboard shortcuts (listed in the included Help), you can define your 
own. You can assign shortcuts to standard AOO functions or your own macros and save them for 
use with the entire OpenOffice.org suite.

Caution

Be careful when reassigning your operating system’s or AOO’s predefined 
shortcut keys. Many key assignments are universally understood shortcuts, 
such as F1 for Help, and are always expected to provide certain results. 
Although you can easily reset the shortcut key assignments to the AOO 
defaults, changing some common shortcut keys can cause confusion, 
frustration and possible data loss or corruption, especially if other users share 
your computer.

To adapt shortcut keys to your needs, use the Customize dialog, as described below.

1) Select Tools > Customize > Keyboard. The Customize dialog opens.

2) To have the shortcut key assignment available in all components of OpenOffice.org select 
the OpenOffice.org button.

3) Next select the required function from the Category and Function lists.

4) Now select the desired shortcut keys in the Shortcut keys list and click the Modify button at 
the upper right.

5) Click OK to accept the change. Now the chosen shortcut keys will execute the function 
chosen in step 3 above whenever they are pressed.

Note

All existing shortcut keys for the currently selected Function are listed in the 
Keys selection box. If the Keys list is empty, it indicates that the chosen key 
combination is free for use. If it were not, and you wanted to reassign a shortcut 
key combination that is already in use, you must first delete the existing key.

Shortcut keys that are greyed-out in the listing on the Customize dialog, such as 
F1 and F10, are not available for reassignment.
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Example: Assigning styles to shortcut keys
You can configure shortcut keys to quickly assign styles in your document. Some shortcuts are 
predefined, such as Ctrl+0 for the Text body paragraph style, Ctrl+1 for the Heading 1 style, and 
Ctrl+2 for Heading 2. You can modify these shortcuts and create your own.

1) Click Tools > Customize > Keyboard. The Keyboard page of the Customize dialog 
(Figure 33) opens.

Figure 36. Defining keyboard shortcuts for applying styles

2) To have the shortcut key assignment available only with one component (for example, 
Writer), select that component’s name in the upper right corner of the page; otherwise 
select OpenOffice.org button to make it available to every component.

3) Choose the shortcut keys you want to assign a style to. In this example, we have chosen 
Ctrl+9.

4) In the Functions section at the bottom of the dialog, scroll down in the Category list to 
Styles. Click the expansion symbol (usually a + sign or triangle) to expand the list of styles.

5) Choose the category of style. (This example uses a paragraph style, but you can also 
choose character styles and others.) The Function list will display the names of the 
available styles for the selected category. The example shows some of AOO’s predefined 
styles.
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6) To assign Ctrl+9 to be the shortcut key combination for the List 1 style, select List 1 in the 
Function list, and then click Modify. Ctrl+9 now appears in the Keys list on the right, and 
List 1 appears next to Ctrl+9 in the Shortcut keys box at the top.

7) Make any other required changes, and then click OK to save these settings and close the 
dialog.

Saving changes to a file
Changes to the shortcut key assignments can be saved in a keyboard configuration file for use at a 
later time, thus permitting you to create and apply different configurations as the need arises. To 
save keyboard shortcuts to a file:

1) After making your keyboard shortcut assignments, click the Save button at the right of the 
Customize dialog (Figure 33).

2) In the Save Keyboard Configuration dialog, select All files from the Save as Type list.

3) Next enter a name for the keyboard configuration file in the File name box, or select an 
existing file from the list. If you need to, browse to find a file from another location.

4) Click Save. A confirmation dialog appears if you are about to overwrite an existing file, 
otherwise the file will be saved immediately.

Loading a saved keyboard configuration
To load a saved keyboard configuration file and replace your existing configuration, click the Load 
button at the right of the Customize dialog, and then select the configuration file from the Load 
Keyboard Configuration dialog.

Resetting the shortcut keys
To reset all of the keyboard shortcuts to their default values, click the Reset button near the bottom 
right of the Customize dialog. Use this feature with care as no confirmation dialog will be displayed; 
the defaults will be set without any further notice or user input.

Adding functionality with extensions

An extension is a package that can be installed into OpenOffice.org to add new functionality.

Although individual extensions can be found in different places, the official extension repository is 
at http://extensions.services.openoffice.org/. Some extensions are free of charge; others are 
available for a fee. Check the descriptions to see what licenses and fees apply to the ones that 
interest you.

Installing extensions
To install an extension, follow these steps:

1) Download an extension and save it anywhere on your computer.

2) In AOO, select Tools > Extension Manager from the menu bar. In the Extension Manager 
dialog (Figure 30), click Add.

3) A file browser window opens. Find and select the extension you want to install and click 
Open. The extension begins installing. You may be asked to accept a license agreement.

4) When the installation is complete, the extension is listed in the Extension Manager dialog.

Tip To get extensions that are listed in the repository, you can open the Extension 
Manager and click the Get more extensions here link.

Adding functionality with extensions 35

http://extensions.services.openoffice.org/


Figure 37: Using the Extension Manager

Note To install a shared extension, you need write access to the Apache OpenOffice 
installation directory.

Some popular extensions
This section describes a few of the more important and popular extensions to Apache OpenOffice. 
In each case, you need to first install the extension as described in the previous section. All tools 
listed here are open source and free of charge.

PDF Import
Enables you to make minor modifications to the text of existing PDF files when the original 
source files do not exist or you are unable to open the source files. (Whenever possible, modify 
the source and regenerate the PDF to obtain the best results.)

When the extension is installed, PDF is listed as a choice in the File Type drop-down list in the 
File > Open dialog.

Best results can be achieved with the PDF/ODF hybrid file format, which this extension also 
enables. A hybrid PDF/ODF file is a PDF file that contains an embedded ODF source file. 
Hybrid PDF/ODF files will be opened in OpenOffice.org as an ODF file without any layout 
changes.

Non-hybrid PDF documents open in Draw. Depending on the complexity of the layout, changes 
may be easy or difficult to make, and the saved result may or may not preserve the original 
layout. Font substitution may occur.

Documents with more sophisticated layouts, such as those created with professional desktop 
publishing applications that use special fonts and complex vector graphics, are not suitable for 
the PDF Import Extension. Similarly, longer documents (> 20 pages) may cause some 
performance and stability problems.
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Professional Template Pack II
Provides more than 120 templates for Writer, Calc, and Impress. Available in several 
languages. After you have installed this extension, you will find the templates under File > New 
> Templates and Documents.

Template Changer (for Writer)
Adds two new items to the File > Templates menu in Writer that allow you to assign a new 
template to the current document or to a folder of documents. All styles and formatting will be 
loaded from that template and the document will behave as it was created using that template.

DataPilot Tools for Calc
Adds some utility functions that make using the Calc DataPilot easier:

• Display the current source range for a DataPilot

• Change the source range for a DataPilot

• Refresh all DataPilots on the current sheet
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