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Note for Mac users

Some keystrokes and menu items are different on a Mac from those used in Windows and Linux. 
The table below gives some common substitutions for the instructions in this chapter. For a more 
detailed list, see the application Help.

Windows or Linux Mac equivalent Effect

Tools > Options 
menu selection

OpenOffice.org > Preferences Access setup options

Right-click Control+click Open a context menu

Ctrl (Control) z (Command) Used with other keys

F5 Shift+z+F5 Open the Navigator

F11 z+T Open the Styles and Formatting window
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What is Apache OpenOffice?

Apache OpenOffice (OpenOffice.org) is a freely available, full-featured office productivity suite. Its 
native file format is OpenDocument, an open standard format that is being adopted by 
governments worldwide as a required file format for publishing and accepting documents. Apache 
OpenOffice can also open and save documents in many other formats, including those used by 
several versions of Microsoft Office.

Note
Apache OpenOffice 3.4 installs as OpenOffice.org 3.4. Therefore, icons, 
window title bars, options in dialogs, and other places show the name 
OpenOffice.org.

Apache OpenOffice includes the following components.

Writer (word processor)
Writer is a feature-rich tool for creating letters, books, reports, newsletters, brochures, and other 
documents. You can insert graphics and objects from other components into Writer documents. 
Writer can export files to HTML, XHTML, XML, Adobe’s Portable Document Format (PDF), and 
several versions of Microsoft Word files.

Calc (spreadsheet)
Calc has all of the advanced analysis, charting, and decision-making features expected from a 
high-end spreadsheet. It includes over 300 functions for financial, statistical, and mathematical 
operations, among others. The Scenario Manager provides “what if” analysis. Calc generates 2-D 
and 3-D charts, which can be integrated into other Apache OpenOffice documents. You can also 
open and work with Microsoft Excel workbooks and save them in Excel .XLS format. Calc can 
export spreadsheets to Adobe’s PDF and to HTML.

Impress (presentations)
Impress provides all the common multimedia presentation tools, such as special effects, animation, 
and drawing tools. It is integrated with the advanced graphics capabilities of Apache OpenOffice’s 
Draw and Math components. Slide shows can be further enhanced with Fontwork’s special effects 
text, as well as sound and video clips. Impress is compatible with Microsoft’s PowerPoint file 
format and can also save your work in numerous graphics formats, including Macromedia Flash 
(SWF).

Draw (vector graphics)
Draw is a vector drawing tool that can produce everything from simple diagrams or flowcharts to 3-
D artwork. Its Smart Connectors feature allows you to define your own connection points. You can 
use Draw to create drawings for use in any of Apache OpenOffice’s other components, and you 
can create your own clip art and add it to the Gallery. Draw can import graphics from many 
common formats and save them in over 20 formats, including PNG, HTML, PDF, and Flash.

Base (database)
Base provides tools for day-to-day database work within a simple interface. It can create and edit 
forms, reports, queries, tables, views, and relations, so that managing a connected database is 
much the same as in other popular database applications. Base provides many new features, such 
as the ability to analyze and edit relationships from a diagram view. Base incorporates HSQLDB as 
its default relational database engine. It can also use dBASE, Microsoft Access, MySQL, or Oracle, 
or any ODBC-compliant or JDBC-compliant database. Base also provides support for a subset of 
ANSI-92 SQL.
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Math (formula editor)
Math is Apache OpenOffice’s formula or equation editor. You can use it to create complex 
equations that include symbols or characters not available in standard font sets. While it is most 
commonly used to create formulas in other documents, such as Writer and Impress files, Math can 
also work as a standalone tool. You can save formulas in the standard Mathematical Markup 
Language (MathML) format for inclusion in web pages and other documents not created by Apache 
OpenOffice.

Minimum requirements

Apache OpenOffice 3.4 requires one of the following operating systems:

• Microsoft Windows XP, 2003, Vista, 7, or 8

• GNU/Linux Kernel version 2.6 and glibc 2.11.1 or higher

• Mac OS X 10.4 (Tiger) or higher

Some features (wizards and the HSQLDB database engine) require that the Java Runtime 
Environment (JRE) 1.5.x or higher be installed on your computer. Although Apache OpenOffice will 
work without Java support, some features will not be available.

How to get and install the software

You can download the installation package (approximately 150MB) from the project’s website, 
www.openoffice.org/.

To install Apache OpenOffice, follow the same procedure that you use to install other software.

Extensions and add-ons

Extensions and add-ons to enhance Apache OpenOffice are collected in the official extensions 
repository, http://extensions.services.openoffice.org/. Most are free, but some are not. See Chapter 
11 (Setting up and Customizing Apache OpenOffice) for more information.

Starting Apache OpenOffice

The most common ways to start Apache OpenOffice are:

• Using the system menu, the standard menu from which most applications are started. On 
Windows, it is called the Start menu. On Mac OS X, it is the Applications menu. On 
GNOME, it is called the Applications menu. On KDE it is identified by the KDE logo.

When Apache OpenOffice was installed on your computer, in most cases a menu entry for 
each component was added to your system menu. If you see only one icon, it opens the 
Start Center (Figure 10), from which the components can be started. The exact name and 
location of these menu entries depend on the operating system and graphical user 
interface.

• From an icon on the desktop or (on a Mac) the Launchpad.
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Starting from an existing document
You can start Apache OpenOffice by double-clicking on the filename of a document with an 
OpenDocument extension such as .odt, .ods, or .odp in a file manager such as Windows Explorer, 
Finder on the Mac, or Nautilus on Linux. The appropriate component will start and the document 
will be loaded.

Note for Windows users
If you have associated Microsoft Office file types with Apache OpenOffice, then when you double-
click on a *.doc (Word) file, it opens in Writer; *.xls (Excel) files open in Calc, and *.ppt 
(PowerPoint) files open in Impress.

If you did not associate the file types, then when you double-click on a Microsoft Word document, it 
opens in Microsoft Word (if Word is installed on your computer), Excel files open in Excel, and 
PowerPoint files open in PowerPoint.

You can use another method to open Microsoft Office files in Apache OpenOffice and save in those 
formats from Apache OpenOffice. See “Opening an existing document” on page 13 for more 
information.

Using the Quickstarter under Windows
The Quickstarter is an icon that is placed in the Windows system tray during system startup. It 
indicates that Apache OpenOffice has been loaded and is ready to use. (The Quickstarter loads 
library *.DLL files required by Apache OpenOffice, thus shortening the startup time for Apache 
OpenOffice components by about half.) If the Quickstarter is disabled, see “Reactivating the 
Quickstarter” if you want to enable it.

Using the Quickstarter icon
Right-click the Quickstarter icon in the system tray to open a pop-up menu (Figure 1) from which 
you can open a new document, open the Templates and Documents dialog, or choose an existing 
document to open. You can also double-click the Quickstarter icon to display the Templates and 
Documents dialog.

Figure 1: Quickstarter pop-up menu
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Disabling the Quickstarter
To close the Quickstarter, right-click on the icon in the system tray, and then click Exit 
Quickstarter on the pop-up menu. The next time the computer is restarted, the Quickstarter will be 
loaded again.

To prevent Apache OpenOffice from loading during system startup, deselect the Load 
OpenOffice.org during system start-up item on the pop-up menu. You might want to do this if 
your computer has insufficient memory, for example.

Reactivating the Quickstarter
If the Quickstarter has been disabled, you can reactivate it by selecting the Load OpenOffice.org 
during system start-up checkbox in Tools > Options > OpenOffice.org > Memory.

Using the Quickstarter in Linux and Mac OS X
Apache OpenOffice under Linux has a Quickstarter that looks and acts like the one described 
above for Windows. (The checkbox on the Memory page is labeled Enable systray quickstarter. 
If you do not have this checkbox, the Quickstarter module is not installed on your system.)

Mac OS X provides similar functionality through a pop-up menu from the dock.

Parts of the main window

The main window is similar in each component of Apache OpenOffice, although some details vary. 
See the chapters in this book about Writer, Calc, Draw, and Impress for descriptions of those 
details.

Common features include the menu bar, the standard toolbar, and the formatting toolbar at the top 
of the window and the status bar at the bottom.

Menu bar
The Menu bar is located across the top of the Apache OpenOffice window, just below the Title bar. 
(On a Mac it is at the top of the screen in the same location as the menu bar for other programs.) 
When you choose one of the menus listed below, a submenu drops down to show commands.

• File contains commands that apply to the entire document such as Open, Save, and Export 
as PDF.

• Edit contains commands for editing the document such as Undo: xxx (where xxx is the 
command to undo) and Find & Replace. It also contains commands to cut, copy, and paste 
selected parts of your document.

• View contains commands for controlling the display of the document such as Zoom and 
Web Layout.

• Insert contains commands for inserting elements into your document such as Header, 
Footer, and Picture.

• Format contains commands, such as Styles and Formatting and AutoCorrect, for 
formatting the layout of your document.

• Table shows all commands to insert and edit a table in a text document.

• Tools contains functions such as Spelling and Grammar, Customize, and Options.

• Window contains commands for the display window.

• Help contains links to the OpenOffice.org Help file, What’s This?, and information about the 
program.
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Toolbars
Apache OpenOffice has several types of toolbars: docked, floating, and tear-off. Docked toolbars 
can be moved to different locations or made to float, and floating toolbars can be docked.

The top docked toolbar is called the Standard toolbar. The Standard toolbar is consistent across 
the OpenOffice.org applications.

The second toolbar at the top is the Formatting toolbar. It is a context-sensitive bar that shows the 
relevant tools in response to the cursor’s current position or selection. For example, when the 
cursor is on a graphic, the Formatting bar provides tools for formatting graphics; when the cursor is 
in text, the tools are for formatting text.

Displaying or hiding toolbars
To display or hide toolbars, choose View > Toolbars, then click on the name of a toolbar in the list.
An active toolbar shows a checkmark beside its name. Tear-off toolbars are not listed in the View 
menu.

Submenus and tear-off toolbars
Toolbar icons with a small triangle to the right will display submenus, tear-off toolbars, and other 
ways of selecting things, depending on the icon.

Figure 2 shows a tear-off toolbar from the Drawing toolbar.

The tear-off toolbars can be floating or docked along an edge of the screen or in one of the existing 
toolbar areas. To move a floating tear-off toolbar, drag it by the title bar. See “Moving toolbars” 
below.

Figure 2: Example of a tear-off toolbar

 

Floating toolbars
Apache OpenOffice includes several additional context-sensitive toolbars, whose defaults appear 
as floating toolbars in response to the cursor’s current position or selection. For example, when the 
cursor is in a table, a floating Table toolbar appears, and when the cursor is in a numbered or bullet 
list, the Bullets and Numbering toolbar appears. You can dock these toolbars to the top, bottom, or 
side of the window, if you wish (see “Moving toolbars” below).

Moving toolbars
To move a docked toolbar, place the mouse pointer over the toolbar handle (the small vertical bar 
to the left of the toolbar), hold down the left mouse button, drag the toolbar to the new location, and 
then release the mouse button (Figure 3). To move a floating toolbar, click on its title bar and drag it 
to a new location (Figure 4).
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Figure 3: Moving a docked toolbar

 

Figure 4: Moving a floating toolbar

 

Docking/floating windows and toolbars
Toolbars and some windows, such as the Navigator and the Styles and Formatting window, are
dockable. You can move, resize, or dock them to an edge.

To dock a window or toolbar, hold down the Control key and double-click on the frame of the 
floating window (or in a vacant area near the icons at the top of the floating window) to dock it in its 
last position.

Figure 5: Control+click to dock or undock  

To undock a window, hold down the Control key and double-click on the frame (or a vacant area 
near the icons at the top) of the docked window.

Customizing toolbars
You can customize toolbars in several ways, including choosing which icons are visible and locking 
the position of a docked toolbar. You can also add icons and create new toolbars, as described in 
Chapter 11.

To access a toolbar’s customization options, use the down-arrow at the end of the toolbar or on its 
title bar.

Figure 6: Customizing toolbars
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To show or hide icons defined for the selected toolbar, choose Visible Buttons from the drop-
down menu. Visible icons are indicated by an outline around the icon. Click on icons to hide or 
show them on the toolbar.

Figure 7: Selection of visible toolbar icons  

Right-click (context) menus
You can quickly access many menu functions by right-clicking on a paragraph, graphic, or other 
object. A context menu will pop up. Often the context menu is the fastest and an easier way to 
reach a function. If you are not sure where a function is located in the menus or toolbars, you can 
often find it by right-clicking.

Status bar
The status bar is located at the bottom of the workspace. It provides information about the 
document and convenient ways to quickly change some features. It is similar in Writer, Calc, 
Impress, and Draw, although each component includes some component-specific items.

Figure 8: Left end of status bar in Writer  

Figure 9: Right end of status bar in Writer  

Common status bar items are described below.

Page, sheet, or slide number
Shows the current page, sheet, or slide number and the total number of pages, sheets, or 
slides in the document. Double-click on this field to open the Navigator. Other uses of this field 
depend on the component.
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Page style or slide design
Shows the current page style or slide design. To edit the current page style or slide design, 
double-click on this field.

Unsaved changes
An asterisk (*) appears here if changes to the document have not been saved.

Digital signature
If the document has been digitally signed, an icon shows here. You can double-click the icon to 
view the certificate.

Object information
Displays information relevant to the cursor’s position or the selected element of the document. 
Double-clicking in this area usually opens a relevant dialog.

Zoom slider and percent
To change the view magnification, drag the Zoom slider, or click on the + and – signs, or right-
click on the zoom level percent to pop up a list of magnification values from which to choose. 
Double-clicking on the zoom level percent opens the Zoom & View Layout dialog.

Starting a new document

You can start a new, blank document in Apache OpenOffice in several ways.

When Apache OpenOffice is open but no document is open (for example if you close all the open 
documents but leave the program running), the Start Center is shown. Click one of the icons to 
open a new document of that type, or click the Templates icon to start a new document using a 
template.

Figure 10: Apache OpenOffice Start Center  
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You can also start a new document in one of the following ways.

• Use File > New and choose the type of document.

• Use the arrow next to the New button on the main toolbar. From the drop-down menu, 
select the type of document to be created.

• Press Control+N on the keyboard.

• Use File > Wizards for some special types of documents.

If a document is already open in Apache OpenOffice, the new document opens in a new window.

Opening an existing document

When no document is open, the Start Center provides an icon for opening an existing document or 
choosing from a list of recently-edited documents.

You can also open an existing document in one of the following ways.

• Choose File > Open.

• Click the Open button on the main toolbar.

• Press Control+O on the keyboard.

In each case, the Open dialog appears. Select the file you want, and then click Open. If a 
document is already open in Apache OpenOffice, the second document opens in a new window.

In the Open dialog, you can reduce the list of files by selecting the type of file you are looking for. 
For example, if you choose Text documents as the file type, you will only see documents Writer 
can open (including .odt, .doc, .txt); if you choose Spreadsheets, you will see .ods, .xls, 
and other files that Calc opens.

You can also open an existing document that is in an OpenDocument format by double-clicking on 
the file’s icon on the desktop or in a file manager such as Windows Explorer.

If you have associated Microsoft Office file formats with Apache OpenOffice, you can also open 
these files by double-clicking on them.

Saving a document

To save a new document, do one of the following:

• Press Control+S.

• Choose File > Save from the menu bar.

• Click the Save button on the main toolbar.

When the Save As dialog appears, enter the file name, verify the file type (if applicable), and click 
Save.

To save an open document with the current file name, choose File > Save. This will overwrite the 
last saved state of the file.
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Password protection
To protect an entire document from being viewable without a password, use the option on the Save 
As dialog to enter a password.

1) On the Save As dialog, select the Save with password option, and then click Save. You 
will receive a prompt (Figure 11).

2) Type the same password in both  fields, and then click OK. If the passwords match, the 
document is saved password protected. If the passwords do not match, you receive an 
error message. Close the message box to return to the Set Password dialog and enter the 
password again.

Caution Apache OpenOffice uses a very strong encryption mechanism that makes it 
almost impossible to recover the contents of a document if you lose the 
password.

Figure 11: Entering a password for a document

Writer and Calc provide a second level of protection, which allows a file to be viewed but not 
changed without a password; that is, the file opens in read-only mode.

To protect a document from being changed:

1) Choose More Options from the Set Password dialog.

2) Enter the password in the Enter password to allow editing field. Repeat the password in the
Confirm password field. Click OK.

Saving a document automatically
You can choose to have Apache OpenOffice save files for you automatically. Automatic saving, like 
manual saving, overwrites the last saved state of the file. To set up automatic file saving:

1) Choose Tools > Options > Load/Save > General.

2) Mark Save AutoRecovery information every, and set the time interval.
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Closing a document

To close a document, choose File > Close.

You can also close a document by clicking on the Close icon on the document window. This button 
may look like the X shown in Figure 12. It may be in a different location on your operating system.

Figure 12. Close icons 

In Windows and Linux, if more than one OpenOffice.org window is open, each window looks like 
the sample shown on the left in Figure 12. Closing this window leaves the other OpenOffice.org 
windows open.

If only one OpenOffice.org window is open, it looks like the sample shown on the right in Figure 12. 
Notice the small X below the large X. Clicking the small X closes the document but leaves  
OpenOffice.org open. Clicking the large X closes Apache OpenOffice completely.

If the document has not been saved since the last change, a message box is displayed. Choose 
whether to save or discard your changes.

• Save: The document is saved and then closed.

• Discard: The document is closed, and all modifications since the last save are lost.

• Cancel: Nothing happens, and you return to the document.

Caution
Not saving your document could result in the loss of recently made changes, or 
worse still, your entire file.

Closing Apache OpenOffice

To close Apache OpenOffice completely, choose File > Exit, or close the last open document as 
described in “Closing a document” above.

If all the documents have been saved, Apache OpenOffice closes immediately. If any documents 
have been modified but not saved, a warning message appears. Follow the procedure in “Closing 
a document” to save or discard your changes.

Using the Open and Save As dialogs

You can choose whether to use the OpenOffice.org Open and Save As dialogs or the ones 
provided by your operating system.

To view or change which type of dialog Apache OpenOffice uses:

1) Choose Tools > Options > OpenOffice.org > General.

2) Select the Use OpenOffice.org dialogs option.

This section discusses the OpenOffice.org Open and Save As dialogs. Figure 13 shows the Save 
As dialog; the Open dialog is similar.
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Figure 13: The OpenOffice.org Save As dialog

The three buttons in the top right of the OpenOffice.org Open and Save As dialogs are, from left to 
right:

• Go Up One Level in the folder (directory) hierarchy. Click and hold this button for a second 
to drop down a list of higher level folders; to go to one of the folders on the list, move the 
mouse pointer over its name and release the mouse button.

• Create New Folder.

• Default Directory.

For documents (in OpenDocument format) that have been saved with more than one version, use 
the Version drop-down to select which version you wish to open in read-only mode. For Microsoft 
Office documents, only the current version can be opened.

Use the File type field to specify the type of file to be opened or the format of the file to be saved.

The Read-only option on the Open dialog opens the file for reading and printing only. 
Consequently, most of the toolbars disappear, and most menu options are disabled. An Edit File 
button is displayed on the Standard toolbar to open the file for editing.

You can open files from the Web by typing a URL in the File name field on the Open dialog.

Using the Navigator

The Navigator lists objects contained in a document, collected into categories. For example, in 
Writer it shows Headings, Tables, Text frames, Comments, Graphics, Bookmarks, and other items, 
as shown in Figure 14. In Calc it shows Sheets, Range Names, Database Ranges, Graphics, 
Drawing Objects, and other items. In Impress and Draw it shows Slides, Pictures, and other items.
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To open the Navigator, click its icon on the Standard toolbar, or press F5, or choose View > 
Navigator on the menu bar.

You can dock the Navigator to either side of the main Apache OpenOffice window or leave it 
floating (see “Docking/floating windows and toolbars“ on page 10).

Figure 14: The Navigator

Click the marker (+ or arrow) by any of the categories to display the list of objects in that category. 

To hide the list of categories and show only the toolbars at the top, click the List Box On/Off icon

. Click this icon again to show the list box.

The Navigator provides several convenient ways to move around a document and find items in it:

• When a category is showing the list of objects in it, double-click on an object to jump 
directly to that object’s location in the document.

Objects are much easier to find if you have given them names when creating them, instead 
of keeping Apache OpenOffice’s default graphics1, graphics2, Table1, Table2, and so on—
which may not correspond to the position of the object in the document.

If you only want to see the content in a certain category, highlight the category and click the

Content View icon . Until you click the icon again, only the objects of that category will 
be displayed.

• Click the Navigation icon  (second icon from the left at the top of the Navigator) to 
display the Navigation toolbar (Figure 15). Here you can pick one of the categories and use 
the Previous and Next icons to move from one item to the next. This is particularly helpful 
for finding items like bookmarks and indexes, which can be difficult to see.

The names of the icons (shown in the tooltips) change to match the selected category; for 
example, Next Graphic or Next Bookmark.

• To jump to a specific page in the document, type its page number in the box at the top of 
the Navigator.

A bit of experimentation with the other icons will demonstrate their functions. Some component-
specific uses are described in the chapters on Writer and the other components.
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Figure 15: Navigation toolbar

A bit of experimentation with the other icons will demonstrate their functions. Some component-
specific uses are described in the chapters on Writer and the other components.

Undoing and redoing changes

To undo the most recent change, press Control+Z, or click the Undo icon  on the Standard 
toolbar, or choose Edit > Undo from the menu bar.

The Edit menu shows the latest change that can be undone (see below for an example from 
Writer).

Figure 16: Edit > Undo last action

Click the small triangle to the right of the Undo icon to get a list of all the changes that can be 
undone. You can select multiple changes and undo them at the same time.

Figure 17: List of actions that can be undone

After changes have been undone, Redo becomes active. To redo a change, select Edit > Redo, or 

press Control+Y or click on the Redo icon . As with Undo, click on the triangle to the right of 
the arrow to get a list of the changes that can be reapplied.

To modify the number of changes Apache OpenOffice remembers, choose Tools > Options > 
OpenOffice.org > Memory and in the Undo section change Number of steps. Be aware that 
asking Apache OpenOffice to remember more changes consumes more computer memory.
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