
Xia
Create HTML5 interactive images

April 9, 2015



Contents

I Introducing Xia . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 1
a What is Xia ? . . . . . . . . . . . . . . . . . . . . . . . . . . 1
b General process . . . . . . . . . . . . . . . . . . . . . . . . . 1
c Installing Inkscape and Xia . . . . . . . . . . . . . . . . . . 1

II Creating your first interactive image using Inkscape and Xia: Basic
features . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 2
a Building the svg source file to generate an interactive image 2
b Generating the interactive image with Xia . . . . . . . . . . 5
c Firefox OS export: how does it work? . . . . . . . . . . . . . 5
d Abstract . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 8

III Enriched interactive image . . . . . . . . . . . . . . . . . . . . . . . 8
a Formatting text . . . . . . . . . . . . . . . . . . . . . . . . . 9
b Inserting multimedia resources into details . . . . . . . . . . 10
c The "audioBrown" template: sounds instead of text . . . . . 11
d Inserting images into your interactive image . . . . . . . . . 11
e Displaying a question and unveiling an answer . . . . . . . . 12
f Controlling details behavior : automatic display and dis-

abled zoom . . . . . . . . . . . . . . . . . . . . . . . . . . . 12
g Controlling order of details display in the lateral comment

zone . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13
h Abstract . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13

IV Creating games with Xia . . . . . . . . . . . . . . . . . . . . . . . . 15
a First game principle: selecting, finding elements in the image 15
b Second game principle: classyfying, ordering, ranking . . . . 16
c Third game principle: collisions . . . . . . . . . . . . . . . . 17
d Advanced interactive games creation tips: Magnet effect,

tooltips, double-scoring. . . . . . . . . . . . . . . . . . . . . . 18
e Abstract . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 21

V Frequently asked questions and Inkscape tips . . . . . . . . . . . . . 21
a FAQ . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 21
b Inkscape tips . . . . . . . . . . . . . . . . . . . . . . . . . . 21

I Introducing Xia

a What is Xia ?
Xia is a free software developped by teachers from the french academy of Ver-

sailles. It is released under GPLv3 license. Xia converter takes a svg file as input
and outputs an interactive image in html5. Xia allows to generate animations and
interactive activities : drag and drop games, discrimination, selection, etc.
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First sections of this documentation (see section II) are dedicated to make a
very simple interactive image: cropped details with comments only made of plain
text. Then, you will learn how to create an enriched interactive image (see section
III). Final sections (section IV) will teach you to create games.

All examples are on line (links and downloads available at the
beginning of each section). At the end of each section, a heading
"Abstract" presents the essential guide lines to remember when
creating an interactive image.

U

b General process
Xia is only needed at the end of the process. As we can see on figure 1, most of

the work is done with a vector graphics editor. We recommend using the free open-
source and muliplatform software Inkscape, which is really easy to use (Inkscape
will be used in this document) 1.

Open an Image in Inkscape

Create details in image

For each detail, edit metadata

Save project

In
ks
ca
pe

Create an interactive image in html5X
ia

Figure 1 – Creation process of an interactive image with Xia

If you have "image active" project files (with a .xia extension),
you can change their extension to .zip, unzip them, get the svg
file located in the unzipped folder, and open it with Inkscape. If
you are using GNU/Linux, just explore the .xia file and extract
the svg file.

U

c Installing Inkscape and Xia
Having Inkscape and Xia installed on your computer is the only thing you

need to read this documentation. You will find any relevant information about the
installation of Inkscape on its website 2

1. It is also possible to use LibreOffice Draw.
2. http://www.inkscape.org/.
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Make sure to install Xia after Inkscape. Otherwise you will not
be able to access Xia directly in Inkscape.
If you work on a Windows system, use the portable version to
access Xia outside of Inkscape.

�

GNU/Linux In a terminal:
$ sudo echo "deb http://repository.crdp.ac-versailles.fr/debian
xia main" | sudo tee /etc/apt/sources.list.d/xia.list
$ wget -q http://repository.crdp.ac-versailles.fr/crdp.gpg -O -
| sudo apt-key add -
$ sudo apt-get update && sudo apt-get install xia

Mac OS X Download and install the package:
http://xia.dane.ac-versailles.fr/download/xia.pkg

Windows Download and install the Inkscape extension (http://xia.dane.ac-
versailles.fr/download/setup.exe) or the portable version (http://xia.dane.ac-
versailles.fr/download/xia-windows.zip).

II Creating your first interactive image using Inkscape
and Xia: Basic features

a Building the svg source file to generate an interactive
image

Explore the interactive image created for this section of the doc-
umentation.
Download the svg source file.

R

Manipulations described in this section will help you to create a "basic" inter-
active image featuring:

— Zoom-in enabled details
— Comments on details only made of plain text
Once you have chosen the image you will work with, open it with Inkscape:
File → Open
When asked by the software if you wish to "Link" or "Incorporate image",

choose "Incorporate".
The information filled in the document Metadata (File menu) will be included

in the interactive image once generated : title, creator, rights, . . . . It is highly
recommended to type in this information. You can see what it looks like once
generated on the image below 3:

3. The fields "author" and "rights" appear in the window "About", symbolized by a clickable
button shaped like the letter "i"
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The title entered in the metadata of the document appears above the interactive
image and gives its name to the web page. The creator and rights appear in the
pop up associated with the "i" button on the right of the title of the interactive
image.

You can save the image in svg format in the earlywork, through File → Save
as....

For more clarity, you should remove the current extension of the image in
the field Name of the dialog window. Finally, in the dropdown menu, choose the
Inkscape svg file format:

SVG Inkscape (*.svg).
Several Inkscape tools can be used to clip the details that will become active

in the animation generated by Xia. Among these:

— Create rectangles and squares

— Create circles, ellipses and arcs

— Draw freehand lines

— Bezier curves and straight lines
Without going in the detail of how these tools work 4 note that the tool "Draw

Bezier curves and straight lines" allows to crop "click by click" (work points
are called "nodes"). You close the figure by clicking on the start node. You can
draw "Bezier curves" by keeping the mouse button pressed after creating a node,
then moving the cursor to bring up the control handles to shape the curve segment
as desired.

If you set a left open shape in Inkscape (for example a line), Xia
will automatically close it by connecting a straight line between
the beginning and the end of it.

�

The order of creation of details in Inkscape will be the same in the
html5 interactive image (for example: the first created detail in
Inkscape will appear at the top of the interactive image). If you
wish to change the sequence without having to create the details
once more, see section g.

�

Once you have cut out a detail 5, you can select it with the tool Select and
transform object to resize it, move it. . .

4. For this, refer to Inkscape manual or Floss manual.
5. The colour of the border will be the same in Inkscape and in the animation generated by

Xia.
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If you have some difficulties to select the details you have drawn,
apply a colour background to them. Choose whatever colour you
like, except for black and white (see why in section f).

U

You can access to the Object properties by right-clicking on the cut-out de-
tail. Thus you also access to the dialog window in which you add the text to be
associated with the detail in the interactive image:

The two fields to be filled in this window are Title and Description. The
title filled in here will be that of the detail, description will be its comment. Do
not forget to click on the Define button before you close the Object Properties
dialog window.

The process described above must also be done with the background image
: the title and description indicated here will serve as an introduction to the
interactive image (title and comment not related to a particular detail).

b Generating the interactive image with Xia
When all the details are clipped and their metadata indicated, Xia can be

launched (see figure 2). You must select the svg source file with the top left
icon 6, choose the export options (see figure 3), and then choose a template and
the destination folder of the interactive image.

Clicking on one of the template icons generates a series of files and folders.
Open the index.html file in a webbrowser to see the html5 interactive image.

6. When launched as an Inkscape extension, the top left icon has a different look, and can
not be selected, since Xia assumes you want to create the html5 animation from the image you
are working on in Inkscape.
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This file will not display anything if used alone. All the other
files and directories generated during the export process must be
stored in the same folder (see figure 4) as the index.html file so
that the animation works properly. It is therefore essential to
dedicate a specific directory for each exported image.

�

Select the svg
source file

Define the options of
the export (see figure
3)

accordionBlack
Large comment zone,
suitable for the in-
sertion of multimedia
resources; to be used
with vertical images
(portrait)

accordionCloud
Narrow comment
zone, with more space
for the image itself ;
to be used with hor-
izontal images (land-
scape)

popYellow
No lateral comment
zone ; a first click
on the detail reveals
it, and a second one
simultaneously un-
veils the comment
and triggers the zoom
function

buttonBlue
No lateral comment
zone ; comments ap-
pear above the im-
age (suitable for long
comments) ; the users
access the comments
through icons placed
above the interactive
image

popBlue
No lateral comment
zone; a first click
on the detail reveals
it, and a second one
pops up the comment
(no zoom)

Figure 2 – Xia’s templates

In fact, since Xia is also an Inkscape plugin, you can generate your project
directly in Inkscape: just click on Plugins → Various → Xia Édu, and choose
your template and destination folder.
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Select the
quality of the
export on a
scale from 1
to 4

Activate or Deacti-
vate the creation of
the FirefoxOS files
(default: deactivated)

In the unique file configuration, you will need an inter-
net connection to access the resource. The xia engine
used in the unique file configuration is hosted on Ver-
sailles academy servers and is automatically updated.
In this configuration, you can not control the back-
ground image and icons (default: deactivated)

Figure 3 – Xia’s exportation options

my_project/

index.html
deploy.html
manifest.webapp
css/
data/
font/
img/
js/
videos/

video.mp4
video.ogv

video.webm

These files and folders have
been manually created by
the interactive image de-
signer. The folder videos
was also manually created,
in order to host videos in-
serted in the comments of
the interactive image using
relative links.

Files and folders generated
by Xia from the svg source
file.

Files generated with Fire-
fox OS export activated

Figure 4 – Files of an interactive image with FirefoxOS export activated
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If you use GNU/Linux or Mac OS X, you can generate your html5
animation using the terminal with the command xia-converter.
The parameters are -i to indicate the input file, -o to indicate
the exportation folder, and -t to indicate the template.
GNU/Linux
$ xia-converter -i myfile.svg -o export_folder/ -t
accordionBlack
Mac OS X
$ cd /Applications/xia.app/Contents/Resources/
$ python xia.py -i myfile.svg -o export_folder/ -t
gameDragAndDrop
The template accordionBlack will be chosen if a syntax error is
made in the -t parameter.

U

c Firefox OS export: how does it work?

If you do not intend to create FirefoxOS applications, skip this
section.

�

Once you have generated the interactive image with the Firefox OS option (see
figure 3), you have to modify the content of deploy.html and manifest.webapp.

1. In the deploy.html file, modify this line:
var manifestUrl = ’http://my-webserver.com/manifest.webapp’;

And indicate the future url of the manifest.webapp file.
2. In the manifest.webapp file, modify these lines:

"name": "XIA",
"size" : define_package.zip_size_here,
"release_notes" : "generated with XIA",
"launch_path": "/index.html",
"package_path" : "http://my-webserver.com/package.zip",
"developer": {

"name": "Académie de Versailles"

The "name", "size", and "package_path" lines are mandatory 7.
Once you have made these modifications, zip all the exportation files and upload

the archive, the deploy.html and the manifest.webapp files to a web server.
When the user opens the deploy.html file in the Firefox OS browser, their

phone will download the interactive image and transform into a html5 application.

Applications made with the FirefoxOS export can also be installed
on GNU/Linux, Mac OS X and Windows operating systems.

U

7. The tricky part is the "size" line, where you must indicate the size of the package even
before you have zipped it.
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d Abstract
1. An interactive image is first built in Inkscape (svg format). Xia only con-

verts the svg source file into an html5 animation ;
2. The title of the interactive image must be indicated in the Metadata of

the document ;
3. The text of the details must be filled in the Object properties, in the

Title and Description fields of the cut out details ;
4. The general description of the interactive image must be indicated in the

Object properties of the background image.

III Enriched interactive image

Explore the interactive image created for this section of the doc-
umentation.
Download the svg source file.

R

In this section, the goal is still to create a "traditional" interactive image (ie.
in which a detail matches with a comment), but the content of the comments will
be enriched with formatted text or multimedia resources.
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a Formatting text
In order to insert formatted text, the tags described in figure 5 should be used.

This text is ***bold***
This text is in bold

This text is in **ital-
ics**

This text is in italics

This text is in
{{{typewriter}}}

This text is in
typewriter

A link to
[https://www.wikipedia.org/ Wikipedia]

A link to Wikipedia

A link to a
[./foo/bar.pdf local file]

A link to a local file a

a. This will not work
on your computer!

Making a list
∗ of bullets
∗ out of
∗ 2 levels a

a. Insert a
(space) before the ∗

Making a list
— of bullets
— out of

— 2 levels

Drawing
- - - -
a line

Drawing

a line

Figure 5 – Tags to format text
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Links to local files must be relative links. Use ./ if the file is con-
tained in the exportation folder, and ../ if the file is somewhere
in a parent folder. Two examples:

— ./folder/file.pdf means that your file is dropped here:
exportation_folder /

index.html
css/
data/
font/
img/
js/
folder/

file.pdf

Exportation
files and folder

Local file

— ../file.pdf means that your file is in a parent folder:
folder/

file.pdf
exportation_folder/

index.html
css/
data/
font/
img/
js/

Exportation
files and folders

Local file

�

b Inserting multimedia resources into details
Inserting multimedia resources into details comments is quite easy: just paste

the resource url (relative or absolute link) or iframe tag of the web service you
want to use. Xia will automatically create a multimedia player in the comment as
long as the resource (image, sound or video) matches its supported formats:

Images jpg, jpeg, png, gif
Audio ogg, mp3
Video ogv, webm, mp4
The link has to be inserted into the Description field of the Object Properties.

Absolute link If the resource url is
http://web.crdp.ac-versailles.fr/02546.ogg
just type it in the Description field of the Object Properties in Inkscape

Relative link If the multimedia file is located in the interactive image folder
or in a folder (see figure 4 and section a) within this one, just indicate

11



its location, keeping in mind that the interactive image folder has to be
considered as the root folder. For example, if the video.ogv file is located
in a videos folder located itself in the interactive image exportation folder,
just indicate:
./videos/video.ogv
in order to create the player.

Since video formats supported by Xia are not natively supported
by every web browsers, it is recommanded to export videos into
the 3 supported formats, and to upload them into a single folder
(from there, the only difference between these files is their ex-
tension, ie. .ogv or .mp4 or .webm). Even if a particular for-
mat is indicated in the description (following the previous exam-
ple : ./videos/video.ogv), if the browser is unable to read the
resource, it will automatically attempt to read the files of the
same name possessing a different extension (ie. video.mp4 then
video.webm).

U

The last option is to insert an iframe tag. It will be interpreted and the reader
will appear in the comment, giving access to the resource.

c The "audioBrown" template: sounds instead of text

Explore the interactive image created for this section of the doc-
umentation.
Download the svg source file (zip file containing the svg source file
and the sounds).

R

The "audioBrown" template is specifically dedicated to the creation of interac-
tive images in which details are associated with sounds instead of text.

The method to insert sounds using absolute or relative links is described in
section b. If you wish the sound to play automatically as the user clicks on the
comment, just add autostart right after the url 8:

./sounds/detail_1_sound.ogg autostart

d Inserting images into your interactive image
Png images can be added to the background. To do so, select File → Import

in Inkscape to incorporate your new image.
The imported image will only appear in the html5 animation if you have ap-

plied white background in Inkscape. Choose white in the horizontal colour palette
at the bottom of Inkscape interface:

8. The "autostart" tag also works with the other Xia templates.
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By indicating a url in the Title of Object properties field, the embedded
image becomes a clickable icon linking to a web page.

e Displaying a question and unveiling an answer
You can create clickable icon which will momentarily prevent the user to read

the end of the comment. You can even ask the user to enter a password to read
the end of the comment.

To do so, just indicate, in the description, the tags described in figure 6.

[[Can I ask you a ques-
tion? (code=12345):
Yes, indeed I can.]]

Figure 6 – Tags to insert a button which will momentarily prevent the user to read
the end of the comment

Use the double brackets tag [[ (...) ]] to indicate you wish to create the
icon, split the text between the question and the answer with the : tag, and add
a code by inserting (code=insert_password) just before the : tag 9.

f Controlling details behavior : automatic display and dis-
abled zoom
Default behavior of details in an interactive image consists in:
— highlighting details only on mouse over or with a click on the comment

detail title
— zoom in effect when clicking again on the active detail 10

Both of these default behaviors can be modified if you apply a white or black
background to cropped details (see section d):

9. The (code=...) is not mandatory. Remember that you can not insert the ) character in
the password.
10. Except for the popBlue template.
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Detail with a white background In the generated image, details will be
immediately visible as a flat area of opaque color, hiding the background
image; once selected, it reveals the background (the zoom effect is still
active).

Detail with a black background Users still have to click on the detail to
unveil it, but the zoom effect is disabled.

Logical consequence : you can not apply a white and a black background all
together on the same detail. A single detail can not be immediately displayed and
have the zoom effect disabled.

g Controlling order of details display in the lateral com-
ment zone

By default, in the interactive image, the details appear vertically following the
order in which these details have been created (the first detail created in Inkscape
corresponding to the detail placed up in the sidebar of the interactive image).

We will work with the Edit → XML Editor to change this default order.
A priori complex to manage, this dialogue window is in fact quite easy to use

: by selecting the input in the XML editor, the corresponding detail will be high-
lighted on the image and the only thing left to do is to drag the files to the desired
location:

The Inkscape XML editor allows to control the display order of the details in
the interactive image. Note the highlighting of an element in the editor and on
the background image by a single mouse click.

h Abstract
1. You can enrich and shaping text using tags
2. A multimedia enrichment is possible through a simple link (relative or ab-

solute) to a file whose format is recognized by Xia
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3. Adding images to the background image is possible by importing them and
applying them a white background

4. It is possible to modify the default behavior of a detail by changing its color
background (white, black)

5. The order of the details in the interactive image depends on the order of
their creation in Inkscape. Nevertheless, the Inkscape XML editor allows
to change this order

6. It is possible prevent the user to access the comments by inserting a clickable
icon and / or a password
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IV Creating games with Xia
Until now, this document was only about creation of traditionnal "interactive

images": background image enriched with cropped details associated with texts.
This kind of interactive image can be used in class in various situations (stu-

dents progressively discovering a document, or creating an interactive image on
their own), but Xia introduces new features, such as the creation of games and
activities, in which the final user has much more to do than simply clicking on
details in order to read the comment.

Select the svg
source file

Define the options of
the export (see figure
3)

game1clic
selecting details on a
background image
How-to in section a

audioBrown
creation of interac-
tive images in which
details are associated
with sounds
How-to in section c

gameDragAndDrop
drag and drop graph-
ical elements on the
background images
How-to in section b

Figure 7 – Xia’s games and multimedia templates

a First game principle: selecting, finding elements in the
image

The game principle described in this section consists in selecting details on a
background image. When the user has reached the goal described in the instruc-
tions, a message appears in a final pop up.
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Goal Enter the number of correct
answers needed to complete
the game

Display a message

Tag <score></score>| <message></message>
Example <score>6</score>

<message>Congratulations!
You have completed the game!</message>

Table 1 – Sum up of tags in a game1clic game

Explore the interactive image created for this section of the doc-
umentation.
Download the svg source file.

R

This kind of game is almost the easiest way to create an interactive image. You
only have to crop the details that the final user will have to select.

The instructions must be completed in the metadata of the document. Xia will
look into the informations filled in the Description field of the metadata of the
document (see section a: File → Metadata of the document), and create an
instruction « pop up » that will show up at the opening of the game. The player
will just have to read the instructions and close the pop up to play the game.

When the user completes the game, a message automatically appears. This
message has to be filled in the Description field of the Object Properties of
the background image.

Two informations are needed in order for this message to pop up : the exact
number of details that have to be selected 11 and the message itself (see table 1).

Text inserted inside the <message></message> tag can be en-
riched. Images, videos or sounds can be inserted. It is also possi-
ble to insert a link, allowing users to play another game, in order
to "chain" activities up by degree of difficulty.

U

Once your svg source file is created, choose the template game1clic to generate
the interactive game.

b Second game principle: classyfying, ordering, ranking
The second kind of game that can be created with Xia consists in dragging and

dropping graphical elements on the background image. If all the elements have been
dropped on their corresponding drop zone, a pop up message appears, confirming
the achievement of the game.

Explore the interactive image created for this section of the doc-
umentation.
Download the svg source file.

R

11. This number does not have to match the number of details on the image.

17

http://xia.dane.ac-versailles.fr/demo/tuto/xia3
http://xia.dane.ac-versailles.fr/demo/tuto/xia3/svg/xia3.svg
http://xia.dane.ac-versailles.fr/demo/tuto/xia5
http://xia.dane.ac-versailles.fr/demo/tuto/xia5/svg/xia5.svg


Graphical element (drag and drop
objects in the game)

Cropped detail (drop
zone)

ID Field Detail_Title
Description
Field

<target>Detail_Title</target>

Table 2 – Sum up of tags in the gameDragAndDrop template

This is how you can create a game based on the drag and drop principle :
1. In Inkscape:

— Choose and import a background picture
— Create the graphical elements the users of the interactive image will

have to drag and drop (ie. images or group of words: see below for a
how-to)

— Create the instruction pop up in File → Metadata of the document
→ Description 12

— Using metadata, make each label match its drop zone (actually being
cropped details)

2. In Xia
— Export the svg source file using the gameDragAndDrop template

Two methods can be used to create the drag and drop "graphical-elements".
A very simple way is to use a screenshot tool, in order to create png files, and
then import them in Inkscape. It is also possible to create these elements directly
in Inkscape, by creating a text, grouping it with a shape, and finally making a
bitmap copy of this group (Edition → Make a bitmap copy)

The graphical elements then have to be associated with their drop zone 13.
In order to do that, make the ID field of the drop zone match the Description
field of the drag and drop graphical element. The only subtlety consists in the
<target></target> tags which have to be filled in the Description field.

You will find in the table 2 an abstract of the metadata to be filled in the Object
Properties of the drag and drop graphical elements and the corresponding details
in order to make them match.

Once your svg source file is created, choose the template gameDragAndDrop to
generate the interactive game.

c Third game principle: collisions
The game principle described in this section consists in moving objects within

bounds you defined. Typically, the "collisions" game principle can be used to create
mazes or gem puzzle.

Explore the interactive image created for this section of the doc-
umentation.
Download the svg source file.

R

12. Exactly as in the game1clic template.
13. One object can only match one drop zone.
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In order to create this kind of game, add the tag <collisions>on</collisions>
to the background image. All the details will then become solid and will prevent
objects (png imported files or bitmap copies of shapes created in Inkscape) from
being moved through them.

The "collision" game is in fact a gameDragAndDrop game, since the goal re-
mains to drag one or several objects and drop them somewhere on the image. The
requisite tags for this template are therefore the same as in the gameDragAndDrop
template 14, but you will apply the <collisions>off</collisions> tag to the
drop zone’s Description field.

Once your svg source file is created, choose the template gameDragAndDrop to
generate the interactive game.

d Advanced interactive games creation tips: Magnet ef-
fect, tooltips, double-scoring. . .

Showing the player’s score (game1clic template)

It is possible to display graphical elements automatically when the user selects
the correct answer. These elements can be png imported images or shapes directly
designed in Inkscape. But as Xia considers as a clickable detail any shapes designed
using Inkscape tools, you will have to transform these shapes in bitmap, using the
"bitmap copy" Inkscape tool. For example :

1. Draw a star with yellow sides on a yellow background with the Inkscape
tools

2. Select this star, and click on the Edition → Make a bitmap copy

3. Delete the first star
When the graphical elements are imported (png files) or created (bitmap copy

of shapes created manually), just apply the following carasteristics to these ele-
ments:

Interactivity > OnClick = off

Then, group the clickable detail to its graphical element (by successively clicking
on the detail and the graphical element with the Shift ⇑ keystroke on), then select
Group in the Inkscape Object menu.

Showing the player’s mistakes (game1clic template)

Games based on the details selection principle are obviously very interesting
educational games. . . but it is also quite obvious to guess how some students may
be tempted to cheat to achieve such games (for example, by frenetically clicking
everywhere on the image, until the final message pops up).

This is why it may be interesting to be able to highlight the user’s mistakes
during the game.

To do so, you will anticipate the user’s probable mistakes, and put explicit
graphical elements symbolizing these errors on the background image. This graph-
ical element may be an imported image (png file) or a shape directly designed with

14. <target></target> on the objects, <score></score> and <message></message> on the
background image: see section b.

19



the Inkscape tools, then converted into bitmap (see section d).. These elements
will have to include the following caracteristics:

Interactivity > OnClick = disable-score

When applied with a disable-score tag, a detail still remains clickable, but does
not add a score to the counter that delivers the final success message pop up.

How to add a "magnet" effect (gameDragAndDrop template)

If you indicate <magnet>on</magnet> in the Description field of the drop
zone, a magnet effect will then be active when the player drops the graphical
element onto its matching drop zone.

Links on drop zones (gameDragAndDrop template)

You can insert links in the Title field of the Object Properties of the drop
zones. The user can then open the link by clicking on it or by dropping its corre-
sponding detail on it.

Tooltips (game1clic and gameDragAndDrop templates)

Explore the interactive image created for this section of the doc-
umentation.
Download the svg source file.

R

It is possible to display tooltips of details on mouse-over. To do so, create the
tooltip with a png imported file or a bitmap copy (see section d) of a text created
in Inkscape 15, and apply to this tooltip a specific ID in its Object Properties.
Then, just apply the tag <tooltip>specific_ID_of_the_tooltip</tooltip> in
the Description field of the Object Properties of the detail that is supposed
to make the tooltip appear (for example, in the image below: on mouse-over, the
yellow square makes the tooltip “Test” appear):

15. Or a bitmap copy of a shape grouped with some text. . .
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Note that the tooltip tool is available in the game1clic and in the gameDra-
gAndDrop templates.

Double scoring (game1clic and gameDragAndDrop templates)

If you indicate score2 in the onclick field (Object Properties → Interactivity)
of the detail, and if you use <score2></score2> and <message2></message2> in
the Object Properties of the background image, you create a double scoring
game. In this kind of game, the user can select two different categories of details,
two messages can pop up at the end, depending on the category and number of
details the user has selected.

For example, you can create a game with 3 details tagged with score2 (corre-
sponding to mistakes), and indicate in the Object Properties of the background
image:
<score>4</score>
<message>Hurray!</message>
<score2>3</score2>
<message2>Three mistakes... that is a bit too much... Concentrate more
and do it again</message2>
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e Abstract
These tables sum up the tags that have to be indicated when a game is created:

V Frequently asked questions and Inkscape tips

a FAQ
I can not see the Xia extension in Inkscape. Why?

→ Have you installed Inkscape first? If not, you must install Xia. If you use the
portable version, Xia does not appear in the extension menu.

The "source file" icon does not appear when I launch Xia from the
extension menu of Inkscape. Why?
→When you launch Xia as an Inkscape extension, there is no "Source File" button,
since Xia assumes you want to create the html5 animation from the image you are
working on in Inkscape. Just choose the exportation options and the template.

I have installed Xia but I can not find it. How can I launch it?
→ Xia can be found in the "Applications" of Mac OS X. On a GNU/Linux system,
the Xia package is called "xia-converter". In Windows, Xia is only an Inkscape
extension. If you wish to launch Xia without Inkscape, use the portable version.

I have added some text on my image with the Inkscape text tool
("Create and Edit text objects"), but it does not appear on my interac-
tive image. Why?
→ Unless you make a bitmap copy of the text, Xia will consider the text created
with the "Create and Edit text Objects" as a detail, and not an image.

b Inkscape tips
— Don’t hesitate to fill your details with different colours. The details will be

easier to select and modify, and it will not have any consequences on the
html5 animation (unless you choose black or white as filling colors)

— If you want to create one detail out of several, you can "Group" them
(Object → Group, or Ctrl + G ) or "Unify" them (Path → Union,
or Ctrl + + ).

— Once a detail is created, it is always possible to modify it: you can add or
remove nodes, move them, etc. Just double-click on the detail, and use the
modifying tools:

— Some keyboard shortcuts are real time savers!
1. Shift ⇑ + Ctrl + a to access the Alignment and Distribution

tools
2. Shift ⇑ + Ctrl + o to access the Object Properties

3. Alt + b to create a bitmap copy of a shape designed in Inkscape

4. Ctrl + g to group different objects or details and Ctrl + Shift ⇑ + g

to ungroup them
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game1clic template
<score></score>

Role Sets the amount of correct answers needed to pop up
the end message of the game

Element Background picture
Where ? Object properties → Description
What ? A number corresponding to the required score

<message></message>
Role Pops up the end message of the game
Element Background picture
Where ? Object properties → Description
What ? A personalized message if necessary enriched with mul-

timedia or html links
off

Role Makes a cropped detail unclickable
Element Detail
Where ? Object properties → Interactivity → Onclick

disable-score
Role Makes a cropped detail clickable, but when clicked, does

not add a point to the score game counter
Element Detail
Where ? Object properties → Interactivity → Onclick

score2
Role Makes a detail add a score to the score2 counter
Element Detail
Where ? Object properties → Interactivity → Onclick

<tooltip></tooltip>
Role Displays a tooltip when moused-over
Element Detail
What ? Make sure to match the ID of the element used as tooltip
Where ? Object properties → Description

<score2></score2>
Role Sets the amount of correct answers needed to pop up

the second end message in a double scoring game
Element Background picture
Where ? Object properties → Description
What ? A number corresponding to the required score

<message2></message2>
Role Pops up the second end message in a double scoring

game
Element Background picture
Where ? Object properties → Description
What ? A personalized message if necessary enriched with mul-

timedia or html links

Table 3 – Complete game1clic tags
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gameDragAndDrop template
<score></score>

Role Sets the amount of correct answers needed to pop up
the end message of the game

Element Background picture
Where ? Object properties → Description
What ? A number corresponding to the required score

<message></message>
Role Pops up the end message of the game
Element Background picture
Where ? Object properties → Description
What ? A personalized message if necessary enriched with mul-

timedia or html links
<target></target>

Role Indicates the corresponding drag and drop element and
drop zone

Element Graphical element to move
Where ? Object Properties → Description
What ? Make sure to match the ID field of the drop zone

<magnet>on</magnet>
Role Adds a "magnet" effect
Element Drop zone
Where ? Object Properties → Description

<collisions>on</collisions>
Role Activates the "collisions" game principle
Element Background picture
Where ? Object Properties → Description

<collisions>off</collisions>
Role Creates a drop zone in a "collisions" game
Element Drop zone
Where ? Object Properties → Description

<tooltip></tooltip>
Role Displays a tooltip when moused-over
Element Drop zone, Graphical element to move
What ? Make sure to match the ID of the element used as tooltip
Where ? Object properties → Description

<score2></score2>
Role Sets the amount of correct answers needed to pop up

the second end message in a double scoring game
Element Background picture
Where ? Object properties → Description
What ? A number corresponding to the required score

<message2></message2>
Role Pops up the second end message in a double scoring

game
Element Background picture
Where ? Object properties → Description
What ? A personalized message if necessary enriched with mul-

timedia or html links

Table 4 – Complete gameDragAndDrop tags
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— If you create your interactive image directly with the Inkscape drawing
tools (with bitmap copies of shapes or imported images), it is highly rec-
ommended to group all the objects, make a bitmap copy of them, and use
this bitmap copy as a background image. Otherwise, some images or bitmap
copies may disappear in the interactive image when details in top of them
are selected (since the main purpose of a detail is to let the user see the
background image when selected).
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