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How to use this user guide

This handbook accompanies the taught sessions for the course. Each section 
contains a brief overview of a topic for your reference and then one or more 
exercises.

Exercises are arranged as follows:

•	 A title and brief overview of the tasks to be carried out;

•	 A numbered set of tasks, together with a brief description of each;

•	 A numbered set of detailed steps that will achieve each task.

Some exercises, particularly those within the same section, assume that you have 
completed earlier exercises. Your teacher will direct you to the location of files that 
are needed for the exercises. If you have any problems with the text or the exercises, 
please ask the teacher or one of the demonstrators for help.

This book includes plenty of exercise activities – more than can usually be completed 
during the hands-on sessions of the course. You should select some to try during the 
course, while the teacher and demonstrator(s) are around to guide you. Later, you 
may attend follow-up sessions at ITLP called Computer8, where you can continue 
work on the exercises, with some support from IT teachers. Other exercises are for 
you to try on your own, as a reminder or an extension of the work done during the 
course.

Text conventions
A number of conventions are used to help you to be clear about what you need to do 
in each step of a task.

•	 	In general, the word press indicates you need to press a key on the keyboard. 
Click, choose or select refer to using the mouse and clicking on items on the 
screen. If you have more than one mouse button, click usually refers to the left 
button unless stated otherwise.

•	 	Names of keys on the keyboard, for example the Enter (or Return) key are 
shown like this ENTER.

•	 	Multiple key names linked by a + (for example, CTRL+Z) indicate that the 
first key should be held down while the remaining keys are pressed; all keys 
can then be released together.

•	 	Words and commands typed in by the user are shown like this.

•	 	Labels and titles on the screen are shown like this.

•	 	Drop-down menu options are indicated by the name of the options separated 
by an angle bracket, for example File>Print. In this example you need to 
select the option Print from the File menu. To do this, click with the mouse 
button on the File menu name; move the cursor to Print; when Print is 
highlighted, click the mouse button again.

•	 	A button to be clicked will look like this

•	 	The names of software packages are identified like this, and the names of files 
to be used like this.
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Software used
Inkscape 0.48.5 r10040
Windows XP or Mac OSX

Files used
Course files folder containing images and documents
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Setting up

Setting up Inkscape

The preferences dialogue is accessed from the File menu.  It lets you customize many 
aspects of the way Inkscape works.

Open Inkscape 
and set 
preferences

Steps

1.	 Open Inkscape.

2.	 Choose File>Inkscape Preferences... This will launch 
the Inkscape Preferences dialogue.

Preferences worth setting include the Rotation snap 
angle under the Step entry; and setting the Default export 
resolution under the Import/Export entry

Overflow exercise Steps

1.  Choose File>Open...  This will launch the Select file to 
open dialogue box.

2.  You will notice that there are options along the top of the 
dialogue box as well as the usual list of folders and drives 
down the left hand side to help you navigate and locate a file 
or folder.

3.  Select the image file called marine life 01.jpg

4.  Choose to embed the image and then click OK.

The aim is to try and recreate this illustration.

Treat this as an overflow exercise while you are waiting, or 
if you finish the exercises in the course book early and would 
like a challenge!

Notes
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Image navigation

Exercise - Using the Zoom Tool

An Inkscape drawing can be viewed in many different ways.  The view can be changed 
by panning and by zooming the canvas.  The Inkscape window can be made full 
screen.

Open an image Steps

1.  Open the SVG file called Houses of Parliament 01.svg  

Use the Zoom in 
or out tool

Steps

1.  From the Tool Box select the Zoom in or out tool (F3) 

.

2.  Move your mouse cursor over the image.  You will notice 
the cursor shows a magnifying glass symbol with a small + 
(plus) sign inside it.

3.  Click with the mouse in the image to zoom in.

4.  Hold down the Shift key.  The symbol in the magnifying 
glass should change to a - (minus) sign.

5.  While holding down Shift click with the mouse in the 
image to zoom out.

Zoom tool options Steps

1.  Take a look at the Tool Controls for the Zoom tool.  You 
will see there are other options for zooming.

2.  Hover your mouse pointer over each in turn to see a tool 
tip describing each option.

Scroll bars Steps

1.  To save zooming in and out of an illustration you can use 
the scroll bars along the bottom and up the right hand side 
of the screen to pan your image while maintaining the current 
level of magnification.

Notes

Tool Controls for the Zoom in and out tool
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Introduction

Exercise - Create simple vector based shapes

The advantage a program like Inkscape has over raster based programs is it’s very 
powerful vector tool set.  This exercise will give you a sampling of the drawing tools 
that come with Inkscape.
Open  Inkscape 
and create a new 
document

Steps

1.  Open Inkscape.

2.  Choose File>New and select the Default document.

3.  You can change the size of the document and the units by 
choosing File>Document Properties...

Create a rectangle Steps

1.  Select the Create rectangles and squares tool (F4) 

.

2.  Your mouse cursor will change to a crosshair and rectangle.  
Move your mouse cursor into your document and click and 
drag to create a rectangle.

Move and resize 
your rectangle

Steps

1.  Select the Select and transform objects tool (F1) 

 from the Tool Box and click and drag one of your 
rectangles to move it.

2.  Take a moment to look at your selected rectangle.  You will 
notice it has eight handles.  One in each corner and one in the 
middle of each of the sides.

3.  Click and drag on any of these handles with the Select and 
transform objects tool to resize the rectangle.  Hold the 
Ctrl key down when dragging a corner handle to maintain the 
rectangles proportions.

Notes
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A Fill is a colour, pattern, or gradient inside an object.  You can apply Fills to open and 
closed objects.

A Stroke is the visible outline of an object.  You can control the width and colour of a 
Stroke. 

Every object in your artwork can have one or more Fills and Strokes, or none at all.  
The current Fill and Stroke colours are displayed in the Toolbox.

Fill your rectangle 
with colour

Steps

1.  Using the Select and transform objects tool (F1) select 
one of your rectangles.

2.  Choose Object>Fill and Stroke...

3.  From the Fill and Stroke dialogue choose colours for the 
Fill and Stroke and change the width of the Stroke.

Notes

Choose Fill 
type, colour 
and opacity

Choose Stroke 
type, colour 
and opacity

Set the Stroke 
style

Set colour 
mode/space
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Working with Layers

Organise your document using Layers and the Layers dialogue

When creating complex artwork, it’s a challenge to keep track of all the items in your 
drawing.  Small items get hidden under larger items, and selecting artwork becomes 
difficult.  Layers provide a way to manage all the items that make up your artwork.  
Think of layers as clear folders that contain artwork. If you reshuffle the folders, you 
change the stacking order of the items in your artwork.

The structure of layers in your document can be as simple or complex as you want 
it to be.  By default, all items are organized in a single, parent layer.  However, you 
can create new layers and move items into them, or move elements from one layer to 
another at any time.  The Layers panel provides an easy way to hide and lock artwork.
Create a new 
document

Steps

1.  Choose File>New and select the Default document.

2.  You can change the size of the document and the units by 
choosing File>Document Properties...

Examine your 
Layers dialogue

Steps

Inkscape documents are automatically set up with one layer 
called Layer 1.  All artwork you create is automatically placed 
in this layer.

1.	 Choose Layer>Layers...

2.	 Your Layers dialogue should look similar to the image 
below.  At the moment your document contains one layer 
called Layer 1.

Notes

Create a new layer

Layer name, 
double-click to 
rename

Turn Layer on or off

Lock or Unlock 
Layer

Layer blending 
mode and opacity 
controls

Delete the current 
layer
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Organise your document using Layers and the Layers dialogue

To add a new layer, you just click the button with the blue plus sign which opens the 
Add Layer dialogue.  In this dialogue you can name your layer and also choose to add it 
above or below the current layer or as a sub-layer.  The four arrow buttons allow you to 
change the order of layers, moving a layer to the top, up one level, down one level and 
to the bottom.  The button with the blue minus sign will delete a layer, but do note that 
any objects on that layer will also be deleted.

Rename Layer 1 Steps

1.  Click over the name Layer 1 in the Layers dialogue.  It 
should become highlighted allowing you to type in a new 
name.

2.  Rename the layer image.
Create two new 
layers

Steps

1.	 Click the button with the blue plus-sign in the Layers 
dialogue.

2.	 Call your new layer circle and click Add.

3.	 Create a third layer and call it rectangle.

Notes



14
IT Learning Programme

TIMGAInkscape

Add artwork to your layers

You can select a layer by clicking on it.  Once selected the layer will be blue.  Once a 
layer has been selected all objects that you add to your document are applied to this 
layer.
Add artwork to 
your layers

Steps

1.  Select the circle layer by clicking on it.  The layer should 
turn blue in the Layers dialogue.

2.  Create a circle and apply stroke and fill.

3.  Select the rectangle layer by clicking on it.  The layer should 
turn blue in the Layers dialogue.

4.  Create a rectangle and apply stroke and fill.
Move your artwork Steps

1.  Rearrange your artwork so that the circle and the rectangle 
overlap each other as shown in the image below.

2.  To move artwork first select the appropriate layer and 
then select and move the artwork using the Select and 

transform objects tool (F1) .

Notes
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Change the layer order

The four arrow buttons along the bottom of the Layers dialogue allow you to change 
the order of layers, moving a layer to the top, up one level, down one level and to the 
bottom.
Change the layer 
order

Steps

1.  Select the circle layer by clicking on it.  The layer should 
turn blue in the Layers dialogue.

2.  Click the Raise the current layer button to move the circle 
layer above the rectangle layer.

The circle should now sit above the rectangle.
Hiding and revealing layers

You can use the Layers dialogue to hide objects quickly without deleting them.  This 
could be useful if you wanted to apply different text on a common background.

To the left of each layer in the Layers dialogue is an eye icon and you only need to click 
on this to hide a layer.  The closed eye icon indicates a hidden layer and clicking it will 
make a layer visible.
Hide and reveal 
layers

Steps

1.  Experiment with clicking on the eye icons to hide and reveal 
your layers.

Locking and unlocking layers

If you have objects within a document that you don’t want moved or deleted, you can 
lock the layer that they are on.

A layer is locked by clicking on the open padlock icon next to it, which then changes to 
a closed padlock.  Clicking the closed padlock will unlock the layer again.
Lock and unlock 
layers

Steps

1.  Experiment with clicking on the padlock icons to lock and 
unlock your layers.

Notes
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Layer blending modes

Inkscape offers a number of blending modes that alter the appearance of layers.

By default, layers are set to Normal mode, but the Blend mode drop down allows you 
to change the mode to Multiply, Screen, Darken and Lighten.
Import an image Steps

1.  Select the image layer.

2.  Choose File>Import...  Select the image file called ripples 
02.jpg and click Open.

3.  The jpeg GDX pixbuf Input dialogue will appear.  Choose to 
embed the image and click OK.

The image will appear in your document underneath the circle 
and the rectangle because it has been placed on the image 
layer. 

4.  You may need to move the image using the Select and 

transform objects tool (F1) .
Change a layers 
blending mode

Steps

1.  Select either the circle or rectangle layer.

2.  From the bottom of the Layers dialogue change the layers 
blending mode using the Blend mode drop down menu.

3.  You can also experiment with the layer Opacity.
Save your 
document

Steps

1.  Choose File>Save As...

2.  Choose a name for your file and a location to save it.  Then 
click Save.

3.  Keep this document open; you will be using it for the next 
exercise.

Notes
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Gradients

Exercise - Create a Gradient

You can use the Gradient editor (accessed via the Fill and Stroke dialogue) or the 
Create and edit gradients tool to apply, create, and modify gradients.

Gradient colours are defined by a series of stops along the gradient slider. A stop 
marks the point at which a gradient changes from one colour to the next.

Using the options in the Gradient dialogue or with the Create and edit gradients tool, 
you can specify the number and location of stops, angle in which the colors display, 
and the opacity of each colour.
Continue working 
with the document 
you created for the 
layers exercises

Steps

1.  Continue working with the document you created for the 
layers exercise.

2.  Alternatively open the file called Gradient 01.svg.
Fill the path with a 
gradient

Steps

1.	 Select one of the shapes, either the rectangle or the circle.

2.	 Choose Object>Fill and Stroke... to launch the Fill and 
Stroke dialogue.

Set a gradient for 
the paths fill type

Steps

1.	 Select the Fill tab and then choose Linear gradient for 
the fill type.

Notes

First choose 
Linear gradient 
for the Fill and then 

choose Edit 
to edit the 
gradient
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Edit the gradient Steps

1.	 Click the Edit... button in the Fill and Stroke dialogue.

2.	 This launches the Gradient editor dialogue.

3.	 Begin by changing the start and end colours of you 
gradient by selecting the colour stops.  See image below.

Add another 
colour stop

Steps

1.	 Add another colour stop, change it’s colour and adjust it’s 
position using the Offset slider.

Notes

Add or delete 
colour stops

Choose colour 
mode and 
select colour 
and opacity

Select a 
colour stop

Adjust 
position of 
colour stop
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Adjust the 
direction of the 
gradient

Steps

1.	 Select the Create and edit gradients tool (Ctrl + F1) 

 from the Tool Box.

2.	 You will see that a line with three control points has 
appeared across the selected shape

3.	 Experiment with clicking-and-dragging the control points 
to adjust the direction and length of the gradient and the 
positions of the colour stops.

Try applying a 
gradient to a 
shapes Stroke

Steps

1.	 Try applying a gradient to a shapes Stroke.

Notes

1st colour 
stop

Beginning of 
gradient

Click-and-
drag to move

3rd colour 
stop.

End of 
gradient

Click-and-
drag to 
move

Position of 
2nd colour 
stop.

Click-and-
drag to 
move.
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Working with Nodes
A path is made up of one or more straight or curved segments.  At the beginning and 
end of each segment are nodes.  You change the shape of a path by editing its nodes.  
You can control curves by dragging the control points at the end of the handles that 
appear at nodes.

A path is either open, like an arc, or closed, like a circle.  For an open path, the starting 
and ending nodes for the path are called endpoints.

Paths can have two kinds of nodes - corner nodes and smooth nodes.  At a corner node, 
a path abruptly changes direction.  At a smooth node, path segments are connected as 
a continuous curve.  You can draw a path using any combination of corner and smooth 
nodes.  If you draw the wrong kind of point, you can always change it.

Nodes on a path A. Four corner nodes B. Four smooth nodes C. Combination of corner and smooth nodes

A corner node can connect any two straight or curved segments, while a smooth node 
always connects two curved segments.

A corner node can connect both straight segments and curved segments.

node

handle

control 
point
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Exercise - Introducing the Draw Bezier curves and straight lines 
tool

The Draw Bezier curves and straight lines tool (Shift + F6) draws straight and curved 
lines to create objects.

The simplest paths you can draw with the tool are straight lines, made by clicking to 
create nodes.  By continuing to click, you create a path made of straight line segments 
connected by corner points.
Create a new 
document

Steps

1.  Choose File>New>A4_landscape.
Create straight 
lines with the Draw 
Bezier curves and 
straight lines tool

Steps

1.  Select the Draw Bezier curves and straight lines tool 

(Shift + F6) .

2.  Position the tool where you want the straight segment to 
begin, and click to define the first node. 

If direction lines appear, you accidentally dragged the tool; 
press escape and start again.

3.  Click again to create the first line or segment.  Continue 
clicking to draw a path like the one shown below.  When you 
have finished press Enter.

Turn some of the 
segments into 
curves with the Edit 
paths by nodes tool

Steps

The Edit paths by nodes tool (F2) changes smooth nodes 
to corner nodes and vice versa.

1.  Select the Edit paths by nodes tool (F2) .

2.  Click on the path you want to modify.
Notes
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3.  Position the Edit paths by nodes tool over a node you 
want to convert and click to select it.  It should change colour, 
from grey to yellow.

4.  From the Tool Controls panel choose Make selected 
nodes smooth.

The node becomes a smooth node.  You will notice that 
handles have appeared from the node.

5.  Adjust the curve of the segments by clicking-and-
dragging the control points at the ends of the handles.

Turn some of the 
nodes into corner 
nodes

Steps

1.  To convert a smooth node to a corner node first select the 
node with the Edit paths by nodes tool.

2.  Then select Make selected nodes corner from the 
Tool Controls panel.

The node becomes a corner node.  Initially it will not look 
any different.  However, when you drag the control points at 
the ends of the handles you will see that you can move them 
independently and create a corner node.

3.  Adjust the curve of the segments by clicking-and-
dragging the control points at the ends of the handles.

Save your 
document

Steps

1.  Choose File>Save As...

2.  Give your document a name and choose Inkscape SVG 
(*.svg) from the Save as type drop-down menu.

Notes
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Exercise - Create a Heart

Continue working with the document you created in the previous exercise
Create a heart 
shape with straight 
lines

Steps

1.  Using the Draw Bezier curves and straight lines tool 

(Shift + F6)  create a heart shape with straight lines.

2.  End or close the path by clicking on the original/first node.

Transform the 
straight lines into 
curves

Steps

1.  Use the Edit paths by nodes tool (F2)  to select 
nodes to convert into smooth nodes.

Tip: for the node at the bottom of the heart try choosing 
Make selected nodes symmetric.

Notes
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Fill your heart 
shaped path with 
colour

Steps

1.  Ensure the heart shape is still selected.  If not, select it using 
the Draw Bezier curves and straight lines tool (Shift + 

F6) .

2.  Change the Fill and Stroke colours using the Fill and Stroke 
dialogue (choose Object>Fill and Stroke...)

Notes

Choose Fill 
type, colour 
and opacity

Set colour 
mode/space

Choose Stroke 
type, colour 
and opacity

Set the Stroke 
style
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Exercise - Create a cloud shape

Use the Draw 
Bezier curves and 
straight lines tool 
to create the cloud 
shape.

Steps

1.  From the Tool Box, select the Draw Bezier curves and 

straight lines tool (Shift + F6) .

2.  Using the Draw Bezier curves and straight lines tool 
create a cloud shape similar to the one shown in the image 
below.  End or close the path by clicking on the original/first 
node.

Convert nodes Steps

1.  Select the Edit paths by nodes tool (F2) .

2.  Use the various options for the Edit paths by nodes tool 
in the Tool Controls panel to convert all of the corner nodes 
to smooth nodes.

Notes

Make selected nodes smooth Make selected nodes symmetric

Make selected nodes corner Make selected nodes 
auto-smooth
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Save your 
document

Steps

1.  Choose File>Save

You will continue working with this file.
Notes
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Closing paths

Exercise - Create a Flag

Join selected nodes:  The Join selected nodes option connects the endpoints of an 
open path to create a closed path or joins the endpoints of two open paths.

Continuing 
working with the 
same document

Steps

1.  Continue working with the same document.

2.  Should you require it, you can Open the document called 
Inkscape Introduction 01 - part 01.svg

Create a flag 
shaped path

Steps

1.  Use the Draw Bezier curves and straight lines tool 

(Shift + F6)  and the Edit paths by nodes tool (F2) 

 to create a flag shape as shown in the image below.

2.  Ensure the flag is an open path because we will be joining 
the end points in the next task.

Notes

start

end
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Join the nodes 
together to create a 
closed path

Steps

1.  To join two nodes together you first need to select them.

2.  Select the Edit paths by nodes tool (F2) .

3.  Click on the path to select it.  Then click and drag a 
selection marquee around the two open nodes.

4.  From the Tool Controls panel choose Join selected 
nodes.

5.  In preparation for the next task choose Edit>Undo: Join 
nodes.

Notes
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Connect the 
nodes with a new 
segment

Steps

1.  To join two nodes together you first need to select the path.

2.  Select the Edit paths by nodes tool (F2) .

3.  Click on the path to select it.

4.  Select the  Draw Bezier curves and straight lines tool 

(Shift + F6) .

5.  Position the tool over one of the nodes.  It should turn red.  
Click and move the tool to the other node.  When it turns red 
click on it.

The path should now be closed by the new segment connecting 
the previously open nodes.

Save your document
Notes
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Exercise - Modify a path using the Linked Offset command

You can create a replica of an object, set off from the selected object by a specified 
distance, by using the Linked Offset command.  This is useful when you want to create 
concentric shapes or make many replications of an object with regular distances 
between each.

The Linked Offset command makes a copy of a path that can then be enlarged or 
shrunk.  A handle controls the magnitude of the offset. The original object is not 
converted to a path and remains editable, and the changes are reflected in linked 
copies. More than one link can be made.
Continuing working with 
the same document

Steps

1.  Continue working with the same document.

2.  Should you require it, you can Open the document 
called Inkscape Introduction 01 - part 02.svg

Use the Offset Path 
command

Steps

1.  Select the flag shape you made earlier using the Edit 

paths by nodes tool (F2) .

2.  Choose Path>Linked Offset

3.  Click-and-drag the handle to offset the path.

The original path and the offset path are linked.  Any 
changes you make to the shape of original path will be 
applied to the offset path.

The offset path can be converted to an editable path 
by choosing Path>Object to Path.  The link is then 
broken and the offset path can be edited using the Edit 
paths by nodes tool.

Notes

Modifying paths

Click-and-drag the 
handle to offset the path
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Modify the two paths 
making up the flag

Steps

Using the Linked Offset command has created a replica 
of the flag, set off from the original flag by a specified 
distance.

You can select each of the flag shapes using the Edit 

paths by nodes tool (F2)  and adjust their fill 
and stroke attributes.

1.  Try filling the inner flag shape with a colour and 
giving the outer flag shape a thicker, coloured stroke.

Notes
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Exercise - Modify a path using the Stroke to Path command

One simple way to make a shape that you can use as a building block to create your 
design, is to convert a path with a thick stroke into an object.
Duplicate a path Steps

1.	 Using the Edit paths by nodes tool (F2)  
select the path you made in the earlier, Draw 
Bezier curves and straight lines tool, exercise.

2.	 Choose Edit>Copy and then Edit>Paste.

3.	 Use the Select and transform objects tool 

 to move the duplicate path into an empty 
area of your artboard.

Increase the Stroke 
weight

Steps

1.	 Ensure your path is still selected.

2.	 Set the Fill to None and set the Stroke Width to 
about 20 pt.

Create an Outline Stroke Steps

1.	 Ensure your path is still selected.

2.	 Choose Path>Stroke to Path.

You will notice that your path has changed from a line 
with a thick stroke to a path with no stroke.  Instead, 
the path is filled with colour.

New nodes have been created around the outside of the 
path.  You can select, move and modify these using the 
Edit paths by nodes tool.

Notes

Use the Edit paths by nodes tool to select, move and 
modify the new nodes
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Exercise - Modify a path using the Break path at selected nodes 
command

The Break path at selected nodes command cuts paths at specified nodes.

In this exercise you will cut the heart shaped path in half, delete one half, duplicate the 
remaining half and join them back together to create a symetrical shape.
Continue using the 
same document

Steps

1.  Select the heart shape you made earlier using the Edit 

paths by nodes tool (F2) .
Use the Scissors Tool 
to cut the path as 
specified points.

Steps

1.  Selecting the path will enable you to see its nodes.

2.  Select the anchor points, as shown in the image below, 
one at a time.

3.  Then choose Break path at selected nodes from the 
Tool Controls.

When you split the path at a node, a new node appears on 
top of the original node, and one node is selected.

Notes

Select this node...

... and this node.
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Delete one half of the 
heart

Steps

1.  Select the heart shape using the Edit paths by nodes 

tool (F2)  and choose Path>Break Apart.

2.  Choose Edit>Deselect.

3.  Use the Select and transform objects tool to select 
one half of the heart and then delete it.

Reflect and copy the 
remaining half of the 
heart shape

Steps

1.  Select the remaining half with the Select and 
transform objects tool.

2.  Choose Edit>Copy then Edit>Paste In Place.

3.  Choose Object>Flip Horizontal.

4.  Use the cursor or arrow keys to move the copied half 
horizontally into position.  Your two halves may not join 
properly at this stage.

Join the two halves 
together

Steps

1.  Use the Edit paths by nodes tool to select both halves 
of your heart.  Select one half and then Shift-select the 
other half.

2.  Choose Path>Combine.

3.  Use the Edit paths by nodes tool to select and join the 
nodes.

Your heart shape should now be a symetrical, single, closed 
path.
Save your document

You will need to join 
this pair of nodes to-
gether...

... and then this pair.
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Working with Text and Paths

Exercise - Create text inside a shape

Using the Create and edit text objects tool, you can create type anywhere in a file 
simply by clicking and starting to type.

In addition, you can flow text into shapes or onto paths.

Create a new 
document.

Steps

1.  Choose File>New>Default.
Create some text Steps

1.  Select the Create and edit text objects tool (F8)  
from the Tool Box.

2.  Click somewhere in your document and type some text.
Create a shape Steps

1.  Select the Create circles, ellipses, and arcs tool (F5) 

 from the Tool Box.

2.  Click-and-drag to create a circle.
Flow the text into 
the shape

Steps

1.  Select the text and the shape by holding down Shift and 
selected them with the Select and transform objects tool.

2.  Then choose Text>Flow into Frame.

The text will flow into the frame.  You can continue editing or 
adding to the text by clicking on it with the Create and edit 
text objects tool.

Flow text around a 
shape

Steps

1.  Create some text and a circle as you did in the task above.

2.  Select both the text and the circle.

3.  Then choose Text>Put on Path.
Notes

Please take a look at the following website for tips and tricks:

http://wiki.inkscape.org/wiki/index.php/Tricks_and_tips#Text_on_circle



36
IT Learning Programme

TIMGAInkscape

Saving your document

Exercise - Saving your Inkscape document

As an SVG file (.svg)

Inkscape drawings are saved as SVG files.  SVG stands for Scalable Vector Graphics 
which is an XML standard for describing a drawing using vector graphics.

As a PDF (.pdf)

You can save your Inkscape document as a PDF (Portable Document Format).

The advantage of using PDF is that it preserves the layout and content of your original 
Inkscape document without your audience needing to have access to Inkscape.  PDFs 
can also have small file sizes and are cross platform compatible.

As an EPS (.eps)

You can save your Inkscape document as an EPS (Portable Document Format).

EPS files can be inserted into Microsoft Word.

As a Bitmap (.png)

You can save your Inkscape document in a bitmap (raster) file format.  Inkscape 
exports to the PNG (Portable Network Graphics) format.

PNG supports lossless compression and is more appropriate for artwork containing 
text and line art.
Save your 
document as an 
SVG file

Steps

1.	 Throughout the exercises you have been asked to save 
your document.  By default Inkscape has been saving the 
document as an SVG file.

This file format will save the document and include your 
layers.  Think of this as your master document.

2.	 If you choose File>Save As... you should see Inkscape 
SVG (*.svg) is selected in the Save as type: field.

3.	 If you wanted to you could enter a new name for your 
document in the File name: field.

Notes



37
IT Learning Programme

TIMGAInkscape

Save your 
document as a 
PDF

Steps

1.	 Choose File>Save As... again.

This time choose Portable Document Format (*.pdf) 
from the Save as type: field.

2.	 You can use the same name or type a different one.

3.	 Click Save.

4.	 The Portable Document Format dialogue will appear.

5.  Click OK to save the document as a PDF.

Notes

For more information on LaTeX visit http://www.latex-project.org/

Save your 
document as an 
EPS

Steps

1.	 Choose File>Save As... again.

This time choose Encapsulated PostScript (*.eps) from 
the Save as type: field.

2.	 You can use the same name or type a different one.

3.	 Click Save.

4.	 The Encapsulated PostScript dialogue will appear.

5.  Click OK to save the document as an EPS.

Notes

Save your 
document as a 
bitmap/raster 
image (PNG file)

Steps

1.	 Choose File>Export Bitmap...

2.	 The Export Bitmap dialogue will appear.

5.  Click Export to save the document as a PNG file.

Notes
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Further information
Bibliography and Recommended reading

You will find most information on the Inkscape website:

•  http://inkscape.org/

There is a good online manual available here:

•  http://tavmjong.free.fr/INKSCAPE/MANUAL/html/index.html

Tips and tricks

•  http://wiki.inkscape.org/wiki/index.php/Tricks_and_tips

Macintosh keyboard equivalents

Command (or Apple) key (MAC) = Control (Ctrl) key (PC)

Ctrl key (MAC) = Alt key (PC)

This documentation uses the terms of the PC keyboard, and so speaks of the “Control” 
(Ctrl) key and the “Alt” key, but these have different meanings in the Macintosh world.

The Mac usually has (moving from the leftmost bottom corner of the keyboard inwards 
toward the space bar) a “Control” key in the same position as the PC control key.  Then 
there is an “Option” key, which has a funny symbol and “Alt” written on it, in the 
position where a “Windows” key often appears on PC keyboards.  Then, next to the 
space bar, there is a “Command” key, with an Apple logo and a sort of quadrifoil symbol, 
which occupies the space in which you usually find the Alt key on a PC.

The problem is that, although the PC and the Mac have a key marked “Control” in the 
same position on the keyboard, they use this key differently.  Whereas PC users use, 
for example, Control-C to copy and Control-S to save, Mac users are accustomed to 
Command-C and Command-S.

Use the Command (or Apple) key as the Control key.  Thus Command-S will save the 
file.  Since you cannot use the Option key (which is marked “Alt”), because it is used 
to enter symbols, this leaves the key marked “Ctrl” to serve as the “Alt” key.  If you are 
a regular Mac user, this is probably the easiest way -- just remember that when the 
documentation refers to the “Ctrl” key, do not use the key with that label, but use the 
Apple key, and when the documentation refers to the “Alt” key, use the key marked 
“Ctrl”.
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What is
Inkscape

Why use Inkscape

Inkscape Photoshop or GIMP



Vector and Raster graphics

Vector Raster

Raster graphics 01

Described by the order of single dots (pixels) in
a matrix

Suitable for graphics where the colour
information changes from dot to dot (e.g.
photographs)

Larger than vector image files

Difficult to convert a raster image to a vector
image



Raster graphics 02

Raster images do not scale as well as vector
images

Their sharpness depends on their resolution

They are resolution dependant

50% 100% 200%

Vector graphics 01

Described by mathematic formula

A circle would be defined by its centre (in the
form of a coordinate), its diameter and the
thickness and colour of the line

Suitable for graphics containing elements like
lines, rectangles, text, etc.

Smaller than raster image files

Easier to convert a vector image to a raster
image



Vector graphics 02

Vector graphics scale well, retaining their
sharpness and detail

They are resolution independant

50% 100% 200%

Bezier curves

Inkscape uses straight lines and Bezier curves
to create shapes and lines that can be scaled
indefinitely

http://www.math.ubc.ca/~cass/gfx/bezier.html



Demonstrations

File formats

Inkscape - .svg

use master file

retains layers

Portable Document Format - .pdf

use sharing documents, integrity

multiplatform and secure



Apple

shift

alt ctrl
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