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Note for Mac users
Some keystrokes and menu items are different on a Mac from those used in Windows and Linux.
The table below gives some common substitutions for the instructions in this chapter. For a more
detailed list, see the application Help.
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Windows or Linux

Mac equivalent

Effect

Tools > Options menu
selection

LibreOffice > Preferences

Access setup options

Right-click

Control+click

Opens a context menu

Ctrl (Control)

⌘ (Command)

Used with other keys

F5

Shift+⌘+F5

Opens the Navigator

F11

⌘+T

Opens the Styles and Formatting window
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Preface

Who is this book for?
Anyone who wants to get up to speed quickly with LibreOffice will find this book valuable. You may
be new to office software, or you may be familiar with another office suite.

What's in this book?
This book introduces the main components of LibreOffice:

•
•
•
•
•
•

Writer (word processing)
Calc (spreadsheets)
Impress (presentations)
Draw (vector graphics)
Base (database
Math (equation editor)

It also covers some of the features common to all components, including setup and customization,
styles and templates, macro recording, and printing. For more detail, see the user guides for the
individual components.

Where to get more help
This book, the other LibreOffice user guides, the built-in Help system, and user support systems
assume that you are familiar with your computer and basic functions such as starting a program,
opening and saving files.

Help system
LibreOffice comes with an extensive Help system. This is your first line of support for using
LibreOffice.
To display the full Help system, press F1 or select LibreOffice Help from the Help menu. In
addition, you can choose whether to activate Tips, Extended tips, and the Help Agent (using Tools
> Options > LibreOffice > General).
If Tips are enabled, place the mouse pointer over any of the icons to see a small box (“tooltip”) with
a brief explanation of the icon’s function. For a more detailed explanation, select Help > What's
This? and hold the pointer over the icon.

Free online support
The LibreOffice community not only develops software, but provides free, volunteer-based support.
See Table 1 and this web page: http://www.libreoffice.org/get-help/
Users can get comprehensive online support from the community through mailing lists. Other
websites run by users also offer free tips and tutorials. This forum provides community support for
LibreOffice and other programs: http://user.services.openoffice.org/en/forum/

Paid support and training
Alternatively, you can pay for support services. Service contracts can be purchased from a vendor
or consulting firm specializing in LibreOffice.
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Table 1: Free support for LibreOffice users
Free LibreOffice support
FAQs

Answers to frequently asked questions
http://www.libreoffice.org/get-help/faq/
http://wiki.documentfoundation.org/Faq

Documentation

User guides, how-tos, and other documentation.
http://www.libreoffice.org/get-help/documentation/
https://wiki.documentfoundation.org/Documentation/Publications

Mailing lists

Free community support is provided by a network of experienced users
http://www.libreoffice.org/get-help/mailing-lists/

International support

Accessibility options

The LibreOffice website in your language.
http://www.libreoffice.org/international-sites/
International mailing lists
http://wiki.documentfoundation.org/Local_Mailing_Lists
Information about available accessibility options.
http://www.libreoffice.org/get-help/accessibility/

What you see may be different
LibreOffice runs on Windows, Linux, and Mac OS X operating systems, each of which has several
versions and can be customized by users (fonts, colors, themes, window managers).
The pictures in this book were taken from a variety of computers and operating systems. Some
pictures will therefore not look exactly like what you see on your computer.

Using LibreOffice on a Mac
Some keystrokes and menu items are different on a Mac from those used in Windows and Linux.
The table below gives some common substitutions for the instructions in this chapter. For a more
detailed list, see the application Help.
Windows or Linux

Mac equivalent

Effect

Tools > Options menu
selection

LibreOffice > Preferences

Access setup options

Right-click

Control+click

Open a context menu

Ctrl (Control)

z (Command)

Used with other keys

F5

Shift+z+F5

Open the Navigator

F11

z+T

Open the Styles and Formatting window
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What are all these things called?
The terms used in LibreOffice for most parts of the user interface (the parts of the program you see
and use, in contrast to the behind-the-scenes code that actually makes it work) are the same as for
most other programs.
A dialog is a special type of window. Its purpose is to inform you of something, or request input
from you, or both. It provides controls for you to use to specify how to carry out an action. The
technical names for common controls are shown in Figure 1; not shown is the list box (from which
you select an item). In most cases we do not use the technical terms in this book, but it is useful to
know them because the Help and other sources of information often use them.
In most cases, you can interact only with the dialog (not the document itself) as long as the dialog
remains open. When you close the dialog after use (usually, clicking OK or another button saves
your changes and closes the dialog), then you can again work with your document.
Some dialogs can be left open as you work, so you can switch back and forth between the dialog
and your document. An example of this type is the Find & Replace dialog.

Figure 1: Dialog showing common controls:
1 = Tabbed page (not strictly speaking a control)
2 = Radio buttons (only one can be selected at a time)
3 = Checkbox (more than one can be selected at a time)
4 = Spin box (click the up and down arrows to change the number shown in the
text box next to it, or type in the text box)
5 = Thumbnail or preview
6 = Drop-down list from which to select an item
7 = Push buttons
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Who wrote this book?
This book was written by volunteers from the LibreOffice community. Profits from sales of the
printed edition will be used to benefit the community.
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Frequently asked questions
How is LibreOffice licensed?
LibreOffice is distributed under the Open Source Initiative (OSI) approved Lesser General
Public License (LGPL). The LGPL license is available from the LibreOffice website:
http://www.libreoffice.org/download/license/
May I distribute LibreOffice to anyone?
Yes.
How many computers may I install it on?
As many as you like.
May I sell it?
Yes.
May I use LibreOffice in my business?
Yes.
Is LibreOffice available in my language?
LibreOffice has been translated (localized) into over 40 languages, so your language probably
is supported. Additionally, there are over 70 spelling, hyphenation, and thesaurus dictionaries
available for languages, and dialects that do not have a localized program interface. The
dictionaries are available from the LibreOffice website at: www.libreoffice.org.
How can you make it for free?
LibreOffice is developed and maintained by volunteers and has the backing of several
orgainzations.

Preface
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I am writing a software application. May I use programming code from LibreOffice in my
program?
You may, within the parameters set in the LGPL. Read the license:
http://www.libreoffice.org/download/license/
Why do I need Java to run LibreOffice? Is it written in Java?
LibreOffice is not written in Java; it is written in the C++ language. Java is one of several
languages that can be used to extend the software. The Java JDK/JRE is only required for
some features. The most notable one is the HSQLDB relational database engine.
Note: Java is available at no cost. If you do not want to use Java, you can still use nearly all of
the features of LibreOffice.
How can I contribute to LibreOffice?
You can help with the development and user support of LibreOffice in many ways, and you do
not need to be a programmer. To start, check out this webpage:
http://www.documentfoundation.org/contribution/
May I distribute the PDF of this book, or print and sell copies?
Yes, as long as you meet the requirements of one of the licenses in the copyright statement at
the beginning of this book. You do not have to request special permission. In addition, we
request that you share with the project some of the profits you make from sales of books, in
consideration of all the work we have put into producing them.

New features in LibreOffice 3.5
For a detailed list of new features, see http://www.libreoffice.org/download/3-5-new-features-and-fixes/.
Here are some of them.

General
• LibreOffice checks for updates automatically at user-defined intervals and allows manual
download of the newest version.

• Import filter for Microsoft Visio documents.
• Color picker (Tools > Options > Colors, click Edit) rewritten to be more usable.
• Application color settings (Tools > Options > Appearance) now have correct color
previews for Automatic colors.

• Moved context-sensitive toolbars to the bottom to prevent them from overlaying important
parts of the document.

• The Insert Movie and Sound dialog now has a Link checkbox, enabling the embedding of
media files into ODF package based documents.
Writer

• Better header/footer handling: easily add header or footers; quickly edit or remove headers
and footers without going through page styles formatting.

• New faster built-in grammar checker for English and several other languages. Reworked
grammar checking dialog better shows the error help.

• Word count dialog updates as you type.
• Improved font hinting for high quality docs.
• Layout fixes including numbering when importing DOC, DOCX, and RTF files, for layout
compatibility with Microsoft Word, and tab stops that fall into margins.

• Auto-generated tables of contents now contain hyperlinks to the relevant pages by default.
14
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• Support for comments export/import in Office Open XML (*.docx) documents.
• Label printing positioning fixed.
• Many new typographic features.
Calc

•
•
•
•

New multi-line input bar.
Supports 10,000 sheets and improved performance for a lot of sheet operations.
New option to specify the initial number of sheets in new documents.
New Calc Functions BITAND, BITOR, BITXOR, BITRSHIFT, and BITLSHIFT, SEC, CSC,
SECH and CSCH, as declared in the ODF 1.2 specification.

• Autofilter popup window has been re-designed for better visual appearance and the ability
to allow multiple selections.

• Redesigned all range name dialogs to work much better with local range names and make
it easier to use the dialogs.

• Unlimited number of rules for conditional formatting.
Impress / Draw
• Start Impress without the wizard by default.

•
•
•
•
•
•

Elliptical arcs are properly imported and rendered.
Better handling of custom animation list,
Better handling of export to PDF for hidden slides.
Better support for importing Smart Art.
Standard palette includes some new line ends.
Custom Shapes import greatly enhanced; many bugs fixed and new presets
implementation added.

Math

• New "does not exist" ∄ symbol.
• Support for export and import of Math formulas in Office Open XML (docx) documents.
• New symbols for Games theory.
Base

• Integrated PostgreSQL native driver (for versions 8.4+).
• Many bug fixes.

Preface
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Chapter 1
Introducing LibreOffice

What is LibreOffice?
LibreOffice is a freely available, fully-featured office productivity suite. Its native file format is
OpenDocument, an open standard format that is being adopted by governments worldwide as a
required file format for publishing and accepting documents. LibreOffice can also open and save
documents in many other formats, including those used by several versions of Microsoft Office.
LibreOffice includes the following components.

Writer (word processor)
Writer is a feature-rich tool for creating letters, books, reports, newsletters, brochures, and other
documents. You can insert graphics and objects from other components into Writer documents.
Writer can export files to HTML, XHTML, XML, Adobe’s Portable Document Format (PDF), and
several versions of Microsoft Word files. It also connects to your email client.

Calc (spreadsheet)
Calc has all of the advanced analysis, charting, and decision-making features expected from a
high-end spreadsheet. It includes over 300 functions for financial, statistical, and mathematical
operations, among others. The Scenario Manager provides “what if” analysis. Calc generates 2-D
and 3-D charts, which can be integrated into other LibreOffice documents. You can also open and
work with Microsoft Excel workbooks and save them in Excel format. Calc can export spreadsheets
to Adobe’s PDF and to HTML.

Impress (presentations)
Impress provides all the common multimedia presentation tools, such as special effects, animation,
and drawing tools. It is integrated with the advanced graphics capabilities of LibreOffice’s Draw and
Math components. Slide shows can be further enhanced with Fontwork’s special effects text, as
well as sound and video clips. Impress is compatible with Microsoft’s PowerPoint file format and
can also save your work in numerous graphics formats, including Macromedia Flash (SWF).

Draw (vector graphics)
Draw is a vector drawing tool that can produce everything from simple diagrams or flowcharts to 3D artwork. Its Smart Connectors feature allows you to define your own connection points. You can
use Draw to create drawings for use in any of LibreOffice’s other components, and you can create
your own clip art and add it to the Gallery. Draw can import graphics from many common formats
and save them in over 20 formats, including PNG, HTML, PDF, and Flash.

Base (database)
Base provides tools for day-to-day database work within a simple interface. It can create and edit
forms, reports, queries, tables, views, and relations, so that managing a relational database is
much the same as in other popular database applications. Base provides many new features, such
as the ability to analyze and edit relationships from a diagram view. Base incorporates HSQLDB as
its default relational database engine. It can also use dBASE, Microsoft Access, MySQL, or Oracle,
or any ODBC-compliant or JDBC-compliant database. Base also provides support for a subset of
ANSI-92 SQL.
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Math (formula editor)
Math is LibreOffice’s formula or equation editor. You can use it to create complex equations that
include symbols or characters not available in standard font sets. While it is most commonly used
to create formulas in other documents, such as Writer and Impress files, Math can also work as a
standalone tool. You can save formulas in the standard Mathematical Markup Language (MathML)
format for inclusion in web pages and other documents not created by LibreOffice.

The advantages of LibreOffice
Here are some of the advantages of LibreOffice over other office suites:

• No licensing fees. LibreOffice is free for anyone to use and distribute at no cost. Many
features that are available as extra cost add-ins in other office suites (like PDF export) are
free with LibreOffice. There are no hidden charges now or in the future.

• Open source. You can distribute, copy, and modify the software as much as you wish, in
accordance with either of LibreOffice’s Open Source licenses.

• Cross-platform. LibreOffice runs on several hardware architectures and under multiple
operating systems, such as Microsoft Windows, Mac OS X and Linux,.

• Extensive language support. LibreOffice’s user interface is available in over 40
languages, and the LibreOffice project provides spelling, hyphenation, and thesaurus
dictionaries in over 70 languages and dialects. LibreOffice also provides support for both
Complex Text Layout (CTL) and Right to Left (RTL) layout languages (such as Urdu,
Hebrew, and Arabic).

• Consistent user interface. All the components have a similar “look and feel,” making them
easy to use and master.

• Integration. The components of LibreOffice are well integrated with one another.
–
All the components share a common spelling checker and other tools, which are used
consistently across the suite. For example, the drawing tools available in Writer are
also found in Calc, with similar but enhanced versions in Impress and Draw.

–

You do not need to know which application was used to create a particular file. For
example, you can open a Draw file from Writer.

• Granularity. Usually, if you change an option, it affects all components. However,
LibreOffice options can be set at a component level or even at document level.

• File compatibility. In addition to its native OpenDocument formats, LibreOffice includes
PDF and Flash export capabilities, as well as support for opening and saving files in many
common formats including Microsoft Office, HTML, XML, WordPerfect, and Lotus 1-2-3
formats. An extension (included) provides the ability to import and edit some PDF files.

• No vendor lock-in. LibreOffice uses OpenDocument, an XML (eXtensible Markup
Language) file format developed as an industry standard by OASIS (Organization for the
Advancement of Structured Information Standards). These files can easily be unzipped and
read by any text editor, and their framework is open and published.

• You have a voice. Enhancements, software fixes, and release dates are communitydriven. You can join the community and affect the course of the product you use.
You can read more about LibreOffice and The Document Foundation on their websites at
http://www.libreoffice.org/ and http://www.documentfoundation.org/.
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Minimum requirements
LibreOffice 3.5 requires one of the following operating systems:

• Microsoft Windows 2000 (Service Pack 4 or higher), XP, Vista, Windows 7, or Windows 8
• GNU/Linux Kernel version 2.6.18, glibc2 v2.5 or higher, and gtk v2.10.4 or higher
• Mac OS X 10.4 (Tiger) or higher
Administrator rights are needed for the installation process.
Some LibreOffice features (wizards and the HSQLDB database engine) require that the Java
Runtime Environment (JRE) be installed on your computer. Although LibreOffice will work without
Java support, some features will not be available.
For a more detailed listing of requirements, see the LibreOffice website,
http://www.libreoffice.org/get-help/system-requirements/.

How to get the software
The software can be downloaded from http://www.libreoffice.org/. You can also download the
software by using a Peer-to-Peer client, such as BitTorrent, at the same address.
Linux users will find LibreOffice included in many of the latest Linux distributions; Ubuntu is just
one example.

How to install the software
Information on installing and setting up LibreOffice on the various supported operating systems is
given here: http://www.libreoffice.org/get-help/installation/.

Extensions and add-ons
Extensions and add-ons are available to enhance LibreOffice. Several extensions are installed with
the program and others are available from the official extensions repository,
http://extensions.libreoffice.org/. See Chapter 14, Customizing LibreOffice, for more information on
installing them.

Starting LibreOffice
The most common way to launch any component of LibreOffice is by using the system menu, the
standard menu from which most applications are started. On Windows, it is called the Start menu.
On GNOME, it is called the Applications menu. On KDE it is identified by the KDE logo. On Mac
OS X, it is the Applications menu.
When LibreOffice was installed on your computer, in most cases a menu entry for each component
was added to your system menu. The exact name and location of these menu entries depend on
the operating system and graphical user interface.

Starting from an existing document
You can start LibreOffice by double-clicking the filename of a ODF (OpenDocument Format)
document in a file manager such as Windows Explorer. The appropriate component of LibreOffice
will start and the document will be loaded.
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Note for Windows users
If you have associated Microsoft Office file types with LibreOffice, then when you double-click on a
*.doc (Word) file, it opens in Writer; *.xls (Excel) files open in Calc; and *.ppt (PowerPoint)
files open in Impress.
If you did not associate the file types, then when you double-click on a Microsoft Word document, it
opens in Microsoft Word (if Word is installed on your computer), Excel files open in Excel, and
PowerPoint files open in PowerPoint.
You can use another method to open Microsoft Office files in LibreOffice and save in those formats
from LibreOffice. See “Opening an existing document” on page 27 for more information.

Using the Quickstarter under Windows
The Quickstarter is an icon that is placed in the Windows system tray during system startup. It
indicates that LibreOffice has been loaded and is ready to use. (The Quickstarter loads library
*.DLL files required by LibreOffice, shortening the startup time for LibreOffice components). If the
Quickstarter is disabled, see “Reactivating the Quickstarter” to enable it.

Using the Quickstarter icon
Right-click the Quickstarter icon in the system tray to open a pop-up menu (Figure 2) from which
you can open a new document, open the Templates and Documents dialog, or choose an existing
document to open. You can also double-click the Quickstarter icon to display the Templates and
Documents dialog.

Figure 2: Quickstarter pop-up menu in Windows

Disabling the Quickstarter
To close the Quickstarter, right-click on the icon in the system tray, and then click Exit
Quickstarter on the pop-up menu. The next time the computer is restarted, the Quickstarter will be
loaded again.
To prevent LibreOffice from loading during system startup, deselect the Load LibreOffice during
system start-up item on the pop-up menu. You might want to do this if your computer has
insufficient memory, for example.
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Reactivating the Quickstarter
If the Quickstarter has been disabled, you can reactivate it by selecting the Load LibreOffice
during system start-up checkbox in Tools > Options > LibreOffice > Memory.

Using the Quickstarter in Linux and Mac OS X
LibreOffice under Linux has a Quickstarter that looks and acts like the one described above for
Windows. The checkbox on the Memory page is labeled Enable systray quickstarter. If you do
not have this checkbox, the Quickstarter module is not installed on your system.
Mac OS X provides similar functionality through a pop-up menu from the dock.

Parts of the main window
The main window is similar in each component of LibreOffice, although some details vary. See the
chapters in this book about Writer, Calc, Draw, and Impress for descriptions of those details.
Common features include the menu bar, the standard toolbar, and the formatting toolbar at the top
of the window and the status bar at the bottom.

Menu bar
The Menu bar is located across the top of the LibreOffice window, just below the Title bar. When
you choose one of the menus listed below, a submenu drops down to show commands.

• File contains commands that apply to the entire document such as Open, Save, and Export
as PDF.

• Edit contains commands for editing the document such as Undo: xxx (where xxx is the
command to undo) and Find & Replace. It also contains commands to cut, copy, and paste
selected parts of your document.

• View contains commands for controlling the display of the document such as Zoom and
Web Layout.

• Insert contains commands for inserting elements into your document such as Header,
Footer, and Picture.

• Format contains commands, such as Styles and Formatting and AutoCorrect, for
formatting the layout of your document.

•
•
•
•

Table shows all commands to insert and edit a table in a text document.
Tools contains functions such as Spelling and Grammar, Customize, and Options.
Window contains commands for the display window.
Help contains links to the LibreOffice Help file, What’s This?, and information about the
program.

Toolbars
LibreOffice has several types of toolbars: docked (fixed in place), floating, and tear-off. Docked
toolbars can be moved to different locations or made to float, and floating toolbars can be docked.
The top docked toolbar, just under the Menu bar, is called the Standard toolbar. It is consistent
across the LibreOffice applications.
The second toolbar at the top is the Formatting bar. It is context-sensitive; that is, it shows the tools
relevant to the cursor’s current position or selection. For example, when the cursor is on a graphic,
the Formatting bar provides tools for formatting graphics; when the cursor is in text, the tools are
for formatting text.
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Displaying or hiding toolbars
To display or hide toolbars, choose View > Toolbars, then click on the name of a toolbar in the list.
An active toolbar shows a checkmark beside its name. Tear-off toolbars are not listed in the View
menu.

Submenus and tear-off toolbars
Toolbar icons with a small triangle to the right will display submenus, tear-off toolbars, and other
ways of selecting things, depending on the icon.
Figure 3 shows a tear-off toolbar from the Drawing toolbar.
Tear-off toolbars can be floated or docked along an edge of the screen or in one of the existing
toolbar areas. To move a floating tear-off toolbar, drag it by the title bar, as shown in Figure 5.

Figure 3: Example of a tear-off toolbar

Moving toolbars
To move a docked toolbar, place the mouse pointer over the toolbar handle (the small vertical bar
to the left of the toolbar), hold down the left mouse button, drag the toolbar to the new location, and
then release the mouse button (Figure 4). To move a floating toolbar, click on its title bar and drag it
to a new location (Figure 5).

Figure 4: Moving a docked toolbar

Figure 5: Moving a floating toolbar

Chapter 1 Introducing LibreOffice

23

Floating toolbars
LibreOffice includes several additional context-sensitive toolbars, whose defaults appear as
floating toolbars in response to the cursor’s current position or selection. For example, when the
cursor is in a table, a floating Table toolbar appears, and when the cursor is in a numbered or bullet
list, the Bullets and Numbering toolbar appears. You can dock these toolbars to the top, bottom, or
side of the window, if you wish (see “Moving toolbars” above).

Docking/floating windows and toolbars
Toolbars and some windows, such as the Navigator and the Styles and Formatting window, are
dockable. You can move, resize, or dock them to an edge.
To dock a window or toolbar, hold down the Control key and double-click on the frame of the
floating window (or in a vacant area near the icons at the top of the floating window) to dock it in its
last position.

Figure 6: Control+click to dock or undock
To undock a window, hold down the Control key and double-click on the frame (or a vacant area
near the icons at the top) of the docked window.

Customizing toolbars
You can customize toolbars in several ways, including choosing which icons are visible and locking
the position of a docked toolbar. You can also add icons and create new toolbars, as described in
Chapter 14.
To access a toolbar’s customization options, use the down-arrow at the end of the toolbar or on its
title bar.

Figure 7: Customizing toolbars
To show or hide icons defined for the selected toolbar, choose Visible Buttons from the dropdown menu. Visible icons are indicated by an outline around the icon. Click on icons to select or
deselect them. (See Figure 8.)

Right-click (context) menus
You can quickly access many menu functions by right-clicking on a paragraph, graphics, or other
object. A context menu will pop up. Often the context menu is the fastest and easiest way to reach
a function. If you are not sure where a function is located in the menus or toolbars , you can often
find it by right-clicking.
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Figure 8: Selection of visible toolbar icons

Status bar
The status bar is located at the bottom of the workspace. It provides information about the
document and convenient ways to quickly change some features. It is similar in Writer, Calc,
Impress, and Draw, although each component includes some component-specific items.

Figure 9: Left end of status bar in Writer

Figure 10: Right end of status bar in Writer
Common status bar items are described below.
Page, sheet, or slide number
Shows the current page, sheet, or slide number and the total number of pages, sheets, or
slides in the document. Double-click on this field to open the Navigator. Other uses of this field
depend on the component.
Page style or slide design
Shows the current page style or slide design. To edit the current page style or slide design,
double-click on this field.
Unsaved changes
An icon appears here if changes to the document have not been saved.
Digital signature
If the document has been digitally signed, an icon shows here. You can double-click the icon to
view the certificate.
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Object information
Displays information relevant to the cursor’s position or the selected element of the document.
Double-clicking in this area usually opens a relevant dialog.
Zoom slider and percent
To change the view magnification, drag the Zoom slider, or click on the + and – signs, or rightclick on the zoom level percent to pop up a list of magnification values from which to choose.
Double-clicking on the zoom level percent opens the Zoom & View Layout dialog.

Starting a new document
You can start a new, blank document in LibreOffice in several ways.
When LibreOffice is open but no document is open (for example if you close all the open
documents but leave the program running), the Start Center is shown. Click one of the icons to
open a new document of that type, or click the Templates icon to start a new document using a
template.
You can also start a new document in one of the following ways:

• Use File > New and choose the type of document.
• Use the arrow next to the New button on the main toolbar. From the drop-down menu,
select the type of document to be created.

• Press Control+N on the keyboard.
• Use File > Wizards for some special types of documents.
If a document is already open in LibreOffice, the new document opens in a new window.

Figure 11: LibreOffice Start Center
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Opening an existing document
When no document is open, the Start Center provides an icon for opening an existing document or
choosing from a list of recently-edited documents.

You can also open an existing document in one of the following ways:

• Choose File > Open.
• Click the Open button on the main toolbar.
• Press Control+O on the keyboard.
In each case, the Open dialog appears. Select the file you want, and then click Open. If a
document is already open in LibreOffice, the second document opens in a new window.
In the Open dialog, you can reduce the list of files by selecting the type of file you are looking for.
For example, if you choose Text documents as the file type, you will only see documents Writer
can open (including .odt, .doc, .txt); if you choose Spreadsheets, you will see .ods, .xls,
and other files that Calc opens.
You can also open an existing document that is in an OpenDocument format by double-clicking on
the file’s icon on the desktop or in a file manager such as Windows Explorer.
If you have associated Microsoft Office file formats with LibreOffice, you can also open these files
by double-clicking on them.

Note

Under Microsoft Windows you can use either the LibreOffice Open and Save As
dialogs or the ones provided by Microsoft Windows. See “Using the Open and Save
As dialogs” on page 29.

Saving a document
To save a new document, do one of the following:

• Press Control+S.
• Choose File > Save from the menu bar.
• Click the Save button on the main toolbar.
When the Save As dialog appears, enter the file name, verify the file type (if applicable), and click
Save.
To save an open document with the current file name, choose File > Save. This will overwrite the
last saved state of the file.

Password protection
To protect a document from being viewable without a password, use the option on the Save As
dialog to enter a password.
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1) On the Save As dialog, select the Save with password option, and then click Save. You
will receive a prompt (Figure 12).
2) Type the same password in both fields, and then click OK. If the passwords match, the
document is saved password protected. If the passwords do not match, you receive an
error message. Close the message box to return to the Set Password dialog and enter the
password again.

Caution

LibreOffice uses a very strong encryption mechanism that makes it almost
impossible to recover the contents of a document in case you lose the password.

Figure 12: Entering a password for a document
Writer and Calc provide a second level of protection, which allows a file to be viewed but not
changed without a password; that is, the file opens in read-only mode.
To protect a document from being changed:
1) Choose More Options from the Set Password dialog.
2) Enter the password in the Enter password to allow editing field. Repeat the password in the
Confirm password field. Click OK.

Changing the password for a document
When a document is password-protected, you can change the password while the document is
open. Choose File > Properties > General and click the Change Password button.

Saving a document automatically
You can choose to have LibreOffice save files for you automatically. Automatic saving, like manual
saving, overwrites the last saved state of the file. To set up automatic file saving:
1) Choose Tools > Options > Load/Save > General.
2) Mark Save AutoRecovery information every, and set the time interval.
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Renaming and deleting files
You can rename or delete files within the LibreOffice dialogs, just as you can in your usual file
manager. However, you cannot copy or paste files within the dialogs.

Using the Open and Save As dialogs
You can choose whether to use the LibreOffice Open and Save As dialogs or the ones provided by
your operating system.
To view or change which type of dialog LibreOffice uses:
1) Choose Tools > Options > LibreOffice > General.
2) Select the Use LibreOffice dialogs option.
This section discusses the LibreOffice Open and Save As dialogs. Figure 13 shows the Save As
dialog; the Open dialog is similar.

Figure 13: The LibreOffice Save as dialog
The three buttons in the top right of the LibreOffice Open and Save As dialogs are, from left:

• Go Up One Level in the folder (directory) hierarchy. Click and hold this button for a second
to drop down a list of higher level folders; to go to one of the folders on the list, move the
mouse pointer over its name and release the mouse button.

• Create New Folder.
• Default Directory.
For LibreOffice documents that have been saved with more than one version, use the Version
drop-down to select which version you wish to open in read-only mode. For Microsoft Office
documents, only the current version can be opened.
Use the File type field to specify the type of file to be opened or the format of the file to be saved.
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The Read-only option on the Open dialog opens the file for reading and printing only.
Consequently, most of the toolbars disappear, and most menu options are disabled. An Edit File
button is displayed on the Standard toolbar to open the file for editing.
You can open files from the Web by typing a URL in the File name field on the Open dialog.

Using the Navigator
The Navigator lists objects contained in a document, collected into categories. For example, in
Writer it shows Headings, Tables, Text frames, Comments, Graphics, Bookmarks, and other items,
as shown in Figure 14. In Calc it shows Sheets, Range Names, Database Ranges, Graphics,
Drawing Objects, and other items. In Impress and Draw it shows Slides, Pictures, and other items.
To open the Navigator, click its icon
Navigator on the menu bar.

on the Standard toolbar, or press F5, or choose View >

You can dock the Navigator to either side of the main LibreOffice window or leave it floating (see
“Docking/floating windows and toolbars“ on page 24).
Click the marker (+ or triangle) by any of the categories to display the list of objects in that
category.
To hide the list of categories and show only the toolbars at the top, click the List Box On/Off icon
. Click this icon again to show the list box.

Figure 14: The Navigator
The Navigator provides several convenient ways to move around a document and find items in it:

• When a category is showing the list of objects in it, double-click on an object to jump
directly to that object’s location in the document.
Objects are much easier to find if you have given them names when creating them, instead
of keeping LibreOffice’s default graphics1, graphics2, Table1, Table2, and so on—which
may not correspond to the position of the object in the document.
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If you only want to see the content in a certain category, highlight the category and click the
Content View icon
be displayed.

. Until you click the icon again, only the objects of that category will

• Click the Navigation icon

(second icon from the left at the top of the Navigator) to
display the Navigation toolbar. Here you can pick one of the categories and use the
Previous and Next icons to move from one item to the next. This is particularly helpful for
finding items like bookmarks and indexes, which can be difficult to see.
The names of the icons (shown in the tooltips) change to match the selected category; for
example, Next Graphic or Next Bookmark.

Figure 15: Navigation toolbar

• To jump to a specific page in the document, type its page number in the box at the top of
the Navigator.
A bit of experimentation with the other icons will demonstrate their functions. Some componentspecific uses are described in the chapters on Writer and the other components.

Undoing and redoing changes
To undo the most recent change, press Control+Z, or click the Undo icon
toolbar, or choose Edit > Undo from the menu bar.

on the Standard

The Edit menu shows the latest change that can be undone (see below for an example from
Writer).

Figure 16: Edit > Undo last action
Click the small triangle to the right of the Undo icon to get a list of all the changes that can be
undone. You can select multiple changes and undo them at the same time.

Figure 17: List of actions that can be undone
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After changes have been undone, Redo becomes active. To redo a change, select Edit > Redo, or
press Control+Y or click on the Redo icon
. As with Undo, click on the triangle to the right of
the arrow to get a list of the changes that can be reapplied.
To modify the number of changes LibreOffice remembers, choose Tools > Options > LibreOffice
> Memory and in the Undo section change Number of steps. Be aware that asking LibreOffice to
remember more changes consumes more computer memory.

Closing a document
To close a document, choose File > Close.
You can also close a document by clicking on the Close icon on the document window. This button
looks like the X shown in Figure 18. It may be in a different location on your operating system.

Figure 18. Close icons
If more than one LibreOffice window is open, each window looks like the sample shown on the left
in Figure 18. Closing this window leaves the other LibreOffice windows open.
If only one LibreOffice window is open, it looks like the sample shown on the right in Figure 18.
Notice the small x below the large X. Clicking the small x closes the document but leaves
LibreOffice open. Clicking the large X closes LibreOffice completely.
If the document has not been saved since the last change, a message box is displayed. Choose
whether to save or discard your changes.

• Save: The document is saved and then closed.
• Discard: The document is closed, and all modifications since the last save are lost.
• Cancel: Nothing happens, and you return to the document.
Caution

Not saving your document could result in the loss of recently made changes, or
worse still, your entire file.

Closing LibreOffice
To close LibreOffice completely, choose File > Exit, or close the last open document as described
in “Closing a document” above.
If all the documents have been saved, LibreOffice closes immediately. If any documents have been
modified but not saved, a warning message appears. Follow the procedure in “Closing a
document” to save or discard your changes.
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Chapter 2
Setting up LibreOffice
Choosing options to suit the way you work

Choosing options for all of LibreOffice
This section covers some of the settings that apply to all the components of LibreOffice. For
information on settings not discussed here, see the online help.
Click Tools > Options. The list in the left-hand box of the Options – LibreOffice dialog varies
depending on which component of LibreOffice is open. The illustrations in this chapter show the list
as it appears when a Writer document is open.
Click the marker (+ or triangle) by LibreOffice on the left-hand side. A list of pages drops down.
Selecting an item in the list causes the right-hand side of the dialog to display the relevant page.

Figure 19: LibreOffice options

Note

The Back button (not shown in the illustration; located in the lower right of the full
Options dialog) has the same effect on all pages of the Options dialog. It resets the
options to the values that were in place when you opened LibreOffice.

User Data options
Because LibreOffice uses the name or initials stored in the LibreOffice – User Data page for
several things, including document properties (created by and last edited by information) and the
name of the author of notes and changes, you will want to ensure that the correct information
appears here.
Fill in the form (shown in Figure 20), or amend or delete any existing incorrect information.
If you are using a version of LibreOffice other than US English, some field labels may be different
from those shown in the illustrations.
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Figure 20: Filling in user data

General options
The options on the LibreOffice – General page are described below.

Figure 21: Setting general options for LibreOffice
Help - Tips
When Tips is active, one or two words will appear when you hold the mouse pointer over an
icon or field, without clicking.
Help - Extended tips
When Extended tips is active, a brief description of the function of a particular icon or menu
command or a field on a dialog appears when you hold the mouse pointer over that item.
Help Agent
To turn off the Help Agent (similar to Microsoft’s Office Assistant), deselect this option. To
restore the default behavior, click Reset Help Agent.
Chapter 2 Setting up LibreOffice

35

Open/Save dialogs – Use LibreOffice dialogs
To use the standard Open and Save dialogs for your operating system, deselect the Use
LibreOffice dialogs option. When this option is selected, the Open and Save dialogs supplied
with LibreOffice will be used. See Chapter 1, Introducing LibreOffice, for more about the
LibreOffice Open and Save dialogs. This book uses the LibreOffice Open and Save dialogs in
illustrations.
Open/Save dialogs - Show ODMA DMS dialogs first
(Windows only) If you have the GroupWise client installed on the computer, you can select this
option to have LibreOffice.org offer to open documents from GroupWise, or save documents in
GroupWise. If the GroupWise client is not installed, this option has no effect.
Print dialogs – Use LibreOffice dialogs
(Mac only) To use the standard Print dialogs for your operating system, deselect the Use
LibreOffice dialogs option. When this option is selected, the Print dialogs supplied with
LibreOffice will be used. This book uses the LibreOffice Print dialogs in illustrations.
Document status – Printing sets “document modified” status
If this option is selected, then the next time you close the document after printing, the print date
is recorded in the document properties as a change and you will be prompted to save the
document again, even if you did not make any other changes.
Document status – Allow to save document even when the document is not modified
Normally when a document has not been modified, the File > Save menu option and the Save
icon on the Standard toolbar are disabled and the keyboard shortcut Ctrl+S has no effect.
Select this option to allow documents to be saved even when they have not been modified.
Year (two digits)
Specifies how two-digit years are interpreted. For example, if the two-digit year is set to 1930,
and you enter a date of 1/1/30 or later into your document, the date is interpreted as 1/1/1930
or later. An “earlier” date is interpreted as being in the following century; that is, 1/1/20 is
interpreted as 1/1/2020.
Enable experimental (unstable) features
To try out two experimental features in LibreOffice, in-line formula editing and macro recording,
select this option.

Memory options
In the Options dialog, click LibreOffice > Memory. These options control how LibreOffice uses
your computer’s memory and how much memory it requires. Before changing them, you may wish
to consider the following points:

• More memory can make LibreOffice faster and more convenient (for example, more undo
steps require more memory); but the trade-off is less memory available for other
applications and you could run out of memory altogether.

• If your documents contain a lot of objects such as images, or the objects are large,
LibreOffice’s performance may improve if you increase the memory for LibreOffice or the
memory per object. If you find that objects seem to disappear from a document that
contains a lot of them, increase the number of objects in the cache. (The objects are still in
the file even if you cannot see them on screen.)
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Figure 22: Choosing Memory options for the LibreOffice applications

• To load the Quickstarter (an icon on the desktop or in the system tray) when you start your
computer, select the option near the bottom of the dialog. This makes LibreOffice start
faster; the trade-off is LibreOffice uses some memory even when not being used. This
option (called Enable systray quickstarter on Linux) is not available on Mac OS X or an
systems where the Quickstarter module has not been installed.

View options
The options on the LibreOffice – View page affect the way the document window looks and
behaves. Some of these options are described below. Set them to suit your personal preferences.

Figure 23: Choosing View options for LibreOffice applications
User Interface – Scaling
If the text in the help files or on the menus of the LibreOffice user interface is too small or too
large, you can change it by specifying a scaling factor. Sometimes a change here can have
unexpected results, depending on the screen fonts available on your system. However, it does
not affect the actual font size of the text in your documents.
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User Interface – Icon size and style
The first box specifies the display size of toolbar icons (Automatic, Small, or Large). The
Automatic icon size option uses the setting for your operating system. The second box
specifies the icon style (theme); here the Automatic option uses an icon set compatible with
your operating system and choice of desktop: for example, KDE or Gnome on Linux.
User Interface – Use system font for user interface
If you prefer to use the system font (the default font for your computer and operating system)
instead of the font provided by LibreOffice for the user interface, select this option.
User interface – Screen font anti-aliasing
(Not available in Windows; not shown in Figure 23.) Select this option to smooth the screen
appearance of text. Enter the smallest font size to apply anti-aliasing.
Menu – icons in menus
Causes icons as well as words to be visible in menus.
Font Lists - Show preview of fonts
Causes the font list to look like Figure 24, Left, with the font names shown as an example of
the font; with the option deselected, the font list shows only the font names, not their formatting
(Figure 24, Right). The fonts you will see listed are those that are installed on your system.
Fonts which are tuned for use with a specific script, such as Arabic, Hebrew, Malayalam, and
so on, now show an additional preview of some sample text in the target script.

Figure 24. Font list (Left) With preview; (Right) Without preview
Font Lists - Show font history
Causes the last five fonts you have assigned to the current document to be displayed at the top
of the font list. Otherwise fonts are shown in alphabetical order.
Graphics output – Use hardware acceleration
Directly accesses hardware features of the graphical display adapter to improve the screen
display. Not supported on all operating systems and LibreOffice distributions.
Graphics output – Use anti-aliasing
Enables and disables anti-aliasing, which makes the display of most graphical objects look
smoother and with fewer artifacts. Not supported on all operating systems and LibreOffice
distributions.

Tip

Press Shift+Control+R to restore or refresh the view of the current document.

Mouse positioning
Specifies if and how the mouse pointer will be positioned in newly opened dialogs.
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Middle mouse button
Defines the function of the middle mouse button.

• Automatic scrolling – dragging while pressing the middle mouse button shifts the view.
• Paste clipboard – pressing the middle mouse button inserts the contents of the “Selection
clipboard” at the cursor position.
The “Selection clipboard” is independent of the normal clipboard that you use by Edit >
Copy/Cut/Paste or their respective keyboard shortcuts. Clipboard and “Selection clipboard”
can contain different contents at the same time.
Function

Clipboard

Selection clipboard

Copy content

Edit > Copy Control+C

Select text, table, or object.

Paste content

Edit > Paste Control+V pastes
at the cursor position.

Clicking the middle mouse button
pastes at the mouse pointer position.

Pasting into another
document

No effect on the clipboard
contents.

The last marked selection is the
content of the selection clipboard.

Selection – Transparency
Determines the appearance of selected text or graphics, which appear on a shaded
background. To make the shaded background more or less dark, increase or decrease the
Transparency setting.
If you prefer selected material to appear in reversed color (typically white text on a black
background), deselect this option.

Print options
On the LibreOffice – Print page, set the print options to suit your default printer and your most
common printing method.

Figure 25: Choosing general printing options to apply to all LibreOffice components
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In the Printer warnings section near the bottom of the page, you can choose whether to be warned
if the paper size or orientation specified in your document does not match the paper size or
orientation available for your printer. Having these warnings turned on can be quite helpful,
particularly if you work with documents produced by people in other countries where the standard
paper size is different from yours.

Tip

If your printouts are incorrectly placed on the page or chopped off at the top, bottom,
or sides, or the printer is refusing to print, the most likely cause is page size
incompatibility.

Path options
On the LibreOffice – Paths page, you can change the location of files associated with, or used by,
LibreOffice to suit your working situation. In a Windows system, for example, you might want to
store documents by default somewhere other than My Documents.
To make changes, select an item in the list shown in Figure 26 and click Edit. On the Select Path
dialog (not shown; may also be titled Edit Paths), add or delete folders as required, and then click
OK to return to the Options dialog. Note that some items can have at least two paths listed: one to
a shared folder (which might be on a network) and one to a user-specific folder (normally on the
user’s personal computer).

Tip

You can use the entries on the LibreOffice – Paths page to compile a list of files,
such as those containing AutoText, that you need to back up or copy to another
computer.

Figure 26: Viewing the paths of files used by LibreOffice
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Color options
On the LibreOffice – Colors page, you can specify colors to use in LibreOffice documents. You can
select a color from a color table, edit an existing color, and define new colors. These colors are
stored in your color palette and are then available in all components of LibreOffice.

Figure 27: Defining colors to use in color palettes in LibreOffice
To modify a color:
1) Select the color to modify from the list or the color table.
2) Enter the new values that define the color. You can choose the RGB (Red, Green, Blue) or
the CMYK (Cyan, Magenta, Yellow, Black) system to specify your color. The changed color
appears in the lower of the two color preview boxes at the top.
3) Modify the Name as required.
4) Click the Modify button. The newly defined color is now listed in the Color table.
Alternatively, click the Edit button to open the Color Picker dialog, shown in Figure 28. Here you
can select a color from the window on the left, or you can enter values on the right using your
choice of RGB, CMYK, or HSB (Hue, Saturation and Brightness) values.
The color window on the left is linked directly with the color input fields on the right; as you choose
a color in the window, the numbers change accordingly. The color field at the lower left shows the
value of the selected color on the left and the currently set value from the color value fields on the
right.
Modify the color components as required and click OK to exit the dialog. The newly defined color
now appears in the lower of the color preview boxes shown in Figure 27. Type a name for this color
in the Name box, then click the Add button. A small box showing the new color is added to the
Color table.
Another way to define or alter colors is through the Colors page of the Area dialog, where you can
also save and load palettes, a feature that is not possible here. In Calc, draw a temporary draw
object and use the context menu of this object to open the Area dialog. If you load a palette in one
component of LibreOffice, it is only active in that component; the other components keep their own
palettes.
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Figure 28: Editing colors

Font options
You can define replacements for any fonts that might appear in your documents. If you receive
from someone else a document containing fonts that you do not have on your system, LibreOffice
will substitute fonts for those it does not find. You might prefer to specify a different font from the
one that the program chooses.

Figure 29: Defining a font to be substituted for another font
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On the LibreOffice – Fonts page:
1) Select the Apply Replacement Table option.
2) Select or type the name of the font to be replaced in the Font box. (If you do not have this
font on your system, it will not appear in the drop-down list in this box, so you need to type
it in.)
3) In the Replace with box, select a suitable font from the drop-down list of fonts installed on
your computer.
4) The checkmark to the right of the Replace with box turns green. Click on this checkmark.
A row of information now appears in the larger box below the input boxes. Select the
options under Always and Screen.
5) In the bottom section of the page, you can change the typeface and size of the font used to
display source code such as HTML and Basic (in macros).

Security options
Use the LibreOffice – Security page to choose security options for saving documents and for
opening documents that contain macros.

Figure 30: Choosing security options for opening and saving documents
Security options and warnings
If you record changes, save multiple versions, or include hidden information or notes in your
documents, and you do not want some of the recipients to see that information, you can set
warnings to remind you to remove it, or you can have LibreOffice remove some of it
automatically. Note that (unless removed) much of this information is retained in a file whether
the file is in LibreOffice’s default OpenDocument format, or has been saved to other formats,
including PDF.
Click the Options button to open a separate dialog with specific choices (Figure 31).
Macro security
Click the Macro Security button to open the Macro Security dialog (not shown here), where
you can adjust the security level for executing macros and specify trusted sources.
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Security options and warnings
The following options are on the Security options and warnings dialog (Figure 31).
Remove personal information on saving
Select this option to always remove user data from the file properties when saving the file. To
manually remove personal information from specific documents, deselect this option and then
use the Delete button under File > Properties > General.
Ctrl-click required to follow hyperlinks
The default behavior in LibreOffice is to Ctrl+click on a hyperlink to open the linked document.
Many people find creation and editing of documents easier when accidental clicks on links do
not activate the links. To set LibreOffice to activate hyperlinks using an ordinary click, deselect
this option.
The other options on this dialog should be self-explanatory.

Figure 31: Security options and warnings dialog

Appearance options
Writing, editing, and (especially) page layout are often easier when you can see the page margins
(text boundaries), the boundaries of tables and sections (in Writer documents), page breaks in
Calc, grid lines in Draw or Writer, and other features. In addition, you might prefer to use colors that
are different from LibreOffice’s defaults for such items as note indicators or field shadings.
On the LibreOffice – Appearance page (Figure 32), you can specify which items are visible and the
colors used to display various items.

• To show or hide items such as text boundaries, select or deselect the options next to the
names of the items.

• To change the default colors for items, click the down-arrow in the Color Setting column by
the name of the item and select a color from the pop-up box.

• To save your color changes as a color scheme, click Save, type a name in the Scheme
box; then click OK.

44

Getting Started with LibreOffice 3.5

Figure 32: Showing or hiding text, object, and table boundaries

Accessibility options
Accessibility options include whether to allow animated graphics or text, how long help tips remain
visible, some options for high contrast display, and a way to change the font for the user interface
of the LibreOffice program.
Accessibility support relies on Sun Microsystems Java technology for communications with
assistive technology tools. See “Java options“ below. The Support assistive technology tools option
is not shown on all LibreOffice installations. See Assistive Tools in LibreOffice in the Help for other
requirements and information.
Select or deselect the options as required.

Figure 33: Choosing accessibility options
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Java options
If you install or update a Java Runtime Environment (JRE) after you install LibreOffice, or if you
have more than one JRE installed on your computer, you can use the LibreOffice – Java options
page to choose the JRE for LibreOffice to use.
If you are a system administrator, programmer, or other person who customizes JRE installations,
you can use the Parameters and Class Path pages (reached from the Java page) to specify this
information.
If you do not see anything listed in the middle of the page, wait a few minutes while LibreOffice
searches for JREs on the hard disk.
If LibreOffice finds one or more JREs, it will display them there. You can then select the Use a
Java runtime environment option and (if necessary) choose one of the JREs listed.

Figure 34: Choosing a Java runtime environment

Online update options
On the LibreOffice – Online Update page (Figure 35), you can choose whether and how often to
have the program check the LibreOffice website for program updates. If the Check for updates
automatically option is selected, an icon appears at the right-hand end of the menu bar when an
update is available. Click this icon to open a dialog where you can choose to download the update.
If the Download updates automatically option is selected, the download starts when you click the
icon. To change the download destination, click the Change button and select the required folder in
the file browser window.
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Figure 35: Online update options

Choosing options for loading and saving documents
You can set the Load/Save options to suit the way you work.
If the Options dialog is not already open, click Tools > Options. Click the expansion symbol (+ or
triangle) to the left of Load/Save.

Figure 36: Load/Save options

General Load/Save options
Most of the choices on the Load/Save – General page are familiar to users of other office suites.
Some items of interest are described below.
Load user-specific settings with the document
When you save a document, certain settings are saved with it. Some settings (printer name,
data source linked to the document) are always loaded with a document, whether or not this
option is selected. If you select this option, these document settings are overruled by the userspecific settings of the person who opens it. If you deselect this option, the user’s personal
settings do not overrule the settings in the document. For example, your choice (in the options
for LibreOffice Writer) of how to update links is affected by the Load user-specific settings
option.
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Figure 37. Choosing Load and Save options
Load printer settings with the document
If this option is not selected, the printer settings that are stored with the document are ignored
when you print it using the Print File Directly icon. The default printer in your system will be
used instead.
Edit document properties before saving
If you select this option, the Document Properties dialog pops up to prompt you to enter
relevant information the first time you save a new document (or whenever you use Save As).
Save AutoRecovery information every
Choose whether to enable AutoRecovery and how often to save the information used by the
AutoRecovery process.
AutoRecovery in LibreOffice overwrites the original file. If you also choose Always create
backup copy, the original file then overwrites the backup copy. If you have this set, recovering
your document after a system crash will be easier; but recovering an earlier version of the
document may be harder.
Save URLs relative to file system / internet
Relative addressing to a file system is only possible if the source document and the referenced
document are both on the same drive. A relative address always starts from the directory in
which the current document is located. It is recommended to save relatively if you want to
create a directory structure on an Internet server.
Default file format and ODF settings
ODF format version. LibreOffice by default saves documents in OpenDocument Format
(ODF) version 1.2 Extended. While this allows for improved functionality, there may be
backwards compatibility issues. When a file saved in ODF 1.2 Extended is opened in an editor
that uses earlier versions of ODF, 1.0/1.1, some of the advanced features may be lost. Two
notable examples are cross-references to headings and the formatting of numbered lists. If you
plan to share documents with people who use editors which use older versions of ODF, save
the document using ODF version 1.0/1.1.
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Size optimization for ODF format. LibreOffice documents are XML files. When you select this
option, LibreOffice writes the XML data without indents and line breaks. If you want to be able
to read the XML files in a text editor in a structured form, deselect this option.
Document type. If you routinely share documents with users of Microsoft Office, you might
want to change the Always save as attribute for documents to one of the Microsoft Office
formats.

Note

Although LibreOffice can open and save files in the .docx and .xlsx formats
produced by Microsoft Office 2007 and 2010, it does not yet save in .pptx format.
This capability is planned for a future release.

VBA Properties Load/Save options
On the Load/Save – VBA Properties page, you can choose whether to keep any macros in
Microsoft Office documents that are opened in LibreOffice.

Figure 38: Choosing Load/Save VBA Properties

• If you choose Load Basic code, the changed code is saved in an LibreOffice document
but is not retained if you save into a Microsoft Office format.

• If you choose Save original Basic code, the macros will not work in LibreOffice but are
retained if you save the file into Microsoft Office format.

• If you are importing a Microsoft Word or Excel file containing VBA code, you can select the
option Executable code. Whereas normally the code is preserved but rendered inactive (if
you inspect it with the StarBasic IDE you will notice that it is all commented), with this
option the code is ready to be executed.

Microsoft Office Load/Save options
On the Load/Save – Microsoft Office page, you can choose what to do when importing and
exporting Microsoft Office OLE objects (linked or embedded objects or documents such as
spreadsheets or equations).
Select the [L] options to convert Microsoft OLE objects into the corresponding LibreOffice OLE
objects when a Microsoft document is loaded into LibreOffice (mnemonic: “L” for “load”).
Select the [S] options to convert LibreOffice OLE objects into the corresponding Microsoft OLE
objects when a document is saved in a Microsoft format (mnemonic: “S” for “save”).
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Figure 39: Choosing Load/Save Microsoft Office options

HTML compatibility Load/Save options
Choices made on the Load/Save – HTML Compatibility page affect HTML pages imported into
LibreOffice and those exported from LibreOffice. See HTML documents; importing/exporting in the
Help for more information.
Font sizes
Use these fields to define the respective font sizes for the HTML <font size=1> to <font size=7>
tags, if they are used in the HTML pages. (Many pages no longer use these tags.)
Import - Use 'English (USA)' locale for numbers
When importing numbers from an HTML page, the decimal and thousands separator
characters differ according to the locale of the HTML page. The clipboard, however, contains
no information about the locale. If this option is not selected, numbers will be interpreted
according to the Language - Locale setting in Tools > Options > Language Settings >
Languages (see page 52). If this option is selected, numbers will be interpreted as for the
English (USA) locale.

Figure 40. Choosing HTML compatibility options
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Import - Import unknown HTML tags as fields
Select this option if you want tags that are not recognized by LibreOffice to be imported as
fields. For an opening tag, an HTML_ON field will be created with the value of the tag name.
For a closing tag, an HTML_OFF will be created. These fields will be converted to tags in the
HTML export.
Import - Ignore font settings
Select this option to have LibreOffice ignore all font settings when importing. The fonts that
were defined in the HTML Page Style will be used.
Export
To optimize the HTML export, select a browser or HTML standard from the Export box. If
LibreOffice Writer is selected, specific LibreOffice Writer instructions are exported.
Export - LibreOffice Basic
Select this option to include LibreOffice Basic macros (scripts) when exporting to HTML format.
You must activate this option before you create the LibreOffice Basic macro; otherwise the
script will not be inserted. LibreOffice Basic macros must be located in the header of the HTML
document. Once you have created the macro in the LibreOffice Basic IDE, it appears in the
source text of the HTML document in the header.
If you want the macro to run automatically when the HTML document is opened, choose Tools
> Customize > Events. See Chapter 13, Getting Started with Macros, for more information.
Export - Display warning
When the LibreOffice Basic option (see above) is not selected, the Display warning option
becomes available. If the Display warning option is selected, then when exporting to HTML a
warning is shown that LibreOffice Basic macros will be lost.
Export - Print layout
Select this option to export the print layout of the current document as well. The HTML filter
supports CSS2 (Cascading Style Sheets Level 2) for printing documents. These capabilities
are only effective if print layout export is activated.
Export - Copy local graphics to Internet
Select this option to automatically upload the embedded pictures to the Internet server when
uploading using FTP.
Export - Character set
Select the appropriate character set for the export.

Choosing language settings
There are several options to customize the language setting in LibreOffice:
• Install the required dictionaries
• Change some locale and language settings
• Choose spelling options

Install the required dictionaries
LibreOffice automatically installs several dictionaries with the program. To add other dictionaries,
be sure you are connected to the Internet, and then use Tools > Language > More Dictionaries
Online. LibreOffice will open your default web browser to a page containing links to additional
dictionaries that you can install.
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When you download the dictionary or dictionaries that you want, they will be in the OpenDocument
extension format (.oxt). To install these extensions, use Tools > Extension Manager. Click on
Add, located at the bottom of the Extension Manager dialog, navigate to the location of your
dictionary in .oxt format, select the .oxt dictionary, and click Open.

Change locale and language settings
You can change some details of the locale and language settings that LibreOffice uses for all
documents, or for specific documents.
In the Options dialog, click Language Settings > Languages.

Figure 41: Language Setting Options
On the right-hand side of the Language Settings – Languages page, change the User interface,
Locale setting, Default currency, and Default languages for documents as required. In the
example, English (USA) has been chosen for all the appropriate settings.

Figure 42: Choosing language options
If you want the language (dictionary) setting to apply to the current document only, instead of being
the default for all new documents, select the option labeled For the current document only.
If necessary, select the options to enable support for Asian languages (Chinese, Japanese,
Korean) and support for CTL (complex text layout) languages such as Urdu, Thai, Hebrew, and
Arabic. If you choose either of these options, the next time you open this dialog, you will see some
extra choices under Language Settings, as shown below. These choices (Searching in Japanese,
Asian Layout, and Complex Text Layout) are not discussed here.
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Figure 43: Extra pages available when enhanced language support options are selected

Choose spelling options
To choose the options for checking spelling, click Language Settings > Writing Aids. In the
Options section of the page (Figure 44), choose the settings that are useful for you.

Figure 44: Choosing languages, dictionaries, and options for checking spelling
Some considerations:

• If you do not want spelling checked while you type, deselect Check spelling as you type
and select Do not mark errors. (To find the second item, scroll down in the Options list.)

• If you use a custom dictionary that includes words in all upper case and words with
numbers (for example, AS/400), select Check uppercase words and Check words with
numbers.

• Check special regions includes headers, footers, frames, and tables when checking
spelling.
Here you can also check which user-defined (custom) dictionaries are active by default, and add or
remove dictionaries, by clicking the New or Delete buttons.

Note

LibreOffice has a spelling and grammar checker called Language Tool. You can
access the tool from Tools > Spelling and Grammar.
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Choosing Internet options
Use the Internet Options pages to define search engines and save proxy settings for use with
LibreOffice.
If you are using a Mozilla browser (such as Firefox) on Windows or Linux, you can enable the
Browser Plug-in so you can open LibreOffice files in your browser, print them, save them, and work
with them in other ways.
If you are using a Unix- or Linux-based operating system (including Mac OS X), an additional page
of E-mail options is available, where you can specify the e-mail program to use when you send the
current document as e-mail. See Figure 45. Under Windows the operating system’s default e-mail
program is always used.

Figure 45: Internet options, showing E-mail page available to Linux users
Windows and Linux installations also have a Wiki Publisher extension included by default. Select
MediaWiki in the Internet options, then click the Add button to open the dialog shown in Figure 46.
Here you can specify the address (URL) and login information for a wiki. You can add several wikis
to the list.

Figure 46: Specifying a MediaWiki server account
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Controlling LibreOffice’s AutoCorrect functions
Some people find some or all of the items in LibreOffice’s AutoCorrect function annoying because
they change what you type when you do not want it changed. Many people find some of the
AutoCorrect functions quite helpful; if you do, then select the relevant options. But if you find
unexplained changes appearing in your document, this is a good place to look to find the cause.
To open the AutoCorrect dialog, click Tools > AutoCorrect Options. (You need to have a
document open for this menu item to appear.)
In Writer, this dialog has five tabs, as shown in Figure 47. In other components of LibreOffice, the
dialog has only four tabs. More details are given in the component guides.

Figure 47: The top portion of the AutoCorrect dialog in Writer
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Chapter 3
Using Styles and Templates

What is a template?
A template is a model that you use to create other documents. For example, you can create a
template for business reports that has your company’s logo on the first page. New documents
created from this template will all have your company’s logo on the first page.
Templates can contain anything that regular documents can contain, such as text, graphics, a set
of styles, and user-specific setup information such as measurement units, language, the default
printer, and toolbar and menu customization.
All documents in LibreOffice are based on templates. You can create a specific template for any
document type (text, spreadsheet, drawing, presentation). If you do not specify a template when
you start a new document, then the document is based on the default template for that type of
document. If you have not specified a default template, LibreOffice uses the blank template for that
type of document that is installed with LibreOffice. See “Setting a default template” on page 71 for
more information.

What are styles?
A style is a set of formats that you can apply to selected pages, text, frames, and other elements in
your document to quickly change their appearance. When you apply a style, you apply a whole
group of formats at the same time.
Many people manually format paragraphs, words, tables, page layouts, and other parts of their
documents without paying any attention to styles. They are used to writing documents according to
physical attributes. For example, you might specify the font family, font size, and any formatting
such as bold or italic.
Styles are logical attributes. Using styles means that you stop saying “font size 14pt, Times New
Roman, bold, centered”, and you start saying “Title” because you have defined the “Title” style to
have those characteristics. In other words, styles means that you shift the emphasis from what the
text (or page, or other element) looks like, to what the text is.
Styles help improve consistency in a document. They also make major formatting changes easy.
For example, you may decide to change the indentation of all paragraphs, or change the font of all
titles. For a long document, this simple task can be prohibitive. Styles make the task easy.
In addition, styles are used by LibreOffice for many processes, even if you are not aware of them.
For example, Writer relies on heading styles (or other styles you specify) when it compiles a table
of contents. Some common examples of style use are given in “Examples of style use” on page 76.
LibreOffice supports the following types of styles:

• Page styles include margins, headers and footers, borders and backgrounds. In Calc, page
styles also include the sequence for printing sheets.

• Paragraph styles control all aspects of a paragraph’s appearance, such as text alignment,
tab stops, line spacing, and borders, and can include character formatting.

• Character styles affect selected text within a paragraph, such as the font and size of text, or
bold and italic formats.

• Frame styles are used to format graphic and text frames, including wrapping type, borders,
backgrounds, and columns.

• Numbering styles apply similar alignment, numbering or bullet characters, and fonts to
numbered or bulleted lists.

• Cell styles include fonts, alignment, borders, background, number formats (for example,
currency, date, number), and cell protection.
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• Graphics styles in drawings and presentations include line, area, shadowing, transparency,
font, connectors, dimensioning, and other attributes.

• Presentation styles include attributes for font, indents, spacing, alignment, and tabs.
Different styles are available in the various components of LibreOffice, as listed in Table 2.
LibreOffice comes with many predefined styles. You can use the styles as provided, modify them,
or create new styles, as described in this chapter.
Table 2. Styles available in LibreOffice components
Style Type

Writer

Calc

Page

X

X

Paragraph

X

Character

X

Frame

X

Numbering

X

Cell

Draw

Impress

X

X

X

X

X

Presentation
Graphics

(included in
Frame styles)

Applying styles
LibreOffice provides several ways for you to select styles to apply.

Using the Styles and Formatting window
1) Click the Styles and Formatting icon
located at the left-hand end of the formatting
toolbar, or click Format > Styles and Formatting, or press F11. The Styles and Formatting
window shows the types of styles available for the LibreOffice component you are using.
Figure 48 shows the window for Writer, with Page Styles visible.
You can move this window to a convenient position on the screen or dock it to an edge
(hold down the Ctrl key and drag it by the title bar to where you want it docked).
2) Click on one of the icons at the top left of the Styles and Formatting window to display a list
of styles in a particular category.
3) To apply an existing style (except for character styles), position the insertion point in the
paragraph, frame, or page, and then double-click on the name of the style in one of these
lists. To apply a character style, select the characters first.

Tip

At the bottom of the Styles and Formatting window is a drop-down list. In Figure 48
the window shows Automatic, meaning the list includes only styles applied
automatically by LibreOffice. You can choose to show all styles or other groups of
styles, for example only custom styles.
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Figure 48: The Styles and Formatting window for Writer, showing paragraph styles

Using Fill Format Mode
Use Fill Format to apply a style to many different areas quickly without having to go back to the
Styles and Formatting window and double-click every time. This method is quite useful when you
need to format many scattered paragraphs, cells, or other items with the same style.
1) Open the Styles and Formatting window and select the style you want to apply.
2) Click the Fill Format Mode icon
.
3) To apply a paragraph, page, or frame style, hover the mouse over the paragraph, page, or
frame and click. To apply a character style, hold down the mouse button while selecting the
characters, Clicking on a word applies the character style for that word. Repeat step 3 until
you made all the changes for that style.
4) To quit Fill Format mode, click the Fill Format Mode icon again or press the Esc key.

Caution

When this mode is active, a right-click anywhere in the document undoes the last Fill
Format action. Be careful not to accidentally right-click and thus undo actions you
want to keep.

Using the Apply Style list
After you have used a style at least once in a document, the style name appears on the Apply Style
list at the left-hand end of the Formatting toolbar, next to the Styles and Formatting icon.
You can open this list and click once on the style you want, or you can use the up and down arrow
keys to move through the list and then press Enter to apply the highlighted style.

Tip
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Figure 49: The Apply Style list on the Formatting toolbar

Using keyboard shortcuts
Some keyboard shortcuts for applying styles are predefined. For example, in Writer Control+0
applies the Text body style, Control+1 applies the Heading 1 style, and Control+2 applies the
Heading 2 style. You can modify these shortcuts and create your own; see Chapter 14,
Customizing LibreOffice, for instructions.

Caution

Manual formatting (also called direct formatting) overrides styles, and you cannot get
rid of the manual formatting by applying a style to it.
To remove manual formatting, select the text, right-click, and choose Clear Direct
Formatting from the pop-up menu.

Modifying styles
LibreOffice provides several ways to modify styles (both the predefined styles and any custom
styles that you create):

•
•
•
•

Changing a style using the Style dialog
Updating a style from a selection
Use AutoUpdate (paragraph and frame styles only)
Load or copy styles from another document or template

Tip

Any changes you make to a style are effective only in the current document. To
change styles in more than one document, you need to change the template or copy
the styles into the other documents as described on page 64.

Changing a style using the Style dialog
To change an existing style using the Style dialog, right-click on the required style in the Styles and
Formatting window and select Modify from the pop-up menu.
The Style dialog displayed depends on the type of style selected. Each style dialog has several
tabs. See the chapters on styles in the user guides for details.
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Updating a style from a selection
To update a style from a selection:
1) Open the Styles and Formatting window.
2) In the document, select an item that has the format you want to adopt as a style.

Caution

Make sure that there are unique properties in this paragraph. For example, if there
are two different font sizes or font styles, that particular property will remain the
same as before.

3) In the Styles and Formatting window, select the style you want to update (single-click, not
double-click), then click on the arrow next to the New Style from Selection icon and click
on Update Style.

Figure 50: Updating a style from a selection

Using AutoUpdate
AutoUpdate applies to paragraph and frame styles only. If the AutoUpdate option is selected on the
Organizer page of the Paragraph Style or Frame Style dialog, applying direct formatting to a
paragraph or frame using this style in your document automatically updates the style itself.

Tip

If you are in the habit of manually overriding styles in your document, be sure that
AutoUpdate is not enabled.

Updating styles from a document or template
You can update styles by copying or loading them from a template or another document. See
“Copying and moving styles” on page 64.

Creating new (custom) styles
You may want to add some new styles. You can do this in two ways:

• Creating a new style using the Style dialog
• Creating a new style from a selection
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Creating a new style using the Style dialog
To create a new style using the Style dialog, right-click in the Styles and Formatting window and
select New from the pop-up menu.
If you want your new style to be linked with an existing style, first select that style and then rightclick and select New.
If you link styles, then when you change the base style (for example, by changing the font from
Times to Helvetica), all the linked styles will change as well. Sometimes this is exactly what you
want; other times you do not want the changes to apply to all the linked styles. It pays to plan
ahead.
The dialogs and choices are the same for defining new styles and for modifying existing styles.
See the chapters on styles in the user guides for details.

Creating a new style from a selection
You can create a new style by copying an existing manual format. This new style applies only to
this document; it will not be saved in the template.
1) Open the Styles and Formatting window and choose the type of style you want to create.
2) In the document, select the item you want to save as a style.
3) In the Styles and Formatting window, click on the New Style from Selection icon.
4) In the Create Style dialog, type a name for the new style. The list shows the names of
existing custom styles of the selected type. Click OK to save the new style.

Figure 51: Naming a new style created from a selection

Dragging and dropping to create a style
You can drag and drop a text selection into the Styles and Formatting window to create a new
style.
Writer
Select some text and drag it to the Styles and Formatting window. If Paragraph Styles are
active, the paragraph style will be added to the list. If Character Styles are active, the character
style will be added to the list.
Calc
Drag a cell selection to the Styles and Formatting window to create cell styles.
Draw/Impress
Select and drag drawing objects to the Styles and Formatting window to create graphics styles.
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Copying and moving styles
You can copy or move styles from one template or document into another template or document, in
two ways:

• Using the Template Management dialog
• Loading styles from a template or document

Using the Template Management dialog
To copy or move styles using the Template Management dialog:
1) Click File > Templates > Organize.
2) In the Template Management dialog (Figure 52), set the lists at the bottom to either
Templates or Documents, as needed. The default is Templates on the left and Documents
on the right.

Figure 52: Choosing to copy styles from a document, not a template

Tip

To copy styles from a file that is not open, click the File button. When you return to
this dialog, both lists show the selected file as well as all the currently open
documents.

3) Open the folders and find your chosen source and destination templates. Double-click on
the name of the template or document, and then double-click the Styles icon to show the
list of individual styles (Figure 53).
4) To copy a style, hold down the Ctrl key and drag the name of the style from one list to the
other.

Caution
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If you do not hold down the Control key when dragging, the style will be moved from
one list to the other rather than copied. The style will be deleted from the list you are
dragging it from.
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5) Repeat for each style you want to copy. If the receiving template or document has many
styles, you may not see any change unless you scroll down in the list. When you are
finished, click Close.

Figure 53: Copying a style from one document to another

Loading styles from a template or document
You can copy styles by loading them from a template or another document:
1) Open the document you want to copy styles into.
2) In the Styles and Formatting window, click on the arrow next to the New Style from
Selection icon, and then click on Load Styles (see Figure 50).
3) On the Load Styles dialog (Figure 54), find and select the template you want to copy styles
from.

Figure 54. Copying styles from a template into the open document
4) Select the categories of styles to be copied. Select Overwrite if you want the styles being
copied to replace any styles of the same names in the document you are copying them
into.
5) Click OK to copy the styles. You will not see any change on screen.
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Note

Caution

To copy the styles from another document, click the From File button to open a
window from which you can select the required document.
If your document has a table of contents, and if you have used custom styles for
headings, the heading levels associated with outline levels (in Tools > Outline
Numbering) will revert to the defaults of Heading 1, Heading 2, and so on when you
load styles this way. You will need to change these back to your custom heading
styles.

Deleting styles
You cannot remove (delete) any of LibreOffice’s predefined styles from a document or template,
even if they are not in use.
You can remove any user-defined (custom) styles; but before you do, you should make sure the
styles are not in use in the current document. If an unwanted style is in use, you will want to
replace it with a substitute style.
To delete unwanted styles, right-click on them (one at a time) in the Styles and Formatting window
and click Delete on the pop-up menu.
If the style is in use, you receive a warning message.

Caution

Make sure the style is not in use before deletion. Otherwise, all objects with that
style will return to the default style and retain their formatting as manual formatting.

If the style is not in use, you receive a confirmation message; click Yes to delete the style.

Using a template to create a document
To use a template to create a document:
1) From the main menu, choose File > New > Templates and Documents. The Templates
and Documents dialog opens.
2) In the box on the left, click the Templates icon if it is not already selected. A list of template
folders appears in the center box.
3) Double-click the folder that contains the template that you want to use. A list of all the
templates contained in that folder appears in the center box (as shown in Figure 55).
4) Select the template that you want to use. You can either preview the selected template or
view the template’s properties:

•

To preview the template, click the Preview icon
appears in the box on the right.

•

To view the template’s properties, click the Document Properties icon
template’s properties appear in the box on the right.

. A preview of the template
. The

5) Click Open. The Templates and Documents dialog closes and a new document based on
the selected template opens in LibreOffice. You can then edit and save the new document
just as you would any other document.
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Figure 55: Templates and Documents dialog

Creating a template
You can create your own templates in two ways: from a document or using a wizard.

Creating a template from a document
To create a template from a document:
1) Open a new or existing document of the type you want to make into a template (text
document, spreadsheet, drawing, presentation).
2) Add the content and styles that you want.
3) From the main menu, choose File > Templates > Save. The Templates dialog opens.

Figure 56: Saving a new template
4) In the New template field, type a name for the new template.
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5) In the Categories list, click the category to which you want to assign the template. The
category you choose has no effect on the template itself; it is simply the folder in which you
save the template. Choosing an appropriate category makes it easier to find the template
when you want to use it. For example, you might save Impress templates under the
Presentations category.
To learn more about template folders, see “Organizing templates” on page 73.
6) Click OK to save the new template.
Any settings that can be added to or modified in a document can be saved in a template. For
example, below are some of the settings (although not a full list) that can be included in a Writer
document and then saved as a template for later use:

• Printer settings: which printer, single-sided or double-sided printing, paper size, and so on
• Styles to be used, including character, page, frame, numbering and paragraph styles
• Format and settings regarding indexes, tables, bibliographies, table of contents
Templates can also contain predefined text, saving you from having to type it every time you create
a new document. For example, a letter template may contain your name, address, and salutation.
You can also save menu and toolbar customizations in templates; see Chapter 14, Customizing
LibreOffice, for more information.

Creating a template using a wizard
You can use wizards to create templates for letters, faxes, agendas, presentations, and Web
pages.
For example, the Fax Wizard guides you through the following choices:

• Type of fax (business or personal)
• Document elements like the date, subject line (business fax), salutation, and
complementary close

• Options for sender and recipient information (business fax)
• Text to include in the footer (business fax)
To create a template using a wizard:
1) From the main menu, choose File > Wizards > [type of template required].

Figure 57. Creating a template using a wizard
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2) Follow the instructions on the pages of the wizard. This process is slightly different for each
type of template, but the format is very similar.
3) In the last section of the wizard, you can specify the name and location for saving the
template. The default location is your user templates directory, but you can choose a
different location if you prefer.
4) Finally, you have the option of creating a new document from your template immediately, or
manually changing the template. For future documents, you can re-use the template
created by the wizard, just as you would use any other template.

Editing a template
You can edit a template’s styles and content, and then, if you wish, you can reapply the template’s
styles to documents that were created from that template. (Note that you can only reapply styles.
You cannot reapply content.)
To edit a template:
1) From the main menu, choose File > Templates > Edit. A standard file browser window
opens.
2) Select and open the template that you want to edit.
3) Edit the template just as you would any other document. To save your changes, choose
File > Save from the main menu.

Updating a document from a changed template
The next time you open a document that was created from the changed template, the following
message appears.

Figure 58. Update styles message
Click Update Styles to apply the template’s changed styles to the document. Click Keep Old
Styles if you do not want to apply the template’s changed styles to the document (but see the
Caution notice below).

Caution

If you choose Keep Old Styles in the message box shown in Figure 58, that
message will not appear again the next time you open the document after changing
the template it is based on. You will not get another chance to update the styles from
the template, although you can use the macro given in the Note below to re-enable
this feature.
If you are using Writer, you can also use the Template Changer extension (see page
73) to reactivate the template.
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Note

To re-enable updating from a template:
1) Use Tools > Macros > Organize Macros > LibreOffice Basic. Select the
document from the list, click the expansion symbol (+ or triangle), and select
Standard. If Standard has an expansion symbol beside it, click that and select a
module.
2) If the Edit button is active, click it. If the Edit button is not active, click New.
3) In the Basic window, enter the following:
Sub FixDocV3
' set UpdateFromTemplate
oDocSettings = ThisComponent.createInstance( _
"com.sun.star.document.Settings" )
oDocSettings.UpdateFromTemplate = True
End Sub 'FixDocV3
4) Click the Run BASIC icon, then close the Basic window.
5) Save the document.
The next time you open this document, you will be prompted to update the styles
from the modified template.

Adding templates obtained from other sources
You can download templates for LibreOffice from many sources, including the official template
repository at http://templates.libreoffice.org/, and install them on your computer. On other websites
you may find collections of templates that have been packaged into extension (.OXT) files. These
are installed a bit differently, as described below.

Installing individual templates
To install individual templates:
1) Download the template and save it anywhere on your computer.
2) Import the template into a template folder by following the instructions in “Importing a
template“ on page 74.

Tip

(For advanced users) If you know the location of LibreOffice template folders, you
can manually copy new templates into them. The location varies with your
computer’s operating system. To learn where the template folders are stored on
your computer, go to Tools > Options > LibreOffice > Paths.

Installing collections of templates
The Extension Manager provides an easy way to install collections of templates that have been
packaged as extensions. Follow these steps:
1) Download the extension package (.OXT file) and save it anywhere on your computer.
2) In LibreOffice, select Tools > Extension Manager from the menu bar. In the Extension
Manager dialog (Figure 59), click Add to open a file browser window.
3) Find and select the package of templates you want to install and click Open. The package
begins installing. You may be asked to accept a license agreement.
4) When the package installation is complete, the templates are available for use through File
> New > Templates and Documents and the extension is listed in the Extension Manager.
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Figure 59: Newly-added package of templates
See Chapter 14, Customizing LibreOffice, for more about the Extension Manager.

Setting a default template
If you create a document by choosing File > New > Text Document (or Spreadsheet,
Presentation, or Drawing) from the main menu, LibreOffice creates the document from the default
template for that type of document. You can, however, set a custom template to be the default. You
can reset the default later if you choose.

Note for
Windows
users

You may know that Microsoft Word employs a normal.docm file for its default
template and how to regenerate it.
LibreOffice does not have a similar default template file; the “factory defaults” are
embedded within the software.

Setting a custom template as the default
You can set any template to be the default, as long as it is in one of the folders displayed in the
Template Management dialog.
To set a custom template as the default:
1) From the main menu, choose File > Templates > Organize. The Template Management
dialog opens.
2) In the box on the left, select the folder containing the template that you want to set as the
default, then select the template.
3) Click the Commands button and choose Set As Default Template from the drop-down
menu.
The next time that you create a document by choosing File > New, the document will be created
from this template.
Chapter 3 Using Styles and Templates

71

Figure 60: Setting a default template using the Template Management dialog
Although many important settings can be changed in the Options dialog (see Chapter 2), for
example default fonts and page size, more advanced settings (such as page margins) can only be
changed by replacing the default template with a new one.

Resetting the default template
To re-enable LibreOffice’s default template for a document type as the default:
1) In the Template Management dialog, click any folder in the box on the left.
2) Click the Commands button and choose Reset Default Template from the drop-down
menu. This command does not appear unless a custom template has previously been set
as the default, as described in the previous section.
The next time that you create a document by choosing File > New, the document will be created
from the default template for the document type.

Associating a document with a different template
At times you might want to associate a document with a different template, or perhaps you are
working with a document that did not start from a template.
One of the major advantages of using templates is the ease of updating styles in more than one
document, as described on page 69. If you update styles by loading a new set of styles from a
different template (as described on page 65), the document has no association with the template
from which the styles were loaded—so you cannot use this method. What you need to do is
associate the document with the different template.
You can do this in two ways. In both cases, for best results the names of styles should be the same
in the existing document and the new template. If they are not, you will need to use Edit > Find &
Replace to replace old styles with new ones. See Chapter 4, Getting Started with Writer, for more
about replacing styles using Find & Replace.
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Method 1
This method includes any graphics and wording (such as legal notices) that exists in the new
template, as well as including styles. If you do not want this material, you need to delete it.
1) Use File > New > Templates and Documents. Choose the template you want. If the
template has unwanted text or graphics in it, delete them.
2) Open the document you want to change. (It opens in a new window.) Press Control+A to
select everything in the document. Paste into the blank document created in step 1.
3) Update the table of contents, if there is one. Save the file.
Method 2 (Writer only)
This method does not include any graphics or text from the new template, except material in
headers and footers; it simply includes styles from the new template and establishes an
association between the template and the document.
1) Open the document whose template you want to change. Choose File > Templates >
Assign Template (current document).
2) In the Select Template window, find and select the required template and click Open.
3) Save the document. If you now look in File > Properties, you will see the new template
listed at the bottom of the General page.

Note

In Writer, if you do not see Assign Template (current document) or Assign
Template (folder) under File > Templates, you need to download the Template
Changer extension from http://extensions.libreoffice.org/ and install it as described
on page 70. Then close and reopen LibreOffice to activate the extension.
In Calc, Impress, and Draw, only the Assign Template (folder) choice is available
when the extension is installed.

Organizing templates
LibreOffice can only use templates that are in LibreOffice template folders. You can create new
LibreOffice template folders and use them to organize your templates. For example, you might
have one template folder for report templates and another for letter templates. You can also import
and export templates.
To begin, choose File > Templates > Organize from the main menu to open the Template
Management dialog (Figure 53 on page 65).

Note

Tip

All the actions made by the Commands button in the Template Management dialog
can be made as well by right-clicking on the templates or the folders.

The location of LibreOffice template folders varies with your computer’s operating
system. To learn where the template folders are stored on your computer, go to
Tools > Options > LibreOffice > Paths.

Creating a template folder
To create a template folder:
1) In the Template Management dialog, click any folder.
2) Click the Commands button and choose New from the drop-down menu. A new folder
called Untitled appears.
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3) Type a name for the new folder, and then press Enter. LibreOffice saves the folder with the
name that you entered.

Deleting a template folder
You cannot delete template folders supplied with LibreOffice or installed using the Extension
Manager; you can only delete template folders that you have created.
To delete a template folder that you have created:
1) In the Template Management dialog, select the folder that you want to delete.
2) Click the Commands button and choose Delete from the drop-down menu. A message box
appears, asking you to confirm the deletion. Click Yes.

Moving a template
To move a template from one template folder to another template folder:
1) In the Template Management dialog, double-click the folder that contains the template you
want to move.
2) Click the template that you want to move and drag it to the desired folder. If you do not
have the authority to delete templates from the source folder, this action copies the
template instead of moving it.

Deleting a template
You cannot delete templates supplied with LibreOffice or installed using the Extension Manager;
you can only delete templates that you have created or imported.
To delete a template:
1) In the Template Management dialog, double-click the folder that contains the template you
want to delete.
2) Click the template that you want to delete.
3) Click the Commands button and choose Delete from the drop-down menu. A message box
appears and asks you to confirm the deletion. Click Yes.

Importing a template
If the template that you want to use is in a different location, you must import it into an LibreOffice
template folder.
To import a template into a template folder:
1) In the Template Management dialog, select the folder into which you want to import the
template.
2) Click the Commands button and choose Import Template from the drop-down menu. A
standard file browser window opens.
3) Find and select the template that you want to import and click Open. The file browser
window closes and the template appears in the selected folder.
4) If you want, type a new name for the template, and then press Enter.
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Exporting a template
To export a template from a template folder to another location:
1) In the Template Management dialog, double-click the folder that contains the template you
want to export. A list of the templates contained in that folder appears underneath the folder
name.
2) Click the template that you want to export.
3) Click the Commands button and choose Export Template from the drop-down menu. The
Save As window opens.
4) Find the folder into which you want to export the template and click Save.

Printing a list of styles defined in a template or document
To print a list of the styles defined in a template:
1) In the Template Management dialog, double-click the folder that contains the template.
2) Double-click the required template. Styles appears below it. Click Styles to select it.
3) Click the Commands button and choose Print from the drop-down menu. The Print dialog
opens. From here you can print to a file or to a printer as usual. For more about the Print
dialog, see Chapter 10.

Figure 61: Printing a list of styles in a template

Tip

To print a list of styles in a document, double-click on the document’s name in the
middle column to display Styles, and then use Commands > Print.

Chapter 3 Using Styles and Templates

75

Examples of style use
The following examples of common use of page and paragraph styles are taken from Writer. There
are many other ways to use styles; see the guides for the various components for details.

Defining a different first page for a document
Many documents, such as letters and reports, have a first page that is different from the other
pages in the document. For example, the first page of a letterhead typically has a different header,
or the first page of a report might have no header or footer, while the other pages do. With
LibreOffice, you can define the page style for the first page and specify the style for the following
pages to be applied automatically.
As an example, we can use the First Page and Default page styles that come with LibreOffice.
Figure 62 shows what we want to happen: the first page is to be followed by the default page, and
all the following pages are to be in the Default page style. Details are in Chapter 4, Formatting
Pages, in the Writer Guide.

Figure 62: Flow of page styles

Dividing a document into chapters
In a similar way, you can divide a document into chapters. Each chapter might start with the First
Page style, with the following pages using the Default page style, as above. At the end of the
chapter, insert a manual page break and specify the next page to have the First Page style to start
the next chapter, as shown in Figure 63.

Figure 63: Dividing a document into chapters using page styles

Changing page orientation within a document
A Writer document can contain pages in more than one orientation. A common scenario is to have
a landscape page in the middle of a document, whereas the other pages are in a portrait
orientation. This can also be done with page breaks and page styles.
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Different headers on right and left pages
Page styles can be set up to have the facing left and right pages mirrored or only right (first pages
of chapters are often defined to be right-page only) or only left. When you insert a header on a
page style set up for mirrored pages or right-and-left pages, you can have the contents of the
header be the same on all pages or be different on the right and left pages. For example, you can
put the page number on the left-hand edge of the left pages and on the right-hand edge of the right
pages, put the document title on the right-hand page only, or make other changes.

Controlling page breaks automatically
Writer automatically flows text from one page to the next. If you do not like the default settings, you
can change them. For example, you can require a paragraph to start on a new page or column and
specify the style of the new page. A typical use is for chapter titles to always start on a new righthand (odd-numbered) page.

Compiling an automatic table of contents
To compile an automatic table of contents, first apply styles to the headings you want to appear in
the contents list, then use Tools > Outline Numbering to tell Writer which styles go with which
level in the table of contents. See Chapter 4 for more information.

Defining a sequence of styles
You can set up one paragraph style so that when you press Enter at the end of that paragraph, the
following paragraph automatically has the style you wish applied to it. For example, you could
define a Heading 1 paragraph to be followed by a Text Body paragraph. A more complex example
would be: Title followed by Author followed by Abstract followed by Heading 1 followed by Text
Body. By setting up these sequences, you can avoid manually applying styles in most cases.
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Chapter 4
Getting Started with Writer
Word Processing with LibreOffice

What is Writer?
Writer is the word processor component of LibreOffice. In addition to the usual features of a word
processor (spelling check, thesaurus, hyphenation, autocorrect, find and replace, automatic
generation of tables of contents and indexes, mail merge and others), Writer provides these
important features:

•
•
•
•
•
•
•
•
•

Templates and styles (see Chapter 3)
Page layout methods, including frames, columns, and tables
Embedding or linking of graphics, spreadsheets, and other objects
Built-in drawing tools
Master documents—to group a collection of documents into a single document
Change tracking during revisions
Database integration, including a bibliography database
Export to PDF, including bookmarks (see Chapter 10)
And many more

These features are covered in detail in the Writer Guide.

The Writer interface
The main Writer workspace is shown in Figure 64. The menus and toolbars are described in
Chapter 1, Introducing LibreOffice.
Some other features of the Writer interface are covered in this chapter.

Figure 64: The main Writer workspace in Print Layout view
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Status bar
The Writer status bar provides information about the document and convenient ways to quickly
change some document features.

Figure 65: Left end of status bar
Page number
Shows the current page number, the sequence number of the current page (if different), and
the total number of pages in the document. For example, if you restarted page numbering at 1
on the third page, its page number is 1 and its sequence number is 3.
If any bookmarks have been defined in the document, a right-click on this field pops up a list of
bookmarks; click on the required one.
To jump to a specific page in the document, double-click on this field. The Navigator opens.
Click in the Page Number field and type the sequence number of the required page. After a
brief delay, the display jumps to the selected page.
Page style
Shows the style of the current page. To change the page style, right-click on this field. A list of
page styles pops up; choose a different style by clicking on it.
To edit the current page style, double-click on this field. The Page Style dialog opens.
Language
Shows the language for the selected text.
Click to open a menu where you can choose another language for the selected text or for the
paragraph where the cursor is located. You can also choose None (Do not check spelling) to
exclude the text from a spelling check or choose More... to open the Character dialog.
Insert mode
Click to toggle between Insert and Overwrite modes when typing.
Selection mode
Click to toggle between STD (Standard), EXT (Extend), ADD (Add) and BLK (Block) selection.
EXT is an alternative to Shift+click when selecting text. See “Working with text” on page 85 for
more information about ADD and BLK.
Unsaved changes
This icon

replaces the default icon here if changes to the document have not been saved.

Figure 66: Right end of status bar
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Digital signature
If the document has been digitally signed, an icon shows here. You can double-click the icon to
view the certificate.
Section or object information
When the cursor is on a section, heading, or list item, or when an object (such as a picture or
table) is selected, information about that item appears in this field. Double-clicking in this area
opens a relevant dialog. For details, consult the Help or the Writer Guide.
View layout
Click an icon to change between single page, side-by-side, and book layout views. The effect
varies with the combination of window width and zoom factor in use. You can edit the document
in any view.

Figure 67: View layouts: single, side-by-side, book.
Zoom
To change the view magnification, drag the Zoom slider, or click on the + and – signs, or rightclick on the zoom level percent to pop up a list of magnification values from which to choose.
Zoom interacts with the selected view layout to determine how many pages are visible in the
document window.

Changing document views
Writer has several ways to view a document: Print Layout, Web Layout, and Full Screen. To access
these and other choices, go to the View menu and click on the required view. (When in Full Screen
view, press the Esc key to return to either Print or Web Layout view.)
When in Print Layout, you can use both the Zoom slider and the View Layout icons on the status
bar. In Web Layout, you can use only the Zoom slider.
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You can also choose View > Zoom from the menu bar to display the Zoom & View Layout dialog,
where you can set the same options as on the Status bar. In Web Layout view, most of the choices
are not available.

Figure 68: Choosing Zoom and View Layout options.

Moving quickly through a document
In addition to the navigation features of the Status bar (described above), you can use the main
Navigator window and the Navigation toolbar as described in Chapter 1, Introducing LibreOffice.
In Writer, you can also display the Navigation toolbar by clicking on the small Navigation icon near
the lower right-hand corner of the window below the vertical scroll bar, as shown in Figure 69.

Figure 69: Navigation icons
The Navigation toolbar (Figure 70) shows icons for all the object types shown in the Navigator, plus
some extras (for example, the results of a Find command).

Figure 70: Navigation toolbar
Click an icon to select that object type. Now all the Previous and Next icons (in the Navigator
itself, in the Navigation Toolbar, and on the scroll bar) will jump to the next object of the selected
type. This is particularly helpful for finding items like index entries, which can be difficult to see in
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the text. The names of the icons (shown in the tooltips) change to match the selected category; for
example, Next Graphic, Next Bookmark, or Continue search forward.
For more uses of the Navigator in Writer, see the Writer Guide.

Working with documents
Chapter 1, Introducing LibreOffice, includes instructions on starting new documents, opening
existing documents, saving documents, and password-protecting documents. Chapter 3, Using
Styles and Templates, covers how to create a document from a template.

Saving as a Microsoft Word file
If you need to exchange documents with users of Microsoft Word who are unwilling or unable to
receive *.odt files, you can save a document as a Microsoft Word file.
1) Important—First save your document in the file format used by LibreOffice Writer (.odt). If
you do not, any changes you made since the last time you saved will appear only in the
Microsoft Word version of the document.
2) Then choose File > Save As. On the Save As dialog, in the File type (or Save as type)
drop-down menu, select the type of Word format you need. Click Save.

Figure 71. Saving a file in Microsoft Word format
From this point on, all changes you make to the document will occur only in the new document.
You have changed the name and file type of your document. If you want to go back to working with
the .odt version of your document, you must open it again.
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Tip

To have Writer save documents by default in the Microsoft Word file format, go to
Tools > Options > Load/Save > General. In the section named Default file format
and ODF settings, under Document type, select Text document, then under
Always save as, select your preferred file format.

Working with text
Working with text (selecting, copying, pasting, moving) in Writer is similar to working with text in
any other program. LibreOffice also has some convenient ways to select items that are not next to
each other, select a vertical block of text, and paste unformatted text.

Selecting items that are not consecutive
To select nonconsecutive items (as shown in Figure 72) using the mouse:
1) Select the first piece of text.
2) Hold down the Ctrl key and use the mouse to select the next piece of text.
3) Repeat as often as needed.
Now you can work with the selected text (copy it, delete it, change the style, or whatever).

Note

Macintosh users: substitute the Command key when instructions in this chapter
say to use the Ctrl key.

Figure 72: Selecting items that are not next to each other
To select nonconsecutive items using the keyboard:
1) Select the first piece of text. (For more information about keyboard selection of text, see the
topic “Navigating and selecting with the keyboard” in the Help.)
2) Press Shift+F8. This puts Writer in “Add” mode. The word ADD appears on the status bar,
replacing STD.
3) Use the arrow keys to move to the start of the next piece of text to be selected. Hold down
the Shift key and select the next piece of text.
4) Repeat as often as needed.
Now you can work with the selected text. Press Esc to exit from this mode.
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Selecting a vertical block of text
You can select a vertical block or “column” of text that is separated by spaces or tabs (as you might
see in text pasted from e-mails, program listings, or other sources), using LibreOffice’s block
selection mode. To change to block selection mode, use Edit > Selection Mode > Block Area, or
press Ctrl+F8, or click several times in the status bar on STD until it changes to BLK.

Now highlight the selection, using mouse or keyboard, as shown below.

Figure 73: Selecting a vertical block of text

Cutting, copying, and pasting text
Cutting and copying text in Writer is similar to cutting and copying text in other applications. You
can use the mouse or the keyboard for these operations. You can copy or move text within a
document, or between documents, by dragging or by using menu selections, icons, or keyboard
shortcuts. You can also copy text from other sources such as Web pages and paste it into a Writer
document.
To move (cut and paste) selected text using the mouse, drag it to the new location and release it.
To copy selected text, hold down the Ctrl key while dragging. The text retains the formatting it had
before dragging.
When you paste text, the result depends on the source of the text and how you paste it. If you click
on the Paste icon, any formatting the text has (such as bold or italics) is retained. Text pasted from
Web sites and other sources may also be placed into frames or tables. If you do not like the
results, click the Undo icon or press Ctrl+Z.
To make the pasted text take on the formatting of the surrounding text where it is being pasted:

• Choose Edit > Paste Special, or
• Click the triangle to the right of the Paste icon, or
• Click the Paste icon without releasing the left mouse button.
Then select Unformatted text from the resulting menu.
The range of choices on the Paste Special menu varies depending on the origin and formatting of
the text (or other object) to be pasted. See Figure 74 for an example with text on the clipboard.

Figure 74: Paste Special menu
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Finding and replacing text and formatting
Writer has two ways to find text within a document: the Find toolbar for fast searching and the Find
& Replace dialog. In the dialog, you can:

•
•
•
•

Find and replace words and phrases
Use wildcards and regular expressions to fine-tune a search
Find and replace specific formatting
Find and replace paragraph styles

Using the Find toolbar
If the Find toolbar is not visible, you can display it by choosing View > Toolbars > Find from the
menu bar or by pressing Ctrl+F. The Find toolbar is shown docked at the bottom of the LibreOffice
window (just above the Status Bar) in Figure 75, but you can float it or dock it in another location.
For more information on floating and docking toolbars, see Chapter 1, Introducing LibreOffice.

Figure 75: Docked position of Find toolbar
To use the Find toolbar, click in the box and type your search text, then press Enter to find the next
occurrence of that term. Click the Find Next or Find Previous buttons as needed.

Using the Find & Replace dialog
To display the Find & Replace dialog (Figure 76), use the keyboard shortcut Ctrl+Alt+F or choose
Edit > Find & Replace from the menu bar. Optionally, click the More Options button to expand
the dialog; the button changes to Fewer Options.
To use the Find & Replace dialog:
1) Type the text you want to find in the Search for box.
2) To replace the text with different text, type the new text in the Replace with box.
3) You can select various options such as matching the case, matching whole words only, or
doing a search for similar words.
4) When you have set up your search, click Find. To replace the found text, click Replace.
For more information on using Find & Replace, see the Writer Guide.

Tip

Caution

If you click Find All, LibreOffice selects all instances of the search text in the
document. Similarly, if you click Replace All, LibreOffice replaces all matches.

Use Replace All with caution; otherwise, you may end up with some hilarious (and
highly embarrassing) mistakes. A mistake with Replace All might require a
manual, word-by-word, search to fix.
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Figure 76: Expanded Find & Replace dialog

Inserting special characters
A special character is one not found on a standard English keyboard. For example, © ¾ æ ç ñ ö ø
¢ are all special characters. To insert a special character:
1) Place the cursor where you want the character to appear.
2) Choose Insert > Special Character to open the Special Characters dialog.
3) Select the characters (from any font or mixture of fonts) you wish to insert, in order, then
click OK. The selected characters are shown in the lower left of the dialog. As you select a
character, it is shown on the lower right, along with its numerical code.

Note
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Different fonts include different special characters. If you do not find a particular
special character, try changing the Font selection.
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Figure 77: The Special Characters dialog, where you can insert special characters

Inserting dashes and non-breaking spaces and hyphens
To prevent two words from being separated at the end of a line, press Ctrl+Shift when you type the
space between the two words.
In cases where you do not want the hyphen to appear at the end of a line, for example in a number
such as 123-4567, you can press Shift+Ctrl+minus sign to insert a non-breaking hyphen.
To enter en and em dashes, you can use the Replace dashes option on the Options tab under
Tools > AutoCorrect Options. This option replaces two hyphens, under certain conditions, with
the corresponding dash.
–

is an en-dash; that is, a dash the width of the letter “n” in the font you are using. Type at
least one character, a space, one or two hyphens, another space, and at least one more
letter, then a space. The one or two hyphens will be replaced by an en-dash.

— is an em-dash; that is, a dash the width of the letter “m” in the font you are using. Type at
least one character, two hyphens, and at least one more character, then a space. The two
hyphens will be replaced by an em-dash.
See the Help for more details. For other methods of inserting dashes, see the Writer Guide.

Setting tab stops and indents
The horizontal ruler shows both the default tab stops and any tab stops that you have defined. Tab
settings affect indentation of full paragraphs (using the Increase Indent and Decrease Indent
icons on the Formatting toolbar) as well as indentation of parts of a paragraph (by pressing the Tab
key on the keyboard).
Using the default tab spacing can cause formatting problems if you share documents with other
people. If you use the default tab spacing and then send the document to someone else who has
chosen a different default tab spacing, tabbed material will change to use the other person’s
settings. Instead of using the defaults, define your own tab settings, as described in this section.
To define indents and tab settings for one or more selected paragraphs, double-click on a part of
the ruler that is not between the left and right indent icons to open the Indents & Spacing page of
the Paragraph dialog. Double-click anywhere between the left and right indent icons on the ruler to
open the Tabs page of the Paragraph dialog.
A better strategy is to define tabs for the paragraph style. See Chapters 6 and 7 in the Writer
Guide for more information.
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Tip

Using tabs to space out material on a page is not recommended. Depending on
what you are trying to accomplish, a table is usually a better choice.

Changing the default tab stop interval
Note

Any changes to the default tab setting will affect the existing default tab stops in
any document you open afterward, as well as tab stops you insert after making the
change.

To set the measurement unit and the spacing of default tab stop intervals, go to Tools > Options >
LibreOffice Writer > General.

Figure 78: Selecting a default tab stop interval
You can also set or change the measurement unit for rulers in the current document by rightclicking on the ruler to open a list of units. Click on one of them to change the ruler to that unit. The
selected setting applies only to that ruler.

Figure 79: Changing the measurement unit for a ruler

Checking spelling and grammar
Writer provides a spelling checker, which can be used in two ways.
AutoSpellcheck checks each word as it is typed and displays a wavy red line under any
misspelled words. When the word is corrected, the line disappears.
To perform a separate spelling check on the document (or a text selection) click the
Spelling and Grammar button. This checks the document or selection and opens the
Spelling and Grammar dialog if any misspelled words are found.
Here are some more features of the spelling checker:

• You can right-click on a word with a wavy underline to open a context menu. If you select
from the suggested words on the menu, the selection will replace the misspelled word in
your text. Other menu options are discussed below.

• You can change the dictionary language (for example, Spanish, French or German) on the
Spelling and Grammar dialog.
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• You can add a word to the dictionary. Click Add in the Spelling and Grammar dialog and
pick the dictionary to add it to.

• Click the Options button on the Spelling and Grammar dialog to open a dialog similar to
the one in Tools > Options > Language Settings > Writing Aids described in Chapter 2.
There you can choose whether to check uppercase words and words with numbers, and
you can manage custom dictionaries, that is, add or delete dictionaries and add or delete
words in a dictionary.

• On the Font tab of the Paragraph Styles dialog, you can set paragraphs to be checked in a
specific language (different from the rest of the document). See Chapter 7, Working with
Styles, in the Writer Guide for more information.
Writer includes a grammar checker (LightProof), which you can access from Tools > Spelling and
Grammar.

Using built-in language tools
Writer provides some tools that make your work easier if you mix multiple languages within the
same document or if you write documents in various languages.
The main advantage of changing the language for a text selection is that you can then use the
correct dictionaries to check spelling and apply the localized versions of Autocorrect replacement
tables, thesaurus, and hyphenation rules.
You can also set the language for a paragraph or a group of characters as None (Do not check
spelling). This option is especially useful when you insert text such as web addresses or
programming language snippets that you do not want to check for spelling.
Specifying the language in character and paragraph styles is the preferred method, because styles
allow a greater level of control and make changing the language much faster. On the Font tab of
the Paragraph Styles dialog, you can specify that certain paragraphs be checked in a language
that is different from the language of the rest of the document. See Chapter 7, Working with Styles,
in the Writer Guide for information on how to manage the language settings of a style.
You can also set the language for the whole document, for individual paragraphs, or even for
individual words and characters, from Tools > Language on the menu bar.
Another way to change the language of a whole document is to use Tools > Options > Language
Settings > Languages. In the Default languages for documents section, you can choose a
different language for all the text that is not explicitly marked as a different language.
The spelling checker works only for those languages in the list that have the symbol
next to
them. If you do not see the symbol next to your preferred language, you can install the additional
dictionary using Tools > Languages > More dictionaries online.
The language used for checking spelling is also shown in the status bar, next to the page style in
use.

Using AutoCorrect
Writer’s AutoCorrect function has a long list of common misspellings and typing errors, which it
corrects automatically. For example, “hte” will be changed to “the”.
AutoCorrect is turned on when Writer is installed. To turn it off, uncheck Format > AutoCorrect >
While Typing.
Choose Tools > AutoCorrect Options to open the AutoCorrect dialog. There you can define
which strings of text are corrected and how. In most cases, the defaults are fine.

Chapter 4 Getting Started with Writer

91

To stop Writer replacing a specific spelling, go to the Replace tab, highlight the word pair, and click
Delete.
To add a new spelling to the list, type it into the Replace and With boxes on the Replace tab, and
click New.
See the different tabs of the dialog for the wide variety of other options available to fine-tune
AutoCorrect.

Tip

AutoCorrect can be used as a quick way to insert special characters. For example,
(c) will be autocorrected to ©. You can add your own special characters.

Using word completion
If Word Completion is enabled, Writer tries to guess which word you are typing and offers to
complete the word for you. To accept the suggestion, press Enter. Otherwise, continue typing.
To turn off Word Completion, select Tools > AutoCorrect Options > Word Completion and
deselect Enable word completion.
You can customize word completion from the Word Completion page of the AutoCorrect dialog:

• Add (append) a space automatically after an accepted word
• Show the suggested word as a tip (hovering over the word) rather than completing the text
as you type

• Collect words when working on a document, and then either save them for later use in
other documents or select the option to remove them from the list when closing the
document.

• Change the maximum number of words remembered for word completion and the length of
the smallest words to be remembered

• Delete specific entries from the word completion list
• Change the key that accepts a suggested entry—the options are Right arrow, End key,
Return (Enter), and Space bar

Note

Automatic word completion only occurs after you type a word for the second time
in a document.

Using AutoText
Use AutoText to store text, tables, graphics and other items for reuse and assign them to a key
combination for easy retrieval. For example, rather than typing “Senior Management” every time
you use that phrase, you can set up an AutoText entry to insert those words when you type “sm”
and press F3.
AutoText is especially powerful when assigned to fields. See Chapter 14, Working with Fields, in
the Writer Guide for more information.

Creating AutoText
To store some text as AutoText:
1) Type the text into your document.
2) Select the text.
3) Choose Edit > AutoText (or press Ctrl+F3).

92

Getting Started with LibreOffice 3.5

4) In the AutoText dialog box, type a name for the AutoText in the Name box. Writer will
suggest a one-letter shortcut, which you can change.
5) In the large box to the left, choose the category for the AutoText entry, for example My
AutoText.
6) Click the AutoText button on the right and select New (text only) from the menu.
7) Click Close to return to your document.

Tip

If the only option under the AutoText button is Import, either you have not entered
a name for your AutoText or there is no text selected in the document.

Inserting AutoText
To insert AutoText, type the shortcut and press F3.

Formatting text
Using styles is recommended
Styles are central to using Writer. Styles enable you to easily format your document consistently,
and to change the format with minimal effort. A style is a named set of formatting options. When
you apply a style, you apply a whole group of formats at the same time. In addition, styles are used
by LibreOffice for many processes, even if you are not aware of them. For example, Writer relies
on heading styles (or other styles you specify) when it compiles a table of contents.

Caution

Manual formatting (also called direct formatting) overrides styles, and you cannot get
rid of the manual formatting by applying a style to it.
To remove manual formatting, select the text, right-click, and choose Clear Direct
Formatting from the pop-up menu.

Writer defines several types of styles, for different types of elements: characters, paragraphs,
pages, frames, and lists. See Chapter 3, Using Styles and Templates, in this book and Chapters 6
and 7 in the Writer Guide.

Formatting paragraphs
You can apply many formats to paragraphs using the buttons on the Formatting toolbar. Figure 80
shows the Formatting toolbar as a floating toolbar, customized to show only the icons for
paragraph formatting. The appearance of the icons may vary with your operating system and the
selection of icon size and style in Tools > Options > LibreOffice > View.
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1 Open Styles and
Formatting Window
2 Apply Style
3 Align Left
4 Centered

5
6
7
8
9

Align Right
Justified
Line Spacing: 1
Line Spacing: 1.5
Line Spacing: 2

10
11
12
13
14

Numbering On/Off
Bullets On/Off
Decrease Indent
Increase Indent
Paragraph format dialog

Figure 80: Formatting toolbar, showing icons for paragraph formatting

Formatting characters
You can apply many formats to characters using the buttons on the Formatting toolbar. Figure 81
shows the Formatting toolbar, customized to include only the icon for character formatting.
The appearance of the icons may vary with your operating system and the selection of icon size
and style in Tools > Options > LibreOffice > View.

1 Open Styles and Formatting
Window
2 Apply Style
3 Font Name
4 Font Size
5 Bold

6 Italic
7 Underline
8 Superscript
9 Subscript
10 Increase Font
11 Reduce Font

12 Font Color
13 Highlighting
14 Background Color
15 Open Character Format Dialog

Figure 81: Formatting toolbar, showing icons for character formatting

Tip

To remove manual formatting, select the text and choose Format > Default
Formatting, or right-click and choose Default Formatting.

Autoformatting
You can set Writer to automatically format parts of a document according to the choices made on
the Options page of the AutoCorrect dialog (Tools > AutoCorrect Options).

Tip

If you notice unexpected formatting changes occurring in your document, this is
the first place to look for the cause.

The Help describes each of these choices and how to activate the autoformats. Some common
unwanted or unexpected formatting changes include:

• Horizontal lines. If you type three or more hyphens (---), underscores (___) or equal signs
(===) on a line and then press Enter, the paragraph is replaced by a horizontal line as wide
as the page. The line is actually the lower border of the preceding paragraph.
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• Bulleted and numbered lists. A bulleted list is created when you type a hyphen (-), star (*),
or plus sign (+), followed by a space or tab at the beginning of a paragraph. A numbered list
is created when you type a number followed by a period (.), followed by a space or tab at
the beginning of a paragraph. Automatic numbering is only applied to paragraphs formatted
with the Default, Text body or Text body indent paragraph styles.
To turn autoformatting on or off, choose Format > AutoCorrect and select or deselect the items on
the list.

Creating numbered or bulleted lists
There are several ways to create numbered or bulleted lists:

• Use autoformatting, as described above.
• Use list (numbering) styles, as described in Chapter 6, Introduction to Styles, and Chapter
7, Working with Styles, in the Writer Guide.

• Use the Numbering and Bullets icons on the paragraph formatting toolbar (see Figure
80): select the paragraphs in the list, and then click the appropriate icon on the toolbar.

Note

It is a matter of personal preference whether you type your information first, then
apply Numbering/Bullets, or apply them as you type.

Using the Bullets and Numbering toolbar
You can create nested lists (where one or more list items has a sub-list under it, as in an outline)
by using the buttons on the Bullets and Numbering toolbar (Figure 82). You can move items up or
down the list, or create sub-points, and even change the style of bullets. Use View > Toolbars >
Bullets and Numbering to see the toolbar.
The appearance of the icons may vary with your operating system and the selection of icon size
and style in Tools > Options > LibreOffice > View.

Note

If numbering or bullets are being applied automatically in a way that you find
inappropriate, you can switch them off temporarily by unchecking Format >
AutoCorrect > While Typing.

1 Bullets On/Off
2 Numbering On/Off
3 Numbering Off
4 Promote One Level
5 Demote One Level

6 Promote One Level with
Subpoints
7 Demote One Level with
Subpoints
8 Insert Unnumbered Entry
9 Move Up

10 Move Down
11 Move Up with Subpoints
12 Move Down with Subpoints
13 Restart Numbering
14 Bullets and Numbering

Figure 82: Bullets and Numbering toolbar
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Hyphenating words
You have several choices regarding hyphenation: let Writer do it automatically (using its
hyphenation dictionaries), insert conditional hyphens manually where necessary, or don’t
hyphenate at all.

Automatic hyphenation
To turn automatic hyphenation of words on or off:
1) Press F11 (z+T on Mac) to open the Styles
and Formatting window.
2) On the Paragraph Styles page (Figure 83),
right-click on Default and select Modify.
3) On the Paragraph Style dialog (Figure 84),
go to the Text Flow page.
4) Under Hyphenation, select or deselect the
Automatically option. Click OK to save.

Figure 83: Modifying a style

Figure 84: Turning on automatic hyphenation

Note

Turning on hyphenation for the Default paragraph style affects all other paragraph
styles that are based on Default. You can individually change other styles so that
hyphenation is not active; for example, you might not want headings to be
hyphenated. Any styles that are not based on Default are not affected. See
Chapter 3, Styles and Templates, for more about styles based on other styles.

You can also set hyphenation choices through Tools > Options > Language Settings > Writing
Aids. In Options, near the bottom of the dialog, scroll down to find the hyphenation settings.

Figure 85: Setting hyphenation options

96

Getting Started with LibreOffice 3.5

To change the minimum number of characters for hyphenation, the minimum number of characters
before a line break, or the minimum number of characters after a line break, select the item, and
then click the Edit button in the Options section.
Hyphenation options set on the Writing Aids dialog are effective only if hyphenation is turned on
through paragraph styles.

Manual hyphenation
To manually hyphenate words, do not use a normal hyphen, which will remain visible even if the
word is no longer at the end of a line when you add or delete text or change margins or font size.
Instead, use a conditional hyphen, which is visible only when required.
To insert a conditional hyphen inside a word, click where you want the hyphen to appear and press
Ctrl+hyphen. The word will be hyphenated at this position when it is at the end of the line, even if
automatic hyphenation for this paragraph is switched off.

Formatting pages
Writer provides several ways for you to control page layouts: page styles, columns, frames, tables,
and sections. For more information, see Chapter 4, Formatting Pages, in the Writer Guide.

Tip

Page layout is usually easier if you show text, object, table, and section
boundaries in Tools > Options > LibreOffice > Appearance, and paragraph
ends, tabs, breaks, and other items in Tools > Options > LibreOffice Writer >
Formatting Aids.

Which layout method to choose?
The best layout method depends on what the final document should look like and what sort of
information will be in the document. Here are some examples.
For a book similar to this user guide, with one
column of text, some figures without text beside
them, and some other figures with descriptive text,
use page styles for basic layout, and tables to place
figures beside descriptive text when necessary.
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For an index or other document with two columns of
text, where the text continues from the left-hand
column to the right-hand column and then to the
next page, all in sequence (also known as “snaking
columns” of text), use page styles (with two
columns). If the title of the document (on the first
page) is full-page width, put it in a single-column
section.

For a newsletter with complex layout, two or three
columns on the page, and some articles that
continue from one page to some place several
pages later, use page styles for basic layout. Place
articles in linked frames and anchor graphics to
fixed positions on the page if necessary.

For a document with terms and translations to
appear side-by-side in what appear to be columns,
use a table to keep items lined up, and so you can
type in both “columns”.
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Creating headers and footers
A header is an area that appears at the top of a page. A footer appears at the bottom of the page.
Information such as page numbers inserted into a header or footer displays on every page of the
document with that page style.

Inserting a header or footer
To insert a header, you can either:

• Choose Insert > Header > Default (or the page style, if not Default), or
• Hover the mouse over the top of the text area until the Header marker appears (Figure 86),
and then click on the +.

Figure 86: Header marker at top of text area
After a header has been created, a down-arrow appears on the header marker. Click on this arrow
to drop down a menu of choices for working with the header (Figure 87).

Figure 87: Header menu
To format a header, you can use either the menu item shown in Figure 87 or Format > Page >
Header. Both methods take you to the same tab on the Page Style dialog.

Inserting header and footer contents
Other information such as document titles and chapter titles is often put into the header or footer.
These items are best added as fields. That way, if something changes, the headers and footers are
updated automatically. Here is one common example.
To insert the document title into the header:
1) Choose File > Properties > Description and type a title for your document.
2) Add a header (Insert > Header > Default).
3) Place the cursor in the header part of the page.
4) Choose Insert > Fields > Title. The title should appear on a gray background (which does
not show when printed and can be turned off).
5) To change the title for the whole document, go back to File > Properties > Description.
Fields are covered in detail in Chapter 14, Working with Fields, in the Writer Guide.
For more about headers and footers, see Chapter 4, Formatting Pages, and Chapter 6,
Introduction to Styles, in the Writer Guide.
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Numbering pages
To automatically number pages:
1) Insert a header or footer, as described in “Creating headers and footers” above.
2) Place the cursor in the header or footer where you want the page number to appear and
choose Insert > Fields > Page Number.

Including the total number of pages
To include the total number of pages (as in “page 1 of 12”):
1) Type the word “page” and a space, then insert the page number as above.
2) Press the spacebar once, type the word “of” and a space, then choose Insert > Fields >
Page Count.

Note

The Page Count field inserts the total number of pages in the document, as shown
on the Statistics tab of the document’s Properties window (File > Properties). If
you restart page numbering anywhere in the document, then the total page count
may not be what you want. See Chapter 4, Formatting Pages, in the Writer Guide
for more information.

Restarting page numbering
Often you will want to restart the page numbering at 1, for example on the page following a title
page or a table of contents. In addition, many documents have the “front matter” (such as the table
of contents) numbered with Roman numerals and the main body of the document numbered in
Arabic numerals, starting with 1.
You can restart page numbering in two ways.
Method 1:
1) Place the cursor in the first paragraph of the new page.
2) Choose Format > Paragraph.
3) On the Text Flow tab of the Paragraph dialog, select Breaks.
4) Select Insert and then With Page Style and specify the page style to use.
5) Specify the page number to start from, and then click OK.

Tip

Method 1 is also useful for numbering the first page of a document with a page
number greater than 1. For example, you may be writing a book, with each chapter
in a separate file. Chapter 1 may start with page 1, but Chapter 2 could begin with
page 25 and Chapter 3 with page 51.

Method 2:
1) Insert > Manual break.
2) By default, Page break is selected on the Insert Break dialog (Figure 88).
3) Choose the required page Style.
4) Select Change page number.
5) Specify the page number to start from, and then click OK.
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Figure 88: Restarting page numbering after a manual page break

Changing page margins
You can change page margins in two ways:

• Using the page rulers—quick and easy, but does not have fine control
• Using the Page Style dialog—can specify margins to two decimal places

Note

If you change the margins using the rulers, the new margins affect the page style
and will be shown in the Page Style dialog the next time you open it.
Because the page style is affected, the changed margins apply to all pages using
that style.

To change margins using the rulers:
1) The gray sections of the rulers are the margins. Put the mouse cursor over the line
between the gray and white sections. The pointer turns into a double-headed arrow.
2) Hold down the left mouse button and drag the mouse to move the margin.

Figure 89: Moving the margins

Tip

The small arrowheads on the ruler are used for indenting paragraphs. They are
often in the same place as the page margins, so you need to be careful to move the
margin marker, not the arrows. Place the mouse pointer between the arrows and,
when the pointer turns into a double-headed arrow, you can move the margin (the
indent arrows will move with it).

To change margins using the Page Style dialog:
1) Right-click anywhere on the page and select Page from the pop-up menu.
2) On the Page tab of the dialog, type the required distances in the Margins boxes.
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Adding comments to a document
Authors and reviewers often use comments (formerly called “notes”) to exchange ideas, ask for
suggestions, or mark items needing attention.
To insert a comment in the text, place the cursor in the place the comment refers to and choose
Insert > Comment or press Ctrl+Alt+C. The anchor point of the comment is connected by a dotted
line to a box on the right-hand side of the page where you can type the text of the comment. Writer
automatically adds at the bottom of the comment the author’s name and a time stamp indicating
when the comment was created. Figure 90 shows an example of text with comments from two
different authors.

Figure 90: Example of comments
Choose Tools > Options > User Data to configure the name you want to appear in the Author field
of the comment, or to change it.
If more than one person edits the document, each author is automatically allocated a different
background color.
Right-clicking on a comment pops up a menu where you can delete the current comment, all the
comments from the same author, or all the comments in the document. From this menu, you can
also apply some basic formatting to the text of the comment. You can also change the font type,
size, and alignment from the main menu.
To navigate from one comment to another, open the Navigator (F5), expand the Comments
section, and click on the comment text to move the cursor to the anchor point of the comment in
the document. Right-click on the comment to quickly edit or delete it.
You can also navigate through the comments using the keyboard. Use Ctrl+Alt+Page Down to
move to the next comment and Ctrl+Alt+Page Up to move to the previous comment.

Creating a table of contents
Writer’s table of contents feature lets you build an automated table of contents from the headings
in your document. Before you start, make sure that the headings are styled consistently. For
example, you can use the Heading 1 style for chapter titles and the Heading 2 and Heading 3
styles for chapter subheadings.
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Although tables of contents can be customized extensively in Writer, often the default settings are
all you need. Creating a quick table of contents is simple:
1) When you create your document, use the following paragraph styles for different heading
levels (such as chapter and section headings): Heading 1, Heading 2, Heading 3, and so
on. These are what will appear in your table of contents.
2) Place the cursor where you want the table of contents to be inserted.
3) Choose Insert > Indexes and Tables > Indexes and Tables.
4) Change nothing in the Insert Index/Table dialog. Click OK.
If you add or delete text (so that headings move to different pages) or you add, delete, or change
headings, you need to update the table of contents.
To do this:
1) Place the cursor within the table of contents.
2) Right-click and choose Update Index/Table from the pop-up menu.

Note

If you cannot place your cursor in the table of contents, choose Tools > Options >
LibreOffice Writer > Formatting Aids, and then select Enable in the Cursor in
protected areas section.

You can customize an existing table of contents at any time. Right-click anywhere in it and choose
Edit Index/Table from the pop-up menu. Chapter 12, Creating Tables of Contents, Indexes and
Bibliographies, of the Writer Guide describes in detail all the customizations you can choose.

Creating indexes and bibliographies
Indexes and bibliographies work in a similar way to tables of contents. Chapter 12, Creating Tables
of Contents, Indexes and Bibliographies, in the Writer Guide describes the process in detail.
In addition to alphabetical indexes, other types of indexes supplied with Writer include those for
illustrations, tables, and objects, and you can even create a user-defined index. For example, you
might want an index containing only the scientific names of species mentioned in the text, and a
separate index containing only the common names of species. Before creating some types of
indexes, you first need to create index entries embedded in your Writer document.

Working with graphics
Graphics in Writer are of three basic types:

• Image files, including photos, drawings, scanned images, and others
• Diagrams created using LibreOffice’s drawing tools
• Charts created using LibreOffice’s Chart component
See Chapter 11, Graphics, the Gallery, and Fontwork, in this book and Chapter 8, Working with
Graphics, in the Writer Guide.

Printing
See Chapter 10, Printing, Exporting, and E-mailing, in this book and Chapter 5, Printing, Exporting,
Faxing, and E-mailing, in the Writer Guide for details on previewing pages before printing, selecting
print options, printing in black and white on a color printer, printing brochures, and other printing
features.
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Using mail merge
Writer provides very useful features to create and print:

• Multiple copies of a document to send to a list of different recipients (form letters)
• Mailing labels
• Envelopes
All these facilities use a registered data source (a spreadsheet or database containing the name
and address records and other information). Chapter 11, Using Mail Merge, in the Writer Guide
describes the process.

Tracking changes to a document
You can use several methods to keep track of changes made to a document.
1) Make your changes to a copy of the document (stored in a different folder, or under a
different name, or both), then use Writer to combine the two files and show the differences.
Choose Edit > Compare Document. This technique is particularly useful if you are the
only person working on the document, as it avoids the increase in file size and complexity
caused by the other methods.
2) Save versions that are stored as part of the original file. However, this method can cause
problems with documents of non-trivial size or complexity, especially if you save a lot of
versions. Avoid this method if you can.
3) Use Writer’s change marks (often called “redlines” or “revision marks”) to show where you
have added or deleted material, or changed formatting. Choose Edit > Changes >
Record. Later, you or another person can review and accept or reject each change. Rightclick on an individual change and choose Accept Change or Reject Change from the popup menu, or choose Edit > Changes > Accept or Reject to view the list of changes and
accept or reject them. Details are in the Writer Guide.

Tip

Not all changes are recorded. For example, changing a tab stop from align left to
align right, and changes in formulas (equations) or linked graphics are not
recorded.

Using fields
Fields are extremely useful features of Writer. They are used for data that changes in a document
(such as the current date or the total number of pages) and for inserting document properties such
as name, author, and date of last update. Fields are the basis of cross-referencing (see below);
automatic numbering of figures, tables, headings, and other elements; and a wide range of other
functions—far too many to describe here. See Chapter 14, Working with Fields, in the Writer Guide
for details.

Linking to another part of a document
If you type in cross-references to other parts of a document, those references can easily get out of
date if you reorganize the order of topics, add or remove material, or reword a heading. Writer
provides two ways to ensure that your references are up to date, by inserting links to other parts of
the same document or to a different document:

• Hyperlinks
• Cross-references
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The two methods have the same result if you Ctrl+click the link when the document is open in
Writer: you are taken directly to the cross-referenced item. However, they also have major
differences:

• The text in a hyperlink does not automatically update if you change the text of the linked
item (although you can change it manually), but changed text does automatically update in
a cross-reference.

• When using a hyperlink, you do not have a choice of the content of the link (for example
text or page number), but when using a cross-reference, you have several choices,
including bookmarks.

• To hyperlink to an object such as a graphic, and have the hyperlink show useful text such
as Figure 6, you need to give such an object a useful name (instead of a default name like
Graphics6), or use the Hyperlink dialog to modify the visible text. In contrast, crossreferences to figures with captions automatically show useful text, and you have a choice of
several variations of the name.

• If you save a Writer document to HTML, hyperlinks remain active but cross-references do
not. (Both remain active when the document is exported to PDF.)

Using hyperlinks
The easiest way to insert a hyperlink to another part of the same document is by using the
Navigator:
1) Open the document containing the items you want to cross-reference.
2) Open the Navigator by clicking its icon, choosing View > Navigator, or pressing F5.
3) Click the arrow next to the Drag Mode icon, and choose Insert as Hyperlink.
4) In the list at the bottom of the Navigator, select the document containing the item that you
want to cross-reference.
5) In the Navigator list, select the item that you want to insert as a hyperlink.
6) Drag the item to where you want to insert the hyperlink in the document. The name of the
item is inserted in the document as an active hyperlink.

Figure 91: Inserting a hyperlink using the Navigator
You can also use the Hyperlink dialog to insert and modify hyperlinks within and between
documents. See Chapter 12, Creating Web Pages.
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Using cross-references
If you type in references to other parts of the document, those references can easily get out of date
if you reword a heading, add or remove figures, or reorganize topics. Replace any typed crossreferences with automatic ones and, when you update fields, all the references will update
automatically to show the current wording or page numbers. The Cross-references tab of the
Fields dialog lists some items, such as headings, bookmarks, figures, tables, and numbered items
such as steps in a procedure. You can also create your own reference items; see “Setting
References” in Chapter 14, Working with Fields, in the Writer Guide for instructions.
To insert a cross-reference to a heading, figure, bookmark, or other item:
1) In your document, place the cursor where you want the cross-reference to appear.
2) If the Fields dialog is not open, click Insert > Cross-reference. On the Cross-references
tab (Figure 92), in the Type list, select the type of item to be referenced (for example,
Heading or Figure). You can leave this page open while you insert many cross-references.
3) Click on the required item in the Selection list, which shows all the items of the selected
type. In the Insert reference to list, choose the format required. The list varies according to
the Type. The most commonly used options are Reference (to insert the full text of a
heading or caption), Category and Number (to insert a figure number preceded by the
word Figure or Table, but without the caption text), Numbering (to insert only the figure or
table number, without the word “Figure” or “Table”), or Page (to insert the number of the
page the referenced text is on). Click Insert.

Figure 92: The Cross-references tab of the Fields dialog
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Using bookmarks
Bookmarks are listed in the Navigator and can be accessed directly from there with a single mouse
click. You can cross-reference to bookmarks and create hyperlinks to bookmarks, as described
above.
1) Select the text you want to bookmark. Click Insert > Bookmark.
2) On the Insert Bookmark dialog, the larger box lists any previously defined bookmarks. Type
a name for this bookmark in the top box, and then click OK.

Figure 93: Inserting a bookmark

Using master documents
Master documents are typically used for producing long documents such as a book, a thesis, or a
long report; or when different people are writing different chapters or other parts of the full
document, so you don’t need to share files. A master document joins separate text documents into
one larger document, and unifies the formatting, table of contents (TOC), bibliography, index, and
other tables or lists.
Yes, master documents do work in Writer. However, until you become familiar with them, you may
think that master documents are unreliable or difficult to use. See Chapter 13, Working with Master
Documents, in the Writer Guide.

Creating fill-in forms
A standard text document displays information: a letter, report, or brochure, for example. Typically
the reader may either edit everything or nothing in any way. A form has sections that are not to be
edited, and other sections that are designed for the reader to make changes. For example, a
questionnaire has an introduction and questions (which do not change) and spaces for the reader
to enter answers.
Forms are used in three ways:

• To create a simple document for the recipient to complete, such as a questionnaire sent out
to a group of people who fill it in and return it.

• To link into a database or data source and allow the user to enter information. Someone
taking orders might enter the information for each order into a database using a form.

• To view information held in a database or data source. A librarian might call up information
about books.
Writer offers several ways to fill information into a form, including check boxes, option buttons, text
boxes, pull-down lists and spinners. See Chapter 15, Using Forms in Writer, in the Writer Guide.
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Chapter 5
Getting Started with Calc
Using Spreadsheets in LibreOffice

What is Calc?
Calc is the spreadsheet component of LibreOffice. You can enter data (usually numerical) in a
spreadsheet and then manipulate this data to produce certain results.
Alternatively you can enter data and then use Calc in a ‘What if...’ manner by changing some of the
data and observing the results without having to retype the entire spreadsheet.
Other features provided by Calc include:

•
•
•
•
•
•

Functions, which can be used to create formulas to perform complex calculations on data
Database functions, to arrange, store, and filter data
Dynamic charts; a wide range of 2D and 3D charts
Macros, for recording and executing repetitive tasks
Ability to open, edit, and save Microsoft Excel spreadsheets
Import and export of spreadsheets in multiple formats, including HTML, CSV, PDF, and
PostScript

Note

If you want to use macros written in Microsoft Excel using the VBA macro code in
LibreOffice, you must first edit the code in the LibreOffice Basic IDE editor. See
Chapter 13, Getting Started with Macros, in this book and Chapter 12 in the Calc
Guide.

Spreadsheets, sheets and cells
Calc works with documents called spreadsheets. Spreadsheets consist of a number of individual
sheets, each sheet containing cells arranged in rows and columns. A particular cell is identified by
its row number and column letter.
Cells hold the individual elements—text, numbers, formulas, and so on—that make up the data to
display and manipulate.
Each spreadsheet can have many sheets, and each sheet can have many individual cells. In Calc
3.3, each sheet can have a maximum of 1,048,576 rows and 1024 columns.

Parts of the main Calc window
When Calc is started, the main window looks similar to Figure 94.

Title bar
The Title bar, located at the top, shows the name of the current spreadsheet. When the
spreadsheet is newly created, its name is Untitled X, where X is a number. When you save a
spreadsheet for the first time, you are prompted to enter a name of your choice.

Menu bar
Under the Title bar is the Menu bar. When you choose one of the menus, a submenu appears with
other options. You can modify the Menu bar, as discussed in Chapter 14, Customizing LibreOffice.
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Figure 94: Parts of the Calc window

Toolbars
Three toolbars are located under the Menu bar by default: the Standard to toolbar, the Formatting
toolbar, and the Formula Bar.
The icons (buttons) on these toolbars provide a wide range of common commands and functions.
You can also modify these toolbars, as discussed in Chapter 14, Customizing LibreOffice.
In the Formatting toolbar, the three boxes on the left are the Apply Style, Font Name, and Font
Size lists. They show the current setting for the selected cell or area. (The Apply Style list may not
be visible by default.) Click the down-arrow to the right of each box to open the list.

Figure 95. Apply Style, Font Name and Font Size lists

Formula bar
On the left hand side of the Formula bar is a small text box, called the Name Box, with a letter and
number combination in it, such as D7. This combination, called the cell reference, is the column
letter and row number of the selected cell.
To the right of the Name box are the the Function Wizard, Sum, and Function buttons.
Clicking the Function Wizard button opens a dialog from which you can search through a list of
available functions This can be very useful because it also shows how the functions are formatted.
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Figure 96. Formula bar
In a spreadsheet the term function covers much more than just mathematical functions. See
Chapter 7 in the Calc Guide for more details.
Clicking the Sum button inserts a formula into the current cell that totals the numbers in the cells
above the current cell. If there are no numbers above the current cell, then the cells to the left are
placed in the Sum formula.
Clicking the Function button inserts an equals (=) sign into the selected cell and the Input line,
enabling the cell to accept a formula.
When you enter new data into a cell, the Sum and Equals buttons change to Cancel and Accept
buttons

.

The contents of the current cell (data, formula, or function) are displayed in the Input line, which
forms the remainder of the Formula Bar. You can edit the contents of the current cell on the Input
line or in the cell itself. To edit on the Input line, click in the line, then type your changes. To edit
within the current cell, just double-click the cell.

Individual cells
The main section of the screen displays the cells in the form of a grid, with each cell being at the
intersection of a column and a row.
At the top of the columns and at the left end of the rows are a series of gray boxes containing
letters and numbers. These are the column and row headers. The columns start at A and go on to
the right, and the rows start at 1 and go down.
These column and row headers form the cell references that appear in the Name Box on the
Formula Bar (Figure 96). You can turn these headers off by selecting View > Column & Row
Headers.

Sheet tabs
At the bottom of the grid of cells are the sheet tabs. These tabs enable access to each individual
sheet, with the visible (active) sheet having a white tab. You can choose colors for the different
sheet tabs by right-clicking the space, choosing Tab Color, and choosing a color from the palette.
Clicking on another sheet tab displays that sheet, and its tab turns white. You can also select
multiple sheet tabs at once by holding down the Control key while you click the names.
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Figure 97: Choosing a tab color

Status bar
At the very bottom of the Calc window is the status bar, which provides information about the
spreadsheet and convenient ways to quickly change some of its features. Most of the fields are
similar to those in other components of LibreOffice; see Chapter 1, Introducing LibreOffice, in this
book and Chapter 1, Introducing Calc, in the Calc Guide.

Figure 98: Left end of Calc status bar

Figure 99: Right end of Calc status bar

Opening and saving CSV files
Chapter 1, Introducing LibreOffice, includes instructions on starting new Calc documents, opening
existing documents, and saving documents.
A special case for Calc is opening and saving comma-separated-values (CSV) files, which are text
files that contain the cell contents of a single sheet. Each line in a CSV file represents a row in a
spreadsheet. Commas, semicolons, or other characters are used to separate the cells. Text is
entered in quotation marks, numbers are entered without quotation marks.
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Opening a CSV file
To open a CSV file in Calc:
1) Choose File > Open.
2) Locate the CSV file that you want to open.
3) If the file has a *.csv extension, select the file and click Open.
4) If the file has another extension (for example, *.txt), select the file, select Text CSV
(*csv;*txt;*xls) in the File type box (you will have to scroll down some distance to find it)
and then click Open.
5) On the Text Import dialog (Figure 100), select the Separator options to divide the text in the
file into columns.
You can preview the layout of the imported data at the bottom of the dialog. Right-click a
column in the preview to set the format or to hide the column.
If the CSV file uses a text delimiter character that is not in the Text delimiter list, click in the
Text delimiter box, and type the character.
6) Click OK to open the file.

Figure 100: Text Import dialog, with Comma (,) selected as the separator and double quotation
mark (“) as the text delimiter.

Saving as a CSV file
To save a spreadsheet as a comma separate value (CSV) file:
1) Choose File > Save As.
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2) In the File name box, type a name for the file.
3) In the File type list, select Text CSV (.csv) and click Save.
You may see the message box shown below. Click Keep Current Format.

4) In the Export text file dialog, select the options you want and then click OK.

Figure 101: Choosing options when exporting to Text CSV

Navigating within spreadsheets
Calc provides many ways to navigate within a spreadsheet from cell to cell and sheet to sheet. You
can generally use the method you prefer.

Going to a particular cell
Using the mouse
Place the mouse pointer over the cell and click.
Using a cell reference
Click on the little inverted black triangle just to the right of the Name Box (Figure 96). The
existing cell reference will be highlighted. Type the cell reference of the cell you want to go to
and press Enter. Or just click into the Name box, backspace over the existing cell reference
and type in the cell reference you want and press Enter.
Using the Navigator
To open the Navigator, click its icon
on the Standard toolbar, or press F5, or choose View
> Navigator on the Menu bar, or double-click on the Sheet Sequence Number
in
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the Status Bar. Type the cell reference into the top two fields, labeled Column and Row, and
press Enter. In Figure 102 the Navigator would select cell A7.
You can dock the Navigator to either side of the main Calc window or leave it floating. (To dock
or float the Navigator, hold down the Control key and double-click in an empty area near the
icons in the Navigator dialog.)

Figure 102: The Navigator in Calc
The Navigator displays lists of all the objects in a document, grouped into categories. If an
indicator (plus sign or arrow) appears next to a category, at least one object of this kind exists.
To open a category and see the list of items, click on the indicator.
To hide the list of categories and show only the icons at the top, click the Contents icon
Click this icon again to show the list.

.

Moving from cell to cell
In the spreadsheet, one cell normally has a black border. This black border indicates where the
focus is (see Figure 103). If a group of cells is selected, they are highlighted in a light blue color,
with the focus cell having a black border.
Using the mouse
To move the focus using the mouse, simply move the mouse pointer to the cell where you want
the focus to be and click the left mouse button. This changes the focus to the new cell. This
method is most useful when the two cells are a large distance apart.
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Figure 103. (Left) One selected cell and (right) a group of selected cells
Using the Tab and Enter keys
• By default, pressing Enter or Shift+Enter moves the focus down or up, respectively.

• Pressing Tab or Shift+Tab moves the focus to the right or to the left, respectively.
Using the arrow keys
Pressing the arrow keys on the keyboard moves the focus in the direction of the arrows.
Using Home, End, Page Up and Page Down
• Home moves the focus to the start of a row.

• End moves the focus to the column furthest to the right that contains data.
• Page Down moves the display down one complete screen and Page Up moves the display
up one complete screen.

• Combinations of Control and Alt with Home, End, Page Down, Page Up, and the cursor
keys move the focus of the current cell in other ways. See the Help or Appendix A,
Keyboard Shortcuts, in the Calc Guide for details.

Tip

Use one of the four Alt+Arrow key combinations to resize a cell.

Customizing the Enter key
You can customize the direction in which the Enter key moves the focus, by selecting Tools >
Options > LibreOffice Calc > General.
The four choices for the direction of the Enter key are shown on the right hand side of Figure 104.
It can move the focus down, right, up, or left. Depending on the file being used or on the type of
data being entered, setting a different direction can be useful.
The Enter key can also be used to switch into and out of editing mode. Use the first two options
under Input settings in Figure 104 to change the Enter key settings.
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Figure 104: Customizing the effect of the Enter key

Moving from sheet to sheet
Each sheet in a spreadsheet is independent of the others, though they can be linked with
references from one sheet to another. There are three ways to navigate between different sheets in
a spreadsheet.
Using the Navigator
When the Navigator is open (Figure 102), double-clicking on any of the listed sheets selects
the sheet.
Using the keyboard
Pressing Control+Page Down moves one sheet to the right and pressing Control+Page Up
moves one sheet to the left.
Using the mouse
Clicking on one of the sheet tabs at the bottom of the spreadsheet selects that sheet.
If you have a lot of sheets, then some of the sheet tabs may be hidden behind the horizontal
scroll bar at the bottom of the screen. If this is the case, then the four buttons at the left of the
sheet tabs can move the tabs into view. Figure 105 shows how to do this.
Move to the first sheet
Move left one sheet
Move right one sheet
Move to the last sheet
Sheet tabs

Figure 105. Sheet tab arrows
Notice that the sheets here are not numbered in order. Sheet numbering is arbitrary; you can name
a sheet as you wish.

Note
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The sheet tab arrows that appear in Figure 105 only appear if you have some
sheet tabs that are hidden by the horizontal scrollbar. Otherwise, they will appear
faded as in Figure 94.
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Selecting items in a sheet or spreadsheet
Selecting cells
Cells can be selected in a variety of combinations and quantities.
Single cell
Left-click in the cell. The result will look like the left side of Figure 103. You can verify your selection
by looking in the Name box.
Range of contiguous cells
A range of cells can be selected using the keyboard or the mouse.
To select a range of cells by dragging the mouse:
1) Click in a cell.
2) Press and hold down the left mouse button.
3) Move the mouse around the screen.
4) Once the desired block of cells is highlighted, release the left mouse button.
To select a range of cells without dragging the mouse:
1) Click in the cell which is to be one corner of the range of cells.
2) Move the mouse to the opposite corner of the range of cells.
3) Hold down the Shift key and click.
To select a range of cells without using the mouse:
1) Select the cell that will be one of the corners in the range of cells.
2) While holding down the Shift key, use the cursor arrows to select the rest of the range.
The result of any of these methods looks like the right side of Figure 103.

Tip

You can also directly select a range of cells using the Name box. Click into the
Name Box as described in “Using a cell reference” on page 115. To select a range
of cells, enter the cell reference for the upper left-hand cell, followed by a colon (:),
and then the lower right-hand cell reference. For example, to select the range that
would go from A3 to C6, you would enter A3:C6.

Range of non-contiguous cells
1) Select the cell or range of cells using one of the methods above.
2) Move the mouse pointer to the start of the next range or single cell.
3) Hold down the Control key and click or click-and-drag to select a range.
4) Repeat as necessary.

Selecting columns and rows
Entire columns and rows can be selected very quickly in LibreOffice.
Single column or row
To select a single column, click on the column identifier letter (see Figure 94).
To select a single row, click on the row identifier number.
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Multiple columns or rows
To select multiple columns or rows that are contiguous:
1) Click on the first column or row in the group.
2) Hold down the Shift key.
3) Click the last column or row in the group.
To select multiple columns or rows that are not contiguous:
1) Click on the first column or row in the group.
2) Hold down the Control key.
3) Click on all of the subsequent columns or rows while holding down the Control key.
Entire sheet
To select the entire sheet, click on the small box between the A column header and the 1 row
header.

Figure 106. Select All box
You can also press Control+A to select the entire sheet.

Selecting sheets
You can select either one or multiple sheets. It can be advantageous to select multiple sheets at
times when you want to make changes to many sheets at once.
Single sheet
Click on the sheet tab for the sheet you want to select. The active sheet becomes white.
Multiple contiguous sheets
To select multiple contiguous sheets:
1) Click on the sheet tab for the first desired sheet.
2) Move the mouse pointer over the sheet tab for the last desired sheet.
3) Hold down the Shift key and click on the sheet tab.
All the tabs between these two sheets will turn white. Any actions that you perform will now affect
all highlighted sheets.
Multiple non-contiguous sheets
To select multiple non-contiguous sheets:
1) Click on the sheet tab for the first sheet.
2) Move the mouse pointer over the second sheet tab.
3) Hold down the Control key and click on the sheet tab.
4) Repeat as necessary.
The selected tabs will turn white. Any actions that you perform will now affect all highlighted sheets.
All sheets
Right-click any one of the sheet tabs and choose Select All Sheets from the pop-up menu.
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Working with columns and rows
Inserting columns and rows
Columns and rows can be inserted individually or in groups.

Note

When you insert a single new column, it is inserted to the left of the highlighted
column. When you insert a single new row, it is inserted above the highlighted row.
Cells in the new columns or rows are formatted like the corresponding cells in the
column or row before (or to the left of) which the new column or row is inserted.

Single column or row
Using the Insert menu:
1) Select the cell, column or row where you want the new column or row inserted.
2) Choose either Insert > Columns or Insert > Rows.
Using the mouse:
1) Select the cell, column or row where you want the new column or row inserted.
2) Right-click the header of the column or row.
3) Choose Insert Rows or Insert Columns.
Multiple columns or rows
Multiple columns or rows can be inserted at once rather than inserting them one at a time.
1) Highlight the required number of columns or rows by holding down the left mouse button on
the first one and then dragging across the required number of identifiers.
2) Proceed as for inserting a single column or row above. The specified number of
rows/columns will be inserted above or to the left of the first one you selected.

Deleting columns and rows
Columns and rows can be deleted individually or in groups.
Single column or row
A single column or row can only be deleted by using the mouse:
1) Select the column or row to be deleted.
2) Right-click on the column or row header.
3) Select Delete Columns or Delete Rows from the pop-up menu.
Multiple columns or rows
Multiple columns or rows can be deleted at once rather than deleting them one at a time.
1) Highlight the required number of columns or rows by holding down the left mouse button on
the first one and then dragging across the required number of identifiers.
2) Proceed as for deleting a single column or row above.

Chapter 5 Getting Started with Calc

121

Working with sheets
Like any other Calc element, sheets can be inserted, copied, moved, deleted, and renamed.

Inserting new sheets
There are several ways to insert a new sheet. The fastest method is to click on the Add Sheet
button
to the right of the sheet tabs. If you cannot see this button, drag the separator bar next
to the tabs towards the right to make space for it. This button inserts one new sheet at that point,
without opening the Insert Sheet dialog.
Use one of the other methods to insert more than one sheet, to rename the sheet at the same
time, or to insert the sheet somewhere else in the sequence. The first step for these methods is to
select the sheet that the new sheet will be inserted next to. Then use any of the following options.

• Choose Insert > Sheet from the menu bar.
• Right-click on a sheet tab and choose Insert Sheet.
• Click in an empty space at the end of the line of sheet tabs.

Figure 107. Creating a new sheet
Each method will open the Insert Sheet dialog (Figure 108). Here you can select whether the new
sheet is to go before or after the selected sheet and how many sheets you want to insert. If you are
inserting only one sheet, there is the opportunity to give the sheet a name.

Figure 108. Insert Sheet dialog
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Moving and copying sheets
You can move or copy sheets within the same spreadsheet by using either the mouse (drag and
drop) or a dialog. Drag and drop does not work if you wish to move or copy a sheet to a different
spreadsheet; instead, you need to use the dialog.

Using the mouse
To move a sheet to a different position within the same spreadsheet, click on the sheet tab and
drag it left or right. Two little triangles indicate where the sheet will be dropped (see Figure 109).
The mouse pointer (not shown in the illustration) may change to include an indicator; the indicator
symbol varies with your operating system.

Figure 109: Dragging a sheet to move it
To copy a sheet within the same spreadsheet, hold down the Control key (Option key on Mac)
while you click on the sheet tab and drag it. The mouse pointer may change to include a plus sign
or other indicator; the symbol varies with your operating system.

Using a dialog
The Move/Copy dialog provides the opportunity to specify exactly where you want the sheet to go
(in the same or a different document, and what its name will be, at the same time as moving or
copying occurs.
When moving or copying sheets between different spreadsheets, be sure that both
documents are open.

Note

Follow these steps:
1) In the current document, right-click on the sheet tab you wish to move or copy.
2) Select Move/Copy Sheet from the context menu.
3) On the Move/Copy Sheet dialog (Figure 110):

• Select the action: Move or Copy.
• To document: select the document in which you want to place the sheet. By default,
the field will show the current document. If you have another spreadsheet open, its
name will appear in the drop-down list along with -new document-.

• Insert before: select the position within the target document.
• New name: you can rename the sheet you are moving or assign a different name to the
copied sheet. If you do not enter a name for a copied sheet, Calc creates a name.
4) When you are done, click OK.

Caution

If you choose -new document- as the location, a new spreadsheet will be
created. This may cause conflicts with formulas linked to other sheets in the
previous location. If you accidentally move a sheet, you can fix it by moving or
copying the sheet back to the original location.
This caution also apply for moving sheets to other existing documents.
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Figure 110: Move/Copy Sheet dialog

Deleting sheets
Sheets can be deleted individually or in groups.
Single sheet
Right-click on the tab of the sheet you want to delete and choose Delete Sheet from the
pop-up menu, or chose Edit > Sheet > Delete from the menu bar.
Multiple sheets
To delete multiple sheets, select them as described earlier, then either right-click over one of
the tabs and select Delete Sheet from the pop-up menu, or choose Edit > Sheet > Delete
from the menu bar.

Renaming sheets
The default name for the a new sheet is SheetX, where X is a number. While this works for a small
spreadsheet with only a few sheets, it becomes awkward when there are many sheets.
To give a sheet a more meaningful name, you can:

• Enter the name in the Name box when you create the sheet, or
• Right-click on a sheet tab and choose Rename Sheet from the pop-up menu; replace the
existing name with one of your choosing.

• Double-click on a sheet tab to pop up the Rename Sheet dialog.

Note

124

Sheet names must start with either a letter or a number. Apart from the first
character of the sheet name, allowed characters are letters, numbers, spaces, and
the underline character. Attempting to rename a sheet with an invalid name will
produce an error message.
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Viewing Calc
Using zoom
Use the zoom function to change the view to show more or fewer cells in the window. For more
about zoom, see Chapter 1, Introducing LibreOffice, in this book.

Freezing rows and columns
Freezing locks a number of rows at the top of a spreadsheet or a number of columns on the left of
a spreadsheet or both. Then when scrolling around within the sheet, any frozen columns and rows
remain in view.
Figure 111 shows some frozen rows and columns. The heavier horizontal line between rows 3 and
14 and the heavier vertical line between columns C and H denote the frozen areas. Rows 4
through 13 and columns D through G have been scrolled off the page. The first three rows and
columns remained because are frozen into place.

Figure 111. Frozen rows and columns
You can set the freeze point at a row, a column, or both a row and a column as in Figure 111.
Freezing single rows or columns
1) Click on the header for the row below where you want the freeze or for the column to the
right of where you want the freeze.
2) Choose Window > Freeze. A dark line appears, indicating where the freeze is put.
Freezing a row and a column
1) Click into the cell that is immediately below the row you want frozen and immediately to the
right of the column you want frozen.
2) Choose Window > Freeze. Two lines appear on the screen, a horizontal line above this
cell and a vertical line to the left of this cell. Now as you scroll around the screen,
everything above and to the left of these lines will remain in view.
Unfreezing
To unfreeze rows or columns, choose Window > Freeze. The check mark by Freeze will vanish.
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Splitting the screen
Another way to change the view is by splitting the window, also known as splitting the screen. The
screen can be split either horizontally or vertically or both. You can therefore have up to four
portions of the spreadsheet in view at any one time.
Why would you want to do this? Imagine you have a large spreadsheet and one of the cells has a
number in it which is used by three formulas in other cells. Using the split screen technique, you
can position the cell containing the number in one section and each of the cells with formulas in the
other sections. Then you can change the number in the cell and watch how it affects each of the
formulas.

Figure 112. Split screen example

Splitting the screen horizontally
To split the screen horizontally:
1) Move the mouse pointer into the vertical scroll bar, on the right-hand side of the screen,
and place it over the small button at the top with the black triangle. Immediately above this
button you will see a thick black line.

Split screen bar

Figure 113. Split screen bar on vertical scroll bar
2) Move the mouse pointer over this line and it turns into a line with two arrows.

Figure 114. Split screen bar on
vertical scroll bar with cursor
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3) Hold down the left mouse button. A gray line appears, running across the page. Drag the
mouse downwards and this line follows.
4) Release the mouse button and the screen splits into two views, each with its own vertical
scroll bar. You can scroll the upper and lower parts independently.
Notice in Figure 112, the Beta and the A0 values are in the upper part of the window and other
calculations are in the lower part. Thus you can make changes to the Beta and A0 values and
watch their affects on the calculations in the lower half of the window.

Tip

You can also split the screen using a menu command. Click in a cell immediately
below and to the right of where you wish the screen to be split, and choose
Window > Split.

Splitting the screen vertically
To split the screen vertically:
1) Move the mouse pointer into the horizontal scroll bar at the bottom of the screen and place
it over the small button on the right with the black triangle. Immediately to the right of this
button is a thick black line.

Split screen bar

Figure 115: Split bar on horizontal scroll bar
2) Move the mouse pointer over this line and it turns into a line with two arrows.
3) Hold down the left mouse button, and a gray line appears, running up the page. Drag the
mouse to the left and this line follows.
4) Release the mouse button and the screen is split into two views, each with its own
horizontal scroll bar. You can scroll the left and right parts of the window independently.

Removing split views
To remove a split view, do any of the following:

• Double-click on each split line.
• Click on and drag the split lines back to their places at the ends of the scroll bars.
• Choose Window > Split to remove all split lines at the same time.

Entering data using the keyboard
Most data entry in Calc can be accomplished using the keyboard.

Entering numbers
Click in the cell and type in the number using the number keys on either the main keyboard or the
numeric keypad.
To enter a negative number, either type a minus (–) sign in front of it or enclose it in parentheses
(brackets), like this: (1234).
By default, numbers are right-aligned and negative numbers have a leading minus symbol.
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Note

If a number beginning with 0 is entered in to a cell, Calc will drop the 0 (for
example 01234 becomes 1234).

To enter a number and retain the leading 0, right-click on the cell and choose Format Cells >
Numbers. In the Format Cells dialog, under Options select the required number of Leading zeros.
The number selected for leading zeros needs to be one higher than the digits in a number. For
example, if the number is 1234, the number entered for the leading zero will be 5.

Figure 116: Adjusting leading zeros

Entering text
Click in the cell and type the text. Text is left-aligned by default.

Entering numbers as text
A number can be entered as text to preserve a leading zero by entering an apostrophe before the
number, like this: '01481.
The data is now regarded as text by Calc and displayed exactly as entered. Typically, formulas will
treat the entry as a zero and functions will ignore it. Take care that the cell containing the number is
not used in a formula.

Note

128

If “smart quotes” are used for apostrophes, the apostrophe remains visible in the
cell.
To choose the type of apostrophe, use Tools > AutoCorrect > Custom Quotes.
The selection of the apostrophe type affects both Calc and Writer.
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Entering dates and times
Select the cell and type the date or time. You can separate the date elements with a slant (/) or a
hyphen (–) or use text such as 15 Oct 10. Calc recognizes a variety of date formats. You can
separate time elements with colons such as 10:43:45.

Deactivating automatic changes
Calc automatically applies many changes during data input, unless you deactivate those changes.
You can also immediately undo any automatic changes with Ctrl+Z.
AutoCorrect changes
Automatic correction of typing errors, replacement of straight quotation marks by curly (custom)
quotes, and starting cell content with an uppercase (capital letter) are controlled by Tools >
AutoCorrect Options. Go to the Custom Quotes, Options, or Replace tabs to deactivate any
of the features that you do not want. On the Replace tab, you can also delete unwanted word
pairs and add new ones as required.
AutoInput
When you are typing in a cell, Calc automatically suggests matching input found in the same
column. To turn the AutoInput on and off, set or remove the check mark in front of Tools > Cell
Contents > AutoInput.
Automatic date conversion
Calc automatically converts certain entries to dates. To ensure that an entry that looks like a
date is interpreted as text, type an apostrophe at the beginning of the entry. The apostrophe is
not displayed in the cell.

Speeding up data entry
Entering data into a spreadsheet can be very labor-intensive, but Calc provides several tools for
removing some of the drudgery from input.
The most basic ability is to drag and drop the contents of one cell to another with a mouse. Calc
also includes several other tools for automating input, especially of repetitive material. They include
the Fill tool, selection lists, and the ability to input information into multiple sheets of the same
document.

Using the Fill tool on cells
At its simplest, the Fill tool is a way to duplicate existing content. Start by selecting the cell to copy,
then drag the mouse in any direction (or hold down the Shift key and click in the last cell you want
to fill), and then choose Edit > Fill and the direction in which you want to copy: Up, Down, Left or
Right.

Caution

Tip

Choices that are not available are grayed out, but you can still choose the
opposite direction from what you intend, which could cause you to overwrite cells
accidentally.

A shortcut way to fill cells is to grab the “handle” in the lower right-hand corner of
the cell and drag it in the direction you want to fill. If the cell contains a number, the
number will fill in series. If the cell contains text, the same text will fill in the
direction you chose.

Chapter 5 Getting Started with Calc

129

Figure 117: Using the Fill tool

Using a fill series
A more complex use of the Fill tool is to use a fill series. The
default lists are for the full and abbreviated days of the week
and the months of the year, but you can create your own lists
as well.
To add a fill series to a spreadsheet, select the cells to fill,
choose Edit > Fill > Series. In the Fill Series dialog (Figure
119), select AutoFill as the Series type, and enter as the
Start value an item from any defined series. The selected
cells then fill in the other items on the list sequentially,
repeating from the top of the list when they reach the end of
the list.

Figure 118: Result of fill series
selection shown in Figure 119

Figure 119: Specifying the start of a fill series (result is in Figure 118)
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You can also use Edit > Fill > Series to create a one-time fill series for numbers by entering the
start and end values and the increment. For example, if you entered start and end values of 1 and
7 with an increment of 2, you would get the sequence of 1, 3, 5, 7.
In all these cases, the Fill tool creates only a momentary connection between the cells. Once they
are filled, the cells have no further connection with one another.

Defining a fill series
To define your own fill series:
1) Go to Tools > Options > LibreOffice Calc > Sort Lists. This dialog shows the previouslydefined series in the Lists box on the left, and the contents of the highlighted list in the
Entries box.

Figure 120: Predefined fill series
2) Click New. The Entries box is cleared.
3) Type the series for the new list in the Entries box (one entry per line). Click Add. The new
list will now appear in the Lists box.
4) Click OK at the bottom of the dialog to save the new list.

Figure 121: Defining a new fill series

Using selection lists
Selection lists are available only for text, and are limited to using only text that has already been
entered in the same column.
To use a selection list, select a blank cell and press Ctrl+D. A drop-down list appears of any cell in
the same column that either has at least one text character or whose format is defined as Text.
Click on the entry you require.
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Figure 122: Using a selection list

Sharing content between sheets
You might want to enter the same information in the same cell on multiple sheets, for example to
set up standard listings for a group of individuals or organizations. Instead of entering the list on
each sheet individually, you can enter it in all the sheets at once. To do this, select all the sheets
(Edit > Sheet > Select), then enter the information in the current one.

Caution

This technique overwrites any information that is already in the cells on the other
sheets—without any warning. For this reason, when you are finished, be sure to
deselect all the sheets except the one you want to edit. (Ctrl+click on a sheet tab
to select or deselect the sheet.)

Validating cell contents
When creating spreadsheets for other people to use, you may want to make sure they enter data
that is valid or appropriate for the cell. You can also use validation in your own work as a guide to
entering data that is either complex or rarely used.
Fill series and selection lists can handle some types of data, but they are limited to predefined
information. To validate new data entered by a user, select a cell and use Data > Validity to define
the type of contents that can be entered in that cell. For example, a cell might require a date or a
whole number, with no alphabetic characters or decimal points; or a cell may not be left empty.
Depending on how validation is set up, the tool can also define the range of contents that can be
entered and provide help messages that explain the content rules you have set up for the cell and
what users should do when they enter invalid content. You can also set the cell to refuse invalid
content, accept it with a warning, or start a macro when an error is entered.
See Chapter 2, Entering, Editing and Formatting Data, in the Calc Guide for more information.

Editing data
Editing data is done in much the same way as entering data. The first step is to select the cell
containing the data to be edited.
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Removing data from a cell
Data can be removed (deleted) from a cell in several ways.
Removing data only
The data alone can be removed from a cell without removing any of the formatting of the cell.
Click in the cell to select it, and then press the Delete key.
Removing data and formatting
The data and the formatting can be removed from a cell at the same time. Press the
Backspace key (or right-click and choose Delete Contents, or use Edit > Delete Contents) to
open the Delete Contents dialog. From this dialog, the different aspects of the cell can be
deleted. To delete everything in a cell (contents and format), check Delete all.

Figure 123: Delete Contents dialog

Replacing all the data in a cell
To remove data and insert new data, simply type over the old data. The new data will retain the
original formatting.

Changing part of the data in a cell
Sometimes it is necessary to change the contents of cell without removing all of the contents, for
example if the phrase “Sales in Qtr. 2” is in a cell and it needs to be changed to “Sales rose in Qtr.
2” It is often useful to do this without deleting the old cell contents first.
The process is the similar to the one described above, but you need to place the cursor inside the
cell. You can do this in two ways.
Using the keyboard
After selecting the appropriate cell, press the F2 key and the cursor is placed at the end of the
cell. Then use the keyboard arrow keys to move the cursor through the text in the cell.
Using the mouse
Using the mouse, either double-click on the appropriate cell (to select it and place the cursor in
it for editing), or single-click to select the cell and then move the mouse pointer up to the input
line and click into it to place the cursor for editing.
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Formatting data
The data in Calc can be formatted in several ways. It can either be edited as part of a cell style so
that it is automatically applied, or it can be applied manually to the cell. Some manual formatting
can be applied using toolbar icons. For more control and extra options, select the appropriate cell
or cells, right-click on it, and select Format Cells. All of the format options are discussed below.

Note

All the settings discussed in this section can also be set as a part of the cell style.
See Chapter 4 in the Calc Guide for more information.

Formatting multiple lines of text
Multiple lines of text can be entered into a single cell using automatic wrapping or manual line
breaks. Each method is useful for different situations.

Using automatic wrapping
To set text to wrap at the end of the cell, right-click on the cell and select Format Cells (or choose
Format > Cells from the menu bar, or press Ctrl+1). On the Alignment tab (Figure 124), under
Properties, select Wrap text automatically and click OK. The results are shown in Figure 125.

Figure 124: Format Cells > Alignment dialog

Figure 125: Automatic text wrap
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Using manual line breaks
To insert a manual line break while typing in a cell, press Ctrl+Enter. This method does not work
with the cursor in the input line. When editing text, first double-click the cell, then single-click at the
position where you want the line break.
When a manual line break is entered, the cell width does not change. Figure 126 shows the results
of using two manual line breaks after the first line of text.

Figure 126: Cell with manual line breaks

Shrinking text to fit the cell
The font size of the data in a cell can automatically adjust to fit in a cell. To do this, select the
Shrink to fit cell size option in the Format Cells dialog (Figure 124). Figure 127 shows the
results.

Figure 127: Shrinking font size to fit cells

Formatting numbers
Several different number formats can be applied to cells by using icons on the Formatting toolbar.
Select the cell, then click the relevant icon.

Figure 128: Number format icons. Left to right: currency, percentage, date,
exponential, standard, add decimal place, delete decimal place.
For more control or to select other number formats, use the Numbers tab (Figure 129) of the
Format Cells dialog:

• Apply any of the data types in the Category list to the data.
• Control the number of decimal places and leading zeros.
• Enter a custom format code.
The Language setting controls the local settings for the different formats such as the date order
and the currency marker.
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Figure 129: Format Cells > Numbers

Formatting the font
To quickly choose the font used in a cell, select the cell, then click the arrow next to the Font Name
box on the Formatting toolbar and choose a font from the list.

Tip

To choose whether to show the font names in their font or in plain text, go to Tools
> Options > LibreOffice > View and select or deselect the Show preview of fonts
option in the Font Lists section. For more information, see Chapter 2, Setting Up
LibreOffice.

To choose the size of the font, click the arrow next to the Font Size
box on the Formatting toolbar. For other formatting, you can use the
Bold, Italic, or Underline icons.
To choose a font color, click the arrow next to the Font Color icon to
display the color palette. Click on the desired color.
(To define custom colors, use Tools > Options > LibreOffice >
Colors. See Chapter 2.)
To specify the language of the cell (useful because it allows different
languages to exist in the same document and be spell checked
correctly), use the Font tab of the Format Cells dialog. Use the Font
Effects tab to set other font characteristics. See Chapter 4, Using
Styles and Templates in Calc, of the Calc Guide for more information.
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Formatting the cell borders
To add a border to a cell (or group of selected cells), click on the Borders icon on the formatting
toolbar, and select one of the border options displayed in the palette.
To quickly choose a line style and color for the borders of a cell, click the small arrows next to the
Line Style and Line Color icons on the Formatting toolbar. In each case, a palette of choices is
displayed.
For more controls, including the spacing between the cell borders and the text, use the Borders tab
of the Format Cells dialog. There you can also define a shadow. See Chapter 4, Using Styles and
Templates in Calc, of the Calc Guide for details.

Note

The cell border properties apply to a cell, and can only be changed if you are
editing that cell. For example, if cell C3 has a top border (which would be
equivalent visually to a bottom border on C2), that border can only be removed by
selecting C3. It cannot be removed in C2.

Formatting the cell background
To quickly choose a background color for a cell, click the small arrow next to the Background Color
icon on the Formatting toolbar. A palette of color choices, similar to the Font Color palette, is
displayed.
(To define custom colors, use Tools > Options > LibreOffice > Colors. See Chapter 2 for more
information.)
You can also use the Background tab of the Format Cells dialog. See Chapter 4, Using Styles and
Templates in Calc, of the Calc Guide for details.

Autoformatting cells and sheets
You can use the AutoFormat feature to quickly apply a set of cell formats to a sheet or a selected
cell range.
1) Select the cells, including the column and row headers, that you want to format.
2) Choose Format > AutoFormat.

Note

The AutoFormat feature can only be applied if the selected set of cells contains at
least 3 columns and 3 rows and also includes the column and row headers.

3) To select which properties (number format, font, alignment, borders, pattern, autofit width
and height) to include in an AutoFormat, click More. Select or deselect the required
options.
4) Click OK.
If you do not see any change in color of the cell contents, choose View > Value Highlighting from
the menu bar.
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Figure 130: Choosing an AutoFormat

Defining a new AutoFormat
You can define a new AutoFormat that is available to all spreadsheets.
1) Format a sheet (in the style for the new AutoFormat).
2) Choose Edit > Select All.
3) Choose Format > AutoFormat. The Add button is now active.
4) Click Add.
5) In the Name box of the Add AutoFormat dialog, type a meaningful name for the new format.
6) Click OK to save. The new format is now available in the Format list in the AutoFormat
dialog.

Formatting spreadsheets using themes
Calc comes with a predefined set of formatting themes that you can apply to your spreadsheets.
It is not possible to add themes to Calc, and they cannot be modified. However, you can modify
their styles after you apply them to a spreadsheet.
To apply a theme to a spreadsheet:
1) Click the Choose Themes icon in the Tools toolbar. If this toolbar is not visible, you can
show it using View > Toolbars > Tools.
The Theme Selection dialog appears. This dialog lists the available themes for the whole
spreadsheet.

2) In the Theme Selection dialog, select the theme that you want to apply to the spreadsheet.
As soon as you select a theme, some of the properties of the custom styles are applied to
the open spreadsheet and are immediately visible.
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3) Click OK. If you wish, you can now go to the Styles and Formatting window to modify
specific styles. These modifications do not change the theme; they only change the
appearance of this specific spreadsheet document.

Using conditional formatting
You can set up cell formats to change depending on conditions that you specify. For example, in a
table of numbers, you can show all the values above the average in green and all those below the
average in red.
Conditional formatting depends upon the use of styles, and the AutoCalculate feature (Tools > Cell
Contents > AutoCalculate) must be enabled. See Chapter 2, Entering, Editing, and Formatting
Data, in the Calc Guide for details.

Hiding and showing data
When elements are hidden, they are neither visible nor printed, but can still be selected for copying
if you select the elements around them. For example, if column B is hidden, it is copied when you
select columns A and C. When you need a hidden element again, you can reverse the process,
and show the element.
To hide or show sheets, rows, and columns, use the options on the Format menu or the right-click
(context) menu. For example, to hide a row, first select the row, and then choose Format > Row >
Hide (or right-click and choose Hide).
To hide or show selected cells, choose Format > Cells from the menu bar (or right-click and
choose Format Cells). On the Format Cells dialog, go to the Cell Protection tab.

Figure 131: Hiding or showing cells

Outline group controls
If you are continually hiding and showing the same cells, you can simplify the process by creating
outline groups, which add a set of controls for hiding and showing the cells in the group that are
quick to use and always available.
If the contents of cells falls into a regular pattern, such as four cells followed by a total, then you
can use Data > Group and Outline > AutoOutline to have Calc add outline controls based on the
pattern. Otherwise, you can set outline groups manually by selecting the cells for grouping, then
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choosing Data > Group and Outline > Group. On the Group dialog, you can choose whether to
group the selected cells by rows or columns.
When you close the dialog, the outline group controls are visible between either the row or column
headers and the edges of the editing window. The controls resemble the tree-structure of a filemanager in appearance, and can be hidden by selecting Data > Outline > Hide Details. They are
strictly for on screen use, and do not print.

Figure 132: Outline group controls
The basic outline controls have plus or minus signs at the start of the group to show or hide hidden
cells. However, if outline groups are nested, the controls have numbered buttons for hiding
different levels.
If you no longer need a group, place the mouse cursor in any cell in it and select Data > Group
and Outline > Ungroup. To remove all groups on a sheet, select Data > Group and Outline >
Remove.

Filtering which cells are visible
A filter is a list of conditions that each entry has to meet in order to be displayed. You can set three
types of filters from the Data > Filter sub-menu.
Automatic filters add a drop-down list to the top row of a column that contains commonly used
filters. They are quick and convenient and are useful with text and with numbers, because the list
includes every unique entry in the selected cells.
In addition to these unique entries, automatic filters include the option to display all entries, the ten
highest numerical values, and all cells that are empty or not-empty, as well as a standard filter. The
automatic filters are somewhat limited. In particular, they do not allow regular expressions, so you
cannot use them to display cell contents that are similar, but not identical.
Standard filters are more complex than automatic filters. You can set as many as three conditions
as a filter, combining them with the operators AND and OR. Standard filters are mostly useful for
numbers, although a few of the conditional operators, such as = and < > can also be useful for text.
Other conditional operators for standard filters include options to display the largest or smallest
values, or a percentage of them. Useful in themselves, standard filters take on added value when
used to further refine automatic filters.
Advanced filters are structured similarly to standard filters. The differences are that advanced
filters are not limited to three conditions, and their criteria are not entered in a dialog. Instead,
advanced filters are entered in a blank area of a sheet, then referenced by the advanced filter tool
to apply them.
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Sorting records
Sorting arranges the visible cells on the sheet. In Calc, you can sort by up to three criteria, which
are applied one after another. Sorts are handy when you are searching for a particular item, and
become even more powerful after you have filtered data.
In addition, sorting is often useful when you add new information. When a list is long, it is usually
easier to add new information at the bottom of the sheet, rather than adding rows in the proper
places. After you have added information, you can then sort it to update the sheet.
Highlight the cells to be sorted, then select Data > Sort to open the Sort dialog (or click the Sort
Ascending or Sort Descending toolbar buttons). Using the dialog, you can sort the selected cells
using up to three columns, in either ascending (A-Z, 1-9) or descending (Z-A, 9-1) order.
On the Options tab of the Sort dialog, you can choose the following options:
Case sensitive
If two entries are otherwise identical, one with an upper case letter is placed before one with a
lower case letter in the same position.
Range contains column labels
Does not include the column heading in the sort.
Include formats
A cell's formatting is moved with its contents. If formatting is used to distinguish different types
of cells, then use this option.
Copy sort results to
Sets a spreadsheet address to which to copy the sort results. If a range is specified that does
not have the necessary number of cells, then cells are added. If a range contains cells that
already have content, then the sort fails.
Custom sort order
Select the box, then choose one of the sort orders defined in Tools > Options > Spreadsheet
> Sort Lists from the drop-down list.
Direction
Sets whether rows or columns are sorted. The default is to sort by columns unless the selected
cells are in a single column.

Using formulas and functions
You may need more than numbers and text on your spreadsheet. Often the contents of one cell
depend on the contents of other cells. Formulas are equations using numbers and variables to get
a result. The variables are cell locations that hold the data you need for the equation.
A function is a predefined calculation entered in a cell to help you analyze or manipulate data. All
you have to do is add the arguments, and the calculation is automatically made for you. Functions
help you create the formulas needed to get the results that you are looking for.
Refer to Chapter 7 in the Calc Guide for more information.
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Analyzing data
Calc includes several tools to help you analyze the information in your spreadsheets, ranging from
features for copying and reusing data, to creating subtotals automatically, to varying information to
help you find the answers you need. These tools are divided between the Tools and Data menus.
One of the most useful of these tools is the PivotTable (called DataPilot in Calc 3.3). This is a tool
for combining, comparing, and analyzing large amounts of data easily. Using the PivotTable, you
can view different summaries of the source data, display the details of areas of interest, and create
reports, whether you are a beginner, an intermediate or advanced user. Refer to Chapter 8 in the
Calc Guide for more information.
Other analysis options include:
Consolidation
Data > Consolidate provides a way to combine data from two or more ranges of cells into a
new range while running one of several functions (such as Sum or Average) on the data.
Subtotals
Use Data > Subtotals to calculate subtotals for up to three columns.
Scenarios
Tools > Scenarios opens a dialog for testing “what-if” questions, such as different interest
rates on a loan.
Goal seek
Use Tools > Goal Seek if you know the result you want, but need to discover what values will
produce this result.
Solver
Tools > Solver is similar to Goal Seek, but you can use more than one variable. The Solver is
designed to minimize or maximize the result according to a set of rules that you define.
All of these options are further discussed in Chapter 9 in the Calc Guide.

Printing
Printing from Calc is much the same as printing from other LibreOffice components (see Chapter
10), but some details are different, especially regarding preparation for printing.

Using print ranges
Print ranges have several uses, including printing only a specific part of the data or printing
selected rows or columns on every page. For more about using print ranges, see Chapter 6,
Printing, Exporting, and E-mailing, in the Calc Guide.

Defining a print range
To define a new print range or modify an existing print range:
1) Highlight the range of cells that comprise the print range.
2) Choose Format > Print Ranges > Define.
The page break lines display on the screen.
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Tip

You can check the print range by using File > Page Preview. LibreOffice will only
display the cells in the print range.

Adding to the print range
After defining a print range, you can add more cells to it. This allows multiple, separate areas of the
same sheet to be printed, while not printing the whole sheet. After you have defined a print range:
1) Highlight the range of cells to be added to the print range.
2) Choose Format > Print Ranges > Add. This adds the extra cells to the print range.
The page break lines no longer display on the screen.

Note

The additional print range will print as a separate page, even if both ranges are on
the same sheet.

Removing a print range
It may become necessary to remove a defined print range, for example if the whole sheet needs to
be printed later.
Choose Format > Print Ranges > Remove. This removes all defined print ranges on the sheet.
After the print range is removed, the default page break lines will appear on the screen.

Editing a print range
At any time, you can directly edit the print range, for example to remove or resize part of the print
range. Choose Format > Print Ranges > Edit.

Selecting the page order, details, and scale
To select the page order, details, and scale to be printed:
1) Choose Format > Page from the main menu.
2) On the Page Style dialog (Figure 133), select the Sheet tab.
3) Make your selections, and then click OK.
Page Order
When a sheet will print on more than one page, you can set the order in which pages print. This is
especially useful in a large document; for example, controlling the print order can save time if you
have to collate the document a certain way. The two available options are shown below.
Top to bottom, then right

Left to right, then down
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Figure 133. The Sheet tab of the Page Style dialog
Details
You can specify which details to print. These details include:

• Row and column headers
• Sheet grid—prints the borders of the cells as a grid
• Comments—prints the comments defined in your spreadsheet on a separate page, along
with the corresponding cell reference

•
•
•
•
•

Objects and graphics
Charts
Drawing objects
Formulas—prints the formulas contained in the cells, instead of the results
Zero Values—prints cells with a zero value

Note

Remember that since the print detail options are a part of the page’s properties,
they are also a part of the page style’s properties. Therefore, different page styles
can be set up to quickly change the print properties of the sheets in the
spreadsheet.

Scale
Use the scale features to control the number of pages the data will print on. This can be useful if a
large amount of data needs to be printed compactly or if you want the text enlarged to make it
easier to read.

• Reduce/Enlarge printout—scales the data in the printout either larger or smaller. For
example if a sheet would normally print out as four pages (two high and two wide), a
scaling of 50% would print as one page (both width and height are halved).
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• Fit print range(s) on number of pages—defines exactly how many pages the printout will
take up. This option will only reduce a printout, it will not enlarge it. To enlarge a printout,
the reduce/enlarge option must be used.

• Fit print range(s) to width/height—defines how high and wide the printout will be, in pages.

Printing rows or columns on every page
If a sheet is printed on multiple pages, you can set up certain rows or columns to repeat on each
printed page.
For example, if the top two rows of the sheet as well as column A need to be printed on all pages,
do the following:
1) Choose Format > Print Ranges > Edit. On the Edit Print Ranges dialog, type the rows in
the text entry box under Rows to repeat. For example, to repeat rows 1 and 2, type $1:$2.
This automatically changes Rows to repeat from, - none - to - user defined -.

Figure 134: Specifying repeating rows
2) To repeat, type the columns in the text entry box under Columns to repeat. For example, to
repeat column A, type $A. In the Columns to repeat list, - none - changes to
- user defined -.
3) Click OK.

Note

You do not need to select the entire range of the rows to be repeated; selecting
one cell in each row works.

Page breaks
While defining a print range can be a powerful tool, it may sometimes be necessary to manually
adjust Calc’s printout. To do this, you can use a manual break. A manual break helps to ensure that
your data prints properly. You can insert a horizontal page break above, or a vertical page break to
the left of, the active cell.

Inserting a page break
To insert a page break:
1) Navigate to the cell where the page break will begin.
2) Select Insert > Manual Break.
3) Select Row Break or Column Break depending on your need.
The break is now set.
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Row break
Selecting Row Break creates a page break above the selected cell. For example, if the active
cell is H15, then the break is created between rows 14 and 15.
Column break
Selecting Column Break creates a page break to the left of the selected cell. For example, if
the active cell is H15, then the break is created between columns G and H.

Tip

To see page break lines more easily on screen, you can change their color.
Choose Tools > Options > LibreOffice > Appearance and scroll down to the
Spreadsheet section.

Deleting a page break
To remove a page break:
1) Navigate to a cell that is next to the break you want to remove.
2) Select Edit > Delete Manual Break.
3) Select Row Break or Column Break depending on your need.
The break is now removed.

Note

Multiple manual row and column breaks can exist on the same page. When you
want to remove them, you have to remove each one individually. This may be
confusing at times, because although there may be a column break set on the
page, when you go to Edit > Manual Break, Column break may be grayed out.
In order to remove the break, you have to be in the cell next to the break. For
example, if you set the column break while you are in H15, you can not remove it if
you are in cell D15. However, you can remove it from any cell in column H.

Headers and footers
Headers and footers are predefined pieces of text that are printed at the top or bottom of a sheet
outside of the sheet area. Headers are set in the same way as footers.
Headers and footers are assigned to a page style. You can define more than one page style for a
spreadsheet and assign different page styles to different sheets. For more about page styles, see
Chapter 4, Using Styles and Templates, in the Calc Guide.

Setting a header or footer
To set a header or footer:
1) Navigate to the sheet that you want to set the header or footer for. Choose Format > Page.
2) On the Page Style dialog, select the Header (or Footer) tab. See Figure 135.
3) Select the Header on option.
From here you can also set the margins, the spacing, and height for the header or footer. You can
check the AutoFit height box to automatically adjust the height of the header or footer.
Margin
Changing the size of the left or right margin adjusts how far the header or footer is from the
side of the page.
Spacing
Spacing affects how far above or below the sheet the header or footer will print. So, if spacing
is set to 1.00", then there will be 1 inch between the header or footer and the sheet.
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Height
Height affects how big the header or footer will be.

Figure 135: Header dialog

Header or footer appearance
To change the appearance of the header or footer, click the More button in the header dialog. This
opens the Border/Background dialog (Figure 136).
From this dialog you can set the background and border of the header or footer. For more
information see Chapter 4, Using Styles and Templates, in the Calc Guide.

Figure 136: Header/Footer - Border/Background
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Setting the contents of the header or footer
The header or footer of a Calc spreadsheet has three columns for text. Each column can have
different contents.
To set the contents of the header or footer, click the Edit button in the header or footer dialog
shown in Figure 136 to display the dialog shown in Figure 137.

Figure 137: Edit contents of header or footer
Areas
Each area in the header or footer is independent and can have different information in it.
Header
You can select from several preset choices in the Header drop-down list, or specify a custom
header using the buttons below the area boxes. (To format a footer, the choices are the same.)
Custom header
Click in the area (Left, Center, Right) that you want to customize, then use the buttons to add
elements or change text attributes.
Opens the Text Attributes dialog.
Inserts the total number of pages.
Inserts the File Name field.
Inserts the Date field.
Inserts the Sheet Name field.
Inserts the Time field.
Inserts the current page number.
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Chapter 6
Getting Started with Impress
Presentations in LibreOffice

What is Impress?
Impress is the presentation (slide show) program included in LibreOffice. You can create slides that
contain many different elements, including text, bulleted and numbered lists, tables, charts, and a
wide range of graphic objects such as clipart, drawings and photographs. Impress also includes a
spelling checker, a thesaurus, text styles, and background styles.
This chapter includes instructions, screenshots, and hints to guide you through the Impress
environment while designing your presentations. Although more difficult designs are mentioned
throughout this chapter, explanations for creating them are in the Impress Guide. If you have a
working knowledge of how to create slide shows, we recommend you use the Impress Guide for
your source of information.
To use Impress for more than very simple slide shows requires some knowledge of the elements
which the slides contain. Slides containing text use styles to determine the appearance of that text.
Creating drawings in Impress is similar to the Draw program included in LibreOffice. For this
reason, we recommend that you also see Chapter 3, Using Styles and Templates, and Chapter 7,
Getting Started with Draw in this book. You may also wish to consult the Draw Guide for more
details on how to use the drawing tools.

Starting Impress
You can start Impress in several ways:

• From the LibreOffice Start Center, if no component is open, click on the Presentation icon.
• From the system menu, the standard menu from which most applications are started. On
Windows, it is called the Start menu. On Gnome, it is called the Applications menu. On
KDE it is identified by the KDE logo. On Mac OS X, it is the Applications menu. Details vary
with your operating system; see Chapter 1 Introducing LibreOffice.

• On Windows, use the Presentation selection in the LibreOffice Quickstarter. (Similar
functions exist for Mac and Linux; see Chapter 1 Introducing LibreOffice.)

• From any open component of LibreOffice. Click the triangle to the right of the New icon on
the main toolbar and select Presentation from the drop-down menu or choose File > New >
Presentation from the menu bar.

Note

When LibreOffice was installed on your computer, in most cases a menu entry for
each component was added to your system menu. The exact name and location of
these menu entries depend on the operating system and graphical user interface.

When you start Impress for the first time, the Presentation Wizard is shown. Here you can choose
from the following options:

•
•
•
•

Empty presentation, which gives you a blank document
From template, which is a presentation designed with a template of your choice
Open existing presentation
Click Create to open the main Impress window.

For detailed instructions about how to use the Presentation Wizard, see “Creating a new
presentation” on page 159.
If you prefer not to use the Presentation Wizard in future, you can select Do not show this wizard
again. You can enable the wizard again later under Tools > Options > LibreOffice Impress > General
> New document, and select the Start with wizard option.
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The main Impress window
The main Impress window (Figure 138) has three parts: the Slides pane, Workspace, and Tasks
pane. Additionally, several toolbars can be displayed or hidden during the creation of a
presentation.

Figure 138: Main window of Impress; ovals indicate the Hide/Show markers

Tip

You can close the Slides pane or the Tasks pane by clicking the X in the upper right
corner of the pane or by choosing View > Slide Pane or View > Tasks Pane to
deselect the pane. To reopen a pane, choose View > Slide Pane or View > Tasks
Pane again.
You can also maximize the Workspace area by clicking on the Hide/Show marker in
the middle of the vertical separator line (indicated by ovals in Figure 138). Using the
Hide/Show marker hides, but does not close, the Slides and Tasks panes. To restore
the pane, click again on its Hide/Show marker.

Slides pane
The Slides pane contains thumbnail pictures of the slides in your presentation, in the order they will
be shown unless you change the slide show order. Clicking a slide in this pane selects it and
places it in the Workspace. When a slide is in the Workspace, you can make changes any way you
like.
Several additional operations can be performed on one or more slides simultaneously in the Slides
pane:

• Add new slides to the presentation.
• Mark a slide as hidden so that it will not be shown as part of the presentation.
• Delete a slide from the presentation if it is no longer needed.
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• Rename a slide.
• Duplicate a slide (copy and paste) or move it to a different position in the presentation (cut
and paste).
It is also possible to perform the following operations, although there are more efficient methods
than using the Slides pane:

• Change the slide transition following the selected slide or after each slide in a group of
slides.

• Change the sequence of slides in the presentation.
• Change the slide design.
• Change slide layout for a group of slides simultaneously.

Tasks pane
The Tasks pane has five sections. To expand the section you wish to use, click on the title bar of
each section. Only one section at a time can be expanded.
Master Pages
Here you define the page (slide) style for your presentation. Impress includes several designs
of Master Pages (slide masters). One of them - Default - is blank, and the rest have
background and styled text.

Tip

Press F11 to open the Styles and Formatting window, where you can modify the
styles used in any master page to suit your purpose. This can be done at any time.

Layout
The layouts included in Impress are shown here. You can choose the one you want and use it
as it is, or you can modify it to meet your own requirements. However, it is not possible to save
custom layouts.
Table Design
The standard table styles are provided in this section. You can further modify the appearance
of a table with the options to show or hide specific rows and columns, or to apply a banded
appearance to the rows and columns.
Custom Animation
A variety of animations can be used to emphasize or enhance different elements of each slide.
The Custom Animation section provides an easy way to add, change, or remove animations.
Slide Transition
The Slide Transition section provides access to a number of slide transition options. The default
is set to No Transition, in which the following slide simply replaces the existing one. However,
many additional transitions are available. You can also specify the transition speed (slow,
medium, fast), choose between an automatic or manual transition, and choose how long the
selected slide should be shown (automatic transition only).

Workspace
The Workspace (normally in the center) has five tabs: Normal, Outline, Notes, Handout, and
Slide Sorter (Figure 139). These five tabs are called View buttons. The Workspace below the View
buttons changes depending on the chosen view. The workspace views are described in detail on
page 154.
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Figure 139: Workspace tabs

Toolbars
Many toolbars can be used during slide creation; they can be displayed or hidden by clicking View
> Toolbars and selecting from the menu.
You can also select the icons that you wish to appear on each toolbar. For more information, refer
to Chapter 1, Introducing LibreOffice.
Many of the toolbars in Impress are similar to the toolbars in Draw. Refer to the Draw Guide for
details on the functions available and how to use them.

Status bar
The Status bar, located at the bottom of the Impress window, contains information that you may
find useful when working on a presentation. For details on the contents and use of these fields, see
Chapter 1, Introducing LibreOffice in this guide and Chapter 1, Introducing Impress in the Impress
Guide.

Note

The sizes are given in the current measurement unit (not to be confused with the
ruler units). This unit is defined in Tools > Options > LibreOffice Impress >
General.

Figure 140: Status bar
From left to right, you will find:

• Information area - changes depending on the selection. For example:
Example selection

Examples of information shown

Text area

Text Edit: Paragraph x, Row y, Column z

Charts, spreadsheets

Embedded object (OLE) “ObjectName” selected

Graphics

Bitmap with transparency selected

• Cursor position - the position of the cursor or of the top left corner of the selection
measured from the top left corner of the slide, followed by the width and height of the
selection or text box where the cursor is located.

• Unsaved changes - a flag indicating that the file needs saving. Double clicking on this flag
opens the file save dialog.
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• Digital signature - a flag indicating whether the document is digitally signed. After the file
has been saved, double clicking on this flag opens the digital signatures dialog.

• Slide number - the slide number currently displayed in the Workspace and the total
number of slides in the presentation.

• Page (slide) style - the style associated with the slide, handout, or notes page currently in
the Workspace. Double clicking on the style name opens the slide design dialog.

• Zoom slider – adjusts the zoom percentage of the Workspace displayed.
• Zoom percentage - indicates the zoom percentage of the Workspace displayed. Double
clicking on zoom percentage opens the zoom and layout dialog.

• You can hide the information in the Status Bar by selecting View > Status Bar from the
main menu.

Navigator
The Navigator displays all objects contained in a document. It provides another convenient way to
move around a document and find items in it. To display the Navigator, click its icon
Standard toolbar, choose View > Navigator on the menu bar, or press Ctrl+Shift+F5.

on the

The Navigator is more useful if you give your slides and objects (pictures, spreadsheets, and so
on) meaningful names, instead of leaving them as the default “Slide 1” and “Shape 2”.

Figure 141: Navigator

Workspace views
Each of the workspace views is designed to ease the completion of certain tasks; it is therefore
useful to familiarize yourself with them in order to quickly accomplish those tasks.

Note
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toolbar sets can be customized by going to View > Toolbars, then check or
uncheck the toolbar you want to add or remove.
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Normal view
Normal view is the main view for working with individual slides. Use this view to format and design
and to add text, graphics, and animation effects.
To place a slide in the slide design area (Normal view) (Figure 138), click the slide thumbnail in the
Slides pane or double-click it in the Navigator (page 154).

Outline view
Outline view contains all the slides of the presentation in their numbered sequence. It shows topic
titles, bulleted lists, and numbered lists for each slide in outline format. Only the text contained in
the default text boxes in each slide is shown, so if your slide includes other text boxes or drawing
objects, the text in these objects is not displayed. Slide names are also not included.

Figure 142: Outline view
Use Outline view for the following purposes.
1) Making changes in the text of a slide:

•
•

Add and delete the text in a slide just as in the Normal view.

•

Change the outline level for any of the paragraphs in a slide using the left and right
arrow buttons (Promote or Demote) on the Text Formatting toolbar.

•

Both move a paragraph and change its outline level using a combination of these four
arrow buttons.

Move the paragraphs of text in the selected slide up or down by using the up and
down arrow buttons (Move Up or Move Down) on the Text Formatting toolbar
(highlighted in Figure 143).

2) Compare slides with your outline (if you have prepared one in advance). If you notice from
your outline that another slide is needed, you can create it directly in the Outline view or
you can return to the Normal view to create it.

Figure 143: Text Formatting toolbar

Notes view
Use the Notes view (Figure 144) to add notes to a slide. These notes are not seen when the
presentation is shown.
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Figure 144: Notes view
1) Click the Notes tab in the Workspace.
2) Select the slide to which you want to add notes.

•
•

Click the slide in the Slides pane, or
Double-click the slide’s name in the Navigator.

3) In the text box below the slide, click on the words Click to add notes and begin typing.
You can resize the Notes text box using the colored resizing handles which appear when you click
on the edge of the box. You can also move the box by placing the pointer on the border, then
clicking and dragging. To make changes in the text style, press the F11 key to open the Styles and
Formatting window.

Handout view
Handout view is for setting up the layout of your slide for a printed handout. Click the Handout tab
in the workspace, then choose Layouts in the Tasks pane. You can then choose to print 1, 2, 3, 4,
6, or 9 slides per page.

Figure 145: Handout layouts
Use this view also to customize the information printed on the handout. Refer to Chapter 10
Printing, E-mailing, Exporting, and Saving Slide Shows of the Impress Guide for instructions on
printing slides, handouts, and notes.
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Select from the main menu Insert > Page Number or Insert > Date and Time and in the dialog
box that opens click on the Notes and Handouts tab (Figure 146). Use this dialog to select the
elements you want to appear on each handout page and their contents. More details on how to use
this dialog are provided in the Impress Guide.

Figure 146: Dialog to set the page information for handouts and notes

Slide Sorter view
Slide Sorter view (Figure 147) contains all of the slide thumbnails. Use this view to work with a
group of slides or with only one slide.

Figure 147: Slide Sorter view
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Customizing Slide Sorter view
To change the number of slides per row:
1) Check View > Toolbars > Slide Sorter and Slide View to show or hide the slide sorter and
view toolbars (Figure 148).
2) Adjust the number of slides (up to a maximum of 15).

Figure 148: Slide Sorter and Slide View toolbars

Moving a slide using Slide Sorter
To move a slide in a presentation in the Slide Sorter:
1) Click the slide and the slide is highlighted (see Figure 147).
2) Drag and drop it to the location you want.

Selecting and moving groups of slides
To select a group of slides, use one of these methods:

• Use the Control (Ctrl) key: Click on the first slide and, while pressing the Control key, select
the other desired slides.

• Use the Shift key: Click on the first slide, and while pressing the Shift key, select the final
slide in the group. This selects all of the other slides between the first and the last.

• Use the mouse: Click slightly to one side (left or right) of the first slide to be selected. Hold
down the left mouse button and drag the mouse pointer until all of the slides you want
selected are highlighted.
To move a group of slides:
1) Select a group of slides.
2) Drag and drop the group to their new location.

Working in Slide Sorter view
You can work with slides in the Slide Sorter view just as you can in the Slide pane.
To make changes, right-click a slide and choose any of the following from the pop-up menu:

•
•
•
•
•

Add a new slide after the selected slide.
Delete Slide: deletes the selected slide.
Rename Slide: allows you to rename the selected slide.
Slide Layout: allows you to change the layout of the selected slide.
Slide Transition: allows you to change the transition of the selected slide.

–
–
•
•
•
•
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For one slide, click the slide to select it and then add the desired transition.
For more than one slide, select the group of slides and add the desired transition.

Hide Slide: hidden slides are not shown in the slide show.
Cut: removes the selected slide and saves it to the clipboard.
Copy: copies the selected slide to the clipboard without removing it.
Paste: inserts a slide from the clipboard. This option will also allow you to specify whether
you want to paste the copied slide Before or After the selected slide.
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Creating a new presentation
This section describes how to start a new presentation using the Presentation Wizard.

Tip

The first thing to do is decide on the purpose of the presentation and plan the
presentation. Although you can make changes as you go, having an idea of who the
audience will be, the structure, the content, and how the presentation will be
delivered, will save you a lot of time from the start.

When you start Impress, the Presentation Wizard appears (Figure 149).

Figure 149. Choosing the type of presentation
1) Under Type, choose one of the options. These options are covered in the Impress Guide.

•
•

Empty presentation creates a blank presentation.
From template uses a template design already created as the basis for a new
presentation. The wizard changes to show a list of available templates. Choose the
template you want.

•

Open existing presentation continues work on a previously created presentation. The
wizard changes to show a list of existing presentations. Choose the presentation you
want.
2) Click Next. Figure 150 shows the Presentation Wizard step 2 as it appears if you selected
Empty Presentation at step 1. If you selected From template, an example slide is shown in
the Preview box.
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Figure 150. Selecting a slide design
3) Choose a design under Select a slide design. The slide design section gives you two
main choices: Presentation Backgrounds and Presentations. Each one has a list of choices
for slide designs. If you want to use one of these other than <Original>, click it to select it.

•

The types of Presentation Backgrounds are shown in Figure 150. By clicking an item,
you will see a preview of the slide design in the Preview window. Impress contains
three choices under Presentations: <Original>, Introducing a New Product, and
Recommendation of a Strategy.

•
•

<Original> is for a blank presentation slide design.

Note

Both Introducing a New Product and Recommendation of a Strategy have their own
prepackaged slide designs. Each design appears in the Preview window when its
name is clicked.
Introducing a New Product and Recommendation of a Strategy are included
presentation templates. They can be used to create a presentation by choosing
From template in the first step (Figure 149).

4) Select how the presentation will be used under Select an output medium. Most often,
presentations are created for computer screen display. Select Screen. You can change the
page format at any time.

Note
5)

The Screen page is optimized for a 4:3 display (28cm x 21cm) so it is not suitable for
modern widescreen displays. You can change the slide size at any time switching to
Normal view and selecting Format > Page.

Click Next. The Presentation Wizard step 3 appears (Figure 151).

•
•

Choose the desired slide transition from the Effect drop-down menu.
Select the desired speed for the transition between the different slides in the
presentation from the Speed drop-down menu. Medium is a good choice for now.

6) Click Create. A new presentation is created.
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Figure 151: Selecting a slide transition effect

Tip

Note

Caution

You can accept the default values for both Effect and Speed unless you are skilled
at creating presentations. Both of these values can be changed later while working
with Slide transitions and animations. These two features are explained in more
detail in Chapter 9 Slide Shows of the Impress Guide.
If you selected From template on step 1 of the Wizard, the Next button will be active
on step 3 and other pages will be available. These pages are not described here.
Remember to save frequently while working on the presentation, to prevent any loss
of information should something unexpected occur. You might also want to activate
the AutoRecovery function (Tools > Options > Load/Save . General). Make sure
Save AutoRecovery information every is selected and that you have entered a
recovery frequency.

Formatting a presentation
A new presentation contains only one empty slide. In this section we will start adding new slides
and preparing them for the intended contents.

Inserting slides
This can be done in a variety of ways; take your pick.

• Insert > Slide.
• Right-click on the present slide, and select Slide > New Slide from the pop-up menu.
• Click the Slide icon

In the Presentation toolbar.
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Sometimes, rather than starting from a new slide you want to duplicate a slide you have already
inserted. To duplicate a slide, select the slide you want from the Slides pane and then choose
Insert > Duplicate Slide.

Selecting a layout
In the Tasks pane, select the Layout drawer to display the available layouts (Figure 152). The
Layouts differ in the number of elements a slide will contain, from a blank slide to a slide with six
contents boxes and a title.

Figure 152: Available slide layouts
The first slide in a presentation is normally a title slide. The Title Slide (which also contains a
section for a subtitle) or Title Only are suitable layouts for the first slide, while for most of the slides
you will probably use the Title, Contents layout.
To create the title, click on Click to add title (assuming the Blank Slide layout was not used) and
then type the title text. To adjust the formatting of the title, modify the Title presentation style; see
Chapter 2 Using Slide Masters, Styles, and Templates in the Impress Guide for instructions.
If you are using the Title Slide layout, click on Click to add text to add a subtitle. Proceed as above
to make adjustments to the formatting if required modifying the Subtitle presentation style instead.

Note

Text and graphic elements can be readjusted at any time during the preparation of the
presentation, but changing the layout of a slide that already contains some contents
can have a dramatic effect. It is therefore recommended that you pay particular
attention to the layout you select. If you do need to change the layout after contents
have been added, the contents are not lost though they may need to be reformatted.

To view the names for the included layouts, use the Tooltip feature: position the
cursor on an icon in the Layout section (or on any toolbar icon) and its name will be
displayed in a small rectangle.

Tip
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If tooltips are not enabled, choose Tools > Options > LibreOffice > General > Help
and select the Tips option. If the Extended tips option is also selected, you will get
more detailed tooltip information, but the tooltip names themselves will not be
provided.
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To select or change the layout, place the slide in the work area and select the desired layout from
the layout drawer in the Task Pane.
Several layouts contain one or more content boxes. Each of these boxes can be configured to
contain one of the following elements: Text, Media clip, Picture, Chart or Table.
You can choose the type of contents by clicking on the corresponding icon that is displayed in the
middle of the contents box as shown in Figure 153. If instead you intend to use the contents box
for text, just click anywhere on the box to get a cursor.

Figure 153: Selecting contents type
To select or change the layout, place the slide in the work area and select the desired layout from
the layout drawer in the Task Pane.
If you have selected a layout with one or more contents boxes, this is a good time to decide what
type of contents you want to insert.

Modifying the slide elements
At this stage, the slide contains elements that were included in the slide master, as well those
elements included in the selected slide layout. It is however unlikely that the predefined layouts will
suit all your needs. You may want to remove any elements that are not required or insert objects
such as text and graphics.
Although Impress does not have the functionality to create new layouts, it allows you to resize and
move the layout elements. It is also possible to add slide elements without being limited to the size
and position of the layout boxes.
To resize a contents box, click on the outer frame so that the 8 resizing handles are displayed. To
move it place the mouse cursor on the frame so that the cursor changes shape. You can now click
the left mouse button and drag the contents box to its new position on the slide.
To remove any unwanted elements, do this:
1) Click the element to highlight it. The colored resizing handles show it is highlighted.
2) Press the Delete key to remove it.
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Caution

Changes to any of the layouts included in Impress can only be made using View >
Normal, which is the default. Attempting any changes by modifying a slide master,
although possible, may result in unpredictable results and requires extra care as well
as a certain amount of trial and error.

Adding text to a slide
To add text to a slide that contains a text frame, click on Click to add text in the text frame and then
type your text. The Outline styles are automatically applied to the text as you insert it. You can
change the outline level of each paragraph as well as its position within the text by using the arrow
buttons on the Text Formatting toolbar (see Outline view on page 155). For more information on
text, see “Adding and formatting text” on page 165.

Adding pictures or objects to a slide
To add any pictures or objects to a slide, for example a picture, clipart, drawing, photograph, or
spreadsheet, click on Insert then select from the drop down menu what type of insert you require.
For more information, see “Adding pictures, tables, charts and media” on page 169.

Modifying the appearance of all slides
To change the background and other characteristics of all slides in the presentation, you need to
modify the master page or choose a different master page as explained in the section “Working
with master pages and styles” on page 172.
A Slide Master is a slide with a specified set of characteristics that acts as a template and is used
as the starting point for creating other slides. These characteristics include the background, objects
in the background, formatting of any text used, and any background graphics.

Note

LibreOffice uses three interchangeable terms for this one concept. Master slide,
slide master, and master page. These terms all refer to a slide that is used to
create other slides. This guide, however, uses only the term slide master, except
when describing the user interface.

Impress has included a range of slide masters, found in the Master Pages section of the Tasks
pane. You can also create and save additional slide masters or add more from other sources. See
Chapter 2 Using Slide Masters, Styles, and Templates in the Impress Guide for information on
creating and modifying slide masters.
If all you need to do is to change the background, you can take a shortcut:
1) Select Format > Page and go to the Background tab.
2) Select the desired background between solid color, gradient, hatching and bitmap.
3) Click OK to apply it.
A dialog box will open asking if the background should be applied to all the slides. If you click yes,
Impress will automatically modify the master page for you.

Note
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Inserting and correctly formatting a background is beyond the scope of this chapter,
but you can find all the information you need in Chapter 4 Changing Object
Attributes of the Draw Guide or in Chapter 6 Formatting Graphic Objects of the
Impress Guide.
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Modifying the slide show
By default the slide show will display all the slides in the same order as they appear in the slide
sorter, without any transition between slides, and you need some keyboard or mouse interaction to
move from one slide to the next.
You can use the Slide Show menu to change the order of the slides, choose which ones are
shown, automate moving from one slide to the next, and other settings. To change the slide
transition, animate slides, add a soundtrack to the presentation, and make other enhancements,
you need to use functions in the Task pane. See the Impress Guide for details on how to use all of
these features.

Adding and formatting text
Many of your slides are likely to contain some text. This section gives you some guidelines on how
to add text and how to change its appearance. Text in slides is contained in text boxes. For more
information on adding and formatting text, see Chapter 3 Adding and Formatting Text in the
Impress Guide.
There are two types of text boxes that you can add to a slide:

• Choose a predefined layout from the Layouts section of the Tasks pane and do not select
any special contents type. These text boxes are called AutoLayout text boxes.

• Create a text box using the text tool

in the Drawing toolbar or the Text toolbar.

Using AutoLayout text boxes
Make sure Normal view is selected:
1) Click in the text box that reads Click to add text.
2) Type or paste your text in the text box.

Using text boxes created from the text tool
Make sure Normal view is selected:
1) Click on the Text icon
on the Drawing toolbar or press F2. If the Drawing toolbar with
the text icon is not visible, choose View > Toolbars > Drawing.
2) Click and drag to draw a box for the text on the slide. Do not worry about the vertical size
and position as the text box will expand if needed as you type.
3) Release the mouse button when finished. The cursor appears in the text box, which is now
in edit mode (gray hashed border shown in Figure 154).
4) Type or paste your text in the text box.
5) Click outside the text box to deselect it.
You can move, resize, and delete text boxes. For more information, see Chapter 3 Adding and
Formatting Text in the Impress Guide.
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Figure 154: Creating and editing text boxes

Using text boxes created from the Text toolbar
Make sure Normal view is selected:
1) Click on the Text icon
on the Text toolbar (Figure 155). If the Text toolbar with the text
icon is not visible, choose View > Toolbars > Text.
2) Click and drag to draw a text box on the slide. This sets the width. Do not worry about the
height because the text box will expand as you type.
3) Release the mouse button when finished. The cursor appears in the text box, which is now
in edit mode (a hashed border; see Figure 154).
4) Type or paste your text into the text box.
5) Click outside the text box to deselect it.

Figure 155: Text toolbar

Note

In addition to the normal text boxes where text is horizontally aligned, it is possible to
insert text boxes where the text is aligned vertically. This choice is available only
when Asian languages are enabled in Tools > Options > Language Settings >
Languages. Click on the
a vertical text box.
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button in the drawing toolbar or text toolbar to create
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Quick font resizing
Impress has icons
on the Text Formatting toolbar to increase or decrease font size of
selected text. The amount by which the font size changes depends on the standard sizes available
for the font in use.

Pasting text
Text may be inserted into the text box by copying it from another document and pasting it into
Impress. However, the pasted text will probably not match the formatting of the surrounding text or
that of the other slides in the presentation. This may be what you want on some occasions;
however in most cases you want to make sure that the presentation style is consistent and does
not become a patchwork of different paragraph styles, font types, bullet points and so on. There
are several ways to ensure consistency; these methods are explained below.

Pasting unformatted text
It is normally good practice to paste text without formatting and apply the formatting later. To paste
without formatting, either press Control+Shift+V and then select Unformatted text from the dialog
that appears, or click on the small black triangle next to the paste symbol in the standard toolbar
and select Unformatted text. The unformatted text will be formatted with the outline style at
the cursor position in an AutoLayout text box or with the default graphic style in a normal text box.

Formatting pasted text
If you are pasting the text into an AutoLayout area, you need to apply the appropriate outline style
to the text to give it the same look and feel as the rest of the presentation.
1) Paste the text in the desired position. Do not worry if it does not look right; it will in a
minute.
2) Select the text you have just pasted.
3) Select Format > Default formatting from the menu bar.
4) Use the four arrow buttons in the Text Formatting toolbar (highlighted in Figure 143) to
move the text to the appropriate position and give it the appropriate outline level. The
button with the arrow pointing left promotes the list entry by one level (for example from
Outline 3 to Outline 2), the right arrow button demotes the list entry by one level, the up and
down arrow buttons move the list entry.
5) Apply manual formatting as required to sections of the text (to change font attributes, tabs,
and so on).
If you are pasting text in a text box, you can still use styles to quickly format the text. Note that one
and only one graphic style can be applied to the copied text. To do that:
1) Paste the text in the desired position.
2) Select the text you have just pasted.
3) Select the desired graphic style.
4) Apply manual formatting as required to sections of the text.

Creating bulleted and numbered lists
The procedure to create a bulleted or numbered list is quite different depending on the type of text
box used, although the tools to manage the list and customize the appearance are the same.
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In text boxes created automatically by Impress (called AutoLayout), the outline styles available are
by default bulleted lists, while for normal text boxes an additional step is required to create a
bulleted list.

Creating lists in AutoLayout text boxes
Every text box included in the available layouts is already formatted as a bulleted list, therefore to
create a bulleted list the only necessary steps are:
1) From the Layout pane, choose a slide design that contains a text box. Those are easily
recognizable from the thumbnail.
2) Click in the text box that reads Click to add an outline.
3) Type the text, then press Enter to start a new bulleted line.
The methods for switching between bulleted and numbered lists are explained in “Changing the
appearance of the list” on page 169.

Tip

Press Shift + Enter to start a new line without creating a new bullet or number. The
new line will have the same indentation of the previous line. To switch off bullets
altogether, click the bullets button on the text formatting toolbar. If the text formatting
toolbar is not showing, enable it selecting View > Toolbar > Text Formatting
(Figure 143) in the menu bar.

Creating lists in other text boxes
To create a list in a text box, follow these steps:
1) Place the cursor in the text box.
2) Click the Bullets On/Off button
on the text formatting toolbar.
3) Type the text and press Enter to start a new bulleted line.
4) The default list type is a bulleted list. Methods for changing the appearance of the list are
explained on page 169.

Creating a new outline level
1) If necessary, press Enter to begin a new line.
2) Press Tab or click the indentation arrows
in the text formatting toolbar. Each time
you press Tab or click the right arrow, the line indents to the next outline level. Pressing
Enter creates a new line at the same level as the previous one. To return to the previous
level, press Shift+Tab or click the left arrow.
In the AutoLayout text boxes, promoting or demoting an item in the list corresponds to applying a
different outline style, so the second outline level corresponds to Outline 2 style, the third to Outline
3 style, and so on. As a consequence, a change in the level also produces other changes (for
example font size, bullet type, and so on).

Note
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Do not try to change the outline level by selecting the text and then clicking the
desired outline style as you would in Writer. Due to the way that presentation styles
work, it is not possible to apply them in this way.
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Changing the appearance of the list
You can fully customize the appearance of a list, changing the bullet type or numbering for the
entire list or for single entry. All of the changes can be made using the Bullets and Numbering
dialog, which is accessed by selecting Format > Bullets and Numbering or by clicking on the
Bullets and Numbering icon on the text formatting toolbar.
For the entire list:
1) Select the entire list or click on the gray border of the text box so that the colored resizing
handles are displayed.
2) Select Format > Bullets and Numbering or click on the Bullets and Numbering icon
on the text formatting toolbar.
3) The Bullets and Numbering dialog (Figure 156) contains five tabs: Bullets, Numbering type,
Graphics, Position, and Customize.

•

If a bullet list is needed, select the desired bullet style from the default styles available
on the Bullets page.

•
•

If a graphics style is needed, select one from those available on the Graphics page.
If a numbered list is needed, select one of the default numbering styles on the
Numbering type page.

Figure 156: Bullets and Numbering dialog
For a single line in the list, click anywhere in the line to place the cursor in it and then follow steps 2
and 3 in the previous instruction set.
If the list was created in an AutoLayout text box, then an alternative way to change the entire list is
to modify the Outline styles. Changes made to the outline style will apply to all the slides using
them. Sometimes this is what you want; sometimes it is not, so some care must be taken.

Adding pictures, tables, charts and media
As we have seen, besides text a contents box can contain also pictures, tables, charts or media
clips. This section provides a quick overview of how to work with these objects, however for a more
detailed description please refer to the Impress Guide.
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Adding pictures
To add a picture to a contents box:

• Go to Insert > Picture on the main menu bar and then select either From file or Scan.
• Alternatively, or after inserting a new slide, click the Insert Picture icon (Figure 153) and
select the file from the Insert Picture dialog that opens. To see a preview of the picture,
check Preview at the bottom of the Insert Picture dialog.

• Move the picture to the desired location.
The picture will resize itself to fill the area of the contents box. Follow the directions in the Caution
note below when manually resizing a graphic.

Caution

When resizing a graphic, right-click the picture. Select Position and Size from the
context menu and make sure that Keep ratio is selected. Then adjust the height or
width to the size you need. (As you adjust one dimension. both dimensions will
change.) Failure to do so will cause the picture to become distorted. Remember also
that resizing a bitmap image will reduce its quality; it is better to create an image of
the desired size outside of Impress.

Adding tables
For displaying tabular data, you can insert basic tables directly into your slides by choosing the
Table contents type. It is also possible to add a table outside a contents box in a number of ways:

• Go to Insert > Table on the main menu bar.
• Click on the Table icon
on the main toolbar or table toolbar.
• After inserting a new slide, click the Insert Table icon (Figure 153).
• Select a style option from the Table Design section of the Tasks pane.
• Alternatively, click on the Table Design icon

on the table toolbar to open the Table
Design section of the Tasks pane and then select a style.
The first three methods above opens the Insert Table dialog (Figure 157) where you can select the
required number of columns and rows. Alternatively, clicking on the black arrow next to the Table
icon displays a graphic allowing you to drag and select the number of required rows and columns
for your table.

Figure 157. Creating a table with the Insert Table dialog

Note
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Selecting from any of the styles in the Table Design section of the Tasks pane
creates a table based on that style. If you create a table by another method, you can
still apply a style of your choice later.
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With the table selected, the Table toolbar should appear. If it does not, you can access it by
selecting View > Toolbars > Table. The Table toolbar offers many of the same icons as the table
toolbar in Writer, with the exception of functions like Sort and Sum for performing calculations. For
those functions, you need to use a spreadsheet inserted from Calc (discussed below).
After the table is created, you can modify it in much the same way as you would modify a table in
Writer: adding and deleting rows and columns, adjusting width and spacing, adding borders,
background colors and so on. Detailed information on working with tables and the Table Properties
dialog can be found in Chapter 3 Adding and Formatting Text of the Impress Guide and Chapter 9
Working with Tables of the Writer Guide.
By modifying the style of the table from the Table Design section of the Tasks pane, you can
quickly change the appearance of the table or any newly created tables based on the Style options
you select. You can choose to add emphasis to a header and total row as well as the first and last
columns of the table, and apply a banded appearance to the rows and columns.
Having completed the table design, entering data into the cells is similar to working with text box
objects. Click in the cell you wish to add data to, and begin typing. To move around cells quickly,
use the following key options:

• The arrow keys move the cursor to the next table cell if the cell is empty, otherwise they
move the cursor to the next character in the cell.

• The Tab key moves to the next cell, skipping over the contents of the cell; Shift+Tab move
backwards from cell to cell.

Adding charts
To insert a chart in a slide you can either use Insert > Chart from the main menu bar, clicking on
the Chart icon
in the main toolbar, or, after inserting a new slide, clicking on the Insert Chart
icon (Figure 153). Impress will insert a default chart and open the Chart dialog. To modify the chart
type, insert your own data and change the formatting refer to the Impress Guide.

Adding media files
You can insert various types of media files, such as music and movie clips, into your slide by
selecting the Insert Movie icon (Figure 153) in an empty contents box. A media player will open at
the bottom of the screen and you can preview the media. When an audio file is inserted, the
contents box will show a loudspeaker image.

Caution

In Linux-based systems such as Ubuntu, media files do not work straight out of the
box. You need to download the Java Media Framework API (JMF) and add the path
to jmf.jar to the Class Path in Tools > Options > LibreOffice > Java.

Adding graphics, spreadsheets, and other objects
Graphics, such as shapes, callouts, arrows, and so on, are often useful to complement the text on
a slide. These objects are handled much the same way as graphics in Draw. For more information,
see Chapter 7 Getting Started with Draw in the Draw Guide, or Chapters 4, 5, and 6 in the Impress
Guide.
Spreadsheets embedded in Impress include most of the functionality of spreadsheets in Calc and
are therefore capable of performing extremely complex calculations and data analysis. If you need
to analyze your data or apply formulas, these operations are best performed in a Calc spreadsheet
and the results displayed in an embedded Impress spreadsheet or even better in a native Impress
table.
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Alternatively, choose Insert > Object > OLE Object from the menu bar. This opens a spreadsheet
in the middle of the slide and the menus and toolbars change to those used in Calc so that you can
start adding data, though you may first need to resize the visible area on the slide. You can also
insert an already existing spreadsheet and use the viewport to select the data that you want to
display on your slide.
Impress offers the capability of inserting in a slide various other types of objects such Writer
documents, Math formulas, or even another presentation. For details on using these objects, refer
to Chapter 7 Including Spreadsheets, Charts, and Other Objects of the Impress Guide.

Working with master pages and styles
A slide master is a slide that is used as the starting point for other slides. It is similar to a page style
in Writer and it controls the basic formatting of all slides based on it. A slide show can have more
than one slide master.

Note

LibreOffice uses three terms for a slide that is used to create other slides: master
slide, slide master, and master page. This book uses the term slide master, except
when describing the user interface.

A slide master has a defined set of characteristics, including the background color, graphic, or
gradient; objects (such as logos, decorative lines, and other graphics) in the background; headers
and footers; placement and size of text frames; and the formatting of text.

Styles
All of the characteristics of slide masters are controlled by styles. The styles of any new slide you
create are inherited from the slide master from which it was created. In other words, the styles of
the slide master are available and applied to all slides created from that slide master. Changing a
style in a slide master results in changes to all the slides based on that slide master, but you can
modify individual slides without affecting the slide master.

Note

Although it is highly recommended to use the slide masters whenever possible, there
are occasions where manual changes are needed for a particular slide, for example
to enlarge the chart area when the text and chart layout is used.

Slide masters have two types of styles associated with them: presentation styles and graphic
styles. The prepackaged presentation styles can be modified, but new presentation styles cannot
be created. In the case of graphic styles, you can modify the prepackaged ones and also create
new ones.
Presentation styles affect three elements of a slide master: background, background objects
(such as icons, decorative lines, and text frames), and text placed on the slide. Text styles are
further divided into Notes, Outline 1 through Outline 9, Subtitle, and Title. The outline styles are
used for the different levels of the outline to which they belong. For example, Outline 2 is used for
the sub-points of Outline 1, and Outline 3 is used for the sub-points of Outline 2.
Graphic styles affect many of the elements of a slide. Notice that text styles exist in both the
presentation and graphic style selections.
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Slide masters
Impress comes with a collection of slide masters. These slide masters are shown in the Master
Pages section of the Tasks pane (Figure 158). This section has three subsections: Used in This
Presentation, Recently Used, and Available for Use. Click the + sign next to the name of a
subsection to expand it to show thumbnails of the slides, or click the – sign to collapse the
subsection to hide the thumbnails.
Each of the slide masters shown in the Available for Use list is from a template of the same name.
If you have created your own templates, or added templates from other sources, slide masters
from those templates will also appear in this list.

Figure 158: Available master pages (slides masters)

Creating a slide master
You can create a new slide master is similar to modifying the default slide master.
To start, enable editing of slide masters by selecting View > Master > Slide Master and the
Master View toolbar opens. You can also right-click on the slide master in the Master Pages
section of the tasks pane and select Edit Master to open the Master View toolbar. On the Master
View toolbar, click the New Master icon (highlighted in Figure 159).

Figure 159: Master View toolbar
A second slide master appears in the Slides pane. Modify this slide master to suit your
requirements. It is also recommended that you rename this new slide master: right-click on the
slide in the Slides pane and select Rename master from the pop-up menu. When you are done,
close the Master View toolbar to return to normal slide editing mode.
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Applying a slide master
In the Tasks Pane, make sure the Master Pages section is showing (Figure 158).
To apply one of the slide masters to all slides in your presentation, click on it in the list.
To apply a different slide master to one or more selected slides:
1) In the Slide Pane, select the slides you want to change.
2) In the Tasks Pane, right-click on the slide master you want to apply to the selected slides,
and click Apply to Selected Slides on the pop-up menu.

Loading additional slide masters
Sometimes, in the same set of slides, you may need to mix multiple slide masters that may belong
to different templates. For example, you may need a completely different layout for the first slide of
the presentation, or you may want to add to your presentation a slide from a different presentation
(based on a template available on the hard disk).
The Slide Design dialog (Figure 160) makes this possible. Access this dialog either from the menu
bar (Format > Slide design) or from the pop-up menu that appears when right-clicking on a slide
in the Slides pane.

Figure 160: Slide Design
The main window in the dialog shows the slide masters already available for use. To add more:
1) Click the Load button.
2) Select in the Load Slide Design dialog (Figure 161) the template from which to load the
slide master and click OK.
3) Click OK again to close the slide design dialog.
The slide masters in the template you selected are now shown also in the Master Pages section of
the Tasks pane in the Available for use subsection.
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Note

Tip

The slide masters you have loaded will also be available the next time you load the
presentation. If you want to delete the unused slide masters, click the corresponding
checkbox in the Slide Design dialog. If the slide master was not used in the
presentation, it is removed from the list of available slide masters anyway.
To limit the size of the presentation file, you may want to minimize the number of
slide masters used.

Figure 161: Load Slide Design dialog for selecting templates

Modifying a slide master
The following items can be changed on a slide master:

•
•
•
•

Background (color, gradient, hatching, or bitmap)
Background objects (for example, add a logo or decorative graphics)
Size, placement, and contents of header and footer elements to appear on every slide
Size and placement of default frames for slide titles and content

Before working on the slide master, make sure that the Styles and Formatting dialog is open.
To select the slide master for modification:
1) Select View > Master > Slide Master from the menu bar. This unlocks the properties of the
slide master so you can edit it.
2) Click Master Pages in the Tasks pane. This gives you access to the slide masters.
3) Click on the slide master you want to modify among the ones available.
4) Make changes as required, then click the Close Master View icon on the Master View
toolbar. For details, see Chapter 2 Using Slide Masters, Styles, and Templates of the
Impress Guide.
5) Save the file before continuing.

Caution

Any changes made to one slide when in Master View mode will appear on all slides
using this slide master. Always make sure you close Master View and return to
Normal view before working on any of the presentation slides. Select View > Normal
from the menu bar, or clicking Close Master View in the Master View toolbar to
return to the normal slide view.

The changes made to one of the slides in Normal view (for example, changes to the bullet point
style, the color of the title area, and so on) will not be overridden by subsequent changes to the
slide master. There are cases, however, where it is desirable to revert a manually modified element
of the slide to the style defined in the slide master: to do that, select that element and choose
Format > Default Formatting from the menu bar.
Chapter 6 Getting Started with Impress

175

Using a slide master to add text to all slides
Some of the supplied slide masters have text objects in the footer. You can add other text objects
to the master page for your slides to act as a header or a footer.
1) Choose View > Master > Slide Master from the menu bar.
2) On the Drawing toolbar, select the Text icon or press F2.
3) Click once and drag in the master page to draw a text object, and then type or paste your
text into the object or add fields as described below.
4) Choose View > Normal when you are finished.
To add page (slide) numbers or date and time to the slide footers in your presentation, select
Insert > Page Number or Insert > Date and Time to open the Header and Footer dialog (Figure
162) where you can select and configure these areas on the slide.

Figure 162: Configuring the slide footer areas
To add a field, such as the date or page number (slide number), into an object or as a separate
object, select Insert > Fields. and select the required field from the submenu. If you want to edit
this field in your slide, see Chapter 3, Adding and Formatting Text in the Impress Guide for more
information.
The fields you can use in Impress are:

•
•
•
•
•
•
•

Date (fixed)
Date (variable): updates automatically when you reload the file
Time (fixed)
Time (variable): updates automatically when you reload the file
Author: first and last names listed in the LibreOffice user data
Page number (slide number)
File name

Tip
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To change the author information, go to Tools > Options > LibreOffice >
User Data.
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Tip

To change the number format (1,2,3 or a,b,c or i,ii,iii, etc.) for the page number field,
choose Format > Page and then select a format from the list in the Layout Settings
area.
To change the paragraph style, modify the Background Objects Presentation style.

Adding comments to a presentation
Impress supports comments similar to those in Writer and Calc.
In Normal View, choose Insert > Comment from the menu bar. A small box containing your initials
appears in the upper left-hand corner of the slide, with a larger text box beside it. Impress
automatically adds your name and the current date at the bottom of the text box.

Figure 163: A comment
Type or paste your comment into the text box. You can optionally apply some basic formatting to
the comment by selecting it, right-clicking, and choosing from the pop-up menu. From this menu,
you can apply formatting to selected text, delete the current comment, delete all comments from
the same author, or delete all comments in the presentation.
You can move the small comment markers to anywhere you wish on the slide. Typically you might
place it on or near an object you refer to in the comment.
To show or hide the comment markers, choose View > Comments.
Select Tools > Options > User Data to configure the name you want to appear in the Author field
of the comment, or to change it.
If more than one person edits the document, each author is automatically allocated a different
background color for their comments.
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Setting up the slide show
As mentioned in “Modifying the slide show” on page 165, Impress allocates reasonable default
settings for slide shows, while at the same time allowing for customizing many aspects of the slide
show experience. This section covers only some aspects; advanced techniques are explained in
Chapter 9 Slide Shows in the Impress Guide.
Most of the tasks are best done in Slide Sorter view where you can see most of the slides
simultaneously. Choose View > Slide Sorter from the menu bar or click the Slide Sorter tab at the
top of the workspace.

One slide set – multiple presentations
In many situations, you may find that you have more slides than the time available to present them
or you may want to provide a rapid overview without dwelling on the details. Rather than having to
create a new presentation, you can use two tools that Impress offers: hiding slides and custom
slide shows.
To hide a slide, right-click on the slide thumbnail either in the Slide pane or in the Workspace area.
If you are using the Slide Sorter view and choose Hide Slide from the pop-up menu. Hidden slides
are marked by a slashed slide number.
If you want to reorder the presentation, choose Slide Show > Custom Slide Show. Click on the
New button to create a new sequence of slides and save it.
You can have as many slide shows as you want from a single slide set.

Slide transitions
Slide transition is the animation that is played when a slide is changed for the next slide in the
presentation. You can configure the slide transition from the Slide Transition drawer in the Tasks
pane. Select the desired transition, the speed of the animation, and whether the transition should
happen when you click the mouse (preferred) or automatically after a certain number of seconds.
Click Apply to all slides unless you prefer to have different transitions in the presentation.

Tip

The Slide transition section has a very useful choice: Automatic preview. Select its
checkbox and when you make any changes in a slide transition, the new slide is
previewed in the Slide Design area, including its transition effect.

Automatic slides advance
You can set the presentation to automatically advance to the next slide after a set amount of time
from the Slide Transition section in the Task pane. Go to Advance slide and select Automatically
after, then choose the required amount of time in seconds that each slide will be displayed. Click
on the Apply to All Slides button to apply the same display time to all slides.
To apply a different display time to each slide in your presentation, choose Slide Show >
Rehearse Timings. Start the slide show and a small timer is displayed in the bottom left corner.
When you are ready to advance to the next slide, mouse click on the display background or press
the right arrow on your keyboard. Impress will memorize the timings for each slide and advance to
the slide automatically after each timing ends when you run the slide show.
To automatically restart a slide show after the last slide has been displayed, go to Slide Show >
Slide Show Settings on the menu bar. Select Auto and the timing of the pause between slide
shows. Click OK when you have finished.
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Running a slide show
To run a slide show, do one of the following:

• Click Slide Show > Slide Show on the menu bar.
• Click the Slide Show icon
• Press F5 on the keyboard.

on the Presentation toolbar.

If the slide transition is Automatic after x seconds, let the slide show run by itself.
If the slide transition is On mouse click, do one of the following to move from one slide to the next:

• Use the arrow keys on the keyboard to go to the next slide or to go back to the previous
one.

• Click the mouse to move to the next slide.
• Press the spacebar on the keyboard to advance to the next slide.
Right-click anywhere on the screen to open a menu from which you can navigate the slides and set
other options.
To exit the slide show at any time including at the end, press the Esc key.

Controlling a slide show using the Presenter Console
LibreOffice Impress come with the Presenter Console extension built in.
The Presenter Console provides extra control over slide shows through different views on the
presenter’s computer screen and on the projection that the audience sees. The view the presenter
sees includes the current slide, the upcoming slide, the slide notes, and a presentation timer.
For details about using the Presenter Console, see Chapter 9 Slide Shows in the Impress Guide.

Note

The Presenter Console works only on operating systems that support two displays,
and only when two displays are connected (one may be the laptop display).
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Chapter 7
Getting Started with Draw
Vector Drawing in LibreOffice

What is Draw?
Draw is a vector graphics drawing program, although it can also perform some operations on raster
graphics (pixels). Using Draw, you can quickly create a wide variety of graphical images.
Vector graphics store and display an image as simple geometric elements such as lines, circles,
and polygons rather than a collections of pixels (points on the screen). Vector graphics allow for
easier storage and scaling of the image.
Draw is fully integrated into the LibreOffice suite, and this simplifies exchanging graphics with all
components of the suite. For example, if you create an image in Draw, reusing it in a Writer
document is as simple as copying and pasting the image. You can also work with drawings directly
from within Writer or Impress, using a subset of the functions and tools from Draw.
The functionality of LibreOffice Draw is extensive and, even though it was not designed to rival
high-end graphics applications, it possesses more functionality than the drawing tools that are
generally integrated with most office productivity suites.
A few examples of the drawing functions are: layer management, magnetic grid-point system,
dimensions and measurement display, connectors for making organization charts, 3D functions
that enable small three-dimensional drawings to be created (with texture and lighting effects),
drawing and page-style integration, and Bézier curves.
This chapter introduces some features of Draw and does not attempt to cover all of the Draw
features. See the Draw Guide and the application help for more information.

Figure 164: LibreOffice Draw workspace
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Draw workspace
The main components of the Draw workspace are shown in Figure 164.
The large area in the center of the window is where you make the drawings. You can surround the
drawing area with toolbars and information areas. The number and position of the visible tools vary
with the task in hand and user preferences. Therefore your setup may look different. For example,
many users put the main Drawing toolbar on the left-hand side of the workspace and not at the
bottom, as shown in Figure 164.
You can split drawings in Draw over several pages. Multi-page drawings are used mainly for
presentations. The Pages pane, on the left side of the Draw window in Figure 164 gives an
overview of the pages that you create. If the Pages pane is not visible on your setup, you can
enable it from the View menu (View > Page Pane). To make changes to the page order, just drag
and drop one or more pages.
In LibreOffice Draw, the maximum size of a drawing page is 300 cm by 300 cm.

Rulers
You should see rulers (bars with numbers) on the upper and left-hand sides of the workspace. If
they are not visible, you can enable them by selecting View > Ruler in the main menu bar. The
rulers show the size of a selected object on the page using double lines (highlighted in Figure 165).
When no object is selected, they show the location of the mouse pointer, which helps to position
drawing objects more accurately.
You can also use the rulers to manage object handles and guide lines, making it easier to position
objects.

Figure 165: Rulers showing size of a selected object

Figure 166: Ruler units
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The page margins in the drawing area are also represented on the rulers. You can change the
margins directly on the rulers by dragging them with the mouse. The margin area is indicated by
the grayed out area on the rulers as shown in Figure 165.
To modify the measurement units of the rulers, which can be defined independently, right-click on
the desired ruler, as illustrated for the horizontal ruler in Figure 166.

Status bar
The Status bar is located at the bottom of the screen in all LibreOffice components; it includes
several Draw-specific fields. For details on the contents and use of these fields, see Chapter 1
Introducing LibreOffice in this guide and Chapter 1 Introducing Draw in the Draw Guide.

Figure 167: Draw status bar

Note

The sizes are given in the current measurement unit and are not to be confused with
the ruler units. This current measurement unit is defined in Tools > Options >
LibreOffice Draw > General, where you can also change the scale of the page.
Another way to change the scale is to double-click on the number shown in the
status bar.

Toolbars
To display or hide the various Draw toolbars. choose View > Toolbars. On the menu that appears,
select which toolbars you want to display. For more about working with toolbars, see Chapter 1
Introducing LibreOffice in this guide.
The tools available in the Draw toolbars are explained in the following sections. The appearance of
the toolbar icons may vary depending on your operating system and the selection of icon size and
style in Tools > Options > LibreOffice > View.

Standard toolbar
The Standard toolbar is the same for all LibreOffice components and is not described in detail in
this chapter.

Figure 168: Standard toolbar

Drawing toolbar
The Drawing toolbar is the most important toolbar in Draw. It contains all the necessary functions
for drawing various geometric and freehand shapes and for organizing them on the page.
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Figure 169: Drawing toolbar

Line and Filling toolbar
The Line and Filling toolbar lets you modify the main properties of a drawing object. The icons and
pull-down lists vary, according to the type of object selected. For example, to change the style of a
line, click on the up and down arrows for Line Style and select the required style. See “Editing
objects” on page 199 for details.

Figure 170: Line and Filling toolbar

Text Formatting toolbar
If the selected object is text, the toolbar changes to the Text Formatting toolbar, which is similar to
the Formatting toolbar in Writer. For more information, see Chapter 4 Getting Started with Writer in
this guide.

Figure 171: Text Formatting toolbar

Options toolbar
Use the Options toolbar to activate or deactivate various drawing aids. The Options toolbar is not
one of the toolbars displayed by default. To display the Options toolbar, select View > Toolbars >
Options.

Figure 172: Options toolbar

Choosing and defining colors
To display the Color bar, use View > Toolbars > Color Bar. The toolbar appears at the bottom of
the workspace and displays the current color palette. This toolbar lets you rapidly choose the color
of the various objects (lines, areas, and 3D effects). The first box in the panel corresponds to
invisible (no color).

Figure 173: Color bar
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Figure 174. Changing the color palette
You can access several specialized color palettes in Draw, as well as change individual colors to
your own taste. This is done using the Area dialog by selecting Format > Area on the main menu
bar or the Area icon
(Figure 174).

on the Line and Filling toolbar (Figure 170), then selecting the Colors tab

To load another palette, click on the Load Color List icon
. The file selector dialog asks you to
choose one of the standard LibreOffice palettes (files with the file extension *.soc). For example,
web.soc is a color palette that is adapted to creating drawings for placing in web pages. These
colors will display correctly on workstations with screens capable of at least 256 colors.
The color selection box also lets you individually change any color by modifying the numerical
values in the fields provided to the right of the color palette. You can use the color schemes known
as CMYK (Cyan, Magenta, Yellow, Black) or RGB (Red, Green, Blue).
Click on the Edit button to open the Color dialog, where you can set individual colors. See “Color
options” in Chapter 2 Setting Up LibreOffice in this guide.
For a more detailed description of color palettes and their options, see Chapter 8 Tips and Tricks in
the Draw Guide.

Drawing basic shapes
Draw provides a wide range of shapes, located in palettes accessed from the Drawing toolbar
(Figure 169). These tools are described, from left to right on the Drawing toolbar, in Table 3.This
section describes only a few of the basic shapes, which are treated as objects in Draw, including
text. See the Draw Guide for a complete description of the shapes available.
Please note that some of the icons on the Drawing toolbar will change according to the shape that
has been selected from the choice available. Available tools are indicated by a small triangle or
arrow to the right of the icon.
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Table 3: Basic drawing tools
Icon

Tool name

Icon

Tool name

Icon

Tool name

Icon

Tool name

Select

Line

Line ends
with arrow

Rectangle

Ellipse

Text

Vertical text

Curve

Connector

Lines and
arrows

Basic
shapes

Symbol
shapes

Block arrows

Flowcharts

Callouts

Stars

Note

When you draw a basic shape or select one for editing, the Info field at the left side
in the status bar changes to reflect the present action: for example Line created,
Text frame xxyy selected, and so on.

Drawing a straight line
Click on the Line icon
and place the mouse pointer at the point where you want to start the line
(Figure 175). Drag the mouse while keeping the mouse button pressed. Release the mouse button
at the point where you want to end the line. A selection handle appears at each end of the line,
showing that this object is the currently selected object. The selection handle at the starting point of
the line is slightly larger than the other selection handle.

Figure 175: Drawing a straight line
Keeping the Shift key pressed while you draw a line restricts the drawing angle of the line to a
multiple of 45 degrees (0, 45, 90, 135, and so on).

Caution

This is the default behavior of the Shift key. However, if the option When creating
or moving objects in the Snap position section of Tools > Options > LibreOffice
Draw > Grid has been selected, the action of the Shift key is the opposite. Lines
will automatically be drawn at a multiple of 45 degrees unless the Shift key is
pressed.

Keeping the Ctrl key pressed while drawing a line enables the end of the line to snap to the nearest
grid point.

Chapter 7 Getting Started with Draw

187

Caution

This is the default behavior of the Ctrl key. However, if the Snap to Grid option on
the View > Grid menu has been selected, the Ctrl key deactivates the snap to grid
activity.

Holding down the Alt key while drawing a line results in the line extending outwards symmetrically
in both directions from the start point. This lets you draw lines by starting from the middle of the
line.
When a line is drawn, it uses default attributes. To change any of these attributes, select the line by
clicking on it, then right-click and select Line to open the Line dialog (Figure 176). Line style, line
width and line color can also be changed using the controls in the Line and Filling toolbar at the top
of the workspace.

Figure 176: Line dialog

Drawing an arrow
Arrows are drawn like lines. In fact Draw classifies arrows as a subgroup of lines: lines with
arrowheads. The information field on the status bar shows them only as lines. Click on the Line
Ends with Arrow icon
to draw an arrow. The arrow head is drawn at the end point of the arrow
when you release the mouse button.

Choosing line endings
Several types of line endings (arrows, circles, squares, and others) are available in Draw. Click on
the small triangle or arrow to the right of the Lines and Arrows
icon on the Drawing toolbar to
open a pop-up toolbar with ten tools for drawing lines and arrows. Alternatively, go to View >
Toolbars > Arrows to open the Arrows toolbar as a floating toolbar (Figure 177 and Table 4). The
icon for the tool used most recently will be shown on the Drawing toolbar to make it easier to use
the same tool again.
After drawing the line, you can change the arrow style by clicking on the Arrowheads icon
the Line and Filling toolbar and select the arrow start and end options.
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Figure 177: Arrows toolbar
Table 4: Tools on the Arrows toolbar
Icon

Tool name

Icon

Tool name

Icon

Tool name

Icon

Tool name

Line

Line ends
with arrow

Line with
arrow/circle

Line with
arrow/square

Line (45°)

Line starts
with arrow

Line with
circle/arrow

Line with
square/arrow

Dimension
line

Line with
arrows

Drawing rectangles or squares
Drawing a rectangle is similar to drawing a straight line. Click on the Rectangle icon
in the
Drawing toolbar. As you draw the rectangle with the mouse cursor, the rectangle appears with the
bottom right corner of the rectangle attached to the cursor.
Squares are rectangles with all sides of equal length. To draw a square, click on the Rectangle
icon
and hold down the Shift key whilst you draw a square.

Note

If the option When creating or moving objects has been selected in Tools >
Options > LibreOffice Draw > General, the action of the Shift key is reversed.
When the Rectangle tool is selected, a square is drawn. To draw a rectangle, you
have to press the Shift key when drawing. This Shift key reversal also applies when
drawing ellipses and circles.

To draw a rectangle or square from its center rather than the bottom right corner, position your
cursor on the drawing, press the mouse button and then hold down the Alt key while dragging with
the cursor. The rectangle or square uses the start point (where you first clicked the mouse button)
as the center.

Drawing circles or ellipses
To draw an ellipse (also called an oval), click on the Ellipse icon
on the Drawing toolbar. A
circle is an ellipse with both axes the same length. To draw a circle, click on the Ellipse icon and
hold down the Shift key whilst you draw a circle.
To draw an ellipse or circle from its center, position your cursor on the drawing, press the mouse
button and then hold down the Alt key while dragging with the cursor. The ellipse or circle uses the
start point (where you first clicked the mouse button) as the center.

Note

If you first press and hold down the Ctrl key and then click on one of the icons for
Line, Rectangle, Ellipse, or Text, a standard sized object is drawn automatically in
the work area; the size, shape, and color are all standard values. These attributes
can be changed later, if desired. See the Draw Guide for more information.
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Drawing curves or polygons
To draw a curve or polygon click the Curve icon
on the Drawing toolbar. Click on the triangle or
arrow to the right of the icon to open the tools that are available (Figure 178 and Table 5).
Hovering the mouse pointer over this icon gives a tooltip of Curve. If you open the
floating toolbar, the title is Lines, as shown in Figure 178.

Note

Holding down the Shift key when drawing lines with the Curve or Polygon tools will
restrict the angles between the lines to 45 or 90 degrees.

Figure 178: Curves (Lines) toolbar
Table 5: Curve and polygon tools
Icon

Tool name

Icon

Tool name

Icon

Tool name

Icon

Tool name

Curve filled

Polygon
filled

Polygon 45°
filled

Freeform line
filled

Curve

Polygon

Polygon 45°

Freeform line

If you move the mouse cursor over one of the icons, a tooltip pops up with a description of the
function.

Curves
Click and hold the left mouse button to create the starting point of your curve, then, while holding
down the left mouse button, drag from the starting point to draw a line. Release the left mouse
button and continue to drag the cursor to bend the line into a curve. Click to set the end point of the
curve and fix the line on the page. To continue with your line, drag the mouse cursor to draw a
straight line. Each mouse click sets a corner point and allows you to continue drawing another
straight line from the corner point. A double click ends the drawing of your line.
A filled curve automatically joins the last point to the first point to close off the figure and fills it with
the current standard fill color. A curve without filling will not be closed at the end of the drawing.

Polygons
Click and draw the first line from the start point with the left mouse button held down. As soon as
you release the mouse button, a line between the first and second points is drawn. Move the
cursor to draw the next line. Each mouse click sets a corner point and allows you to draw another
line. A double-click ends the drawing.
A filled polygon automatically joins the last point to the first point to close off the figure and fills it
with the current standard fill color. A polygon without filling will not be closed at the end of the
drawing.

Polygons 45°
Like ordinary polygons, these are formed from lines, but the angles between lines are restricted to
45 or 90 degrees.
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Freeform lines
Using the Freeform Line tools is similar to drawing with a pencil on paper. Press and hold the left
mouse button and drag the cursor to the line shape you require. It is not necessary to end the
drawing with a double-click, just release the mouse button and the drawing is completed.
If Freeform Line Filled is selected, the end point is joined automatically to the start point and the
object is filled with the appropriate color.

Adding text
To activate the text tool, click on the Text icon
for horizontal text or the Vertical Text icon
for
vertical script. If the Vertical Text icon is not visible, check that the option Enabled for Asian
languages has been selected in Tools > Options > Language Settings > Languages. The Text
Formatting toolbar appears (Figure 171 on page 185) when the Text icon is selected; from this
toolbar you can select font type, font size, and other text properties before you start typing your
text.
After activating the Text command, click at the location where you want to position the text. A small
text frame appears, containing only the cursor. This frame can be moved like any other object. A
text frame is also dynamic and grows as you enter text.
Observe the information field in the status bar: it shows that you are editing text and also provides
details about the current cursor location using paragraph, row, and column numbers.

Figure 179: Text information on the Status Bar
You can insert a line break with the Shift+Enter key combination or start a new paragraph with the
Enter key. The insertion of line breaks or new paragraphs does not terminate text editing or
deselect the text frame. When you have finished typing text, click outside the text frame to cancel
adding text.
If you want to edit text, double-click on the text to open the Text Formatting toolbar and highlight
the text to start editing.
Text properties can also be changed during text input, with any changes taking effect from the
cursor position onwards. To change the properties for all of the text in the text frame, you have to
highlight all text in the text frame.
You can create Graphics styles that you can reuse for other text frames. Select Format > Styles
and Formatting or press F11 to open the Styles and Formatting dialog. Graphics styles affect all
of the text within a text frame. To only format parts of the text, use direct formatting with the toolbar.
Text frames can also have fill colors, shadows, and other attributes, just like any other Draw object.
You can rotate the frame and write the text at any angle. These options are available by rightclicking on the text frame itself.
If you double-click on a graphic object, or press F2 or click on the Text icon when an object is
selected, you can add text to the graphic object. This text then becomes part of the graphic object.
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A graphic object is not dynamic and does not behave like a text frame. To keep text within the
borders of the object, you have to use paragraphs, line breaks, or smaller text size, increase the
object size, or combine all four methods.
For more information about text, see Chapter 2 Drawing Basic Shapes and Chapter 10 Advanced
Draw Techniques in the Draw Guide.

Gluepoints and connectors
Gluepoints
All Draw objects have gluepoints, which normally are not displayed. Gluepoints become visible
when the Connectors icon

on the Drawing toolbar is selected.

Most objects have four gluepoints (Figure 180). You can add more gluepoints and customize
gluepoints, using the Gluepoints toolbar (Figure 181). Go to View > Toolbars > Gluepoints to
open the toolbar.

Figure 180: Gluepoints

Figure 181: Gluepoints toolbar
Gluepoints are not the same as the selection handles of an object. The handles are for moving or
changing the shape of an object. Gluepoints are used to fix or glue a connector to an object so that
when the object moves, the connector stays fixed to the object. For a more detailed description on
the use of gluepoints, see Chapter 3 Working with Objects and Object Points and Chapter 9
Organization Charts, Flow Diagrams, and More in the Draw Guide.

Connectors
Connectors are lines or arrows whose ends automatically snap to a gluepoint of an object.
Connectors are especially useful in drawing organization charts, flow diagrams, and mind-maps.
When objects are moved or reordered, the connectors remain attached to a gluepoint. Figure 182
shows an example of two objects and a connector.
Draw offers a range of different connectors and connector functions. Click on the arrow next to the
Connector icon
to open the Connectors toolbar (Figure 183 and Table 6). For a more
detailed description of the use of connectors, see Chapter 9 Organization Charts, Flow Diagrams,
and More in the Draw Guide.
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Figure 182: A connector between two objects

Figure 183: Connectors toolbar
Table 6: Connector tools
Icon

Tool name

Icon

Connector

Tool name
Connector
ends with
arrow

Icon

Tool name

Icon

Tool name

Connector
with arrows

Line connector

Line connector
ends with
arrow

Line
connector
with arrows

Straight
connector

Straight
connector ends
with arrow

Straight
connector with
arrows

Curved
connector

Curved
connector
ends with
arrow

Curved
connector with
arrows

Drawing geometric shapes
The icons for drawing geometric shapes are located on the Drawing toolbar and each geometric
shape is explained in the following sections. Clicking on the triangle or arrow to the right of the icon
opens a floating toolbar giving access to the tools for that geometric shape.

Tip

The use of these tools for geometric shapes is similar to the tool used for drawing
rectangles and squares. For more information, see “Drawing rectangles or squares”
on page 189 and Chapter 2 Drawing Basic Shapes in the Draw Guide.

Note

The icons for geometric shapes displayed on the Drawing toolbar will change shape
according to the last tool selected and used to draw an object.
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Basic shapes
Click on the triangle or arrow to the right of the Basic Shapes icon
to open the Basic Shapes
toolbar for drawing basic shapes. This toolbar also includes a rectangle tool identical to the one
already displayed on the Drawing toolbar.

Figure 184: Basic Shapes toolbar

Symbol shapes
Click on the triangle or arrow to the right of the Symbol Shapes icon
Shapes toolbar for drawing symbols.

to open the Symbol

Figure 185: Symbol Shapes toolbar

Block arrows
Click on the triangle or arrow to the right of the Block Arrows icon
toolbar for drawing block arrows.

to open the Block Arrows

Figure 186: Block Arrows toolbar

Flowcharts
Click on the triangle or arrow to the right of the Flowcharts icon
to open the Flowchart toolbar
for symbols used in drawing flowcharts. The creation of flowcharts, organization charts, and similar
planning tools are further described in Chapter 9 Organization Charts, Flow Diagrams, and More in
the Draw Guide.

Figure 187: Flowcharts toolbar
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Callouts
Click on the triangle or arrow to the right of the Callouts icon
drawing callouts.

to open the Callouts toolbar for

Figure 188: Callouts toolbar

Stars and banners
Click on the triangle or arrow to the right of the Stars icon
toolbar for drawing stars and banners.

to open the Stars and Banners

Figure 189: Stars and Banners toolbar

Note

You can add text to all these geometric shapes. See Chapter 2 Drawing Basic
Shapes and Chapter 10 Advanced Draw Techniques in the Draw Guide for details.

Selecting objects
Direct selection
The easiest way to select an object is to click directly on it. For objects that are not filled, click on
the object outline to select it. One click selects; a second click deselects. To select or deselect
more than one object, hold the shift button down while clicking.

Selection by framing
You can also select several objects at once by dragging the mouse cursor around the objects. This
cursor dragging draws a rectangle around the objects and only objects that lie entirely within the
rectangle will be selected.
To select multiple objects by framing, the Select icon

Note

on the Drawing toolbar must be active.

When dragging the mouse cursor to select multiple objects, the selection rectangle
being drawn is also known as a marquee.

Selecting hidden objects
Even if objects are located behind others and not visible, they can still be selected. Hold down the
Alt key and click on the object at the front of where the hidden object is located, then click again to
select the hidden object. If there are several hidden objects, keep holding down the Alt key and
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clicking until you reach the object you want. To cycle through the objects in reverse order, hold
down the Alt+Shift keys and click.
When you click on the selected object, its outline will appear briefly through the objects covering it.

Note

Using the Alt key method works on computers using a Windows or Mac operating
systems. On a computer using a Linux operating system the Tab key method,
described below, has to be used.

To select an object that is covered by another object using the keyboard, use the Tab key to cycle
through the objects, stopping at the object you want to select. To cycle through the objects in
reverse order, press Shift+Tab. This is a very quick way to reach an object, but it may not be
practical if there a large number of objects in a drawing.

Arranging objects
In a complex drawing, several objects may be stacked on top of one another. To rearrange the
stacking order by moving an object forward or backward, select an object, click Modify > Arrange
on the main menu bar and select Bring Forward or Send Backward. Alternatively, right-click the
object, select Arrange from the context menu, then Bring Forward or Send Backward.
The Arrange options are also available by clicking on the small triangle or arrow to the right of the
Arrange icon
on the Drawing toolbar. This opens the Position toolbar giving access to the
various arrangement options.

Moving and adjusting object size
When moving an object or changing its size, check the left-hand area of the status bar at the
bottom of the Draw window (Figure 190). The area on the left of the Drawing toolbar, from left to
right, shows what object is selected, its position on the drawing in X/Y coordinates and dimensions
of the object. The units of measurement are those selected in Tools > Options > LibreOffice
Draw > General.
For more information on moving and adjusting object size, see Chapter 3 Working with Objects
and Object Points in the Draw Guide.

Figure 190: Left end of status bar when moving or adjusting an object

Moving objects
To move an object (or a group of objects), select it and then click within the object borders and hold
down the left mouse button while dragging the mouse. During movement, the shape of the object
appears as dotted lines to help with repositioning (Figure 191). To locate the object at its new
location, release the mouse button.
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Figure 191: Moving an object

Adjusting object size
To change the size of a selected object (or a group of selected objects), move the mouse cursor to
one of the selection handles. The mouse cursor will change shape to indicate the direction of
movement for that selection handle. As you change the size of the object, a ghosted outline of the
object appears (Figure 192). When you have reached the desired size of the object, release the
mouse button.
The results depend on which selection handle you use. To resize an object along one axis, use a
side handle. To resize along both axes, use a corner handle.

Figure 192: Adjusting object size
If you press the Shift key while resizing an object, the change in size will be carried
out symmetrically with respect to the two axes so that the aspect ratio of the object
remains the same. This Shift key behavior works on all selection handles.

Note

This is the default behavior of the Shift key. However, if When creating or moving
objects has been selected in Tools > Options > LibreOffice Draw > Grid, the
action of the Shift key is reversed: that is the aspect ratio will be preserved unless
the Shift key is pressed.

Rotating and slanting an object
For more information on rotating and slanting an object, see Chapter 3 Working with Objects and
Object Points in the Draw Guide.

Rotating an object
To rotate an object (or a group of objects), select the object, then go to rotation mode using one of
the following methods:

• Click on the object again. Do not double click as this will cancel object selection.
• Click on the Rotate icon

on the Drawing toolbar.

• Go to View > Toolbars > Mode and select the Rotate icon

.

The selection handles will change shape and color (Figure 193). Also a center of rotation point will
appear in the center of the object. As you move the mouse cursor over the handles the cursor
changes shape. The corner handles are for rotating an object and the top, bottom and side handles
are to shear or slant an object.
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Figure 193: Rotating an object
Move the mouse cursor to one of the corner handles and it normally changes to an arc with an
arrow at each end. Click and hold the mouse button, then start to move the cursor to rotate the
object. A dotted outline of the object being rotated appears and the current angle of rotation is
shown in the status bar.

Note

Rotation works differently for 3D objects because rotation occurs in global axes and
not in a single axis. See Chapter 7 Working with 3D Objects for more information.

The rotation point is normally located at the center of an object. To change the position of the
rotation point, click on the object with the mouse cursor and drag the object until the rotation point
is at the desired position. This rotation point can even be outside of the object.
If you press the Shift key while rotating an object, rotation will be restricted to 15° of
movement.

Note

This is the default behavior of the Shift key. However, if When creating or moving
objects has been selected in Tools > Options > LibreOffice Draw > Grid, the
action of the Shift key is reversed: that is rotation will be restricted to 15° of
movement unless the Shift key is pressed.

Slanting an object
To slant an object, use the handles located at the midpoints on the top, bottom and sides of a
selected object. The mouse cursor changes when it hovers over one of these midpoint handles.
The axis used for slanting an object is the object edge directly opposite the midpoint handle being
used to slant the object. This axis stays fixed in location while the other sides of the object move in
relation to it as you drag the mouse cursor.
Click and hold the mouse button, then start to move the cursor to shear the object. A dotted outline
of the object being slanted appears (Figure 194) and the current angle of slanting is shown in the
status bar.
If you press the Shift key while slanting an object, slanting will be restricted to 15° of
movement.

Note

198
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objects has been selected in Tools > Options > LibreOffice Draw > Grid, the
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movement unless the Shift key is pressed.

Getting Started with LibreOffice 3.5

Figure 194: Shearing an object

Editing objects
To edit an object or change its attributes, such as color or border width, and so on, the Line and
Filling toolbar, the Text Formatting toolbar, or the context menu can be used. More information on
editing objects and changing attributes can be found in Chapter 4 Changing Object Attributes in the
Draw Guide.

Line and Filling toolbar
If the Line and Filling toolbar is not displayed, go to View > Toolbars > Line and Filling to open
the toolbar (Figure 195). The most common object attributes can be edited using this toolbar. You
can also open the Line dialog by clicking on the Line icon

and the Area dialog by clicking on the

Area icon
for access to more formatting options. Available tools on the Line and Filling toolbar
are shown from left to right in Figure 196.

Figure 195: Line and Filling toolbar

Figure 196: Available tools
on Line and Filling toolbar
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Text Formatting toolbar
When you select text, the Line and Filling toolbar automatically changes to show the Text
Formatting toolbar (Figure 197). You can also open the Text Formatting toolbar by selecting View >
Toolbars > Text Formatting. The tools on this toolbar will not become active until text has been
selected. Available tools on the Text Formatting toolbar are shown from left to right in Figure 198.

Figure 197: Text Formatting toolbar

Figure 198: Available tools on Text Formatting toolbar

Figure 199: Context menu
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Context menu
When an object is selected and you right-click on the object, a context menu (Figure 199) opens
that applies to the selected object. This context menu provides access to the options available and
allows you to change object attributes without having to open a dialog. Menu entries with a small
arrow on the right-hand side contain a submenu.

Formatting lines and borders
In LibreOffice the term line indicates both a freestanding segment (line), outer edge of a shape
(border), or an arrow. In most cases the properties of the line you can modify are its style (solid,
dashed, invisible, and so on), its width and its color.
Select the line you need to format and then use the controls on the Line and Filling toolbar to
change the most common options highlighted in Figure 200.

Figure 200: Common line properties (style, color, width)
If you need to fine tune the appearance of a line, choose Format > Line from the menu bar, or
right-click on the line and select Line from the context menu, or select the Line icon
from the
Line and Filling toolbar. All of these methods open the Line dialog (Figure 201), where you can set
line properties. This dialog consists of four pages: Line, Shadow, Line Styles, and Arrow Styles.

Figure 201: Line properties dialog
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Arrows, arrowheads and line endings
Arrows, arrowheads and other line endings are usually referred to as arrows and can be treated
the same as lines when editing and changing attributes. Select a line and click on the Arrow Style
icon

from the Line and Filling toolbar to open the Arrowheads menu (Figure 202).

Several types of arrowheads are available. Each end of a line can have a different arrowhead or no
arrowhead). Arrowheads are only applicable to lines and they have no effect on the border of an
object.

Figure 202: Arrowheads menu

Formatting area fill
The term area fill refers to the inside of an object, which can be a uniform color, gradient, hatching
pattern, or bitmap (Figure 203). An area fill can be made partly or wholly transparent. In most
cases, you will choose one of the standard fill options, which are all available from the Line and
Filling toolbar. You can also define your own area fills. For more information on formatting area fill,
see Chapter 4 Changing Object Attributes in the Draw Guide.

Figure 203: Different types of area fill
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Using styles
Suppose that you want to apply the same area fill, line thickness, and border to a set of objects.
This repetitive process can be greatly simplified by the use of styles. Styles allow you to define a
formatting template (a style) and then to apply that style to multiple objects. For more information
on styles, see Chapter 3 Using Styles and Templates in this guide, Chapter 6 Introduction to Styles
in the Writer Guide and Chapter 4 Changing Object Attributes in the Draw Guide.

Positioning objects
Snap function
In Draw, objects can be accurately and consistently positioned using the snap function. Grid points,
snap points and lines, object frames, individual points on objects, or page edges can all be used
with the snap function.
Snap function is easier to work with at the high zoom values that are practical for your display. Two
different snap functions can be used at the same time; for example snapping to a guide line and to
the page edge. It is recommended, however, to activate only the functions that you really need.
For more detailed information about the snap function, see Chapter 8 Tips and Tricks and Chapter
10 Advanced Draw Techniques in the Draw Guide.

Snap to grid
Snap to grid allows you to position an object to a grid point (Figure 204). Go to View > Grid >
Snap to Grid or click on the Snap to Grid icon
on the Options toolbar to turn on or off the
snap to grid function. If the Options toolbar is not displayed, go to View > Toolbars > Options.

Figure 204: Positioning with snap to grid

Displaying the grid
To display the grid in Draw or to switch off the grid, go to View > Grid > Display Grid or click on
with the Display Grid

icon on the Options toolbar.
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Figure 205: Configuring the grid

Configuring the grid
The resolution, snap and snap position of the grid points can be configured. Go to Tools >
Options > LibreOffice Draw > Grid to open the options dialog for the grid (Figure 205).

• Vertical and horizontal spacing of the dots in the grid. You can also change the unit of
measurement used in the general Draw options by going to Tools > Options > LibreOffice
Draw > General.

• The resolution is the size of the squares or rectangles in the grid. If the resolution is 1 cm
horizontal and 2 cm vertical, the grid consists of rectangles 2 cm high and 1 cm wide.

• Subdivisions are additional points that appear along the sides of each rectangle or square
in the grid. Objects snap to subdivisions as well as to the corners of the grid.

• The pixel size of the snap area defines how close you need to bring an object to a snap
point or line before it will snap to it.

• The default color of the grid is light gray. To change the color of the grid points, go to Tools
> Options > LibreOffice > Appearance.

Help lines
Draw has help lines to easily allow you to position an object using the rulers at the top and left side
of the workspace. To turn on or off the help lines, go to Tools > Options > LibreOffice Draw >
View and select Snap Lines when moving option or go to the Options toolbar and by click on the
Helplines While Moving icon

.

Applying special effects
With Draw, you can apply many special effects to objects and groups of objects and this section is
an introduction to some of these effects. For more information on special effects can be found in
Chapter 4 Changing Object Attributes of the Draw Guide.
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To access the tools used for special effects, go to View > Toolbars > Mode (Figure 206 and Figure
207). Rotate and Flip can also be accessed by going to Modify on the main menu bar or by right
clicking on the object and using the context menu.

Figure 206: Mode toolbar

Figure 207: Available tools on
Mode toolbar

Flipping objects
The quickest and easiest method to flip an object horizontally or vertically is as follows:
1) Click on a graphic object and the selection handles will show.
2) Right-click and select Flip > Vertically or Horizontally, or got to Modify > Flip > Vertically
or Horizontally on the main menu bar and the selected object will be flipped to face the
other direction.
However, the Flip tool on the Mode or Drawing toolbar can be used to give you greater control
over the flipping process. Using the Flip tool allows you to change the position and angle that the
object flips over and this is described in Chapter 4 Changing Object Attributes of the Draw Guide.

Mirror copies
At the moment there is no mirror command existing in Draw. However, mirroring an object can be
emulated by using the Flip tool and this is described Chapter 4 Changing Object Attributes of the
Draw Guide.

Distorting an object
Three tools on the Mode toolbar let you drag the corners and edges of an object to distort the
image.

• Distort tool

distorts an object in perspective.

• Set to Circle (slant)

creates a pseudo three-dimensional effect.

• Set in Circle (perspective)
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In all three cases you are initially asked if you want to transform the object to a curve. This is a
necessary first step, so click Yes. Then you can move the object handles to produce the desired
effect. See for Chapter 4 Changing Object Attributes of the Draw Guide for more information on
how to distort an object.

Dynamic transparency gradients
You can control transparency gradients in the same manner as color gradients. Both types of
gradient can be used together. With a transparency gradient, the direction and degree of object fill
color changes from opaque to transparent. In a regular gradient, the fill changes from one color to
another, but the degree of transparency remains the same.
The Transparency and Gradient tools on the Mode toolbar dynamically control transparency and
color gradients. See Chapter 4 Changing Object Attributes of the Draw Guide for more information
on how to create transparencies and gradients in an object.

Duplication
Duplication makes copies of an object while applying a set of changes such as color or rotation to
the duplicates that are created. Click on an object or group of objects and go to Edit > Duplicate
on the main menu bar to open the Duplicate dialog (Figure 208). Select the required options
chosen from the options available. When the options in the dialog are applied to a blue rectangle,
they produce the result shown in Figure 209.

Figure 208: Duplicate dialog

Figure 209: Result of a duplication
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Cross-fading
Cross-fading transforms one object shape to another object shape and only works when two
objects are selected.
1)
2)
3)
4)

Select two differently shaped objects.
Go to Edit > Cross-fading to open the Cross-fading dialog (Figure 210).
Select Increments to determine the number of shapes between the two objects.
Select Cross-fading to apply a gradual change of line and fill properties between the two
objects.
5) Select Same orientation to apply a smooth transition between the two objects.
6) Click on OK and the result is a new group of objects with the first object selected as the
start object and the second object selected as the end object. The intermediate objects
show the transformation from one shape to another (Figure 211).

Figure 210: Cross-fading dialog

Figure 211: Cross-fading result

Combining multiple objects
Using Draw, you can group or combine objects together allowing you to treat multiple objects as
one unit, or to merge objects to form a new shape. For more information, see Chapter 5
Combining Multiple Objects in the Draw Guide.
Grouping of objects is similar to putting objects into a container. You can move the objects as a
group and apply global changes to the objects withing the group. A group can always be undone
and the objects that make up the group can always be manipulated separately. The objects within
a group also retain their own individual properties.
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Combining objects is a permanent merging of objects that creates a new object. The original
objects are no longer available as individual entities and cannot be edited as individual objects.
Any editing of a combined object affects all the objects that were used when combination was
carried out.

Grouping
Temporary grouping
A temporary grouping is when several objects are selected using the Select icon
on the
Drawing toolbar or using the mouse to drag a rectangle around the objects (also known as a
marquee). Any changes to object parameters you carry out are applied to all of the objects within
the temporary group. For example, you can rotate a temporary group of objects in its entirety.
To cancel a temporary grouping of objects simply click outside of the selection handles displayed
around the objects.

Permanent grouping
A permanent grouping of objects is created after you have selected your objects and then going to
Modify > Group on the main menu bar, or right clicking on the selection and select Group from
the context menu, or using the keyboard shortcut Ctrl+Shift+G. When you deselect your selection
the objects remain grouped together.
When objects are permanently grouped, any editing operations carried out on that group are
applied to all members of the group. If you click on one member of the group, the whole group is
selected.
You can edit an individual member of a group without ungrouping or breaking the group. Select the
group and go to Modify > Enter Group, or right click and select Enter Group from the context
menu, or double click on the group.
When you have finished editing an individual member of a group, go to Modify > Exit Group, or
right click and select Exit Group from the context menu.

Ungrouping
To ungroup or break apart a group of objects, select the group then go to Modify > Ungroup on
the main menu bar, or right click and select Ungroup from the context menu or use the keyboard
shortcut Ctrl+Alt+Shift+G.

Combining objects
Combining objects is a permanent merging of objects that creates a new object. The original
objects are no longer available as individual entities and cannot be edited as individual objects.
Any editing of a combined object affects all the objects that were used when combination was
carried out.
Select several objects, then go to Modify > Combine on the main menu bar, or right click on the
objects and select Combine from the context menu, or use the keyboard shortcut Ctrl+Shift+K.
After you have selected your objects, the Merge, Subtract, and Intersect functions also become
available so that you can create a new object from your selected objects. See Chapter 5
Combining Multiple Objects in the Draw Guide for more information on these functions.
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Arranging, aligning and distributing objects
In Draw you can arrange, align and distribute selected objects in relation to each other:

• Arrange the position of an object by moving it either forward or backward in relation to the
order of objects.

• Align objects with respect to each other using Left, Centered, or Right for horizontal
alignment and Top, Center or Bottom for vertical alignment.

• Distribute objects so that the space between each of the objects is the same.
See Chapter 5 Combining Multiple Objects in the Draw Guide for more information on arranging
and aligning objects in relation to each other.

Inserting and editing pictures
Draw contains a number of functions for editing pictures or raster graphics (bitmaps); for example,
photos and scanned images. This includes the import and export of graphics, and the conversion
of one graphic format to another graphic format.
Draw includes a large range of graphic filters so that it can read and display several graphic file
formats. It also includes several tools for working with raster graphics, but does not have the same
functionality as specialized graphic programs like Gimp or Adobe Photoshop. See Chapter 6
Editing Pictures in the Draw Guide for more information.
You can add pictures from several sources:

• Directly from a scanner (Insert > Picture > Scan)
• Images created by another program, including photographs from a digital camera (Insert >
Picture > From File)

• The Draw Gallery; see Chapter 11 Graphics, the Gallery, and Fontwork in this guide for
more information.

Working with 3D objects
Although Draw does not match the functionality of the leading drawing or picture editing programs,
it is capable of producing and editing very good 3D drawings.
Draw offers two types of 3D objects: 3D bodies and 3D shapes. Depending on which type you
choose, there are different methods of editing of a 3D object (rotation, illumination, perspective,
and so on) with 3D shapes being simpler to set up and edit than 3D bodies. However, 3D bodies
currently allow for more customization.
See Chapter 7 Working with 3D Objects in the Draw Guide for more information.

Exporting graphics
Draw saves graphics and images in the open source format *.odg. To save a graphic or the entire
file in another format, use File > Export and select a format from the list displayed. The graphic
formats that Draw can export and save to are listed in Appendix B Open Source, Open Standards,
OpenDocument in this guide.
You can also export Draw files to HTML, XHTML, PDF, or Flash. PDF export for modules of
LibreOffice a and is described in Chapter 10 Printing, Exporting, and E-mailing of this guide.
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HTML export uses a conversion wizard that creates as many web pages as there are pages in
your Draw document. You can optionally choose to display pages in frames with a navigator and
set an index page. For more information, see Chapter 12 Creating Web Pages in this guide.

Inserting comments in a drawing
You can insert comments into your drawing and this a similar process used in Writer and Calc.
1) Go to Insert > Comment on the menu bar. A small box containing your initials appears in
the upper left-hand corner of your drawing with a larger text box beside it (Figure 212).
Draw automatically adds your name and the date at the bottom of this text box.

Figure 212: Inserting comments
2) Type or paste your comment into the text box. You can apply basic formatting to parts of
the text by selecting it, right-clicking, and choosing from the context menu. From this menu,
you can also delete the current comment, all the comments from the same author, or all the
comments in the document.
3) You can move the small comment markers to anywhere you wish on the drawing. Typically
you might place it on or near an object you refer to in the comment.
4) To show or hide the comment markers, go to View > Comments on the main menu bar.
5) Go to Tools > Options > User Data to enter the name you want to appear in the Author
field of the comment.
6) If more than one person edits the document, each author is automatically allocated a
different background color.
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Chapter 8
Getting Started with Base
LibreOffice's Database Component

Introduction
A data source, or database, is a collection of pieces of information that can be accessed or
managed by LibreOffice. For example, a list of names and addresses is a data source that could
be used for producing a mail merge letter. A shop stock list could be a data source managed
through LibreOffice.

Note

LibreOffice uses the terms “Data Source” and “Database” to refer to the same thing,
which could be a database such as MySQL or dBase or a spreadsheet or text
document holding data.

This chapter covers creating a database, showing what is contained in a database and how the
different parts are used by LibreOffice. It also covers using the Base component of LibreOffice to
register other data sources. A data source can be a database, spreadsheet, or text document.

Note

LibreOffice Base uses the HSQL database engine. All of the files created by this
engine, including the database forms, are kept in one zipped file.

A database consists of a number of fields that contain the individual pieces of data. Each table of
the database is a group of fields. When creating a table, you also determine the characteristics of
each field within it. Forms are for data entry into the fields of one or more tables which have been
associated with the form. They can also be used for viewing fields from one or more tables
associated with the form. A query creates a new table from the existing tables based upon how you
create the query. A report organizes the information from the fields of a query into a document
according to your requirements.

Caution

The database in LibreOffice requires Java Runtime Environment (JRE). If you do not
have it on your computer, you can download it from www.java.com and install it
following the instructions on the site. It should be Java 6.0. In LibreOffice, u se Tools
> Options > LibreOffice > Java to register Java.
Windows' version of JRE can not be used, while there are other versions that can.

Base creates relational databases. This makes it fairly easy to create a database in which the
fields of the database have relationships with each other.
For example: Consider a database for a library. It will contain a field for the names of the authors
and another field for the names of the books. There is an obvious relationship between the authors
and the books they have written. The library may contain more than one book by the same author.
This is what is known as a one-to-many relationship: one author and more than one book. Most if
not all the relationships in such a database are one-to-many relationships.
Consider an employment database for the same library. One of the fields contains the names of
the employees while others contain the social security numbers, and other personal data. The
relationship between the names and social security numbers is one-to-one: only one social security
number for each name.
If you are acquainted with mathematical sets, a relational database can easily be explained in
terms of sets: elements, subsets, unions, and intersections. The fields of a database are the
elements. The tables are subsets. Relationships are defined in terms of unions and intersections of
the subsets (tables).
To explain how a database works and how to to use it, we will create one for automobile expenses.
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Planning a database
The first step in creating a database is to ask yourself many questions. Write them down, and
leave some space between the questions to write the answers later. At least some of the answers
should seem obvious after you take some time to think.
You may have to go through this process a few times before everything becomes clear in your
mind and on paper. Using a text document for these questions and answers makes it easier to
move the questions around, add additional questions, or change the answers.
Here are some of the questions and answers I developed before I created a database for
automobile expenses. I had an idea of what I wanted before I started, but as I began asking
questions and listing the answers, I discovered that I needed additional tables and fields.
What are the fields going to be? My expenses divided into three broad areas: fuel purchases,
maintenance, and vacations. The annual cost for the car’s license plate and driver’s license every
four years did not fit into any of these. It will be a table of its own: license fees.
What fields fit the fuel purchases area? Date purchased, odometer reading, fuel cost, fuel quantity,
and payment method fit. (Fuel economy need not be included, as it can be calculated using a
query.)
What fields fit the maintenance area? Date of service, odometer reading, type of service, cost of
service, and next scheduled service of this type (for example, for oil changes list when the next oil
change should be). But it would be nice if there was a way to write notes. So a field for notes was
added to the list.
What fields fit the vacations area? Date, odometer reading, fuel (including all the fields of the fuel
table), food (including meals and snacks), motel, total tolls, and miscellaneous. Since these
purchases are made by one of two bank cards or with cash, I want a field to state which payment
type was used for each item.
What fields fit into the food category? Breakfast, lunch, supper, and snacks seem to fit. Do I list all
the snacks individually or list the total cost for snacks for the day? I chose to divide snacks into two
fields: number of snacks and total cost of snacks. I also need a payment type for each of these:
breakfast, lunch, supper, and total cost of snacks.
What are the fields that are common to more than one area? Date appears in all of the areas as
does odometer reading and payment type.
How will I use this information about these three fields? While on vacation, I want the expenses for
each day to be listed together. The date fields suggest a relationship between the vacation table
and the dates in each of these tables: fuel and food, This means that the date fields in these tables
will be linked as we create the database.
The type of payment includes two bank cards and cash. So we will create a table with a field for
the type of payment and use it in list boxes in the forms.

Tip

While we have listed fields we will create in the tables of the database, there is one
more field that may be needed in a table: the field for the primary key. In some
tables, the field for the primary key has already been listed. In other tables such as
the payment type, an additional field for the primary key must be created.
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Creating a new database
To create a new database, choose File > New > Database from the menu bar, or click the arrow
next to the New icon on the Standard toolbar and select Database from the drop down menu. Both
methods open the Database Wizard.
On the first page of the Database Wizard, select Create a new database and then click Next.
The second page has two questions. Make sure the choice for the first question is Yes, register
the database for me and the choice for the second question is Open the database for editing.
Click Finish.

Note

If the database is not registered, it will not be accessible to the other LibreOffice
components such as Writer and Calc. If the database is registered, other components
can access it.

Save the new database with the name Automobile. This opens the Automobile – LibreOffice Base
window. Figure 213 shows part of this window.

Figure 213: Creating database tables

Tip

Caution

Every time the Automobile database is opened, the Automobile – LibreOffice Base
window opens. Changes can then be made to the database. The title for this window
is always <database name> – LibreOffice Base.

As you create a database, you should save your work regularly. This means more
than saving what you have just created. You must save the whole database as well.
For example, when you create your first table, you must save it before you can close
it. When the table is first saved, it is also made part of the database. you write the
table in the database file.
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Creating database tables
In a database, a table stores information for a group of things we call fields. For example, a table
might hold an address book, a stock list, a phone book or a price list. A database must have at
least one table and may have several.
To work with tables, click the Tables icon in the Database list, or press Alt+a. The three tasks that
you can perform on a table are in the Tasks list (see Figure 213).

Using the Wizard to create a table
Wizards are designed to do the basic work. Sometimes this is not sufficient for what we want; in
those cases we can use a wizard as a starting point and then build upon what it produces.
The Table Wizard in Base contains two categories of suggested tables: business and personal.
Each category contains sample tables from which to choose. Each table has a list of available
fields. We can delete some of these fields and add other fields.
A field in a table is one bit of information. For example, a price list table might have one field for
item name, one for the description, and a third for the price.
Since none of the fields we need for our Automobile database are contained in any of the sample
wizard tables, we will create a simple table using the wizard that has nothing to do with our
database. This section is merely an exercise in explaining how the Wizard works.
The Wizard permits the fields of the table to come from more than one suggested table. We will
create a table with fields from three different suggested tables in the Wizard.

Caution

Every table requires a Primary key field. (What this field does will be explained later.)
We will use this field to number our entries and want that number to automatically
increase as we add each entry .

Click Use Wizard to Create Table. This opens the Table Wizard (Figure 214).
Step 1: Select fields.
We will use the CD-Collection Sample table in the Personal category to select the fields we need.
1) Category: Select Personal. The Sample Tables drop down list changes to a list of personal
sample tables.
2) Sample tables: Select CD-Collection. The Available fields box changes to a list of available
fields for this table.
3) Selected fields: Using the > button, move the following fields from the Available fields
window to the Selected fields window in this order: CollectionID, AlbumTitle, Artist,
DatePurchased, Format, Notes, and NumberofTracks.
4) Selected Fields from another sample table. Click Business as the Category. Select
Employees from the drop down list of sample tables. Use the > button to move the Photo
field from the Available fields window to the Selected fields window. It will be at the bottom
of the list directly below the NumberofTracks field.
5) If you make a mistake in selecting fields, click on the field name in the Selected fields list
and use the < button to move it from the Selected fields list back to the Available fields list.
6) If you make a mistake in the order of the selected fields, click on the field name that is in
the wrong order and use the Up or Down arrow on the right side of the Selected fields list
to move the field name to the correct position.
7) Click Next.
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Figure 214: Selecting fields for the table
Step 2: Set field types and formats.
In this step you give the fields their properties. When you click a field, the information on the right
changes. (See Figure 215.) You can then make changes to meet your needs. Click each field, one
at a time, and make the changes listed below.

Figure 215: Changing field types

Note

If any of these fields requires a mandatory entry, set Entry required to Yes. A blank
field will then not be allowed . In general, only set Entry required to Yes if something
must always be put in that field. By default, Entry required is set to No.

• CollectionID: Change AutoValue from No to Yes. (example of a manditory entry)
• AlbumTitle:
–
Entry required: Leave Entry required as No, unless all of your music is in albums.
–
Length: Unless you have an album title that exceeds 100 characters counting the
spaces, do not change the length.

• Artist: Use the Default setting. And since music has artists, set Entry Required to Yes.
• Date Purchased: Field type: default date setting. Entry required should be No. (You may
not know the date.)
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Note

In Base the maximum length of each field must be specified on creation . It is not
easy to change this later, so if in doubt specify a greater length. Base uses VCHAR
as the field format for text fields. This format uses only the actual number of
characters in a field up to the limit set, so a field containing 20 characters will
occupy only 20 characters even if the limit is set at 100. Two album titles containing
25 and 32 characters respectively will use space for 25 and 32 characters and not
100 characters.

• Format: Only change the Entry Required setting: from No to Yes.
• Notes: No changes are required.
• NumberofTracks: Change the Field Type to Tiny Integer [TINYINT]. Your allowable number
of tracks will be 999. Small Integer [SMALLINT] would allow 99999 tracks if you needed
more than 999 tracks.

• Photo: Use the default settings.
When you have finished, click Next.

Note

Each field has a Field Type, which must be specified. Types include text, integer, date,
and decimal. If the field is going to have general information in it (for example, a name
or a description), use text . If the field will always contain a number (for example, a
price), the type should be decimal or another numerical field . The wizard picks the
right field type, so to get an idea of how this works, see what the wizard has chosen
for different fields.

Step 3: Set primary key.
1)
2)
3)
4)
5)

Create a primary key should be checked.
Select option Use an existing field as a primary key.
In the Fieldname drop down list, select CollectionID.
Check Auto value if it is not already checked.
Click Next.
A primary key uniquely identifies an item (or record) in the table . For example, you
might know two people called “Randy Herring” or three people living at the same
address and the database needs to distinguish between them.

Note

The simplest method is to assign a unique number to each one: number the first
person 1, the second 2, and so on . Each entry has one number and every number is
different, so it is easy to say “record ID 172”. This is the option chosen here:
CollectionID is just a number assigned automatically by Base to each record of this
table.

Step 4: Create the table.
1) If desired, rename the table at this point. If you rename it, make the name meaningful to
you. For this example, make no changes.
2) Leave the option Insert data immediately checked.
3) Click Finish to complete the table wizard. Close the window created by the table wizard.
You are now back to the main window of the database with the listing of the tables, queries,
forms, and reports. Notice that a table named “CD-Collection” is now listed in the Tables
portion of the window.
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Creating a table by copying an existing table
If you have a large collection of music, you might want to create a table for each type of music you
have. Rather than creating each table from the wizard, you can make copies of the original table,
naming each according to the type of music contained in it.
1) Click on the Tables icon in the Database pane to see the existing tables.
2) Right-click on the CD-Collection table icon. Choose Copy from the pop-up menu.
3) Move the mouse pointer below this table, right-click, and select Paste. The Copy table
dialog opens.
4) Change the table name to Pop and click Next.
5) Click the >> button to move all the fields from the left box to the right box and click Next.
6) Since all the fields already have the proper Field type, no changes should be needed.
However, this is the time and place to make any changes if they are needed. (See Caution
below for the reason why.) Click Create. The new table is created.

Caution

Once tables have been created using the wizard, and data has been entered, editing
them should be very limited. Fields can be added or deleted, but adding a field
requires you to enter the data for that one field for every existing record with an entry
for that field.
Deleting a field deletes all the data once contained in that field. Changing the field
type of a field can lead to data being lost either partially or completely. When
creating a new table, it pays to create the fields with the correct names, length, and
format before you add any data.
Deleting a table removes all of the data contained in every field of the table. Unless
you are sure, do not delete a table.

Creating tables in Design View
Design View is a more advanced method for creating a new table, in which you directly enter
information about each field in the table. We will use this method for the tables of our database.

Note

While the Field type and formatting are different in Design View, the concepts are
the same as in the Wizard.

The first table to be created is Fuel. Its fields are FuelID, Date, FuelCost, FuelQuantity, Odometer,
and PaymentType.
1) Click Create Table in Design View.
2) FuelID field: Type FuelID as the first Field Name. Press the Tab key to move to the Field
Type column. Select Integer [INTEGER] as the Field Type from the drop down list. (The
default setting is Text [VARCHAR].)

Tip

A shortcut for selecting from the Field Type drop down list: press the key for the first
letter of the choice. You can cycle through the choices for a given letter by
repeatedly pressing that key.

a) Change the Field Properties in the bottom section.
Change AutoValue from No to Yes.
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b) Set FuelID as the Primary key.
Right-click on the green triangle to the left of FuelID (Figure 216) and choose Primary
Key from the menu. This places a key icon in front of FuelID.

Figure 216: Defining the primary key field
The primary key serves only one purpose: to identify the record uniquely. Any name
can be used for this field. We have used FuelID for convenience, so we know to
which table it belongs.

Note

3) All other fields (Date, FuelCost, FuelQuantity, Odometer, and PaymentType):
a) Type the next field name in the Field Name column.
b) Select the Field Type for each field.
• For Date use Date[DATE]. (Press the D key to select it.)

c)

•
•

PaymentType uses Text [VARCHAR], the default setting.

•
•

Odometer: Change the Length to 10 and the Decimal places to 1.

All other fields use Number [NUMERIC]. (Press the N key once to select it.)
FuelCost, FuelQuantity, and Odometer need changes in the Field Properties section
(Figure 217).
• FuelQuantity: Change Length to 6 and Decimal places to 3. (Many fuel pumps
measure fuel to thousandths of a gallon in the USA, where I live.)
FuelCost: Change the Length to 5 and Decimal places to 2. Click the Format
example button (Figure 217). This opens the Field Format window (Figure 218).
Use Currency as the Category and your currency as the Format. My currency
has two decimal places. Use what is appropriate for yours.
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Figure 217: Changing field properties

Figure 218: Field Format options
4) To access additional formatting options, click the button to the right of the Format example
field.
5) Description can be anything, or can be left blank.
6) To save and close the table, choose File > Save. Name the table Fuel. Close the Fuel
table.
Follow the same steps to create the Vacations table. The fields and their field types are listed in
Figure 219. Make sure you make the Date field the primary key before closing. (Right-click the gray
box to the left of Date and select Primary key from the menu.) Save the table and name it
Vacations. Close the Vacations table.
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Figure 219: Fields in Vacations table

Defining relationships
Now that the tables have been created, what are the relationships between our tables? This is the
time to define them based upon the questions we asked and answered in the beginning.
When on vacation, we want to enter all of our expenses at once each day. Most of these expenses
are in the Vacations table, but the fuel we buy is not. So we will link these two tables using the
Date fields. Since the Fuel table may have more than one entry per date, this relationship between
the Vacations and Fuel tables is one to many (it is designated 1:n.)
The Fuel and Maintenance tables do not really have a relationship even though they share similar
fields: Date and Odometer.

Tip

As you create your own databases, you will also need to determine where tables are
related and how.

1) To begin defining relationships, choose Tools > Relationships. The Automobile –
LibreOffice Base: Relation Design window opens and the Add Tables dialog pops up. (You
can also open it by clicking the Add Tables icon on the Relation Design window.)
2) On the Add Tables dialog, use either of these ways to add a table to the Relation Design
window:

•
•

Double-click the name of the table. In our case, do this for both Vacations and Fuel.

Or, click the name of the table and then click Add for each table.
3) Click Close to close the Add Tables dialog when you have added the tables you want.
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4) You can define the relationship between the Vacations and Fuel tables in two ways:

•

Click and drag the Date field in the Fuel table to the Date field in the Vacations table.
When you release the mouse button, a connecting line forms between the two date
fields (Figure 220).

•

Or, click the New Relation icon. This opens the Relations window (Figure 221). Our
two tables are listed in the Tables involved section.
a) In the Fields involved section, click the drop down list under the Fuel label.
b) Select Date from the Fuel table list.
c) Click in the cell to the right of this drop down list. This opens a drop down list for
the Vacations table.
d) Select Date from the Vacations table list. It should now look like Figure 221.
e) Click OK.

Figure 220: Designation for a 1:n relationship

Figure 221: Selected fields in a relationship
5) Modifying the Update options and Delete options section of the Relation window.
a) Right-click the line connecting the Date fields in the two table lists to open a menu.
b) Select Edit to open the Relations dialog (Figure 222).

Figure 222: Update options and Delete options section
c)
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Select Update cascade.
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d)
e)

Select Delete cascade.
Click OK to close the Relations dialog and choose File > Save to save the Relation
Design window.

While these options are not strictly necessary, they do help. Having them selected permits
you to update a table that has a relationship defined with another table which has been
modified. It also permits you to delete a field from the table without causing inconsistencies.

Creating a database form
Databases are used to store data. But, how is the data put into the database? Forms are used to
do this. In the language of databases, a form is a front end for data entry and editing.

Figure 223: Fields of a simple form

Figure 224: Simple form with additions

A simple form consists of the fields from a table (Figure 223). More complex forms can contain
much more, including additional text, graphics, selection boxes, and many other elements. Figure
224 is made from the same table with a text label (Fuel Purchases), a list box placed in
PaymentType, and a graphic background.
A list box is useful when a field contains a fixed choice of options. It saves you from having to type
in data by hand, and ensures that invalid options are not entered.
In our database, payments for food or fuel might be made from one of two credit cards (Dan or
Kevin) or in cash, so these would be the available options for all boxes that contain payments.
To create a list box, we first need to create a small, separate table containing the options. This is
then linked to the corresponding field in the form. The topic is dealt with in detail in the Base User
Guide and will not be pursued further here.

Using the Wizard to create a form
We will use the Form Wizard to create a Vacations form, which will contain a form and a subform
In the main database window (Figure 213), click the Forms icon in the left column. In the Tasks list,
double-click Use Wizard to Create Form to open the Form Wizard (Figure 225). Simple forms
require only some of these steps, while more complex forms may use all of them.
Step 1: Select fields.
1) Under Tables or queries, select Table: Vacations. Available fields lists the fields for the
Vacations table.
2) Click the right double arrow to move all of these fields to the Fields in the form list. Click
Next.
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Figure 225: Form Wizard steps
Step 2: Set up a subform
Since we have already created a relationship between the Fuel and Vacations tables, we will use
that relationship. If no relationship had been defined, this would need to be done in step 4.
1) Click the box labeled Add Subform.
2) Click Sub form based upon existing relation.
3) Fuel is listed as a relation we want to add. So click Fuel to highlight it, as in Figure 226.
Click Next.

Figure 226: Adding a subform
Step 3: Add subform fields.
This step is exactly the same as step 1. The only difference is that not all of the fields will be used
in the subform
1) Fuel is preselected under Tables or queries.
2) Use the >> button to move all the fields to the right.
3) Click the FuelID field to highlight it.
4) Use the < button to move the FuelID to the left (Figure 227).
5) Click Next.
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Figure 227: Selecting fields of a sub form
Step 4: Get joined fields.
This step is for tables or queries for which no relationship has been defined. Because we have
already defined the relationship, the wizard skips this step.

Note

It is possible to create a relationship between two tables that is based upon more
than one pair of fields. How to do that and why is discussed in the Base Guide.

When selecting a pair of fields from two tables to use as a relationship, they have to
have the same field type. That is why we used the Date field from both tables: both
their field types are Date[DATE].

Caution

Whether a single pair of fields from two tables are chosen as the relationship or two
or more pairs are chosen, certain requirements must be met for the form to work.

• No field from the subform can be the Primary key for its table. (FuelID cannot be
used.)

• Each pair of joined fields must have the same file type.
• One of the fields from the main form must be the Primary key for its table. (Date
would have to be used.)
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Step 5: Arrange controls.
A control in a form consists of two parts: label and field. This step in creating the form determines
where a control’s label and field are placed relative to each other. The four choices from left to right
are Columnar left, Columnar - Labels on top, As Data Sheet, and In Blocks - Labels Above.
1) Arrangement of the main form: Click the second icon (Columnar - Labels on top). The
labels will be placed above their field.
2) Arrangement of the sub form: Click the third icon (As Data Sheet). (The labels are column
headings and the field entries are in spreadsheet format.) Click Next.
Step 6: Set data entry.
Unless you have a need for any of these entries to be checked, accept the default settings. Click
Next.
Step 7: Apply styles.
1) Select the color you want in the Apply Styles list. (I chose the beige which is Orange 4 in
the Color table.)
2) Select the Field border you want. (I prefer the 3D look. You might want to experiment with
the different possible settings.)
3) Click Next.
Step 8: Set name.
1) Enter the name for the form. In this case, it is Fuel.
2) Click Modify the form.
3) Click Finish. The form opens in Edit mode.

Modifying a form
We will be moving the controls to different places in the form and changing the background to a
picture. We will also modify the label for the PaymentType field as well as change the field to a list
box.
First, we must decide what we want to change. The discussion will follow this ten step outline of
our planned changes.

• Provide a drop-down capability for the Date field in the main form, and lengthen the field to
show the day of the week, month, day, and year.

• Shorten the length of the payment fields (all fields containing the word Payment).
• Move the controls into groups: food, fuel subform, and miscellaneous.
• Change the wording of some of the labels. Some single words should be two words. Some
abbreviations should be used if possible (Misc. for miscellaneous).

• Change the lengths of several fields and labels. Only Lunch, Supper, Motel, and Tolls have
acceptable lengths. But for a better appearance, changes will be made to these as well.

• Lengthen the Note field vertically, add a scroll bar, and move it.
• Make changes in the Date and PaymentType columns of the subform to match the
changes in the main form.

• Add headings for each group in the main form.
• Change the background to a picture, then modify some of the labels so that they can be
read clearly against this background. Change the font color of the headings.
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Here are some methods that we will be using in these steps. The controls in the main form consists
of a label and its field. Sometimes we want to work with the entire control, sometimes with only the
label or the field, and there are times when we want to work with a group of controls.

• Clicking a label or field selects the entire control. A border appears around the control with
eight green handles. You can then drag and drop it where you want.

Figure 228: A selected control

• Control+click a label or field selects only the label or the field. You can press the Tab key to
change the selection from the field to the label or the label to the field.

Figure 229: Selecting a field of a control

• Moving a group of controls is almost as easy as moving one of them.
1)
2)
3)

Click the field of the top left control to be moved, to select it.
Move the cursor to just above and to the left of the selected control.
Drag the cursor to the bottom right of the group of controls and release the mouse
button.

As you drag the cursor, a dashed box appears, showing what is contained in your selection. Make
sure it is big enough to include the entire length of all the controls.
When you release the mouse button, a border with its green handles appears around the controls
you selected.

Figure 230: Selecting multiple controls
Move the cursor over one of the fields. It changes to a drag icon. Drag the group of controls to
where you want them.

• Click the Tolls control to select it. Then drag it to the right close to the Lunch control.

Tip

When either changing size or moving a control, two properties of the Form Design
toolbar should be selected: Snap to Grid, and Guides when Moving. Your controls will
line up better, and an outline of what you are moving moves as the cursor moves.
You should also have both rulers active (View > Ruler).

Step 1: Change the Date field.
1) Control+click the Date field to select it.
2) Move the cursor over the middle green handle on the right side. It should change to a
double-headed arrow.
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3) Hold the left mouse button down as you drag the cursor to the right until the length is 6 cm.
The vertical dashed line is lined up with the 6. Release the mouse button.
4) Click the Control icon in the Form Controls toolbar. If it is not visible, choose View >
Toolbars > Form Controls. The Properties: Date Field window opens. Each line contains
a property of the field.

Figure 231: Form Controls toolbar

•

Scroll down to the Date format property. This is a drop down list with Standard (short)
as the default setting. Click it to open the list. Select the Standard (long) entry.

•

Scroll down to the Drop down property. Its default setting is No. It is also a drop down
list. Click to open the list. Select Yes.

Tip

To see what the Date field will look like, click the Form Mode On/Off icon (the
second icon from the left in Figure 231). You can do this any time you want to see
the form with the changes you have made.

Step 2: Shorten the width of some fields.
All of the fields with a label containing the word payment are too wide. They need to be shortened
before the controls are moved.

Figure 232: Selecting a field
1) Control+click the BPayment field.
2) Move the cursor over the middle green handle on the right. The cursor becomes a doubleheaded arrow.
3) Drag the cursor to the left until the field is 2.5 cm (1 inch) wide.
4) Repeat these steps to shorten these fields: Lpayment, SPayment, SnPayment, Mpayment,
and MiscPayment.

Tip

If you have the Snap to Grid and Guides when moving icons selected in the Design
Format toolbar, you will see how wide the field is as you shorten it.

Step 3: Move the controls to group them by category.
We want to move the controls so that they look like Figure 233.
1) Click the first control you want to move. A border appears around the control with eight
green handles.
2) Move the cursor over the label or field of the control. It change shape to a drag icon.
3) Drag and drop the control to where you want it.
4) Use the same steps to move the rest of the controls to where they belong.
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Figure 233: Positioning of controls

Caution

Do not use Control+click when moving a field. It moves either the field or the label
but not both. To move both, use a plain mouse click and drag to the desired spot.

Step 4: Change the label wording.
Field names have been required to be single words for some time. However, the labels for the
fields in a form can be more than one word. So we will change them by editing the text in the label.
1) Control+click the SnackNo label. Do one of the following:

•
•

Right-click the SnackNo label and select Control from the pop-up menu.

•
•

In the Label selection, edit the label to Snack No.

Or click the Control icon in the Form Control toolbar (Figure 231).
2) The dialog that opens is labeled Properties: Label Field. It contains all the properties of the
selected label.
Close the Properties dialog.
3) Use the same procedure to change these labels as well: BPayment to Payment, LPayment
to Payment, SPayment to Payment, Miscellaneous to Misc., SnackCost to Snack Cost,
MPayment to Payment, MiscPayment to Misc. Payment, and MiscNotes to Misc. Notes.

Tip

You can modify all of the listings in the Properties window. For example, if you
change the Alignment from Left to Center, the word or words in the label are
centered within the label. When you have some time, you might want to experiment
with different settings just to see the results you get.

Step 5: Change the widths of the labels and fields.
We want the following controls to be 2 cm wide (0.8 inches): Breakfast, Lunch, Supper, Odometer,
Snack No., Tolls, Snack Cost, Motel, and Misc. All of the payment fields were changed in step 2,
but Misc. Payment needs to be changed to 3 cm (1.2 inches).
1) Right-click Breakfast and choose Position and Size. On the Position and Size dialog,
change Width to 2 cm.
2) Repeat for the other listed controls, using 3 cm for Misc.Payment.
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When changing the position or size of an entire control, use the Position and Size
dialog or the drag and drop method.

Caution

Note

When working with either the label or the field (but not both at the same time), you
can use the Properties dialog to make these changes when you want to be exact.
However, you need to be careful not to accidentally select the entire control for use
with the Properties dialog or you will apply exactly the same values to both the label
and field. For example, if you enter the values for a new position, both the field and
the label moves to the same position and the field is positioned on top of the label.
Then you will have to move each of them to where you really want them.
To open the Properties window, right-click a control and select Control from the
pop-up menu. Or, you can click the Control icon in the Form Controls toolbar. Just
be careful, and use Control+Z to undo any mistakes you may make. Detailed
instructions on how to use the Properties window are given in the Base Guide.

Step 6: Change the Misc. Notes field.
We want the Misc. Notes control, which has a field type of Memo, to have a vertical scroll bar for
additional text space if desired.

Figure 234: Scroll bar selections in the Properties window
1) Control+click the Misc. Notes field. The green handles should surround the field but not its
label.
2) Click the Control icon to open the Properties window (Figure 234).
3) Scroll down to the Text type property with single-line as the default value.

•

Change it to Multi-line.
4) Scroll down to the Scrollbars setting. Change the selection from None to Vertical in this list.
5) Close the Properties window. (Esc key)
6) Lengthen the Misc. Notes field by moving the cursor over the middle green handle at the
bottom of the field and dragging down until the length is 6 cm (2.4 inches).
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Step 7: Change labels and fields in the subform
The subform is located at the bottom of the form. We want to widen the Date column, and change
the label for the PaymentType column to two words.

• To widen the Date column, move the mouse pointer over the dividing line between the Date
and FuelCost columns. When the pointer changes shape, click and drag to move the
divider to the right.

• To change the PaymentType column:
–
Right-click the label PaymentType to open the menu.
–
Select Column to open the Properties dialog . In the Label property, change
PaymentType to Payment Type.

–

Close the Properties dialog.

Step 8: Add headings to groups.
This step is easier to do if you have end-of-paragraph markers visible. Choose View > Non
printing Characters to turn them on.

Figure 235: Apply Styles list
1) Make sure the cursor is in the upper left corner. If it is not, click in that corner to move it
there.
2) Press the Enter key to move the cursor down to the space between the Date field and the
Breakfast field.
3) Change the Apply Styles drop down list from Default to Heading 2.
4) Use the spacebar to move the cursor to where you want the heading to start.
5) Type the heading Meals.
6) Use the spacebar to move the cursor to the center of snack area.
7) Type the heading Snacks.
8) Use the Enter key to move the cursor between the Supper control and the subform
9) Use the spacebar to move the cursor to the center of the subform
10) Type the heading Fuel Data.

Note

If you know how to use styles, you can open the Styles and Formatting window
using F11. Right-clicking the Heading 2 paragraph style allows you to modify the
appearance of all three headings. See Chapter 6 of the Writer Guide for details.
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Step 9: Change the background of a form.
The background for a form can be a color, or a graphic (picture). You can use any of the colors in
the Color Table at Tools > Options > LibreOffice > Colors. If you know how to create custom
colors, you can use them. You can also use a picture (graphic file) as the background.
1) Right click the form to open a context menu.
2) Select Page.
3) Make sure the Background tab has been selected. (It will be in bold type while the other
tabs will be in default type.)

Figure 236: Page style dialog
4) Click Light cyan. (Second row, fourth column from the left.)
5) Click Apply to see the effects of adding the color. OR, click OK to close the dialog.

Tip

Learning how to use styles can be very helpful at times. By using styles, we changed
the font color for all three headings at one time. There are other methods of
changing the font color, but they require repeating the same steps for each heading.

6) To add a graphic to the background:
a) Click the Gallery tool (circled in red). The gallery window opens.

b)
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c)

Select the graphic you want to use. ( have done these steps selecting pebble-light.)
i)
Browse through the choices.
ii)
Right click your choice.
iii) Insert > Background > Page
Click the Gallery tool to close the gallery window.

d)

The form should look like Figure 237.
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Figure 237: Finished form
Step 10: Change the tab order.
The Tab key moves the cursor from field to field. This is much easier to do than to click each field
to enter data into it. It also permits us to group our expenses into areas before we begin entering
data. For example, all of our meal receipts can be grouped together as can our snacks and also
our fuel purchases.

Figure 238: Form Design toolbar with Activation Order icon circled
1) Control+click the Date field.
2) Click the Form Design icon in the Form Controls toolbar to open the Form Design toolbar
(Figure 238), or choose View > Toolbar > Form Design to open this toolbar.
3) Click the Activation Order icon (circled).
4) Rearrange the order of the fields in the Tab Order window.
a) Find the txtMPayment listing near the bottom of the list and click it.
b) Click the Move Up button until txtPayment is just below fmtMotel.
c) Use the same two steps to put the fields in the same order as in Figure 239. Click OK.
5) Save and close the form.
6) Save the database.

Chapter 8 Getting Started with Base

233

Figure 239: Tab order for the main form

Creating forms and sub forms in Design View
This method requires using the Form Controls and Form Design toolbars extensively. These
techniques are beyond the scope of this document. Instructions for creating forms using Design
view will be described in the Database Guide.

Accessing other data sources
LibreOffice allows data sources to be accessed and then linked into LibreOffice documents. For
example, a mail merge links an external document containing a list of names and addresses into a
letter, with one copy of the letter being generated for each entry.
To access a data source that is not a *.odb file:
1) File > New > Database opens the Database Wizard window.
2) Select Connect to an existing database. Click the arrow next to the Database type field
and select the database type from the drop down list. Click Next.
3) Click Browse and select the database. Click Next.
4) Accept the default settings: Register the database for me, and Open the database for
editing. Click Finish. Name and save the database in the location of your choice.

Accessing a spreadsheet as a data source
Accessing a spreadsheet is similar to accessing other databases:
1) Choose File > New > Database.
2) Select Connect to an existing database. Select Spreadsheet as the Database type.
3) Click Browse to locate the spreadsheet you want to access. If the spreadsheet is
password protected, check the Password required box. Click Next.
4) If the spreadsheet requires a user’s name, enter it. If a password is also required, check its
box. Click Next.
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Using this method of accessing a spreadsheet, you cannot change anything in the
spreadsheet. You can only view the contents of the spreadsheet, run queries, and
create reports based upon the data already entered into the spreadsheet.

Note

All changes in a spreadsheet must be made in the spreadsheet itself, using Calc.
After modifying the spreadsheet and saving it, you will see the changes in the
database. If you create and save an additional sheet in your spreadsheet, the
database will have a new table the next time you access it.

Registering *.odb databases
Databases created by LibreOffice2.x or later are in the *.odb (OpenDocument Base) format. Other
programs can also produce databases in this format. Registered a *.odb database is simple:
1)
2)
3)
4)
5)

Choose Tools > Options > LibreOffice Base > Databases.
Under Registered databases, click New.
Browse to where the database is located.
Make sure the registered name is correct.
Click OK.

Note

Sometimes when updating LibreOffice to a newer version, your list of registered
database files disappears. When that happens, you need to use these steps to
register your database files with your latest version of LibreOffice.

Using data sources in LibreOffice
Having registered the data source, whether a spreadsheet, text document, external database or
other accepted data source, you can use it in other LibreOffice components including Writer and
Calc.

Viewing data sources
Open a document in Writer or Calc. To view the data sources available, press F4 or select View >
Data Sources from the pull-down menu. This brings up a list of registered databases, which will
include Bibliography and any other database registered, such as the Automobile database created
earlier in this chapter.
To view each database, click on the
to the left of the database’s name (see Figure 240). This
brings up Tables and Queries. Click on the
next to Tables to view the individual tables created.
Now click on a table to see all the records held in it.

Figure 240: Databases
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Editing data sources
Some data sources (but not spreadsheets) can be edited in the View Data Sources dialog. A
record can be edited, added, or deleted.
View a table’s data
If you click on a table its rows and columns of data appear on the right side of the Data Source
window. Editing this data requires only a click in the cell whose data should be changed, change
the data, and click in the row above or below it to save the new data.
Beneath the records are five tiny buttons. The first four move backwards or forwards through the
records, or to the beginning or end. The fifth button, with a small star, inserts a new record.

Figure 241: View Data Sources navigation buttons
To delete a record, right-click on the gray box to the left of a row to highlight the entire row, and
select Delete Rows to remove the selected row.

Figure 242: Deleting a row in the Data View window

Launching Base to work on data sources
You can launch LibreOffice Base at any time from the View Data Source pane. Just right-click on a
database or the Tables or Queries icons and select Edit Database File. Once in Base, you can
edit, add, and delete tables, queries, forms, and reports.

Using data sources in Writer and Calc
Data can be placed into Writer and Calc documents from the tables in the data source window. In
Writer, values from individual fields can be inserted. Or a complete table can be created in the
Writer document. One common way to use a data source is to perform a mail merge.

Tip

Choosing Tools > Mail Merge Wizard or clicking on the Mail Merge icon on the
View Data Source pane launches the Mail Merge wizard which steps you through
creating a mail merge document. See Chapter 11 in the Writer Guide.

Writer documents
To insert a field from a table opened in the data source window into a Writer document, click on the
field name (the gray square at the top of the field list) and, with the left mouse button held down,
drag the field onto the document. In a Writer document, it will appear as <FIELD> (where FIELD is
the name of the field you dragged).
For example, to enter the cost of meals and who paid for them on a certain date of a vacation:
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1) Open the list of data sources (F4) and select the Vacations table in the Automobile
database.
2) Use this sentence: “On (date), our breakfast cost (amount) paid by (name), our lunch cost
(amount) paid by (name), and our supper cost (amount) paid by (name).” But only type
“On , our breakfast cost paid by , our lunch cost paid by , and our supper cost paid by .”
3) To replace (date), click the field name Date in the data source window and drag it to the
right of the word On. The result: On <Date>. If you have Field shadings turned on (View >
Field shading), <Date> has a gray background. Otherwise it does not.
4) To replace first (amount), click the Breakfast field name and drag it to the right of our
breakfast cost. Make sure you have the proper spacing between the field names and the
words before and after them. Result: breakfast cost <Breakfast>.
5) To replace the first (name), click the Bpayment field name and drag it to the right of paid by.
Result: paid by <Bpayment>.
6) In the same way, fill in the rest of the fields in the sentence.

•

Use <Lunch> and <LPayment> for the second set of (amount) and (name) in the
sentence.

•

Use <Supper> and <SPayment> for the third set of (amount) and (name) in the
sentence.
7) Final result: On <Date>, our breakfast cost <Breakfast> paid by <BPayment>, our lunch
cost <Lunch> paid by <LPayment>, and our supper cost <Supper> paid by <SPayment>.
8) Add data to the fields of the sentence:

•

Click the gray box to the left of the row of data you want to add. That row should be
highlighted like the second row of Figure 243.

•

Click the Data to Fields icon (circled). This should fill the fields with the data from the
row you chose.

•

Click another row and then click this icon again. The data in the sentence changes to
this selected row of data.

•

Save the document if you want to use it as an example later.

Figure 243: Selected row in data source window
Adding data in table format is a little easier and takes perhaps fewer steps. Some of the steps will
be quite similar.
1) Navigate to the place you want to place the table and click the location.
2) Control+Click the gray box to the left of each row of the data source that you want to be a
row in your table if the rows are not consecutive. To select consecutive rows, click the gray
box to the left of the top desired row and Shift+click the bottom desired row.
3) Click the Data to text icon to open the Insert Database Columns dialog (Figure 244). (The
Data to text icon is to the left of the Data to Fields icon in Figure 243.)
4) Move the fields you want in your table from the Database Columns list to the Table
column(s) list.

•

To place the fields in the order you select, click the field and use the single arrow to
move the fields in the order you desire. You can also limit the fields you use to less
than all of the fields available.
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• If you want to use all of the fields, use the double arrow pointing to the right to move all
of them at one time. The order of the fields in the table you create will be the same as in
the data source table.

• To remove a single field from the Table Column(s) list, click the field and use the single
arrow pointing to the left.
5) To start over, click the double arrow pointing to the left.
6) Select the settings for your table. Use the default settings as in Figure 244.
7) Click OK. Save the document.

Figure 244: Insert Database Columns dialog

Calc spreadsheets
There are two ways to transfer data into a Calc spreadsheet. One enters the data into the
spreadsheet cells. The other creates complete new records in the spreadsheet. . While you can
directly access the data inserted into the spreadsheet cells, new records created in the
spreadsheet are read-only.
Entering data directly to the spreadsheet cells uses the Data to Text icon as when making a table
in a Writer document. But there are certain differences.
The steps are straightforward.
1) Click the cell of the spreadsheet which you want to be the top left cell of your data,
including the column names.
2) Use F4 to open the database source window and select the table whose data you want to
use.
3) Select the rows of data you want to add to the spreadsheet:

•

Click the gray box to the left of the row you want to select if only selecting one row.
That row is highlighted.

•

To select multiple rows, hold down the Control key while clicking the gray box of the
rows you need. Those rows are highlighted.

•

To select all the rows, click the gray box in the upper left corner. All rows are
highlighted.

4) Click the Data to text icon to insert the data into the spreadsheet cells.
5) Save the spreadsheet.
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Adding records to a spreadsheet is fairly easy. You need to have the Data Source window open,
your spreadsheet open, and the table you want to use selected.
1) Click the gray box containing the field name for the table’s ID field.
2) Drop and drag the gray box for the table’s ID field to where you want the record to appear
in the spreadsheet.
3) Repeat until you have moved all of the fields you need to where you want them.
4) Name and save the spreadsheet.
5) Click a row of the table in the Data Source window.
6) Drag the data in the ID field in the selected row onto the ID field in the spreadsheet. The
Save icon should activate.
7) Click the Edit File button to make the spreadsheet read-only. Click Save when asked if you
want to save the file.
The Data Source window goes blank, the fields in the spreadsheet are populated with data from
the row you selected, and the Form Navigation toolbar appears at the bottom of the spreadsheet.
8) Click the arrows on the Form Navigation toolbar to view the different records of the table.
(The arrows are circled in red.) The number in the box changes when you change the
record number by clicking an arrow. The data in the fields changes correspondingly to the
data for that particular record number.

Figure 245: Navigation arrows of a form

Entering data in a form
Records are used to organize the data we enter into a form. They also organize the data we enter
into a subform
Different types of field allow different methods of data entry. In many cases, more than one
method can be used.
The first step to entering data in a form is to open it from the main database window (Figure 213).
1) Click the Forms icon in the Database list.
2) Find the form’s name in the Forms list (Vacations).
3) Double-click the form’s name.
The quickest way to enter a date in the Date field is to click the arrow that opens the drop down
calendar (Figure 246). Then click the day the you want. Then press the Tab key to go to the
Odometer field.

Figure 246: Calendar drop down
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The Odometer, Tolls, and Motel fields are numeric fields. Enter values directly into them, or use the
up and down arrows. When the value has been entered, use the Tab key to go to the next field.

• Clicking the up arrow increases the value, and the down arrow decreases the value by one
unit.

• These two arrows only change the numerals to the left of the decimal place.
• Numerals to the right of the decimal place must be changed by deleting them and typing
the desired ones.
The Motel’s Payment field is a drop-down list. If, as in my case, all of the elements of the list start
with different letters, typing the first letter selects the desired entry.

• If two or more elements of the list have the same first letter, repeated typing of the first
letter will cycle through these elements.

• When the selection is correct, use the Tab key to go to the Misc. field.
The rest of the fields of the main form are either numeric fields or drop-down lists until we reach the
Misc. Notes field. It is a text field. Type anything you desire in this field just as you would any
simple text editor.

Note

Since the Tab key is used to move between fields, it can not be used in a text field.
All spacing must be done by the spacebar. Furthermore in text fields, the Enter key
acts only as a line break to move the cursor to the next line. While the Enter key will
move between non-text fields, it will not do so from a text field. Use the Tab key
instead.
If we did not have a subform for fuel data, pressing the Tab key in the last field would
save all of the fields, clear them, and make the form ready to accept data on the
second record.

Since we have a subform, using the Tab key places the cursor in the first Date field of the subform
with the date automatically entered to match the Date field of the main form.
The FuelCost, FuelQuantity, and Odometer fields are numeric fields. The Payment field is a dropdown list. Enter the data just as you did in the main form, and use the Tab key to go to the next
field.
When you use the Tab key to leave the Payment field, it goes to the Date field of the next line and
automatically enters the date. Now you can enter your second set of fuel data for this day.
To move to another record when the form has a subform, click any of the fields of the main form. In
this case, click the Date field of the main form. Then use the directional arrows at the bottom.
There are four of them from left to right: First Record, Previous Record, Next Record, and Last
Record (Figure 245). To the right of these arrows is the New Record icon.
To create a new record while in another record in the main form, click either the Next Record icon
or the New Record icon.

Tip

The number in the Record box is the number of the record whose data is shown in
the form.
If you know the number of the record you want, you can enter it into the record box
and then press Enter to take you to that record.

Figure 247 is a record with data inserted in its fields.
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Figure 247: Sample record of the Vacation form and sub form

Creating queries
Queries are used to get specific information from a database. Query results are special tables
within the database.
To demonstrate the use of queries, we will use two different methods:

• Using our CD-Collection table, we will create a list of albums by a particular artist. We will
do this using the Wizard.

• The information we might want from the Fuel table includes what our fuel economy is. We
will do this using the Design View. (Queries that require calculations are best created with
the Design view.)

Using the Wizard to create a query
Queries created by the wizard provide a list or lists of information based upon what one wants to
know. It is possible to obtain a single answer or multiple answers, depending upon the
circumstances.
In the main database window (Figure 213), click the Queries icon in the Databases section, then in
the Tasks section, click Use Wizard to Create Query. The Query Wizard window opens (Figure
248). The information we want is what albums are by a certain musical group or individual (the
album’s author). We can include when each album was bought.

Note

When working with a query, more than one table can be used. Since different tables
may contain the same field names, the format for naming fields in a query is Table
name.field name, with a period (.) between the table name and the field name. For
example, the Lunch field of the Vacation table used in a query has the name
Vacation.Lunch.
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Step 1: Select the fields.
1) Select the CD-Collection table from the drop down list of tables.
2) Select fields from the CD-Collection table in the Available fields list.
a) Click Artist, and use the > button to move it to the Fields in the Query list.
b) Move the AlbumTitle and DatePurchased fields in the same manner.
c) Click Next.

Tip

To change the order of the fields, select the field you want to move and click the up
or down arrow.

Figure 248: First page of the Query Wizard
Step 2: Select the sorting order.
Up to four fields can be used to sort the information of our query. A little simple logic helps at this
point. Which field is most important?
In our query, the artist is most important. The album title is less important, and the date purchased
is of least importance. Of course, if we were interested in what music we bought on a given day,
the date purchased would be the most important.

Figure 249: Sorting order page
1) Click the first Sort by drop down list.
a) Click CD-Collection.Artist to select it.
b) To list the artists in alphabetical order (a-z), select Ascending on the right.
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2) Click the second Sort by drop down list.

•

Click CD-Collection.ArtistTitle. and select Ascending.
3) Repeat this process for CD-Collection.DatePurchased.
4) Click Next.
Step 3: Select the search conditions.
The search conditions allow us to compare the name we entered with the names of the artist in our
database and decide whether to include a particular artist in our query or not.

•
•
•
•
•
•
•

is equal to: the same as
is not equal to: not the same as
is smaller than: comes before
is greater than: comes after
is equal or less than: the same as or comes before
is equal or greater than: the same as or comes after
like: similar to in some way

Note

These conditions apply to numbers, letters (using alphabetical order), and dates.

1) Since we are only searching for one thing, we will use the default setting of Match all of the
following.
2) We are looking for a particular artist, so select CD-Collection. Artist in the Fields list and is
equal to as the Condition.
3) Type the name of the artist in the Value box. Click Next.
Step 4: Select type of query.
We want simple information, so the default setting: Detailed query is what we want. Click Next at
the bottom of the window.

Note

Since we have a simple query, the Grouping and Grouping conditions are not
needed. Steps 5 and 6 of the wizard are skipped in our query.

Step 7: Assign aliases if desired.
We want the default settings. Click Next.
Step 8: Overview.
Name the query (suggestion: Query_Artists). To the right of this are two choices. Select Display
Query. Click Finish.

Using the Design View to create a query
Creating a query using Design View is not as difficult as it may first seem. It may take multiple
steps, but each step is fairly simple.
What fuel economy is our vehicle getting (miles per gallon in the USA)? This question requires
creating two queries, with the first query used as part of the second query.
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Step 1: Open the first query in Design View.

• Click Create Query in Design View.
Step 2: Add tables.

Figure 250: Add Tables or Query dialog
1) Click Fuel to highlight it.
2) Click Add. Click Close.

Tip

Move the cursor over the bottom edge of the fuel table (Figure 250) and drag the
edge to make it longer and easier to see all of the fields in the table.

Figure 251: Fuel table in query
Step 3: Add fields to the table at the bottom.
1) Double-click the FuelID field in the Fuel table.
2) Double-click the Odometer field.
3) Double-click the FuelQuantity field.
The table at the bottom of the query window should now have three columns.
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Figure 252: Query table
Step 4: Set the criterion for the query.
We want the query’s FuelID to begin with the numeral 1.
1) Type >0 in the Criterion cell under FuelID in the query table.
2) Click the Run Query icon in the Query Design toolbar.

Figure 253: Query Design toolbar
Figure 254 contains the Fuel table with my entries and the query results based upon the Fuel table:
the query results are in Figure 255.

Figure 254: Fuel table

Figure 255: Query of Fuel table
Step 5: Save and close the query.
Since this query contains the final odometer reading for our calculations, name it End-Reading
when saving it. Then close the query.
Step 6: Create the query to calculate the fuel economy.
1) Click Create Query in Design View to open a new query.
2) Add the Fuel table to the query just as you did in step 2: Add tables But, do not close the
Add Tables window.
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3) Add the End-Reading query to this query.
a) Click Queries to get the list of queries in the database (Figure 256).
b) Click End-Reading.
c) Click Add, and then click Close.

Figure 256: Selecting queries to add to another query
Step 7: Add fields to the table at the bottom of the query.
We are going to calculate the fuel economy. To do this we need the FuelQuantity and distance
traveled. Since the FuelQuantity we want to use is the final odometer reading, we will use the EndReading query to get it. We will also use the Odometer field from the Fuel table and End-Reading
query.

Figure 257: Tables in this query
1) Double-click FuelQuantity in the End-Reading query.
2) Double-click Odometer in the End-Reading query.
3) Double-click Odometer in the Fuel table.

Figure 258: Added fields to the query
Step 8: Enter the FuelID difference field.
We want the difference between the FuelID value of the Fuel table and FuelID value of the EndReading query to equal one (1).
1) Type "End-Reading"."FuelID" - "Fuel"."FuelID" in the field to the right of the
Odometer field of the Fuel Table.
2) Type the numeral 1 (one) in the Criterion cell of this column.
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3) Calculate the distance traveled:

•
•

Type "End-Reading"."Odometer" – "Fuel"."Odometer" in the Field cell.
Type >0 in the Criterion cell.

4) Calculate fuel economy: Type ("End-Reading"."Odometer" –
"Fuel"."Odometer")/"End-Reading"."FuelQuantity" in the next column to the
right of the word Field.

Figure 259: Typing in calculation of fields

Figure 260: Field for distance traveled calculations

Figure 261: Fuel economy calculation field
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Note

When entering fields for these calculations, you must follow this format: table or
query name followed by a period follow by the field name. For hyphenated or
multiple-word names (table or query), use double quotes around the table or query
name. The query will then add the rest of the double quotes as in Figure 261.
Use the arithmetical symbol between the two. More than one calculation can be
done by using parentheses to group the arithmetical operations.

Step 9: Run the query and make some modification.
After we run the query to make sure it works correctly, we will hide all of the fields that we do not
need.

Figure 262: Result of running the fuel economy query
1) Click the Run Query icon in the Design Query toolbar (Figure 253). The results are in
Figure 262.
Notice that not all of the last column label is visible because some of the labels are long.
We can fix this problem by using an alias for many of the fields. The labels are replaced by
their aliases.
2) Add Aliases:
Type in the aliases as they are listed in Figure 263.

Figure 263: Query table with aliases added
3) Run the query again. The results are in Figure 264.

Figure 264: Query run with aliases
We really do not need the column showing the difference between the FuelID fields from the table
and query, so we will hide it. While it will not be visible, it will still be used in the calculations.
4) Hide a column that does not need to be seen.
Remove the check in the box of the Visible cell as in Figure 265.

Figure 265: Making a field invisible in a query run
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5) Rerun the query (Figure 266).

Figure 266: Query run with a hidden column
Step 10: Close, save, and name the query.
My suggestion for a name is Fuel Economy.
There are obviously other calculations that can be made in this query such as cost per distance
traveled and how much of the cost belongs to each of the payment types.

Note

To fully use queries requires a knowledge of set operations (unions, intersections,
and, or, complements, and any combinations of these). Having a copy of the
HSQLDB User Guide, available from http://hsqldb.org/, is also extremely useful.

Creating reports
Reports provide information found in the database arranged in a useful way. In this respect, they
are similar to queries. Reports are generated from the database’s tables, views, or queries.
All reports are based upon a single table, view, or query, so you need first to decide what fields you
want to use in the report. If you want to use fields from different tables, you must first combine
these fields in a single query or view. Then you can create a report from this.
For example, a report on vacation expenses includes both fuel costs and meal costs. These values
are contained in fields of two different tables: Vacations and Fuel. So this report requires you to
create a query or view.

Caution

Dynamic reports update only the data that is changed or added to a table or query.
They do not show any modifications made to the table or query itself. For example,
after creating the report below, open the fuel economy query created in the previous
section. For the "End-Reading".”Odometer” – “Fuel.”Odometer” column, change the
number 1 to the number 3. The report will be identical before and after you make the
change. But if you add more data to the query and run the report again, it will contain
the new data.

Creating a report
We will create a report on vacation expenses. Certain questions need to be asked before creating
the report.

•
•
•
•
•

What information do we want in the report?
How do we want the information arranged?
What fields are required to provide this information?
Will a query or view have to be created because these fields are in different tables?
Are there any calculations required in the data before being added to the report?

The expenses for our vacation are motel, tolls, miscellaneous, breakfast, lunch, supper, snacks,
and fuel. One possible report could list the totals of each of these expense groups. Another could
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list the expense totals for each day of the vacation. A third could list the totals for each expense
group for each type of payment. (This would let us know where the money came from to pay the
expenses.) Once you create a query to do any one of these, you can create a report based upon
the query.
We will create two reports, one listing the expenses each day (other than fuel) and the second
listing fuel statistics. The fields we need for the first report from the Vacations table are: Date,
Motel, Toll, Breakfast, Lunch, Supper, SnackCost, and Miscellaneous. This report only requires the
Vacation table. Had the report listed the total expenses for each of these fields, we would have to
create a query to provide us with these totals.
The second report involves the Fuel table. Since this table includes fuel purchases at times other
than during the vacation, we need to create a query that contains only the fuel purchased during
the vacation.

Static vs dynamic reports
When creating a report using the Report Wizard, you have a choice of two types of reports in the
last page of the wizard: static or dynamic. What you should select depends more upon whether
you have a working Report Builder extension or not. If this extension works in your version of
LibreOffice, you should select dynamic every time. Otherwise, your selection should depend upon
whether you want to update the report later. In this case, select dynamic. If you choose static, the
report will always contain the data for the original report date.
LibreOffice has always included the Report Builder extension. For some reason, it does not work in
some versions. For these, creating a report is done the same way as is done using OpenOffice.org
3.3, and the Getting Started with Base chapter for OpenOffice.org 3.3 explains the basics for
creating a report that can be used.
With the report builder extension working, selecting the type of report as static gives only a table
layout of the report's data similar to Figure 271 on page 253. The area above the data can be
contain things like the author the report, its date, and its name. A company logo can be placed
there as well. The area below the data can also contain text and fields such as page number of
page count.

Note

Editing a static report will be discussed in Chapter 4 of the Base Guide, Data Output.

When dynamic is selected as the report type and the report builder extension is working, the report
can be edited. Its layout can be in one of two formats: a text document or a spreadsheet. Also, it
can be saved in a variety of formats that are available for Writer and Calc documents.
My recommendation for those that have the report builder extension working in their version of
LibreOffice is that they always select dynamic as the report type. You will have more control over
the layout of the report than if you had selected static instead.

Vacations table report
To create a new report.
1) Click the Reports icon in the Database list in the Automobile – LibreOffice Base window
(Figure 213).
2) In the Tasks list, click Use Wizard to Create Report. The Report Wizard opens.

Tip
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When the Report Wizard opens, the Oracle Report Builder opens in the background.
As you perform the steps of the wizard, it applies these steps to the Report Builder.
You will not be directly using the Report Builder in these steps.
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Step 1: Field selection
1) Select Table: Vacations in the Tables or Queries drop down list.
2) Use the > to move these fields from the Available fields list to the Fields in report list: Date,
Motel, Tolls, Miscellaneous, Breakfast, Lunch, Supper, and SnackCost. Click Next.

Figure 267: Adding fields to a report
Step 2: Labeling fields
Change any field labels you wish. We will shorten Miscellaneous to Misc. and make SnackCost
into two words.
1) Shorten Miscellaneous to Misc.
2) Add a space to separate SnackCost into Snack Cost.
3) Click Next.

Figure 268: Giving aliases to fields
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Step 3: Grouping
Since we are grouping by the date, use the > button to move the Date field to the Grouping list.
Click Next.

Figure 269: Selecting fields for grouping data
Step 4: Sort options
We do not want to do any additional sorting.

• Click Next.
Step 5: Choose layout
Use Columnar, three columns for the layout.
1)
2)
3)
4)

Select Columnar, three columns for the Layout of data.
Layout of headers and footers has no possible selections.
Select Landscape as the Orientation for the page layout.
Click Next.

Figure 270: Report Builder template determined by the Report Wizard
Step 6: Create report
1) Label the report: Vacation Expenses.
2) Select Dynamic report.
3) Click Finish.
The report has been created, but it needs some editing. The date could be formatted better, and all
the numbers need to be formatted as currency. It could use a heading that includes its name, its
author, and the date it was prepared. If the report had more than one page, the page numbers
could be put in a footer of each page, perhaps including the total number of pages.
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Figure 271: Report without modifications
Report Builder: another way to create reports
When we used the Report Wizard, we created a template in Report Builder for our report. If we edit
our report, we open Report Builder with this template. By modifying the template, we also modify
the report. For example, we can change the Date field’s format, and it will change the format of all
the dates contained in that field in the above report. Similarly, we can change the field formatting of
any of the other fields and change the format everywhere that field appears in the report.
Report Builder can also create reports by itself. To do this you click Create Report in design
View. For instructions on how to use the Report Builder, see Chapter 4 of the Base Guide, Data
Output. We will discuss it in detail there.
For detailed instructions on using Report Builder, see Dmitri Popov’s Sun Report Builder
Guidebook, available in PDF (search for “Sun Report Builder Guidebook”) and printed versions
from Lulu.com: http://www.lulu.com/spotlight/writertools

Note

Report Builder is a LibreOffice extension to assist in report creation. With Report
Builder, you can create stylish, complex database reports. You can define group and
page headers, group and page footers, and calculation fields. It is installed by
default with LibreOffice.

Chapter 8 Getting Started with Base

253

Chapter 9
Getting Started with Math
LibreOffice's Equation Editor

What is Math?
Math is LibreOffice’s component for writing mathematical and chemical equations. It is most
commonly used as an equation editor for text documents, but it can also be used with other types
of documents or stand-alone. When used inside Writer, the equation is treated as an object inside
the text document.

Note

The equation editor is for writing equations in symbolic form, as in equation 1. If you
want to evaluate a numeric value, see the Calc Guide.

df (x )
=ln( x )+tan−1 ( x 2)
dx

(1)

or
NH3 + H2 O ⇌NH+4 + OH −

Getting started
You can create an equation (formula) as a separate document or insert it into a document in Writer
or another component of LibreOffice.

Creating an equation as a separate document
To create an equation as a separate document, open the Math component of LibreOffice using one
of these methods:

• On the menu bar, choose File > New > Formula.
• On the standard toolbar, click the triangle to the left of the New icon and choose Formula.
• From the Start Center, click Formula.
An empty formula document opens (see Figure 272).

Figure 272: An empty formula document
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The upper area is the preview window, where the equation will appear during and after input. The
lower area is the equation editor, where the markup code for the equation is entered. The floating
Elements window will also appear.

Inserting a formula into a Writer document
To insert a formula into a Writer document, open the document and then choose Insert > Object >
Formula from the menu bar.
The formula editor opens at the bottom of the Writer window, and the floating Elements window
appears. You will also see a small box with a gray border in your document, where the formula will
be displayed, as shown in Figure 273.

Figure 273: Equation Editor, Elements window, and location of resulting equation in Writer

Tip

If the Elements window is missing, show it with View > Elements.

When you are done entering the formula, you can close the editor by pressing the Esc key or by
clicking an area outside the formula in the main document. A double-click will open the editor
again, so you can edit the formula.
Formulas are inserted as OLE objects. In a Writer document, the formula is anchored as a
character, so it is embedded in the continuous text. You can, as with any other OLE object, change
the anchor and make the formula floating. In Calc, Impress and Draw documents, formulas are
embedded as floating OLE objects.
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If you frequently need to insert formulas, it is advisable to add the Formula button to the Standard
toolbar or create a keyboard shortcut. See Chapter 14, Customizing LibreOffice, for more
information.

Entering a formula
The equation editor uses a markup language to represent formulas. For example, %beta creates
the Greek character beta ( β ). This markup is designed to read similar to English whenever
a
possible. For example, a over b produces a fraction:
.
b
You can enter a formula in three ways:

• Select a symbol from the Elements window.
• Right-click on the equation editor and select the symbol from the context menu.
• Type markup in the equation editor.
The context menu and the Elements window insert the markup corresponding to a symbol. This
provides a convenient way to learn the LibreOffice Math markup.

Note

Click on the document body to exit the formula editor.
Double-click on a formula to enter the formula editor again.

The Elements window
The simplest method for entering a formula is the Elements window.

Figure 274: Symbols are divided into categories
The Elements window is divided into two main parts.

• The top shows the symbol categories. Click on these to change the list of symbols.
• The bottom shows the symbols available in the current category.
Tip

You can hide or show the Elements window with View > Elements.
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Example 1: 5×4
For this example we will enter a simple formula: 5×4 . On the Elements window:
7) Select the top-left button of the categories (top) section.
8) Click on the multiplication symbol.

Figure 275: Selecting the multiplication symbol
When you select the multiplication symbol on the Elements window, two things happen:
• The equation editor shows the markup: <?> times <?>

• The body of the document shows a gray box like this: ❑×❑

Figure 276: Result of selecting the multiplication symbol
The <?> symbols shown in Figure 276 are placeholders that you can replace by other text, for
example 5 and 4. The equation will update automatically, and the result should resemble Figure
277.

Tip
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When you add a formula, reserved placeholders are indicated by squares in the
formula and <?> in the command window. You can navigate through these
placeholders using F4 and Shift+F4.
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Figure 277: Result of entering 5 and 4 next to the times operator

Tip

To keep the equation from updating automatically, select View > AutoUpdate display
to deselect it. To update a formula manually, press F9 or select View > Update.

Right-click (context) menu
Another way to access mathematical symbols is to right-click on the equation editor. This pops up
the menu shown in Figure 278. The items in this menu correspond to those in the Elements
window, with some extra commands.

Figure 278: Right-click (context) menu

Note

Neither the window elements, nor the context menu contain a complete list of
commands. For some seldom-used commands, you must always enter the markup.
A complete list of commands can be found in Appendix of the Math Guide.
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Markup
You can type the markup directly in the equation editor. For example, you can type 5 times 4 to
obtain 5×4 . If you know the markup, this can be the fastest way to enter a formula.
The formula markup resembles the way the formula reads in English.

Tip

Below is a short list of common equations and their corresponding markup.
Display

Command

Display

Command

a=b

a=b

√a

sqrt {a}

a2

a^2

an

a_n

∫ f ( x )dx

int f(x) dx

∑ an

sum a_n

a≤b

a <= b

∞

infinity

a×b

a times b

x⋅y

x cdot y

Greek characters
Greek characters ( α , β , γ ,θ , etc) are common in mathematical formulas. These characters are
not available in the Elements window or the right-click menu. Fortunately, the markup for Greek
characters is simple: Type a % sign followed by the name of the character, in English.

• To write a lowercase character, type the name of the character in lowercase.
• To write an uppercase character, type the name of the character in uppercase.
•

To write in italic, just add an i between % sign and the name of the character.

A complete table of Greek characters is provided in appendix of the Math Guide. See the table
below for some examples.
Lowercase

Uppercase

Italic lowercase

Italic uppercase

%alpha → α

%ALPHA → Α

%ialpha → α

%iALPHA → Α

%beta

→ β

%gamma → γ

%BETA

→ Β

%GAMMA → Γ

%ibeta

→ β

%igamma → γ

%iBETA

→ Β

%iGAMMA → Γ

%psi

→ ψ

%PSI

→ Ψ

%ipsi

→ ψ

%iPSI

→ Ψ

%phi

→ ϕ

%PHI

→ Φ

%iphi

→ ϕ

%iPHI

→ Φ

%theta → θ

%THETA → Θ

%itheta → θ

%iTHETA → Θ

Another way to enter Greek characters is by using the Symbols catalog window. Choose Tools >
Catalog. This window is shown in Figure 279. Under Symbol set, select Greek and double-click on
a Greek letter from the list. The markup name of the character is shown below the list window.
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Figure 279: Symbols catalog, used for entering Greek characters and some special symbols

Example 2: π ≃ 3.14159
For this example we will suppose that:

• We want to enter the above formula (the value of pi rounded to 5 decimal places).
• We know the name of the Greek character (pi).
• But we do not know the markup associated with the ≃ symbol.
Step 1: Type % followed by the text pi. This displays the Greek character π .
Step 2: Open the Elements window (View > Elements).
Step 3: The ≃ symbol is a relation, so we click on the Relations button. If you hover the mouse
over this button you see the tooltip Relations (Figure 280).
Figure 281 shows the Elements window after clicking the Relations button. The symbol we want is
circled.

Figure 280: Tooltip indicates the
Relations button
Figure 281: After selecting Relations
Step 4: Click on the a ≃ b symbol. The equation editor now shows the markup %pi<?> simeq
<?>.
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Step 5: Delete the <?> text, press F4 key and type 3.14159 at the end of the equation. We end
up with the markup %pi simeq 3.14159. The result is shown in Figure 282.

Figure 282. Final result

Changing a formula
You can change a formula at any time. To switch into edit mode, double-click on the formula.
To get to the appropriate section in the markup code, do any one of the following:

• In the equation editor, click on the location.
• Select an area of the markup code that you wish to change.
• Click on an element in the preview area; the cursor will automatically move to the
corresponding point in the equation editor.

• Double-click on an element in the preview area; the corresponding section in the equation
editor will be selected.
To be able to work in the upper (preview) area in the stand-alone Math window (Figure 272), the
formula cursor must be activated. Use the Formula Cursor button on the Tools toolbar.

You can change an equation by overwriting selected text or by inserting new markup code at the
cursor position.

Formula layout
The most difficult part of using LibreOffice Math comes when writing complicated formulas. This
section provides some advice.

Brackets are your friends
Math knows nothing about order of operation. You must use brackets to state the order of
operations explicitly. Consider the following examples.
Markup
2 over

Result
x + 1

– 1 over 2
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Markup

Result

2
+1
x

2 over {x + 1}

2
x +1

−1
2

– {1 over 2}

−

1
2
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In the first example, Math has recognized that the 2 before and the x after the over belong to the
fraction, and has represented them accordingly. If you want x+1 rather than x to be the
denominator, you must bracket them together so that both will be placed there.
In the second example, Math has recognized the minus sign as a prefix for the 1 and has therefore
placed it in the numerator of the fraction. If you wish to show that the whole thing is negative, with
the minus sign in front of the fraction, you must put the fraction in brackets in order to signify to
Math that the characters belong together.
The braces belong solely to the layout of the markup code and are not printed. If you wish to use
braces in the formula, use the commands lbrace and rbrace.
Compare the following examples:
Markup

Result

x over {–x + 1}

Markup

x
−x +1

Result

x over lbrace –x + 1
rbrace

x
{−x +1}

Brackets with matrices look ugly!
For background, we start with an overview of the matrix command.
Markup

Result
a b
c d

matrix { a # b ## c # d }

Rows are separated by two #’s and entries within each row are separated by one #.

Note

The first problem people have with matrices is that brackets do not scale with the matrix:
Markup
(

Result

matrix { a # b ## c # d }

(a b)
c d

)

Math provides scalable brackets. That is, the brackets grow in size to match the size of their
contents. Use the commands left( and right) to make scalable brackets.
Markup
left(

Tip

Result
matrix { a # b ## c # d }

right)

( )
a b
c d

Use left[ and right] to obtain square brackets. The list of all available brackets is
available in appendix of Math Guide.

These scalable brackets may also be used with any element, such as fraction, square root, etc.
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Isolated and unpaired brackets
Math expects that for every opening bracket there will be a closing one. If you forget a bracket,
Math places an inverted question mark by the corresponding bracket. This disappears when all
brackets are matched. Sometimes forgetting a bracket causes the whole structure of the formula to
fall apart.
However, an unpaired bracket is sometimes necessary. In such cases, you have two options:

• With non-scalable brackets, use a preceding backslash \ to indicate that the following
character should not be regarded as a bracket but as a literal character. So the half-open
interval [a;b[ is represented by \[a;b\[ — try comparing this with [a;b[

• Scalable brackets can also be unpaired. The same half-open interval is represented by
left [ a; b right [
For scalable brackets, you can also use the command none to replace a non-existent paired
bracket.

{

∣ x∣= x for x≥0
−x for x <0
can be represented by
abs x = left lbrace stack {x "for" x >= 0 # -x "for" x < 0} right none

Recognizing functions in Math
In the basic installation, Math outputs variables in italics. If you enter a function, Math usually
recognizes it and outputs it normally (a list of recognized functions is available in the Math Guide).
If Math fails to recognize a function, you can inform Math about it. Enter the markup code func
before the function, and the following text will be recognized as a function.
Some functions recognized by Math need to be followed by numbers or variables. If these are
missing, Math puts an inverted red question mark ¿ in their place, which you can only remove by
correcting the formula: enter a variable or a number, or a pair of empty braces { } as a placeholder.

Tip

You can navigate through errors using F3 and Shift+F3.

Equations over more than one line
Suppose you want to make an equation covering more than one line, for example:

x =3
y =1

Your first reaction would be to simply press the Enter key. However, if you press the Enter key,
although the markup goes to a new line, the resulting equation does not. You must type the
newline command explicitly. This is illustrated in the table below.
Markup
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Result

x = 3
y = 1

x =3 y =1

x = 3 newline
y = 1

x =3
y =1

Getting Started with LibreOffice 3.5

Continuing the calculation on a new line without writing a complete new equation is not directly
possible, because Math expects a term on the left hand side of an equals sign. You can substitute:

• Empty quotes "". This will automatically cause the line to be left-justified.
• Empty braces { }. The following line will then be centered.
• Spaces characters ` or ~. The line will be centered with the spaces.
The alignment of equals signs under each other is described on page 267.
As well, spacing between elements in formulas are not set by space characters in the code. You
need to use special markup to add spaces: ` (grave) for a small space, ~ for a large space.
Another solution would be to add space characters between quotes, to be considered as text.
Space markup at the end of a formula are ignored by default.

How do I add limits to my sum/integral?
The sum and int commands (see complete list in appendix of Math Guide) can (optionally) take the
parameters from and to. These are used for lower and upper limits respectively. These parameters
can be used singly or together.
Markup

Result
n

sum from k = 1 to n a_k

∑ ak
k= 1

int from 0 to x f(t) dt
or

x

∫ f (t )dt
0

or

x

∫0 f (t ) dt

int_0^x f(t) dt
int from Re f

∫f

sum to infinity 2^{-n}

∑ 2−n

ℜ

∞

How do I write a derivative?
Writing derivatives essentially comes down to one trick: Tell LibreOffice it’s a fraction.
In other words, you have to use the over command. Combine this with either the letter d (for a total
derivative) or the partial command (for a partial derivative) to achieve the effect of a derivative.

Note

Notice that we have to use braces (squiggly brackets) to make the derivative.
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Markup

Result

{df} over {dx}

df
dx

{partial f} over {partial y}

∂f
∂y

{partial^2 f} over {partial t^2}

∂2 f
∂t 2

To write function names with primes, as is usual in school notation, you must first add the signs to
the catalog. Using single and double quotes is typographically ugly. See “Customizing the catalog”
on page 273.

Markup characters as regular characters
Characters that are used for controlling markup cannot be entered directly as normal characters.
The characters concerned are: %, {, }, &, |, _, ^ and ". So, for example, you cannot write 2% =
0.02 or 1" = 2.56cm. Two methods are available to overcome this limitation:

• Use double quotes to mark the character as text, for example 2"%"= 0.02. Obviously this is
not possible for the double-quote character itself.

• Add the character to the catalog. See the section “Customizing the catalog” on page 273.
In some cases you can use commands:

• lbrace and rbrace give you literal braces {}.
• mline gives you the vertical line, for example 2 mline 3 for (2∣3)
Conversion into a character entity as in HTML or the use of an escape character is not possible in
Math.

Text in a formula
To include text in a formula, enclose it in straight double-quotes:
abs x = left lbrace matrix {x # "for " x >= 0 ## -x # "for " x < 0} right none

{

∣ x∣= x for x ≥0
−x for x <0
All characters except double quotes are permissible in text. Unfortunately the Special characters
dialog is not available. If necessary, you can write the text in a text document and copy it into the
equation editor via the clipboard. In this way smart quotes can be inserted, as shown below.
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Figure 283: Smart quotes included by copy and paste from Writer.
Text is shown in the font that was selected from the Text list in the Fonts dialog (compare with the
section “Changing the font” on page 269). To use a font from the lower window of the equation
editor, set the attribute Serif, Sans or Fixed before the text.
By default, text is left-justified. You can change the justification with alignc or alignr.
Commands are not interpreted within text. Use quotes to break up the text if you wish to use
special formatting commands.
"In " color blue bold "isosceles" "triangles, the base angles are equal"

In isosceles triangles, the base angles are equal

How do I align my equations at the equals sign?
Math does not have a command for aligning equations on a particular character, but you can use a
matrix to do this, as shown below.
Markup

Result

matrix{
alignr x+y # {}={} # alignl 2 ##
alignr x

# {}={} # alignl 2-y

x+ y
x

= 2
= 2− y

}

The empty braces around = are necessary because = is a binary operator and thus needs an
expression on each side.
You can reduce the spacing around = if you change the inter-column spacing of the matrix:
1) With the equation editor open, choose Format > Spacing from the menu bar.
2) In the Spacing dialog (Figure 284), click the Category button and select Matrices in the
drop-down menu.
3) Enter 0% for Column spacing and click OK.
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Figure 284: Changing spacing in a matrix formula

Changing the appearance of formulas
Changing the font size
This is one of the most common questions people ask about LibreOffice Math. The answer is
simple, but not intuitive:
1) Start the formula editor and choose Format > Font size.
2) Select a larger font size under Base size (top-most entry).

Figure 285. Edit Base size (top) to make a formula bigger
The result of this change is illustrated in Figure 286.

Figure 286. Result of changing the base font size
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Note

The change in font size applies only to the current formula. To change the font size
generally, click on the Default button and then OK. A general change in the font size
might, for example, make your work easier when you are preparing a big
presentation and want all the formulas in it to have a base size of 28pt—but do not
forget to set the font size back to its original value when the work is finished.
Warning: this modify only current formula and future formulas you will write. To
modify all formulas already existing in the document, you need to use a macro (see
section about macros in Math Guide).

The size of a subset of characters in a formula may be modified using the size command. For
example: b size 5{a} : b a . In the Elements window, the icon
on the Attributes tab gives
the size command. The value just after size may be absolute (numeric value) or relative to the
context (base size by default): for example, +6, -3, /2, or *2/

Changing the font
The fonts used in formulas can be changed using Format > Fonts.
The Formula fonts section of the Fonts dialog (Figure 287) refers to the four specified formula
elements. The font for operators, relationships and brackets is not affected, as these elements
normally come from the OpenSymbol font. Similarly elements from the catalog (see “Customizing
the catalog” on page 273) continue to be displayed in the font specified there.

Figure 287: Fonts dialog
The Custom fonts section determines which font will be used when the attribute font serif, font
sans or font fixed is specified.
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To change a font, first click on Modify and choose the type of entry you wish to modify. The Fonts
dialog opens, showing all the fonts available on your system.

Figure 288: Font dialog
If you enter an initial character in the upper text box, the list will jump to that place. By entering a
few additional characters, you can specify the exact font that you want. If you do not know its
name, use the scrollbar to scroll through them. Click on any name and the box below will show a
preview.
Variables should be written in italics, so make sure that the Italic box is checked. For all other
elements, use the basic (Roman) form. The style can be easily altered in the formula itself by using
the commands italic or bold to set these characteristics and nitalic or nbold to unset them.
When you have chosen a new font for a formula, the old font remains in the list alongside the new
one and can be selected again. This applies only to the current session; the old font is not stored
permanently.
You can choose whatever fonts you like, but if you are exchanging documents with someone else,
you should choose fonts that are present on your colleague’s computer.

Changing the color
Use the command color to change the color of a subset of a formula: color red ABC gives
ABC . Choose from 8 colors: white, black, cyan, magenta, red, blue, green, yellow.
You may give a color to a subset of a formula if it is gathered between { } or other parentheses.
For instance: A B color green {C D} E gives A BC D E .
If several colors are used, the one the more inside the formula is applied as with this example :
color blue {A B color yellow C D} gives A BC D .
It is not possible to select a background color: it is always transparent in Math. The background
color of the whole formula is then the same as the background of the document or frame (in a text
document for instance). In Writer, you can use object properties (right-click > Object) to choose a
background color for the whole formula (see “Background, borders, and size” on page 273).
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Formulas in Writer documents
Numbering equations
Equation numbering is one of Writer’s best hidden features. The steps are simple, but obscure:
1) Start a new line.
2) Type fn and then press F3.
The fn is replaced by a numbered formula:

E=mc 2

(2)

Now you can double-click on the formula to edit it.
You can reference an equation (“as shown in Equation (2)”) with these steps:
1) Choose Insert > Cross-reference from the menu bar.
2) On the Cross-references tab (Figure 289), under Type, select Text.
3) Under Selection, select the equation number.
4) Under Insert reference to, select Reference.
5) Click Insert.
If you later add more equations to the paper before the referenced equation, all the equations will
automatically renumber and the cross-references will update.

Tip

To insert the equation number without parentheses around it, choose Numbering
instead of Reference under Insert reference to.

Figure 289: Inserting a cross-reference to an equation number
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The AutoText inserted as a result of the above procedure consists of a 1x2 table. The left cell
contains the formula and the right one the number. The number is an automatic counter named
Text. You can edit the AutoText if, for example, you prefer square rather than round brackets, or if
you want formula and number to be separated by tabs rather than formatted as a table. Read the
section on “Using AutoText” in Chapter 3 (Working with Text) in the Writer Guide.

Position
Normally a formula is anchored As character in a Writer document. But as with any other OLE
object, you can change the anchoring mode to position the formula where you want it. For more
information, see Chapter 11 (Graphics, the Gallery, and Fontwork) of the Getting Started guide.
By default, formula objects anchored As character are automatically aligned vertically to the
baseline of the surrounding text. To align the formula manually, go to Tools > Options >
LibreOffice Writer > Formatting Aids and uncheck the option Math baseline alignment. This
setting is stored with the document and applies to all formulas within it. New documents use the
current setting from this dialog.

Margins
An inserted Math object has margins to left and right of it, separating it from surrounding text. If you
do not want this, it is best to alter the frame style for formulas, as this will apply simultaneously to
all existing formulas and those still to be inserted in the document. Proceed as follows:
1) Press F11. The Styles and Formatting dialog opens.
2) Click on the Frame Styles tab.
3) Find the Formula frame style and right-click on it.
4) Choose Modify from the context menu. The Frame Style dialog opens.
5) Switch to the Wrap tab of the dialog. Change the values for Left and Right in the Spacing
section to 0.00.
6) Click OK to close the dialog.
This changes the spacing for all formulas that have not had their spacing adjusted manually. You
can find more information on using styles in “Default layout with style” on page 275 and in Chapter
3 (Using Styles and Templates) of the Getting Started guide.

Text mode
Larger formulas should always be in a paragraph of their own, separated from the text. When you
use formula elements in running text, they can often be higher than the letter height.
However, if it is necessary to place a formula within running text, switch into the equation editor
and go to Format > Text mode. Math will try to shrink the formula to fit the letter height. The
numerators and denominators of fractions are shrunk, and the limits of integrals and sums are
placed beside the integral/sum sign.

Example:
A formula in a separate paragraph:
5

∑ i2
i =2

and the same formula embedded in text mode: ∑5i= 2 i 2
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Background, borders, and size
With regard to formatting, formulas are treated as objects of the Frame Style type with the Formula
frame style. Background color and borders can be set using this style or directly with Format >
Frame/Object, or by right-clicking the formula and choosing Object from the context menu. In the
basic installation, formulas have a transparent background and no borders. The size of a formula
cannot be adjusted; in a Writer document it depends directly on the way the formula is constructed
(see “Changing the font size” on page 268).

Creating a formula library
When you use the Math component of LibreOffice directly with File > New > Formula, you create
documents with the file suffix .odf, each containing a single formula. You can use these to build up
a library of frequently-used formulas. Embedded formulas can also be stored as separate Math
documents by right-clicking on the formula and choosing Save copy as from the context menu. To
insert such a Math document into a Writer document, use Insert > Object > OLE Object. Select
the option Create from file and enter the pathname of the file or browse for it using your system’s
file manager by pressing the Search button.

Note

You cannot insert the document by dragging and dropping with the mouse, nor by
using Insert > File.

Formulas cannot be stored in the gallery because they are not in graphical format. You can
however store a formula as AutoText. Write the formula in a separate paragraph, select it and go to
Edit > AutoText. For further information see “Using AutoText” in Chapter 3 (Working with Text) in
the Writer Guide.

Fast insertion of formulas
If you already know the markup of your formula, here is a faster method to build your formula:

• Write formula markup in Writer.
• Select the markup.
• Insert the formula using a toolbar button, a menu item, or a keyboard shortcut.
This method avoids the need to open and close the Math window and thus saves time.

Customizations
Customizing the catalog
If you need to use a symbol that is not available in Math, you can add it to the catalog yourself. The
following example shows the procedure for symbols that are used in marking school work.
1) Go to Tools > Catalog or click on the catalog button
to open the Symbols catalog
(Figure 279).
2) Click the Edit button. The Edit symbols window (Figure 290) opens.
3) The symbols are arranged in so-called symbol sets. In the lower part of the window, choose
an available set for your new symbol from the Symbol set list, for example the Special set.
Or you can type the name of a new symbol set directly into the box.
4) From the Font list, choose a font that contains the desired symbol.

Chapter 9 Getting Started with Math

273

5)
6)
7)
8)
9)

When you have selected a font, its characters appear in the font summary window. You can
scroll through it using the scrollbar at the side, or use the Subset list to go straight to the
place you need.
To follow this example, choose the font DejaVu Sans and the subset General punctuation.
Click on the desired symbol (here Ux2032). It appears enlarged in the right-hand preview
box (see Figure 291). Make sure that the symbol set is set to Special.
In the Symbol field, enter a name for the symbol, for example prime.
If the name is not already in use, the Add button becomes active. Click on it.
You can immediately add more symbols. In the example, the “U+2033” symbol, named
dblprime, and the “U+2034” symbol, named triprime, are added (see Figure 292).
Click OK to close the dialog.

Figure 290: Edit Symbols dialog

Figure 291: Edit Symbols dialog: characters selected
Now the Symbol set view area shows the new symbol. It can be selected just like the other
symbols, either from here, or by writing them directly into the equation editor in the form %prime.

Caution
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Symbols (Greek or Special), in contrast to commands, are case sensitive
(lowercase/uppercase).
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Numerous free fonts contain a great number of mathematical symbols. The “STIX1” font is worthy
of special mention here. It was developed specially for writing mathematical/technical texts. The
DejaVu2 and Lucida3 fonts also have a wide range of symbols.

Figure 292: Catalog with new symbol

Note

Many symbols occur in more than one font. If you want to exchange documents with
others, take care to use a font that is installed on their machine.

In the basic LibreOffice installation, only those user-defined symbols that actually occur in the
document are stored with it. Sometimes it is useful to embed all the user-defined symbols, for
example when the document is going to be further edited by another person. Go to Tools >
Options > LibreOffice Math and on the Settings page, uncheck the option Embed only used
symbols (smaller file size).This setting is only available when you are working on a Math
document.

Default layout with style
In Writer, formulas are formatted according to the Formula
frame style. In the Style and Formatting window (displayed
with F11), click on the third icon at the top: Frame Styles.
Right-click on Formula and select Modify. By this means,
you can directly modify all formulas in your document,
regarding spacing (page 272) or background (page 273),
unless you manually modify formula formatting.
To apply this style in all your new Writer documents, you
Figure 293: Modify Frame Style
must include the Formula style in your default template. To
Formula
do so, create a new Writer document and modify the Formula
frame style as you wish. Save the document using File > Templates > Save. To define this
template as your default template, select File > Templates > Organize and double-click on My
Templates. Right-click on the template you just created and choose Set As Default Template. If
you wish to return to the default template given at installation, use the command Reset Default
Template.
New text documents will be based on this template.

1 Font files for STIX are available from http://www.stixfonts.org
2 Font files for DejaVu Sans are available from http://www.dejavu-fonts.org
3 Lucida Sans belongs to the JRE package, which is probably already on your computer.
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Application to chemical formulas
Math was designed to build mathematical formulas, but it can also be used to write chemical
formulas. In chemistry, formulas look like H2O: names are usually non-italic uppercase. To write
chemical formulas with Math, you may begin with setting non-italic for variables (see “Changing the
font” on page 269).
Here some examples of chemical formulas:
Construction

Example

Entry

Molecules

H2 SO4

H_2 SO_4 (please note the space!)

Isotopes

238
92

U lsub 92 lsup 238

Ions

SO2−
4

SO_4^{2-{}} or SO_4^{2"-"}

U

Notes: lsub or lsup are abreviations for left subscript and left superscript. Empty braces after 2are necessary to avoid errors as there is no right member after the minus sign.
For reversible reactions, there is no satisfactory double arrow in Math. If you have a font with a
correct symbol, you may use the method described in “Customizing the catalog” on page 273. For
instance, DejaVu fonts have these double arrows ⇄ ⇆ ⇋ ⇌.
Otherwise, you may find a special character in a document and copy it, for instance in this formula:
C+O ⇌ CO "⇌". You will find other double arrows here:
http://dev.w3.org/html5/html-author/charref from character x021C4.

Math commands – Reference
The complete list of commands and reserved words used by Math is available in the Math Guide:

•
•
•
•
•
•
•
•
•
•
•
•
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Unary / binary operators
Relations
Set operations
Functions
Operators
Attributes
Brackets
Formats
Others
Characters – Greek
Characters – Special
Reserved words in alphabetic order
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Chapter 10
Printing, Exporting, and
E-mailing

Introduction
This chapter provides general information about printing, exporting, and e-mailing documents from
LibreOffice.

Quick printing
Click the Print File Directly icon
your computer.

Note

to send the entire document to the default printer defined for

You can change the action of the Print File Directly icon to send the document to
the printer defined for the document instead of the default printer for the computer.
Go to Tools > Options > Load/Save > General and select the Load printer
settings with the document option.

Controlling printing
Note for
Mac users

If you prefer to use the standard Mac Print dialogs, deselect the Print dialogs – Use
LibreOffice dialogs option in LibreOffice > Preferences > General.
This book uses the LibreOffice Print dialogs in illustrations.

For more control over printing, use the Print dialog (File > Print or Ctrl+P).

Figure 294. The Print dialog
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The Print dialog has four tabs, from which you can choose a range of options, as described in the
following sections.
The options selected on the Print dialog apply to this printing of this document only.

Note

To specify default printing settings for LibreOffice, go to Tools > Options >
LibreOffice – Print and Tools > Options > LibreOffice Writer – Print. See
Chapter 2, Setting Up LibreOffice, for more details.

The different components of LibreOffice have different available print settings, as summarized in
Table 7.
Table 7: Print options in LibreOffice components
Feature

Writer

Calc

Impress

Draw

Select pages/sheets/slides to print

Yes

Yes

Yes

Yes

Print multiple pages/sheets/slides on one
page

Yes

Yes

Yes

Yes

Print a brochure

Yes

No

Yes

Yes

Print envelopes

Yes

No

No

No

Print labels or business cards

Yes

No

No

No

Preview pages/sheets before printing

Yes

Yes

No

No

Selecting general printing options
On the General tab of the Print dialog, you can choose:

• The printer (from the printers available)
• Which pages to print, the number of copies to print, and whether to collate multiple copies
(Range and copies section)

• Whether to print any comments that are in the document, and where to print the
comments.
Some selections may not be available all the time. For example, if the document contains no
comments, the Print – Comments drop-down list does not work.

Figure 295: Choosing whether and where to print comments
Select the Properties button to display a dialog where you can choose portrait or landscape
orientation, which paper tray to use, and the paper size to print on.
On the Options tab of the Print dialog (Figure 296), the last item, Use only paper tray from printer
preference, is not available in Calc.
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Figure 296: General print options

Printing multiple pages on a single sheet of paper
You can print multiple pages of a document on one sheet of paper. To do this:
1) In the Print dialog, select the Page Layout tab (Figure 297).

Figure 297: Printing multiple page per sheet of paper
2) In the Layout section, select from the drop-down list the number of pages to print per sheet.
The preview panel on the left of the Print dialog shows how the printed document will look.
When printing more than 2 pages per sheet, you can choose the order in which they are
printing across and down the paper.
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3) In the Page sides section, select whether to print all pages or only some pages. Click the
Print button.

Tip

In Writer, to print two pages per sheet in “facing pages” (book layout) style, print from
Print Preview instead. See page 286.

Selecting pages/sheets/slides to print
In addition to printing a full document, you can choose to print individual pages/sheets/slides,
ranges of pages/sheets/slides, or a selection of a document. The details vary slightly in Writer,
Calc, Draw and Impress, as described in this section.

Writer
Printing an individual page:
1) Choose File > Print from the menu bar.
2) On the Print dialog, select the page to print.
a) In the Ranges and copies section of the General page, select the Pages option.
b) Enter the sequence number of the page you want to print. This may differ from the page
number if you have restarted page numbering within the document. The preview box
changes to show the selected page.
3) Click the Print button.
Printing a range of pages:
1) Choose File > Print from the menu bar.
2) On the Print dialog, select the range of pages to print.
a) In the Ranges and copies section of the General page, select the Pages option.
b) Enter the sequence numbers of the pages to print (for example, 1–4 or 1,3,7,11).
3) Click the Print button.
Printing a selection of text:
1) In the document, select the material (text and graphics) to print.
2) Choose File > Print from the menu bar.
3) The Ranges and copies section of the Print dialog now includes a Selection option and the
preview box shows the selected material. See Figure 298.
4) Click the Print button.
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Figure 298: Printing a selection of text

Calc
You can choose single sheets, multiple sheets, and selections of cells for printing.

Figure 299: Choosing what to print in Calc
Printing an individual sheet:
1) In the spreadsheet, click on the sheet tab to select the sheet you want to print.
2) Choose File > Print from the menu bar.
3) In the Ranges and copies section of the Print dialog, choose the Selected sheets option.
4) Click the Print button.
282

Getting Started with LibreOffice 3.5

Printing a range of sheets:
1) In the spreadsheet, select the sheets to print.
a) Select the first sheet.
b) Hold down the Control key.
c) Click on the additional sheet tabs.
d) Release the Control key when all required sheets are selected.
2) Choose File > Print from the menu bar.
3) In the Ranges and copies section of the Print dialog, choose the Selected sheets option.
4) Click the Print button.
Printing a selection of cells:
1) In the document, select the section of cells to print.
2) Choose File > Print from the menu.
3) In the Ranges and copies section of the Print dialog, select the Selected cells option.
4) Click the Print button.

Caution

After printing, be sure to deselect the extra sheets. If you keep them selected, the
next time you enter data on one sheet, you enter data on all the selected sheets.
This might not be what you want.

Impress and Draw
You can choose individual slides, ranges of slides, or selections of slides for printing.

Printing an individual slide:
1) Choose File > Print from the menu bar.
2) Select the slide to print.
a) In the Ranges and copies section of the Print dialog, select the Slides option.
b) Enter the number of the slide to print.
3) Click the Print button.
Printing a range of pages:
1) Choose File > Print from the menu bar.
2) Select the slides to print.
a) In the Ranges and copies section of the Print dialog, select the Slides option.
b) Enter the number of the slides to print (for example 1-4 or 1,3,7,11).
3) Click the Print button.
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Printing a selection of a slide, or a selection from multiple slides:
1) In the document, select the section of the slide to print.
2) Choose File > Print from the menu bar.
3) Select the Selection option in the Ranges and copies section of the Print dialog.
4) Click the Print button.

Printing handouts, notes, or outlines in Impress
Handouts prints the slides in reduced size on the page, from one to nine slides per page. The
slides can be printed horizontally (landscape orientation) or vertically (portrait orientation) on the
page.
Notes prints a single slide per page with any notes entered for that slide in Notes View.
Outline prints the title and headings of each slide in outline format.
To print handouts, notes, or outlines:
1) Choose File > Print from the menu bar.
2) In the Print section of the Print dialog, select the required option.
3) For Handouts, you can then choose how many slides to print per page, and the order in
which they are printed.
4) Click the Print button.

Printing a brochure
In Writer, Impress, and Draw, you can print a document with two pages on each side of a sheet of
paper, arranged so that when the printed pages are folded in half, the pages are in the correct
order to form a booklet or brochure.

Tip

Plan your document so it will look good when printed half size; choose appropriate
margins, font sizes, and so on. You may need to experiment.

To print a brochure on a single-sided printer:
1. Choose File > Print.
2. In the Print dialog, click Properties.
3. Check the printer is set to the same orientation (portrait or landscape) as specified in the
page setup for your document. Usually the orientation does not matter, but it does for
brochures. Click OK to return to the Print dialog.
4. Select the Page layout tab in the Print dialog.
5. Select the Brochure option.
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6. In the Page sides section, select Back sides / left pages option from the Include drop-down
list.

7. Click the Print button.
8. Take the printed pages out of the printer, turn the pages over, and put them back into the
printer in the correct orientation to print on the blank side. You may need to experiment a bit
to find out what the correct arrangement is for your printer.
9. On the Print dialog, in the Page sides section, select Front sides / right pages option from
the Include drop down box.
10. Click the Print button.

Tip

If your printer can print double-sided automatically, choose All pages.

Printing envelopes, labels, business cards
Printing envelopes, labels, or business cards using Writer involves two steps: setup and printing.
For details of how to set these up, see Chapter 11, Using Mail Merge, in the Writer Guide. To print:
1) Choose File > Print from the menu bar.
2) On the Print dialog, under Ranges and copies, choose Pages and type 1 in the box. Click
the Print button.

Printing in black and white (on a color printer)
You may wish to print documents in black and white on a color printer. Several choices are
available. Please note that some color printers may print in color regardless of the settings you
choose.
Change the printer settings to print in black and white or grayscale:
1) Choose File > Print to open the Print dialog.
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2) Click Properties to open the Properties dialog for the printer. The available choices vary
from one printer to another, but you should find options for the Color settings. See your
printer’s help or user manual for more information.
3) The choices for color might include black and white or grayscale. Choose the required
setting.
4) Click OK to confirm your choice and return to the Print dialog,
5) Click the Print button to print the document.

Tip

Grayscale is best if you have any graphics in the document.

Change the LibreOffice settings to print all color text and graphics as grayscale:
1) Choose Tools > Options > LibreOffice > Print.
2) Select the Convert colors to grayscale option. Click OK to save the change.
3) Open the Print dialog (File > Print).
4) Click the Print button to print the document.
Change the LibreOffice Writer (or Calc, Impress, Draw) settings to print all color text as black, and
all graphics as grayscale:
1) Choose Tools > Options > LibreOffice Writer > Print.
2) Under Contents, select the Print text in black option. Click OK to save the change.
3) Open the Print dialog (File > Print).
4) Click the Print button to print the document.

Previewing pages/sheets before printing
You can use the previewing options in Writer and Calc to view the document as it will be printed.
Different viewing options are available.

Writer
The normal page view in Writer shows you what each page will look like when printed and you can
edit the pages in that view. If you are designing a document to be printed double-sided, you may
want to see what facing pages look like. Writer provides two ways to do this:

• View Layout (editable view): use the Facing Pages (Book Preview) button on the status bar.

• Page Preview (read-only view).
To use Page Preview:
1) Choose File > Page Preview (or click the Page Preview button
on the Standard
toolbar).
Writer now displays the Page Preview toolbar instead of the Formatting toolbar.

Figure 300. Page Preview toolbar (Writer)
2) Select the required preview icon: Two Pages (
Preview (
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3) To print the document from this view, click the Print document icon(
dialog. Choose the print options and click the Print button.

) to open the Print

Calc
To preview the sheets in Calc before printing:
1) Choose File > Page Preview.
The Calc window now displays the Page Preview toolbar instead of the Formatting toolbar.

Figure 301. Page Preview toolbar (Calc)
2) To print the document from this view, click the Print document icon
dialog.
3) Choose the print options and click the Print button.

to open the Print

Exporting to PDF
LibreOffice can export documents to PDF (Portable Document Format). This industry-standard file
format is ideal for sending the file to someone else to view using Adobe Reader or other PDF
viewers.
The process and dialogs are the same for Writer, Calc, Impress, and Draw, with a few minor
differences mentioned in this section.

Quick export to PDF
Click the Export Directly as PDF icon
to export the entire document using the PDF settings
you most recently selected on the PDF Options dialog. You are asked to enter the file name and
location for the PDF file, but you do not get a chance to choose a page range, the image
compression, or other options.

Controlling PDF content and quality
For more control over the content and quality of the resulting PDF, use File > Export as PDF. The
PDF Options dialog opens. This dialog has five pages (General, Initial View, User Interface, Links,
and Security). Select the appropriate settings, and then click Export. Then you are asked to enter
the location and file name of the PDF to be created, and click Save to export the file.

General page of PDF Options dialog
On the General page, you can choose which pages to include in the PDF, the type of compression
to use for images (which affects the quality of images in the PDF), and other options.
Range section
• All: Exports the entire document to PDF.

• Pages: To export a range of pages, use the format 3-6 (pages 3 to 6). To export single
pages, use the format 7;9;11 (pages 7, 9, and 11). You can also export a combination of
page ranges and single pages, by using a format like 3-6;8;10;12.

• Selection: Exports all the selected material.
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Figure 302: General page of PDF Options dialog
Images section
• Lossless compression: Images are stored without any loss of quality. Tends to make
large files when used with photographs. Recommended for other kinds of images or
graphics.

• JPEG compression: Allows for varying degrees of quality. A setting of 90% works well with
photographs (small file size, little perceptible loss of quality).

• Reduce image resolution: Lower-DPI (dots per inch) images have lower quality. For
viewing on a computer screen generally a resolution of 72dpi (for Windows) or 96dpi
(GNU/Linux) is sufficient, while for printing it is generally preferable to use at least 300 or
600 dpi, depending on the capability of the printer. Higher dpi settings greatly increase the
size of the exported file.

Note

EPS (Encapsulated PostScript) images with embedded previews are exported only
as previews. EPS images without embedded previews are exported as empty
placeholders.

General section
• Embed OpenDocument file: Makes this PDF easily editable in LibreOffice or similar
programs.

• PDF/A-1a: PDF/A is an ISO standard for long-term preservation of documents, by
embedding all the information necessary for faithful reproduction (such as fonts) while
forbidding other elements (including forms, security, and encryption). PDF tags are written.
If you select PDF/A-1a, the forbidden elements are grayed-out (not available).

• Tagged PDF: Tagged PDF contains information about the structure of the document’s
contents. This can help to display the document on devices with different screens, and
when using screen reader software. Some tags that are exported are table of contents,
hyperlinks, and controls. This option can increase file sizes significantly.

• Create PDF form - Submit format: Choose the format of submitting forms from within the
PDF file. This setting overrides the control’s URL property that you set in the document.
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There is only one common setting valid for the whole PDF document: PDF (sends the
whole document), FDF (sends the control contents), HTML, and XML. Most often you will
choose the PDF format.

• Export bookmarks: Exports headings in Writer documents, and page or slide names in
Impress and Draw documents, as “bookmarks” (a table of contents list displayed by most
PDF viewers, including Adobe Reader).

• Export comments: Exports comments as PDF notes. You may not want this!
• Export automatically inserted blank pages: If selected, automatically inserted blank
pages are exported to the PDF. This is best if you are printing the PDF double-sided. For
example, books usually have chapters set to always start on an odd-numbered (right-hand)
page. When the previous chapter ends on an odd page, LibreOffice inserts a blank page
between the two odd pages. This option controls whether to export that blank page.

• Embed standard fonts: Normally the 14 standard PostScript fonts are not embedded in a
PDF file, because PDF reader software already contains these fonts. However, you can
choose to embed these fonts in all PDF documents created by LibreOffice to enhance
display accuracy in PDF viewers. Font embedding may also be required by some printers.

Initial View page of PDF Options dialog
On the Initial View page (Figure 303), you can choose how the PDF opens by default in a PDF
viewer. The selections should be self-explanatory.
If you have Complex Text Layout enabled (in Tools > Options > Language settings >
Languages), an additional selection is available under Continuous facing: First page is left
(normally, the first page is on the right when using the Continuous facing option).

Figure 303: Initial View page of PDF Options dialog

User Interface page of PDF Options dialog
On the User Interface page (Figure 304), you can choose more settings to control how a PDF
viewer displays the file. Some of these choices are particularly useful when you are creating a PDF
to be used as a presentation or a kiosk-type display.
Window options section
• Resize window to initial page. Causes the PDF viewer window to resize to fit the first
page of the PDF.
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Figure 304: User Interface page of PDF Options dialog

• Center window on screen. Causes the PDF viewer window to be centered on the
computer screen.

• Open in full screen mode. Causes the PDF viewer to open full-screen instead of in a
smaller window.

• Display document title. Causes the PDF viewer to display the document’s title in the title
bar.
User interface options section
• Hide menubar. Causes the PDF viewer to hide the menu bar.

• Hide toolbar. Causes the PDF viewer to hide the toolbar.
• Hide window controls. Causes the PDF viewer to hide other window controls.
Transitions
In Impress, displays slide transition effects as their respective PDF effects.
Bookmarks
Select how many heading levels are displayed as bookmarks, if Export bookmarks is selected
on the General page.

Links page of PDF Options dialog
On the Links page, you can choose how links are exported to PDF.

Figure 305: Links page of PDF Options dialog
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Export bookmarks as named destinations
If you have defined Writer bookmarks, Impress or Draw slide names, or Calc sheet names, this
option exports them as “named destinations” to which Web pages and PDF documents can
link.
Convert document references to PDF targets
If you have defined links to other documents with OpenDocument extensions (such as
.ODT, .ODS, and .ODP), this option converts the files names to .PDF in the exported PDF
document.
Export URLs relative to file system
If you have defined relative links in a document, this option exports those links to the PDF.
Cross-document links
Defines the behavior of links clicked in PDF files.

Security page of PDF Options dialog
PDF export includes options to encrypt the PDF (so it cannot be opened without a password) and
apply some digital rights management (DRM) features.

• With an open password set, the PDF can only be opened with the password. Once opened,
there are no restrictions on what the user can do with the document (for example, print,
copy, or change it).

• With a permissions password set, the PDF can be opened by anyone, but its permissions
can be restricted. See Figure 306. After you set a password for permissions, the other
choices on the Security page become available.

• With both the open password and permission password set, the PDF can only be opened
with the correct password, and its permissions can be restricted.

Note

Permissions settings are effective only if the user’s PDF viewer respects the settings.

Figure 306: Security page of PDF Options dialog
Figure 307 shows the pop-up dialog displayed when you click the Set open password button on
the Security page of the PDF Options dialog.
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Figure 307: Setting a password to encrypt a PDF

Exporting to other formats
LibreOffice uses the term “export” for some file operations involving a change of file type. If you
cannot find what you want under File > Save As, look under File > Export as well.
LibreOffice can export files to XHTML, if the appropriate filter is installed (standard on Mac and
Linux; optional on Windows). In addition, Draw and Impress can export to Adobe Flash (.swf) and a
range of image formats.
To export to one of these formats, choose File > Export. On the Export dialog, specify a file name
for the exported document, then select the required format in the File format list and click the
Export button.

E-mailing documents
LibreOffice provides several ways to send documents quickly and easily as e-mail attachments in
one of three formats: OpenDocument (LibreOffice’s default format), Microsoft Office formats, or
PDF.

Note

Documents can only be sent from the LibreOffice menu if a mail profile has been set
up in Tools > Options > LibreOffice Writer > Mail Merge E-mail.

To send the current document in OpenDocument format:
1) Choose File > Send > Document as E-mail. LibreOffice opens your default e-mail
program. The document is attached.
2) In your e-mail program, enter the recipient, subject, and any text you want to add, then
send the e-mail.
File > Send > E-mail as OpenDocument Text (or Spreadsheet or Presentation) has the same
effect.
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If you choose E-mail as Microsoft [Word, Excel, or Powerpoint], LibreOffice first creates a file in
one of those formats and then opens your e-mail program with the file attached.
Similarly, if you choose E-mail as PDF, LibreOffice first creates a PDF using your default PDF
settings (as when using the Export Directly as PDF toolbar button) and then opens your email
program with the .PDF file attached.

E-mailing a document to several recipients
To e-mail a document to several recipients, you can use the features in your e-mail program or you
can use LibreOffice’s mail merge facilities to extract email addresses from an address book.
You can use LibreOffice’s mail merge to send e-mail in two ways:

• Use the Mail Merge Wizard to create the document and send it. See Chapter 11, Using Mail
Merge, in the Writer Guide for details.

• Create the document in Writer without using the Wizard, then use the Wizard to send it.
This method is described here.
To use the Mail Merge Wizard to send a previously-created Writer document:
1) Click Tools > Mail Merge Wizard. On the first page of the wizard, select Use the current
document and click Next.

Figure 308: Select starting document
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2) On the second page, select E-mail message and click Next.

Figure 309: Select document type
3) On the third page, click the Select Address List button. Select the required address list
(even if only one is shown) and then click OK. (If the address list you need is not shown
here, you can click Add to find it and add it to the list.)

Figure 310: Selecting an address list
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4) Back on the Select address list page, click Next. On the Create salutation page, deselect
This document should contain a salutation.

Figure 311: Deselecting a salutation
5) In the left-hand list, click 8. Save, print or send. LibreOffice displays a “Creating
documents” message and then displays the Save, print or send page of the Wizard.
6) Select Send merged document as E-Mail. The lower part of the page changes to show email settings choices.

Figure 312: Sending a document as an email message
7) Type a subject for your email and click Send documents. LibreOffice sends the e-mails.
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Digital signing of documents
To sign a document digitally, you need a personal key, also known as a certificate. A personal key
is stored on your computer as a combination of a private key, which must be kept secret, and a
public key, which you add to your documents when you sign them. You can get a certificate from a
certification authority, which may be a private company or a governmental institution.
When you apply a digital signature to a document, a kind of checksum is computed from the
document’s content plus your personal key. The checksum and your public key are stored together
with the document.
When someone later opens the document on any computer with a recent version of LibreOffice,
the program will compute the checksum again and compare it with the stored checksum. If both
are the same, the program will signal that you see the original, unchanged document. In addition,
the program can show you the public key information from the certificate. You can compare the
public key with the public key that is published on the web site of the certificate authority.
Whenever someone changes something in the document, this change breaks the digital signature.
On Windows operating systems, the Windows features of validating a signature are used. On
Solaris and Linux systems, files that are supplied by Thunderbird, Mozilla or Firefox are used. For
a more detailed description of how to get and manage a certificate, and signature validation, see
“About Digital Signatures” in the LibreOffice Help.
To sign a document:
1) Choose File > Digital Signatures.
2) If you have not saved the document since the last change, a message box appears. Click
Yes to save the file.
3) After saving, you see the Digital Signatures dialog. Click Add to add a public key to the
document.
4) In the Select Certificate dialog, select your certificate and click OK.
5) You see again the Digital Signatures dialog, where you can add more certificates if you
want. Click OK to add the public key to the saved file.
A signed document shows an icon in the status bar. You can double-click the icon to view the
certificate.

Removing personal data
You may wish to ensure that personal data, versions, notes, hidden information, or recorded
changes are removed from files before you send them to other people or create PDFs from them.
In Tools > Options > LibreOffice > Security > Options, you can set LibreOffice to remind (warn)
you when files contain certain information and remove personal information automatically on
saving.
To remove personal and some other data from a file, go to File > Properties. On the General tab,
uncheck Apply user data and then click the Reset button. This removes any names in the created
and modified fields, deletes the modification and printing dates, and resets the editing time to zero,
the creation date to the current date and time, and the version number to 1.
To remove version information, either (a) go to File > Versions, select the versions from the list
and click Delete; or (b) use File > Save As and save the file with a different name.
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Chapter 11
Graphics, the Gallery, and
Fontwork

Introduction
You can add graphic and image files, including photos, drawings, scanned images, and others, to
LibreOffice documents. LibreOffice can import various vector (line drawing) and raster (bitmap) file
formats. The most commonly used graphic formats are GIF, JPG, PNG, and BMP. See Appendix B
for a full list of the graphic formats LibreOffice can import.
Graphics in LibreOffice are of three basic types:

• Image files, such as photos, drawings, and scanned images
• Diagrams created using LibreOffice’s drawing tools
• Charts created using LibreOffice’s Chart component
This chapter covers images and diagrams.
More detailed descriptions on working with drawing tools can be found in the Draw Guide and
Impress Guide. Instructions on how to create charts are given in the Calc Guide.

Adding images to a document
Images can be added to a document in several ways: by inserting an image file, directly from a
graphics program or a scanner, or from the LibreOffice Gallery.

Inserting an image file
When the image is in a file stored on the computer, you can insert it into an LibreOffice document
using either of the following methods.

Drag and drop
1) Open a file browser window and locate the image you want to insert.
2) Drag the image into the LibreOffice document and drop it where you want it to appear. A
faint vertical line marks where the image will be dropped.
This method embeds (saves a copy of) the image file in the document. To link the file instead of
embedding it, hold down the Control+Shift keys while dragging the image.

Insert Picture dialog
1) Click in the LibreOffice document where you want the image to appear.
2) Choose Insert > Picture > From File from the menu bar.
3) On the Insert Picture dialog (Figure 313), notice the two options at the bottom left: Preview
and Link. Choose Preview to view a thumbnail of the selected image on the right, so you
can verify that you have the correct file. See page 299 for the use of Link.
4) Navigate to the file to be inserted, select it, and click Open.

Note
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If you choose the Link option, a message box appears when you click Open. The
message states that the picture will not be stored with the document, but only
referenced as a link, and asks if you want to embed the graphic instead. Choose
Keep Link if you want the link, or Embed Graphic if you do not. To prevent this
message from appearing again, deselect the box by Ask when linking a graphic at
the bottom of the message.
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Figure 313. Insert picture dialog

Linking an image file
If the Link option in the Insert picture dialog is selected, LibreOffice creates a link to the file
containing the image instead of saving a copy of the image in the document. The result is that the
image is displayed in the document, but when the document is saved, it contains only a reference
to the image file—not the image itself. The document and the image remain as two separate files,
and they are merged together only when you open the document again.
Linking an image has two advantages and one disadvantage:

• Advantage – Linking can reduce the size of the document when it is saved, because the
image file itself is not included. File size is usually not a problem on a modern computer
with a reasonable amount of memory, unless the document includes many large graphics
files; LibreOffice can handle quite large files.

• Advantage – You can modify the image file separately without changing the document
because the link to the file remains valid, and the modified image will appear when you
next open the document. This can be a big advantage if you (or someone else, perhaps a
graphic artist) is updating images.

• Disadvantage – If you send the document to someone else, or move it to a different
computer, you must also send the image files, or the receiver will not be able to see the
linked images. You need to keep track of the location of the images and make sure the
recipient knows where to put them on another machine, so that the document can find
them. For example, you might keep images in a subfolder named Images (under the folder
containing the document); the recipient of the file needs to put the images in a subfolder
with the same name and in the same place relative to the document.

Note

When inserting the same image several times in the document, it would appear
beneficial to link rather than embed; however, this is not necessary as LibreOffice
embeds in the document only one copy of the image file.

Embedding linked images
If you originally linked the images, you can easily embed one or more of them later if you wish. To
do so:
1) Open the document in LibreOffice and choose Edit > Links.
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2) The Edit Links dialog (Figure 314) shows all the linked files. In the Source file list, select the
files you want to change from linked to embedded.
3) Click the Break Link button.
4) Save the document.

Note

Going the other way, from embedded to linked, is not so easy—you must delete and
reinsert the images, one at a time, selecting the Link option when you do so.

Figure 314: The Edit Links dialog

Inserting an image from the clipboard
Using the clipboard, you can copy images into a LibreOffice document from another LibreOffice
document and from other programs. To do this:
1) Open both the source document and the target document.
2) In the source document, select the image to be copied.
3) Move the mouse pointer over the selected image and press Control+C to copy the image to
the clipboard.
4) Switch to the target document.
5) Click to place the cursor where the graphic is to be inserted.
6) Press Control+V to insert the image.

Caution

If the application from which the graphic was copied is closed before the graphic is
pasted into the target, the image stored on the clipboard could be lost.

Inserting an image using a scanner
If a scanner is connected to your computer, LibreOffice can call the scanning application and
inserted the scanned item into the LibreOffice document as an image. To start this procedure,
place the cursor where you want the graphic to be inserted and choose Insert > Picture > Scan >
Select Source.
Although this practice is quick and easy, it is unlikely to result in a high-quality image of the correct
size. You may get better results by scanned material into a graphics program and cleaning it up
there before inserting the resulting image into LibreOffice.
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Inserting an image from the Gallery
The Gallery provides a convenient way to group reusable objects such as graphics and sounds
that you can insert into your documents. The Gallery is available in all components of LibreOffice.
See “Managing the LibreOffice Gallery“ on page 302. You can copy or link an object from the
Gallery into a document.
To insert an object:
1) Choose Tools > Gallery or click the Gallery icon
on the Standard toolbar (in Writer
and Calc) or the Drawing toolbar (in Impress and Draw).
2) Select a theme.
3) Select an object with a single click.
4) Drag and drop the image into the document. (See Figure 315.)
You can also right-click on the object and choose Insert > Copy.

Figure 315. Copying a graphic object from the Gallery into a document (oval marks the Hide/Show
button for the Gallery)
To insert an object as a link:
1) Choose Tools > Gallery and select a theme.
2) Select an object with a single click, then while pressing the Shift and Control keys, drag
and drop the object into the document.

Inserting an image as a background
To insert an image as the background to a page or paragraph:
1) Choose Tools > Gallery and select a theme.
2) Select an object with a single click, right-click on the object, and choose Insert >
Background > Page or > Paragraph.
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Modifying and positioning graphics
LibreOffice provides many tools for resizing, modifying, filtering, and positioning graphics; wrapping
text around graphics; and using graphics as backgrounds and watermarks. These tools are
described in relevant chapters of the other guides. Some sophisticated adjustments of the graphics
are best done in an image manipulation program and the results brought into LibreOffice, rather
than using LibreOffice’s inbuilt tools.

Managing the LibreOffice Gallery
Graphics in the Gallery are grouped by themes, such as Bullets, Rulers, and Backgrounds. You
can create other groups or themes and add your own pictures or find extensions containing more
graphics.
The box on the left of the gallery window lists the available themes. Click on a theme to see its
contents displayed in the Gallery window.
You can display the Gallery in Icon View (Figure 316) or Detailed View, and you can hide or show
the Gallery by clicking on the Hide button (similar to the Hide button for the Navigator and the
Styles and Formatting window when they are docked).

Figure 316. Icon view of one theme in the Gallery
By default, the Gallery is docked above the workspace. To expand the Gallery, position the pointer
over the line that divides it from the top of the workspace. When the pointer changes to parallel
lines with arrows, click and drag downward. The workspace resizes in response.
As with other docked windows, you can “float” the Gallery by moving the mouse pointer over an
edge of the Gallery window, holding down the Control key, and double-clicking. Repeat this
procedure to dock the Gallery again.
The default themes are locked; no items can be added to or deleted from these themes. The
locked themes are easily recognizable by right-clicking on them; the only available option in the
pop-up menu is Properties.
In a default installation, only the My themes theme is customizable, although new themes can be
added as explained in “Adding a new theme to the Gallery” on page 304.

Adding objects to the Gallery
You may wish to add to the Gallery any images that you use frequently, for example, a company
logo. You can then very easily insert these graphics into a document later.
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You can add images only to “My Theme” or to any other theme that you have created; these are
indicated by a green icon in the list of themes. You cannot add images to the built-in themes,
indicated by an icon of another color.
Method 1 (selecting a file)
1) Right-click on the desired theme and select Properties from the context menu.
2) In the theme’s Properties dialog, go to the Files page and click the Find Files button.

Figure 317. Gallery Properties dialog
3) The Select path dialog (not shown) opens. You can enter the path for the file’s directory in
the Path text box, or you can navigate to locate the file’s directory.
4) Click the Select button to start the search. A list of graphic files is then displayed in the
Properties dialog. You can use the File type drop-down list to limit the files displayed.
5) To add all of the files shown in the list, click Add All. Otherwise, select the files to add and
then click Add. (Hold down either the Shift key or the Control key while you click on the
files.)
Method 2 (drag and drop)
You can drag and drop an image into the Gallery from a document.
1) Open the document containing an image you want to add to the Gallery, and display the
Gallery theme to which you want to add it.
2) Position the mouse pointer above the image, without clicking.
3) If the mouse pointer changes to a hand symbol, the image refers to a hyperlink. In this
case, press the Alt key while you click the image, to select it without activating the link. If
the mouse pointer does not change to a hand symbol, you can simply click the image to
select it.
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4) Once the image is selected, evident from the colored selection handles around it, release
the mouse button. Click again on the image, keeping the mouse button pressed for more
than two seconds. Without releasing the mouse button, drag the image into the Gallery.
5) Release the mouse button.

Deleting images from the Gallery
To delete an image from a theme that you created:
1) Right-click on the name of the image file or its thumbnail in the Gallery.
2) Click Delete on the pop-up menu. A message appears, asking if you want to delete this
object. Click Yes.

Note

Deleting the name of a file from the list in the Gallery does not delete the file from
the hard disk or other location.

Adding a new theme to the Gallery
To add a new theme to the Gallery:
1) Click the New Theme button above the list of themes (Figure 316).
2) In the Properties of New Theme dialog, click the General tab and type a name for the new
theme.
3) Click the Files tab and add images to the theme, as described earlier.

Deleting a theme from the Gallery
You can delete only themes that you have added to the Gallery; you cannot delete any of the
inbuilt themes. To delete a theme from the Gallery:
1) Go to Tools > Gallery.
2) In the left part of the Gallery, select in the list the theme you wish to delete.
3) Right-click on the theme, then click Delete on the pop-up menu.

Location of the Gallery and the objects in it
Graphics and other objects shown in the Gallery can be located anywhere on your computer’s hard
disk, on a network drive, or on a CD-ROM. Listings in the Gallery refer to the location of each
object. When you add graphics to the Gallery, the files are not moved or copied; only the location
of each new object is added as a reference.
In a workgroup, you may have access to a shared Gallery (where you cannot change the contents
unless authorized to do so) and a user Gallery, where you can add, change, or delete objects.
The location of the user Gallery is specified in Tools > Options > LibreOffice > Paths. You can
change this location, and you can copy your gallery files (*.sdv) to other computers.
Gallery contents provided with LibreOffice are stored in a different location. You cannot change this
location.
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Creating an image map
An image map defines areas of an image (called hotspots) with hyperlinks to web addresses, other
files on the computer, or parts of the same document. Hotspots are the graphic equivalent of text
hyperlinks (described in Chapter 12). Clicking on a hotspot causes LibreOffice to open the linked
page in the appropriate program (for example, the default browser for an HTML page; LibreOffice
Calc for a .ODS file; a PDF viewer for a PDF file). You can create hotspots of various shapes and
include several hotspots in the same image.
To use the image map editor:
1) In your LibreOffice document, select the picture where you want to define the hotspots.
2) Choose Edit > ImageMap from the menu bar. The ImageMap Editor (Figure 318) opens.
3) Use the tools and fields in the dialog (described below) to define the hotspots and links
necessary.
4) Click the Apply icon

to apply the settings.

5) When done, click the Save icon
to save the image map to a file, then click the X in the
upper right corner to close the dialog.

Figure 318: The dialog to create or edit an image map
The main part of the dialog shows the image on which the hotspots are defined. A hotspot is
identified by a line indicating its shape.
The toolbar at the top of the dialog contains the following tools:

• Apply button: click this button to apply the changes.
• Load, Save, and Select icons.
• Tools for drawing a hotspot shape: these tools work in exactly the same way as the
corresponding tools in the Drawing toolbar.
Chapter 11 Graphics, the Gallery, and Fontwork

305

• Edit, Move, Insert, Delete Points: advanced editing tools to manipulate the shape of a
polygon hotspot. Choose the Edit Points tool to activate the other tools.

• Active icon: toggles the status of a selected hotspot between active and inactive.
• Macro: associates a macro with the hotspot instead of just associating an hyperlink.
• Properties: sets the hyperlink properties and adds the Name attribute to the hyperlink.
Below the toolbar, specify for the selected hotspot:

• Address: the address pointed to by the hyperlink. You can also point to an anchor in a
document; to do this, write the address in this format:
file:///<path>/document_name#anchor_name

• Text: type the text that you want to be displayed when the mouse pointer is moved over the
hotspot.

• Frame: where the target of the hyperlink will open: pick among _blank (opens in a new
browser window), _self (opens in the active browser window), _top or _parent.

Tip

The value _self for the target frame will usually work just fine. It is therefore not
recommended to use the other choices unless absolutely necessary.

Using LibreOffice’s drawing tools
You can use LibreOffice’s drawing tools to create graphics such as simple diagrams using
rectangles, circles, lines, text, and other predefined shapes. You can also group several drawing
objects to make sure they maintain their relative position and proportion.
You can place the drawing objects directly on a page in your document, or you can insert them into
a frame.
You can also use the drawing tools to annotate photographs, screen captures, or other illustrations
produced by other programs, but this is not recommended because:

• You cannot include images in a group with drawing objects, so they may get out of
alignment in your document.

• If you convert a document to another format, such as HTML, the drawing objects and the
graphics will not remain associated; they are saved separately.
In general, if you need to create complex drawings, it is recommended to use LibreOffice Draw,
which includes many more features such as layers, styles, and so on.

Creating drawing objects
To begin using the drawing tools, display the Drawing toolbar (Figure 319) by clicking View >
Toolbars > Drawing.
If you are planning to use the drawing tools repeatedly, you can tear off this toolbar and move it to
a convenient place on the window.
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1 Select
2 Line

5 Freeform Line
6 Text

9 Symbol Shapes
10 Block arrows

13 Stars
14 Points

3 Rectangle
4 Ellipse

7 Callouts
8 Basic Shapes

11 Flowcharts
12 (Graphic) Callouts

15 Fontwork Gallery
16 From File
17 Extrusion On/Off

Figure 319. The Drawing toolbar

To use a drawing tool:
1) Click in the document where you want the drawing to be anchored. You can change the
anchor later, if necessary.
2) Choose the tool from the Drawing toolbar (Figure 319). The mouse pointer changes to a
drawing-functions pointer
.
3) Move the cross-hair pointer to the place in the document where you want the graphic to
appear and then click and drag to create the drawing object. Release the mouse button.
The selected drawing function remains active, so that you can draw another object of the
same type.
4) To cancel the selected drawing function, press the Esc key or click on the Select icon (the
arrow) on the Drawing toolbar.
5) You can now change the properties (fill color, line type and weight, anchoring, and others)
of the drawing object using either the Drawing Object Properties toolbar (Figure 320) or the
choices and dialogs reached by right-clicking on the drawing object.

Set or change properties for drawing objects
To set the properties for a drawing object before you draw it:
1) On the Drawing toolbar (Figure 319), click the Select tool.
2) On the Drawing Object Properties toolbar (Figure 320), click on the icon for each property
and select the value you want for that property.
3) For more control, or to define new attributes, you can click on the Area or Line icons on the
toolbar to display detailed dialogs.

1 Line

5 Line Color

9 To Foreground

13 Alignment

2 Arrow Style

6 Area

10 To Background

14 Change Anchor

3 Line Style

7 Area Style / Filling

11 Bring to Front

15 Ungroup

4 Line Width

8 Rotate

12 Send to Back

16 Group

Figure 320. Drawing Object Properties toolbar
The default you set applies to the current document and session. It is not retained when you close
the document or close Writer, and it does not apply to any other document you open. The defaults
apply to all the drawing objects except text objects.
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To change the properties for an existing drawing object:
1) Select the object.
2) Continue as described above.
You can also specify the position and size, rotation, and slant and corner radius properties of the
drawing object:
1) Right-click on the drawing object and then choose Position and Size from the pop-up
menu. The Position and Size dialog is displayed.
2) Choose any properties, as required.

Resizing a drawing object
An object is resized in a similar way to an image. Select the object, click on one of the eight
handles around it and drag it to its new position. For a scaled resizing, select one of the corner
handles and keep the Shift key pressed while dragging the handle to its new position.
For more sophisticated control of the size of the object, choose Format > Object > Position and
Size from the menu bar. Use the Position and Size dialog to set the width and height
independently. If the Keep ratio option is selected, then the two dimensions change so that the
proportion is maintained, allowing for a scaled resizing.

Grouping drawing objects
To group drawing objects:
1) Select one object, then hold down the Shift key and select the others you want to include in
the group. The bounding box expands to include all the selected objects.
2) With the objects selected, hover the mouse pointer over one of the objects and choose
Format > Group > Group from the menu bar or right-click and choose Group > Group
from the pop-up menu.

Note

You cannot include an embedded or linked graphic in a group with drawing objects.

Using Fontwork
With Fontwork you can create graphical text art objects to make your work more attractive. There
are many different settings for text art objects (line, area, position, size, and more), so you have a
large choice. You will surely find one that fits your document.
Fontwork is available with each component of LibreOffice, but you will notice small differences in
the way that each component displays it.

The Fontwork toolbars
You can use two different toolbars for creating and editing a Fontwork object.

• Go to View > Toolbars > Fontwork.

Figure 321. The floating Fontwork toolbar
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• If you click on an existing Fontwork object, the Formatting toolbar changes to display the
Fontwork options as shown in Figure 326. The contents of this toolbar vary depending on
the LibreOffice component with which it is being used.

Creating a Fontwork object
1) On the Drawing or Fontwork toolbar, click the Fontwork Gallery icon
toolbar is not visible, go to View > Toolbars > Drawing to display it.

. If the Drawing

Figure 322. The Fontwork Gallery
2) In the Fontwork Gallery, select a Fontwork style, then click OK. The Fontwork object will
appear in your document. Notice the colored squares around the edge (indicating that the
object is selected) and the yellow dot; these are discussed in “Moving and resizing
Fontwork objects” on page 313.
3) Double-click the object to edit the Fontwork text (see Figure 323). Type your own text in
place of the black Fontwork text that appears over the object.
4) Click anywhere in a free space or press Esc to apply your changes.

Chapter 11 Graphics, the Gallery, and Fontwork

309

Figure 323. Editing Fontwork text

Editing a Fontwork object
Now that the Fontwork object is created, you can edit some of its attributes. To do this, you can use
the Fontwork toolbar, the Formatting toolbar, or menu options as described in this section. If the
selected Fontwork object is a 3-D object, you can also use the 3D-Settings toolbar.

Using the Fontwork toolbar
Make sure that the Fontwork toolbar, shown in Figure 321, is visible. If you do not see it, go to
View > Toolbars > Fontwork. Click on the different icons to edit Fontwork objects.
Fontwork Shape: Edits the shape of the selected object.
You can choose from a palette of shapes.

Figure 324. Fontwork toolbar
showing palette of shapes
Fontwork Same Letter Heights: Changes the height of characters in the object. Toggles
between normal height (some characters taller than others, for example capital letters, d,
h, l and others) and all letters the same height.

Figure 325. Left: normal letters; right: same letter heights
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Fontwork Alignment: Changes the alignment of characters.
Choices are left align, center, right align, word justify, and
stretch justify. The effects of the text alignment can only be
seen if the text spans over two or more lines. In the stretch
justify mode, all the lines are filled completely.

Fontwork Character Spacing: Changes the character spacing
and kerning in the object. For custom spacing, input a
percentage value: 100% is normal spacing; less than 100% is
tight spacing; more than 100% is expanded spacing.

Using the Formatting toolbar
Now let us go further and customize the Fontwork object with several more attributes.
Click on the Fontwork object. The Formatting toolbar changes to show the options for editing the
object. (The toolbar shown in Figure 326 appears when you use Fontwork in Writer.)

Figure 326. Formatting toolbar for a Fontwork object in Writer
This figure shows the toolbar floating. In its default, docked position it is one of the toolbars located
below the menu bar. The example toolbar has also been customized to show all of the available
options; by default only a subset of these options is shown.
On the Formatting toolbar you have a large choice of options for customizing your object. These
choices are the same as the ones for other drawing objects. For more information, see the Draw
Guide.
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Line options
Line icon: Opens a dialog with three tabs: Line, Line Styles, Arrow Styles. Use the Line tab to
edit the most common properties of the line around the selected Fontwork object, by choosing from
previously-defined attributes including line style, line color, and arrow styles. Use the Lines Styles
and Arrow Styles tabs to edit the properties of line and arrow styles, and define new styles.
Arrow Style icon: Choose from the different arrow styles.
Line Style box: Choose from the available line styles.
Line Width box: Set the width of the line.
Line Color box: Select the color of the line.
Area options
Area icon: Opens a dialog with seven tabs: Area, Shadow, Transparency, Colors, Gradients,
Hatching, Bitmaps.

• Area tab: Choose from the predefined list a color, bitmap, gradient or hatching pattern to fill
the selected object.

•
•
•
•
•

Shadow tab: Set the shadow properties of the selected object.
Transparency tab: Set the transparency properties of the selected object.
Colors tab: Modify the available colors or add new ones to appear on the Area tab.
Gradients tab: Modify the available gradients or add new ones to appear on the Area tab.
Hatching tab: Modify the available hatching patterns or add new ones to appear on the
Area tab.

• Bitmaps tab: Create simple bitmap patterns and import bitmaps, to make them available
on the Area tab.
Area Style / Filling boxes: Select the type of the fill of the selected object. For more detailed
settings, use the Area icon.
Positioning options
Rotate icon: Rotate the selected object manually using the mouse to drag the object.
To Foreground icon: Move the selected object in front of the text.
To Background icon: Move the selected object behind the text.
Alignment icon: Modify the alignment of the selected objects.
Bring to front icon: Move the selected object in front of the others.
Send to back icon: Move the selected object behind the others.
Change Anchor icon: Choose between anchoring options:

• To Page—The object keeps the same position in relation to the page margins. It does not
move as you add or delete text.

• To Paragraph—The object is associated with a paragraph and moves with the paragraph. It
may be placed in the margin or another location.

• To Character—The object is associated with a character but is not in the text sequence. It
moves with the paragraph but may be placed in the margin or another location. This
method resembles anchoring to a paragraph.

• As Character—The object is placed in the document like any character and moves with the
paragraph as you add or delete text before the object.
Ungroup icon: Ungroup the selected objects, so you can manage them individually.
Group icon: Group the selected objects, so you can manage them as a single object.
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Using menu options
You can use some the choices on the Format menu to anchor, align, arrange and group selected
Fontwork objects, wrap text around them, and flip them horizontally and vertically.
You can also right-click on a Fontwork object and choose many of the same options from the popup menu. The pop-up menu also provides quick access to the Line, Area, Text, and Position and
Size dialogs. The Text dialog offers only a few options for Fontwork objects and is not discussed
here. On the Position and Size dialog, you can enter precise values concerning size and position.
For more information on all of these menu options, see the Draw Guide.

Using the 3D-Settings toolbar
If the selected Fontwork object is a 3-D object, you can also use the options on the 3D-Settings
toolbar. You can also change a 2-D Fontwork object into a 3-D object (or change a 3-D object into
a 2-D object) by clicking the Extrusion On/Off icon on the 3D-Settings toolbar. For more
information, see the Draw Guide.

Figure 327: 3D-Settings toolbar

Moving and resizing Fontwork objects
When you select a Fontwork object, eight colored squares (known as handles) appear around the
edge of the object, as shown below. You can drag these handles to resize the object.
A yellow dot also appears on the object. This dot may be
along an edge of the object, or it may be somewhere else;
see figure to right for an example. If you hover the pointer
over this yellow dot, the pointer turns into a hand symbol.
You can drag the dot in different directions to distort the
object.
Hovering the pointer over other parts of the object turns the
pointer into the usual symbol for dragging the object to
another part of the page.
For precise control of the location and size of the object, use the Position and Size dialog.
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Chapter 12
Creating Web Pages
Saving Documents as HTML Files

Introduction
This chapter describes how to do the following in Writer, Calc, Draw, and Impress:

• Create hyperlinks within a document and to other documents such as web pages, PDFs,
and other files.

• Save documents as web pages (HTML documents).
When creating a document that you plan to deliver as a web page, you need to consider the
following:

• In an HTML document, hyperlinks are active (clickable) but other cross-references inserted
by LibreOffice are not active links.

• An object such as a image is saved as a separate file. However, if that object has been
placed in a frame (for example, with an associated caption), it is not saved and does not
appear in the HTML document; instead, the name of the frame appears.

Relative and absolute hyperlinks
Hyperlinks stored within a file can be either relative or absolute.
A relative hyperlink says, Here is how to get there starting from where you are now (meaning from
the folder in which your current document is saved) while an absolute hyperlink says, Here is how
to get there no matter where you start from.
An absolute link will stop working if the target is moved. A relative link will stop working if the start
and target locations change relative to each other. For instance, if you have two spreadsheets in
the same folder linked to each other and you move the entire folder to a new location, an absolute
hyperlink will break but a relative one will not.
To change the way that LibreOffice stores the hyperlinks in your file, select Tools > Options >
Load/Save > General and choose if you want URLs saved relatively when referencing the File
System, or the Internet, or both.
Calc will always display an absolute hyperlink. Don’t be alarmed when it does this even when you
have saved a relative hyperlink—this ‘absolute’ target address will be updated if you move the file.

Note

Make sure that the folder structure on your computer is the same as the file structure
on your web server if you save your links as relative to the file system and you are
going to upload pages to the Internet.

Tip

When you rest the mouse pointer on a hyperlink, a help tip displays the absolute
reference, since LibreOffice uses absolute path names internally. The complete path
and address can only be seen when you view the result of the HTML export (saving
the spreadsheet as an HTML file), by loading the HTML file as Text, or by opening it
with a text editor.

Creating hyperlinks
When you type text (such as a website addresses or URL) that can be used as a hyperlink, and
then press the spacebar or the Enter key, LibreOffice automatically creates the hyperlink and
applies formatting to the text (usually a color and underlining). If this does not happen, you can
enable this feature using Tools > AutoCorrect Options > Options and selecting the URL
Recognition option.
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If you do not want LibreOffice to convert a specific URL to a hyperlink, choose Edit > Undo Insert
from the menu bar or press Control+Z immediately after the formatting has been applied. You can
also place the cursor in the hyperlink, right-click, and choose Remove Hyperlink.

Tip

To change the color of hyperlinks, go to Tools > Options > LibreOffice >
Appearance, scroll to Unvisited links and/or Visited links, pick the new colors and
click OK. Caution: this will change the color for all hyperlinks in all components of
LibreOffice; this may not be what you want.
In Writer and Calc (but not Draw or Impress), you can also change the Internet link
character style or define and apply new styles to selected links.

You can also insert hyperlinks using the Navigator and the Hyperlink dialog, and you can modify all
hyperlinks using the Hyperlink dialog as described in this section.

Using the Navigator
The easiest way to insert a hyperlink to another part of the same document is by using the
Navigator:
1) Open the documents containing the items you want to cross-reference.
2) Open the Navigator by clicking its icon
, by choosing View > Navigator, or by pressing
F5.
3) Click the arrow next to the Drag Mode icon, and choose Insert as Hyperlink. (See
Figure 328.)
4) In the list at the bottom of the Navigator, select the document containing the item that you
want to cross-reference.
5) In the Navigator list, select the item that you want to insert as a hyperlink.
6) Drag the item to where you want to insert the hyperlink in the document. The name of the
item is inserted in the document as an active hyperlink.

Figure 328: Inserting a hyperlink using the Navigator
When using the Navigator to hyperlink to an object such as a graphic, to have the hyperlink show
useful text such as 2009 Sales Graph, you need to give such objects useful names instead of
leaving them as the default names (“Graphics6”), or you need to edit the resulting link text using
the Hyperlink dialog, as described below.
You can also use the Navigator to insert a hyperlink from one document (the source) to a specific
place in another document (the target). Open the Navigator in the target document and drag the
item to the spot in the source document where you want the hyperlink to appear.
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Using the Hyperlink dialog
To display the dialog, click the Hyperlink icon
on the Standard toolbar or choose Insert >
Hyperlink from the menu bar. To turn existing text into a link, highlight it before opening the dialog.

Figure 329. Hyperlink dialog showing details for Internet links
On the left side, select one of the four categories of hyperlink:

• Internet: the hyperlink points to a web address, normally starting with http://
• Mail & News: the hyperlink opens an email message that is pre-addressed to a particular
recipient

• Document: the hyperlink points to another document or to another place in the current
document

• New document: the hyperlink creates a new document
The top right part of the dialog changes according to the choice made for the hyperlink category in
the left panel. A full description of all the choices and their interactions is beyond the scope of this
chapter. Here is a summary of the most common choices.
For an Internet hyperlink, choose the type of hyperlink (Web, FTP, or Telnet), and enter the
required web address (URL).
For a Mail and News hyperlink, specify whether it is a mail or news link, the receiver’s address,
and for email, also the subject.
For a Document hyperlink, specify the document path (the Open File button opens a file browser)
or leave this blank if you want to link to a target in the same document. Optionally specify the target
in the document (for example a specific slide). Click on the Target in Document icon to open the
Navigator where you can select the target; or if you know the name of the target, you can type it
into the box.
For a New Document hyperlink, specify whether to edit the newly created document immediately
(Edit now) or just create it (Edit later), enter the file name, and select the type of document to
create (text, spreadsheet, and so on). Click the Select Path button to open a file browser and
choose where to store the file.
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The Further settings section in the bottom right part of the dialog is common to all the hyperlink
categories, although some choices are more relevant to some types of links.

• Set the value of Frame to determine how the hyperlink will open. This applies to documents
that open in a Web browser.

• Form specifies if the link is to be presented as text or as a button. Figure 330 shows a link
formatted as a button. A hyperlink button is a type of form control. See Chapter 15 of the
Writer Guide for more information.

Figure 330: Authors hyperlink as button (in Calc)

• Text specifies the text that will be visible to the user. If you do not enter anything here,
LibreOffice uses the full URL or path as the link text. Note that if the link is relative and you
move the file, this text will not change, though the target will.

• Name is applicable to HTML documents. It specifies text that will be added as a NAME
attribute in the HTML code behind the hyperlink.

• Events button

: click this button to open the Assign Macro dialog and choose a macro
to run when the link is clicked. See Chapter 13, Getting Started with Macros, for more
information.

Editing hyperlinks
To edit an existing link, click anywhere in the link text and then click the Hyperlink icon
on the
Standard toolbar or choose Edit > Hyperlink from the menu bar or right-click and choose Edit
Hyperlink from the context menu. The Hyperlink dialog opens. Make your changes and click
Apply. If you need to edit several hyperlinks, you can leave the Hyperlink dialog open until you
have edited all of them. Be sure to click Apply after each one. When you are finished, click Close.
The standard (default) behavior for activating hyperlinks within LibreOffice is to use Ctrl+click. This
behavior can be changed in Tools > Options > LibreOffice > Security > Options, by deselecting
the option Ctrl-click required to follow hyperlinks. If clicking in your links activates them, check
that page to see if the option has been deselected.

Removing hyperlinks
You can remove the clickable link from hyperlink text—leaving just the text—by right-clicking on the
link and selecting Remove Hyperlink. You may then need to re-apply some formatting in order for
the text to match the rest of your document.
To erase the link text or button from the document completely, select it and press the Backspace or
Delete key.
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Saving Writer documents as web pages
Writer’s HTML capabilities include saving existing documents in HTML format, creating new
documents as HTML (not described here), and creating several different types of web pages using
a wizard.
The easiest way to create HTML documents is to start with an existing Writer document. You can
get a good idea of how it will appear as a web page by using View > Web Layout. However, web
layout view will not show you which features will or will not save correctly to HTML. Some
considerations are described in the introduction to this chapter.

Saving a document as a single web page
To save a document as a single web page (HTML format), choose File > Save As and specify
HTML Document as the file type.

Note

Writer does not replace multiple spaces in the original document with the HTML code
for non-breaking spaces. If you want to have extra spaces in your HTML file or web
page, you need to insert non-breaking spaces in LibreOffice. To do this, press
Control+Spacebar instead of just Spacebar.

Saving a document as a series of web pages
Writer can save a large document as a series of web pages (HTML files) with a table of contents
page. To do this:
1) Decide which headings in the document should start on a new page and make sure all
those headings have the same style (for example, Heading 1).
2) Choose File > Send > Create HTML Document.
3) In the Name and Path of the HTML Document dialog, type the file name to save the pages
under. Also specify which style indicates a new page (as decided in step 1).

Figure 331. Creating a series of web pages from one document
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4) Click Save to create the multi-page HTML document. The resulting HTML files conform to
the HTML 4 Transitional.

Creating web pages using a Wizard
LibreOffice’s Web wizard allows you to create several types of standard web pages. To use it:
1) Choose File > Wizards > Web Page. On the first page of the Wizard, choose settings and
click Next >. If this is your first web page, the only choice is <default>.

2) Choose or browse to the document you would like to format. The Title, Summary and
Author information is picked up from the document’s properties; if necessary, edit it. Click
Next >.
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3) Chose a layout for the web site by clicking on the layout boxes. Click Next >.

4) Chose the information to be listed and the screen resolution. Click Next >.

5) Select a style for the page. Use the drop-down list to choose different styles and color
combinations. You can browse to select a background image and icon set from the Gallery.
Click Next >.
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6) Enter general information such as Title and HTML Metadata information. Click Next >.

7) Chose where to save the file and preview the page if you wish. Click Finish.

To edit or view the document’s underlying HTML code, open the document, and then choose
View > HTML Source or click the HTML Source icon

on the Main toolbar.

Saving Calc spreadsheets as web pages
Calc can save files as HTML documents. As for Writer, choose File > Save As and select HTML
Document, or choose File > Wizards > Web Page.
If the file contains more than one sheet, the additional sheets will follow one another in the HTML
file. Links to each sheet will be placed at the top of the document. Calc also allows the insertion of
links directly into the spreadsheet using the Hyperlink dialog.
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Saving Impress presentations as web pages
You can export presentations as Macromedia Flash files: choose File > Export and select
Macromedia Flash for the file type.
You can also convert presentations into a series of web pages, as described below.
Saving as web pages (HTML format) does not retain animation and slide transitions.

Note

1) To begin, choose File > Export and select HTML Document as the file type.
2) Create a folder for the files, supply a name for the resulting HTML file, and click Save. The
HTML Export Wizard opens.
Depending on the size of your presentation and the number of graphics it contains,
the HTML export function may create many HTML, JPG, and GIF files. If you simply
save to your desktop (not in a specific folder), these separate HTML and graphics
files will be all over your desktop. So be sure to create a folder to hold all the files.

Note

3) Choose the design for all of the pages, either from an existing design or by creating a new
one. If you have not previously saved a design, the Existing Design choice is not available.

4) Click Next to select the type of web pages to create.

• Standard HTML: one page for each slide, with navigation links to move from slide to
slide.

• Standard HTML with frames: one page with a navigation bar on the left-hand side; uses
slide title as navigation links. Click on links to display pages in right-hand side.

• Automatic: one page for each slide, with each page set with the Refresh meta tag so a
browser automatically cycles from one page to the next.

• WebCast: generates an ASP or Perl application to display the slides. Unfortunately
LibreOffice has no direct support for PHP yet.
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5) Decide how the images will be saved (PNG, GIF, or JPG) and what resolution to use.
When choosing a resolution, consider what the majority of your viewers might be using. If
you specify a high resolution, then a viewer with a medium-resolution monitor will have to
scroll sideways to see the entire slide, which isprobably not desirable.

6) If Create title page was chosen in step 4, supply the information for it on the next page. The
title contains an author name, e-mail address and home page, along with any additional
information you want to include.
This page of the Wizard does not display if Create title page was not chosen.
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7) Choose the navigation button style to use to move from one page to another. If you do not
choose any, LibreOffice will create a text navigator.

8) Select the color scheme for the web pages. Available schemes include the document’s
existing scheme, one based upon browser colors, and a completely user-defined scheme.
You can save a new scheme so that it will appear on the first page of the HTML export
wizard.
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9) Click Create to generate the HTML files. If this is a new design, a small dialog pops up. If
you might want to reuse this design, you can give it a name and save it. Otherwise, click
Do Not Save.

Saving Draw documents as web pages
Exporting drawings from LibreOffice’s Draw application is similar to exporting a presentation from
Impress. Choose File > Export and select HTML Document as the file type.
When using the wizard, you can choose to create the web page at any time by clicking the Create
button.
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Chapter 13
Getting Started with Macros
Using the Macro Recorder … and Beyond

Your first macros
A macro is a saved sequence of commands or keystrokes that are stored for later use. An example
of a simple macro is one that “types” your address. The LibreOffice macro language is very
flexible, allowing automation of both simple and complex tasks. Macros are especially useful to
repeat a task the same way over and over again.
LibreOffice macros are usually written in a language called LibreOffice Basic, or just abbreviated
Basic. Although you can learn Basic and write macros, there is a steep learning curve to writing
macros from scratch. The usual methods for a beginner are to add macros that someone else has
written and to use the built-in macro recorder, which records your keystrokes and saves them for
use.
In LibreOffice recording of macros is currently classified as an “experimental (unstable)” feature. To
enable macro recording, use Tools > Options > LibreOffice > General and select the Enable
experimental (unstable) features option.

Figure 332: Enable macros in the Options dialog.
Most tasks in LibreOffice are accomplished by “dispatching a command” (sending a command),
which is intercepted and used. The macro recorder works by recording the commands that are
dispatched (see “The dispatch framework” on page 338).

Adding an existing macro
The first step in learning macro programming is to find and use existing macros. This section
assumes that you have a macro that you want to use; the macro may be in an email, on a web
page, or even in a book. For this example, use the macro in Listing 1.
Listing 1: Simple macro that says hello.
Sub HelloMacro
Print "Hello"
End Sub

330

Getting Started with LibreOffice 3.5

You must create a library and module to contain your macro; this is covered in “Macro
organization” on page 339. Use these steps to create a library to contain your macro:
1) Use Tools > Macros > Organize Macros > LibreOffice Basic to open the Macro dialog
(see Figure 333 and Figure 338).
2) Click Organizer to open the Basic Macro Organizer dialog (see Figure 339).
3) Select the Libraries tab.
4) Set the Location to My Macros & Dialogs, which is the default.
5) Click New to open the New Library dialog. Enter a library name such as “TestLibrary” and
click OK.
6) Select the Modules tab.
7) In the Module list, expand My Macros and select TestLibrary. A module named Module1
already exists and can contain your macro. You can click New to create another module in
TestLibrary.
8) Select the Module1, or the new module that you created, and click Edit to open the
Integrated Debugging Environment (IDE).
9) The IDE is a text editor for macros that allows you to edit and create macros. Copy the
macro into the IDE.
When a new module is created, it contains a comment and an empty macro named Main, that
does nothing.
Listing 2: Contents of Module1 after it is created.
REM

*****

BASIC

*****

Sub Main
End Sub

Add the new macro either before Sub Main or after End Sub. In Listing 3, the new macro has been
added before Sub Main.
Listing 3: Module1 after adding the new macro.
REM

*****

BASIC

*****

Sub HelloMacro
Print "Hello"
End Sub
Sub Main
End Sub

Click the Run Basic button

in the toolbar, or press F5, to run the first macro in the module. Use

the Macro dialog, opened using the Select macro button
or Tools > Macros > Organize
Macros > LibreOffice Basic, to select and run any macro in the module.

Creating a simple macro
Imagine repeatedly entering simple information. Although you can store the information in the
clipboard, if you use the clipboard for something else, the contents are changed. Storing the
contents as a macro is a simple solution. (In some simple cases, including the example used here,
a better solution is to use AutoText.)
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1) Use Tools > Macros > Record Macro to start recording a macro.
A small window is displayed so you know that LibreOffice is recording.
2) Type the desired information or perform an appropriate series of
operations. In this case, I typed the name, Andrew Pitonyak.
3) Click the Stop Recording button to stop recording, save the macro, and display the
LibreOffice Basic Macros dialog.

Macros

Library Containers

Libraries
Modules

Figure 333: LibreOffice Macro Organizer dialog, Writer module selected

Tip

The buttons in the Macro Organizer dialog differ depending on what is selected in
the LibreOffice Basic Macros dialog (see Figure 333 and Figure 338).

4) Be certain to open the library container named My Macros. Find the library named
Standard under My Macros. Be warned, every library container has a library named
Standard. Select the Standard library and click New Module to create a new module to
contain the macro.
5) The default module name is Module1. Type a descriptive name and click OK to create the
module. The LibreOffice Basic Macros dialog is displayed again, showing the new module.

Figure 334: Give your module a meaningful name
6) Highlight the newly created module. In the upper left corner, type the macro name to use,
such as “EnterMyname”, and then click Save to save the macro.
If you followed all of the steps, the Standard library now contains a module named Recorded,
which contains the EnterMyName macro, as shown in Figure 335.

Note

332

When LibreOffice creates a new module, it automatically adds the macro named
Main.

Getting Started with LibreOffice 3.5

Running the macro
Use Tools > Macros > Run Macro to open the Macro Selector dialog. Select the newly created
macro and click Run.

Figure 335: Select a macro and click Run
There are other methods to run a macro. For example, use Tools > Macros > Organize Macros >
LibreOffice Basic to open the LibreOffice Basic Macros dialog, which contains a Run button as
well.

Viewing and editing the macro
You can view and edit the macro that was just created. Use Tools > Macros > Organize Macros >
LibreOffice Basic to open the LibreOffice Basic Macros dialog (see Figure 333). Select the new
macro and click Edit to open the macro in the Basic IDE (Integrated Development Environment).
Listing 4: Generated “EnterMyname” macro.
REM *****
Sub Main

BASIC

*****

End Sub
sub EnterMyName
rem ------------------------------------------------------------rem define variables
dim document
as object
dim dispatcher as object
rem ------------------------------------------------------------rem get access to the document
document
= ThisComponent.CurrentController.Frame
dispatcher = createUnoService("com.sun.star.frame.DispatchHelper")
rem ------------------------------------------------------------dim args1(0) as new com.sun.star.beans.PropertyValue
args1(0).Name = "Text"
args1(0).Value = "Andrew Pitonyak"
dispatcher.executeDispatch(document, ".uno:InsertText", "", 0, args1())
end sub
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The macro in Listing 4 is not as complicated as it first appears. Learning a few things helps
significantly in understanding the generated macros. The discussion starts with features near the
top of the macro listing and describes them. If you like to avoid details, then simply change the text
“Andrew Pitonyak” in the macro above to what you want to insert at the current cursor position.

Comments start with REM
The keyword REM, short for remark, starts a macro comment. All text after REM (on the same line)
is ignored. As a short cut, the single quote character can also be used to start a comment.

Tip

LibreOffice Basic is not case-sensitive for keywords, so REM, Rem, and rem all start
a comment. If you use symbolic constants defined by the API, it is safer to assume
that the names are case-sensitive—symbolic constants are an advanced topic not
usually needed by people that use the macro recorder.

Defining subroutines with SUB
Individual macros are stored in subroutines defined with the keyword SUB. The end of a subroutine
is indicated by the words END SUB. The code starts by defining the subroutine named Main, which
is empty and does nothing. The next subroutine, EnterMyName, contains the generated code.

Tip

LibreOffice always creates an empty subroutine named Main when it creates a
module.

There are advanced topics that are beyond the scope of this document, but knowing about them
might be of interest:

• You can write a macro so that values can be passed to the subroutine. The values are
called arguments. Recorded macros do not accept arguments.

• Another kind of subroutine is called a function. A function is a subroutine that returns a
value. The keyword FUNCTION is used rather than SUB to define a function. Generated
macros are always of type SUB.

Defining variables using DIM
You can write information on a piece of paper so that you can look at it later. A variable, like a piece
of paper, contains information that can be changed and read. The DIM statement is similar to
setting aside a piece of paper to be used to store a message or note.
The EnterMyName macro defines the variables document and dispatcher as type object. Other
common variable types include string, integer, and date. A third variable, named args1, is an array
of property values. A variable of type array allows a single variable to contain multiple values,
similar to storing multiple pages in a single book. Values in an array are usually numbered starting
from zero. The number in the parentheses indicates the highest usable number to access a
storage location. In this example, there is only one value, and it is numbered zero.

Pulling the macro together
The following details are very complete; it is not important to understand all of the details. The first
line defines the start of the macro.
sub EnterMyName

Declare two variables:
dim document
as object
dim dispatcher as object
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ThisComponent refers to the current document.
The CurrentController property of a document refers to a service that “controls” the document. For
example, when you type, it is the current controller that notices. The current controller then
dispatches the changes to the document’s frame.
The Frame property of a controller returns a main frame for a document. Therefore, the variable
named document refers to a document’s frame, which receives dispatched commands.
document = ThisComponent.CurrentController.Frame

Most tasks in LibreOffice are accomplished by dispatching a command. LibreOffice includes a
dispatch helper service, which does most of the work to use dispatches in macros. The method
CreateUnoService accepts the name of a service and it tries to create an instance of that service.
On completion, the dispatcher variable contains a reference to a DispatchHelper.
dispatcher = createUnoService("com.sun.star.frame.DispatchHelper")

Declare an array of properties. Each property has a name and a value. In other words, it is a
name/value pair. The created array has one property at index zero.
dim args1(0) as new com.sun.star.beans.PropertyValue

Give the property the name “Text” and the value “Andrew Pitonyak”, which is the text that is
inserted when the macro is run.
args1(0).Name = "Text"
args1(0).Value = "Andrew Pitonyak"

This is where the magic happens. The dispatch helper sends a dispatch to the document’s frame
(stored in the variable named document) with the command .uno:InsertText. The next two
arguments, frame name and search flags, are beyond the scope of this document. The last
argument is the array of property values to be used while executing the command InsertText.
dispatcher.executeDispatch(document, ".uno:InsertText", "", 0, args1())

Finally, the end of the subroutine.
end sub

Creating a macro
When creating a macro, it is important to ask two questions before recording:
1) Can the task be written as a simple set of commands?
2) Can the steps be arranged such that the last command leaves the cursor ready for the next
command?

A complicated example
I frequently copy rows and columns of data from a web site and format them as a table in a text
document. First, I copy the table from the web site to the clipboard. To avoid strange formatting and
fonts, I paste the text into a Writer document as unformatted text. I reformat the text with tabs
between columns so that I can use Table > Convert > Text to Table to convert to a table.
I inspect the text to see if I can record a macro to format the text (remember the two questions that
I ask). As an example, I copied the FontWeight constants group from the API web site. The first
column indicates the constant name. Each name is followed by a space and a tab.
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DONTKNOW

The font weight is not specified/known.

THIN

specifies a 50% font weight.

ULTRALIGHT

specifies a 60% font weight.

LIGHT

specifies a 75% font weight.

SEMILIGHT

specifies a 90% font weight.

NORMAL

specifies a normal font weight.

SEMIBOLD

specifies a 110% font weight.

BOLD

specifies a 150% font weight.

ULTRABOLD

specifies a 175% font weight.

BLACK

specifies a 200% font weight.

I want the first column to contain the numeric value, the second column the name, and the third
column the description. The desired work is easily accomplished for every row except for
DONTKNOW and NORMAL, which do not contain a numeric value—but I know that the values are
0 and 100, so I will enter those manually.
The data can be cleaned in multiple ways—all of them easy. The first example uses keystrokes
that assume the cursor is at the start of the line with the text THIN.
1)
2)
3)
4)
5)
6)
7)
8)
9)
10)
11)
12)
13)
14)
15)
16)
17)

Use Tools > Macros > Record Macro to start recording.
Press Ctrl+Right Arrow to move the cursor to the start of “specifies”.
Press Backspace twice to remove the tab and the space.
Press Tab to add the tab without the space after the constant name.
Press Delete to delete the lower case s and then press S to add an upper case S.
Press Ctrl+Right Arrow twice to move the cursor to the start of the number.
Press Ctrl+Shift+Right Arrow to select and move the cursor before the % sign.
Press Ctrl+C to copy the selected text to the clipboard.
Press End to move the cursor to the end of the line.
Press Backspace twice to remove the two trailing spaces.
Press Home to move the cursor to the start of the line.
Press Ctrl+V to paste the selected number to the start of the line.
Pasting the value also pasted an extra space, so press Backspace to remove the extra
space.
Press Tab to insert a tab between the number and the name.
Press Home to move to the start of the line.
Press down arrow to move to the next line.
Stop recording the macro and save the macro.

It takes much longer to read and write the steps than to record the macro. Work slowly and think
about the steps as you do them. With practice this becomes second nature.
The generated macro has been modified to contain the step number in the comments to match the
code to the step above.
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Listing 5: Copy the numeric value to the start of the column.
sub CopyNumToCol1
rem ------------------------------------------------------------rem define variables
dim document
as object
dim dispatcher as object
rem ------------------------------------------------------------rem get access to the document
document
= ThisComponent.CurrentController.Frame
dispatcher = createUnoService("com.sun.star.frame.DispatchHelper")
rem (2) Press Ctrl+Right Arrow to move the cursor to the start of “specifies”.
dispatcher.executeDispatch(document, ".uno:GoToNextWord", "", 0, Array())
rem (3) Press Backspace twice to remove the tab and the space.
dispatcher.executeDispatch(document, ".uno:SwBackspace", "", 0, Array())
rem ------------------------------------------------------------dispatcher.executeDispatch(document, ".uno:SwBackspace", "", 0, Array())
rem (4) Press Tab to add the tab without the space after the constant name.
dim args4(0) as new com.sun.star.beans.PropertyValue
args4(0).Name = "Text"
args4(0).Value = CHR$(9)
dispatcher.executeDispatch(document, ".uno:InsertText", "", 0, args4())
rem (5) Press Delete to delete the lower case s ....
dispatcher.executeDispatch(document, ".uno:Delete", "", 0, Array())
rem (5) ... and then press S to add an upper case S.
dim args6(0) as new com.sun.star.beans.PropertyValue
args6(0).Name = "Text"
args6(0).Value = "S"
dispatcher.executeDispatch(document, ".uno:InsertText", "", 0, args6())
rem (6) Press Ctrl+Right Arrow twice to move the cursor to the number.
dispatcher.executeDispatch(document, ".uno:GoToNextWord", "", 0, Array())
rem ------------------------------------------------------------dispatcher.executeDispatch(document, ".uno:GoToNextWord", "", 0, Array())
rem (7) Press Ctrl+Shift+Right Arrow to select the number.
dispatcher.executeDispatch(document, ".uno:WordRightSel", "", 0, Array())
rem (8) Press Ctrl+C to copy the selected text to the clipboard.
dispatcher.executeDispatch(document, ".uno:Copy", "", 0, Array())
rem (9) Press End to move the cursor to the end of the line.
dispatcher.executeDispatch(document, ".uno:GoToEndOfLine", "", 0, Array())
rem (10) Press Backspace twice to remove the two trailing spaces.
dispatcher.executeDispatch(document, ".uno:SwBackspace", "", 0, Array())
rem ------------------------------------------------------------dispatcher.executeDispatch(document, ".uno:SwBackspace", "", 0, Array())
rem (11) Press Home to move the cursor to the start of the line.
dispatcher.executeDispatch(document, ".uno:GoToStartOfLine", "", 0, Array())
rem (12) Press Ctrl+V to paste the selected number to the start of the line.
dispatcher.executeDispatch(document, ".uno:Paste", "", 0, Array())
rem (13) Press Backspace to remove the extra space.
dispatcher.executeDispatch(document, ".uno:SwBackspace", "", 0, Array())
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rem (14) Press Tab to insert a tab between the number and the name.
dim args17(0) as new com.sun.star.beans.PropertyValue
args17(0).Name = "Text"
args17(0).Value = CHR$(9)
dispatcher.executeDispatch(document, ".uno:InsertText", "", 0, args17())
rem (15) Press Home to move to the start of the line.
dispatcher.executeDispatch(document, ".uno:GoToStartOfLine", "", 0, Array())
rem (16) Press Down Arrow to move to the next line.
dim args19(1) as new com.sun.star.beans.PropertyValue
args19(0).Name = "Count"
args19(0).Value = 1
args19(1).Name = "Select"
args19(1).Value = false
dispatcher.executeDispatch(document, ".uno:GoDown", "", 0, args19())
end sub

Cursor movements are used for all operations (as opposed to searching). If run on the
DONTKNOW line, the word weight is moved to the front of the line, and the first “The” is changed
to “She”. This is not perfect, but I should not have run the macro on the lines that did not have the
proper format; I need to do these manually.

Running the macro quickly
It is tedious to repeatedly run the macro using Tools > Macros > Run Macro (see Figure 335).
The macro can be run from the IDE. Use Tools > Macros > Organize Macros > LibreOffice
Basic to open the Basic Macro dialog. Select your macro and click Edit to open the macro in the
IDE.
The IDE has a Run Basic icon in the toolbar that runs the first macro in the IDE. Unless you
change the first macro, it is the empty macro named Main. Modify Main so that it reads as shown in
Listing 6.
Listing 6: Modify Main to call CopyNumToCol1.
Sub Main
CopyNumToCol1
End Sub

Now, you can run CopyNumToCol1 by repeatedly clicking the Run Basic icon in the toolbar of the
IDE. This is very fast and easy, especially for temporary macros that will be used a few times and
then discarded.

Sometimes the macro recorder fails
Understanding the LibreOffice internals helps to understand how and why the macro recorder
frequently fails. The primary offender is related to the dispatch framework and its relationship to the
macro recorder.

The dispatch framework
The purpose of the dispatch framework is to provide uniform access to components (documents)
for commands that usually correspond to menu items. I can use File > Save from the menu, the
shortcut keys Ctrl+S, or click on the Save toolbar icon. All of these commands are translated into
the same “dispatch command”.

338

Getting Started with LibreOffice 3.5

The dispatch framework can also be used to send “commands” back to the UI (User Interface). For
example, after saving the document, the File Save command is disabled. As soon as the document
has been changed, the File Save command is enabled.
If we see a dispatch command, it is text such as .uno:InsertObject or .uno:GoToStartOfLine. The
command is sent to the document’s frame, and the frame passes on the command until an object
is found that can handle the command.

How the macro recorder uses the dispatch framework
The macro recorder records the generated dispatches. The recorder is relatively simple to
implement and the same commands that are issued are recorded for later use. The problem is that
not all dispatched commands are complete. For example, inserting an object generates the
following code:
dispatcher.executeDispatch(document, ".uno:InsertObject", "", 0, Array())

It is not possible to specify what kind of object to create or insert. If an object is inserted from a file,
you cannot specify which file to insert.
I recorded a macro and used Tools > Options to open and modify configuration items. The
generated macro does not record any configuration changes; in fact, the generated code is
commented so it will not even be run.
rem dispatcher.executeDispatch(document,
".uno:OptionsTreeDialog", "", 0, Array())

If a dialog is opened, the command to open the dialog is likely to be generated. Any work done
inside the dialog is not usually recorded. Examples include macro organization dialogs, inserting
special characters, and similar types of dialogs. Other possible problems using the macro recorder
include things such as inserting a formula, setting user data, setting filters in Calc, actions in
database forms, and exporting a document to an encrypted PDF file. You never know for certain
what will work unless you try it, however. The actions from the search dialog are properly captured,
for example.

Other options
When the macro recorder is not able to solve a specific problem, the usual solution is to write code
using the LibreOffice objects. Unfortunately, there is a steep learning curve for the objects. It is
usually best to start with simple examples and then branch out slowly as you learn more. Learning
to read generated macros is a good place to start.
If you record Calc macros, and the recorder can correctly generate a macro, there is an add-in
created by Paolo Mantovani, which converts Calc macros when they are recorded. The final code
manipulates LibreOffice objects rather than generating dispatches. This can be very useful for
learning the object model.
You can download the macro recorder from Paolo’s web site directly:
http://www.paolo-mantovani.org/downloads/DispatchToApiRecorder/

Macro organization
In LibreOffice, macros are grouped in modules, modules are grouped in libraries, and libraries are
grouped in library containers. A library is usually used as a major grouping for either an entire
category of macros, or for an entire application. Modules usually split functionality, such as user
interaction and calculations. Individual macros are subroutines and functions.
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Figure 336: Macro Library hierarchy
A computer scientist would use Figure 337 to precisely describe the situation. The text “1..*” means
one or more, and “0..*” means zero or more. The black triangle means composed of or contains.

• A library container contains one or more libraries, and each library is contained in one
library container.

• A library contains zero or more modules, and each module is contained in one library.
• A module contains zero or more macros, and each macro is contained in one module.

Figure 337: Macro Library hierarchy
Use Tools > Macros > Organize Macros > LibreOffice Basic to open the LibreOffice Basic
Macros dialog (see Figure 338). All available library containers are shown in the Macro from list.
Every document is a library container, capable of containing multiple libraries. The application itself
acts as two library containers, one container for macros distributed with LibreOffice called
LibreOffice Macros, and one container for personal macros called My Macros. As shown in Figure
338, only two documents are currently open.
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Figure 338: Library containers are shown on the left
The LibreOffice Macros are stored with the application runtime code, which may not be editable to
you unless you are an administrator. This is just as well since these macros should not be changed
and you should not store your own macros in the LibreOffice container.
Unless your macros are applicable to a single document, and only to a single document, your
macros will probably be stored in the My Macros container. The My Macros container is stored in
your user area or home directory.
If a macro is contained in a document, then a recorded macro will attempt to work on that
document; primarily because it uses “ThisComponent” for its actions.
Every library container contains a library named Standard. It is better to create your own libraries
with meaningful names than to use the Standard library. Not only are meaningful names easier to
manage, but they can also be imported into other library containers whereas the Standard library
cannot.

Caution

LibreOffice allows you to import libraries into a library container, but it will not allow
you to overwrite the library named Standard. Therefore, if you store your macros in
the Standard library, you cannot import them into another library container.

Just as it makes good sense to give your libraries meaningful names, it is prudent to use
meaningful names for your modules. By default, LibreOffice uses names such as Module1. Feel
free to use your own meaningful name.
As you create your macros, you must decide where to store them. Storing a macro in a document
is useful if the document will be shared and you want the macro to be included with the document.
Macros stored in the application library container named My Macros, however, are globally
available to all documents.
Macros are not available until the library that contains them is loaded. The Standard library and
Template library, however, are automatically loaded. A loaded library is displayed differently from a
library that is not loaded. To load the library and the modules it contains, double-click on the library.
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Where are macros stored?
LibreOffice stores user-specific data in a directory under the user’s home directory. The location is
operating system specific. Use Tools > Options > LibreOffice > Paths to view where other
configuration data is stored. On Windows XP, this is C:\Documents and Settings\<name>\
Application Data. User macros are stored in LibreOffice\3\user\basic. Each library is
stored in its own directory off the basic directory.
It is not important to understand where macros are stored for casual use. If you know where they
are stored, however, you can create a backup, share your macros, or inspect them if there is an
error.
Use Tools > Macros > Organize Dialogs to open the LibreOffice Macro Organizer dialog. Another
common way to open this dialog is to use Tools > Macros > Organize Macros > LibreOffice
Basic to open the LibreOffice Macros dialog and then click the Organizer button.

Figure 339: The macro organizer dialog

Importing macros
The LibreOffice Macro Organizer dialog provides functionality to create, delete, and rename
libraries, modules, and dialogs. Select the library container to use and then click the Import button
to import macro libraries (see Figure 340).

Note

Tip
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You cannot import the library named Standard.
On Linux, the LibreOffice-specific files are stored under the user's home directory in
a directory whose name begins with a period. Directories and files with names
beginning with a period are not shown in a normal selection dialog. To open the
directory, either navigate to the home directory, enter the name .libreoffice\3, and
then click Open or press Ctrl-H to show hidden folders and files and navigate as
usual. This will open the directory, which is not initially shown.

Getting Started with LibreOffice 3.5

Figure 340: Select a macro library to import
Navigate to the directory containing the library to import. There are usually two files from which to
choose, dialog.xlb and script.xlb. It does not matter which of these two files you select; both will be
imported. Select a file and click Open to continue.

Figure 341: Choose library import options
If the library already exists, it will not be replaced unless Replace existing libraries is checked. If
Insert as reference is checked, the library is referenced in its current location, but you cannot edit
the library. If Insert as reference is not checked, however, the library is copied to the user’s macro
directory.
Macros can be stored in libraries inside LibreOffice documents. Select a document rather than a
directory on disk (as shown in Figure 340) to import libraries contained in a document.
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Downloading macros to import
Macros are available for download. Some macros are contained in documents, some as regular
files that you must select and import, and some as macro text that should be copied and pasted
into the Basic IDE; use Tools > Macros > Organize Macros > LibreOffice Basic to open the
LibreOffice Macros dialog, choose the macro to edit, and then click Edit to open the macro in the
Basic IDE.
Some macros are available as free downloads on the Internet (see Table 8). “Adding an existing
macro“ on page 330 describes how to add these macros to your macros library.
Table 8. Places to find macro examples
Location

Description

http://www.ooomacros.org/

Collection of packaged macros – now somewhat
dated.

http://www.pitonyak.org/oo.php

Reference materials regarding macros.

http://www.pitonyak.org/database/

Reference materials regarding database macros.

http://development.openoffice.org/

Lots of links to everything.

http://www.oooforum.org/

A forum, with many examples and help.

http://user.services.openoffice.org/

Another forum, with many examples and help.

How to run a macro
A typical method to run a macro is as follows:
1) Use Tools > Macros > Run Macro to open the Macro Selector dialog (see Figure 342).
2) Select the library and module in the Library list (left hand side).
3) Select the macro in the Macro name list (right hand side).
4) Click Run to run the macro.

Figure 342: Use the Macro Selector dialog to run macros
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Although you can use Tools > Macros > Run Macro to run all macros, this is not efficient for
frequently run macros. A more common technique is to assign a macro to a toolbar button, menu
item, keyboard shortcut, or a button embedded in a document. While choosing a method, it is also
good to ask questions such as:

• Should the macro be available for only one document, or globally for all documents?
• Does the macro pertain to a specific document type, such as a Calc document?
• How frequently will the macro be used?
The answers will determine where to store the macro and how to make it available. For example,
you will probably not add a rarely used macro to a toolbar. To help determine your choices, see
Table 9.
Table 9. Methods for starting a macro
Type

LibreOffice

Document Type

Document

Toolbar

No

Yes

Yes

Menu

No

Yes

Yes

Shortcut

Yes

Yes

No

Event

Yes

No

Yes

To add a menu item, keyboard shortcut, or toolbar icon that calls a macro, use the Customize
dialog (see Figure 343). Open this dialog in either of these ways:

• Choose Tools > Customize from the main menu bar.
• Each toolbar has an icon
Tip

that opens a menu; choose the Customize Toolbar option.

Complete coverage of the Customize dialog is beyond the scope of this document.
Click the Help button to access the help pages included with LibreOffice.

The Customize dialog contains tabs to configure menus, keyboard bindings, toolbars, and events.

Toolbar
Macros can be added to toolbars. For more about modifying toolbars, see Chapter 14, Customizing
LibreOffice.

Menu item
Use Tools > Customize to open the Customize dialog, and select the Menus tab. You can modify
an existing menu, or create new menus that call macros. For more about modifying menus, see
Chapter 14.

Keyboard shortcuts
Use Tools > Customize to open the Customize dialog, and select the Keyboard tab. Assigning
keyboard shortcuts is discussed in Chapter 14.
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Figure 343: LibreOffice Customize dialog

Event
In LibreOffice, when something happens, we say that an event occurred. For example, a document
was opened, a key was pressed, or the mouse moved. LibreOffice allows events to cause a macro
to be called; the macro is then called an event handler. Full coverage of event handlers is well
beyond the scope of this document, but a little knowledge can accomplish much.

Caution

Be careful when you configure an event handler. For example, assume that you
write an event handler that is called every time that a key is pressed, but you make a
mistake so the event is not properly handled. One possible result is that your event
handler will consume all key presses, forcing you to forcibly terminate LibreOffice.

Use Tools > Customize to open the Customize dialog, and select the Events tab (see Figure 344).
The events in the Customize dialog are related to the entire application and specific documents.
Use the Save In box to choose LibreOffice, or a specific document.
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Figure 344: Assign macro to an application level event
A common use is to assign the Open Document event to call a specific macro. The macro then
performs certain setup tasks for the document. Select the desired event and click the Macro button
to open the Macro Selector dialog (see Figure 345).

Figure 345: Assign macro to the document open event
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Select the desired macro and click OK to assign the macro to the event. The Events tab shows
that the event has been assigned to a macro (see Figure 346). When the document opens, the
PrintHello macro is run.
Many objects in a document can be set to call macros when events occur. The most common
usage is to add a control, such as a button, into a document. Even double-clicking on a graphic
opens a dialog with a Macros tab that allows you to assign a macro to an event.

Figure 346: HelloMacro is assigned to the Open Document event

Extensions
An extension is a package that can be installed into LibreOffice to add new functionality.
Extensions can be written in almost any programming language and may be simple or
sophisticated. Extensions can be grouped into types:

• Calc Add-Ins, which provide new functionality for Calc, including new functions that act like
normal built-in functions

• New components and functionality, which normally include some level of UI integration
such as new menus or toolbars

•
•
•
•

Data pilots that are used directly in Calc
Chart Add-Ins with new chart types
Linguistic components such as spell checkers
Document templates and images

Although individual extensions can be found in different places, there is currently an extension
repository at: http://extensions.libreoffice.org/ and some documentation at
http://libreplanet.org/wiki/Group:OpenOfficeExtensions/List
For more about obtaining and installing extensions, see Chapter 14, Customizing LibreOffice.

Writing macros without the recorder
The examples covered in this chapter are created using the macro recorder and the dispatcher.
You can also write macros that directly access the objects that comprise LibreOffice. In other
words, you can directly manipulate a document.
Directly manipulating LibreOffice's internal objects is an advanced topic that is beyond the scope of
this chapter. A simple example, however, demonstrates how this works.
Listing 7: Append the text “Hello” to the current document.
Sub AppendHello
Dim oDoc
Dim sTextService$
Dim oCurs
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REM ThisComponent refers to the currently active document.
oDoc = ThisComponent
REM Verify that this is a text document
sTextService = "com.sun.star.text.TextDocument"
If NOT oDoc.supportsService(sTextService) Then
MsgBox "This macro only works with a text document"
Exit Sub
End If
REM Get the view cursor from the current controller.
oCurs = oDoc.currentController.getViewCursor()
REM Move the cursor to the end of the document
oCurs.gotoEnd(False)
REM Insert text "Hello" at the end of the document
oCurs.Text.insertString(oCurs, "Hello", False)
End Sub

Finding more information
Numerous resources are available that provide help with writing macros. Use Help > LibreOffice
Help to open the LibreOffice help pages. The upper left corner of the LibreOffice help system
contains a drop-down list that determines which help set is displayed. To view the help for Basic,
choose LibreOffice Basic from this list.

Included material
Many excellent macros are included with LibreOffice. Use Tools > Macros > Organize Macros >
LibreOffice Basic to open the Macro dialog. Expand the Tools library in the LibreOffice library
container. Inspect the Debug module—some good examples include WritedbgInfo(document) and
printdbgInfo(sheet).

Online resources
The following links and references contain information regarding macro programming:
http://user.services.openoffice.org/ (OOo forums, well supported; volunteers answer questions
about LibreOffice as well)
http://api.openoffice.org/docs/common/ref/com/sun/star/module-ix.html (official IDL reference; here
you'll find almost every command with a description)
http://wiki.documentfoundation.org/Documentation/Publications#Other_Documentation_and_Reso
urces (BASIC Programming Guide and Developers Guide; the latter contains a detailed
explanation)
http://www.pitonyak.org/oo.php (Andrew Pitonyak’s macro page)
http://www.pitonyak.org/AndrewMacro.odt (numerous examples of working macros)
http://www.pitonyak.org/OOME_3_0.odt (Andrew Pitonyak’s book on macros)
http://www.pitonyak.org/database/ (numerous macro examples using Base)
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Printed and eBook materials
There are currently no books specific to LibreOffice macros that are available for download.
For OpenOffice.org the following books are available for purchase in both printed and eBook form
from their publishers:
Dr. Mark Alexander Bain’s Learn OpenOffice.org Spreadsheet Macro Programming.
See http://www.packtpub.com/openoffice-ooobasic-calc-automation/book.
Roberto Benitez's Database Programming with OpenOffice.org Base & Basic.
See http://www.lulu.com/product/paperback/database-programming-with-openofficeorg-basebasic/3568728
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Chapter 14
Customizing LibreOffice

Introduction
This chapter describes some common customizations that you may wish to do.
You can customize menus, toolbars, and keyboard shortcuts in LibreOffice, add new menus and
toolbars, and assign macros to events. However, you cannot customize context (right-click) menus.
Other customizations are made easy by extensions that you can install from the LibreOffice
website or from other providers.

Note

Customizations to menus and toolbars can be saved in a template. To do so, first
save them in a document and then save the document as a template as described in
Chapter 3, Using Styles and Templates.

Customizing menu content
In addition to changing the menu font (described in Chapter 2, Setting up LibreOffice), you can add
and rearrange categories on the menu bar, add commands to menus, and make other changes.
To customize menus:
1) Choose Tools > Customize.
2) On the Customize dialog, choose the Menus page.

Figure 347. The Menus page of the Customize dialog
3) In the Save In drop-down list, choose whether to save this changed menu for the
application (for example, LibreOffice Writer) or for a selected document (for example,
SampleDocument.odt).
4) In the section LibreOffice [name of the program (example: Writer)] Menus, select from
the Menu drop-down list the menu that you want to customize. The list includes all the main
menus as well as submenus (menus that are contained under another menu). For
352

Getting Started with LibreOffice 3.5

example, in addition to File, Edit, View, and so on, there is File | Send and File |Templates.
The commands available for the selected menu are shown in the central part of the dialog.
5) To customize the selected menu, click on the Menu or Modify buttons. You can also add
commands to a menu by clicking on the Add button. These actions are described in the
following sections. Use the up and down arrows next to the Entries list to move the
selected menu item to a different position.
6) When you have finished making all your changes, click OK (not shown in illustration) to
save them.

Creating a new menu
In the Menus page of the Customize dialog, click New to display the New Menu dialog, shown in
Figure 348.
1) Type a name for your new menu in the Menu name box.
2) Use the up and down arrow buttons to move the new menu into the required position on
the menu bar.
3) Click OK to save.
The new menu now appears on the list of menus in the Customize dialog. (It will appear on the
menu bar itself after you save your customizations.)
After creating a new menu, you need to add some commands to it, as described in “Adding a
command to a menu” on page 354.

Figure 348: Adding a new menu

Modifying existing menus
To modify an existing menu, either user-made or inbuilt, select it in the Menu list and click the
Menu button to drop down a list of modifications: Move, Rename, Delete. Not all of these
modifications can be applied to all the entries in the Menu list. For example, Rename and Delete
are not available for the supplied menus, and Move is not available for submenus.
To move a menu (such as File), choose Menu > Move. A dialog similar to the one shown in Figure
348 (but without the Menu name box) opens. Use the up and down arrow buttons to move the
menu into the required position.
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To move submenus (such as File | Send), select the main menu (File) in the Menu list and then, in
the Menu Content section of the dialog, select the submenu (Send) in the Entries list and use the
arrow keys to move it up or down in the sequence. Submenus are easily identified in the Entries list
by a small black triangle on the right hand side of the name.
In addition to renaming, you can allocate a letter in a custom menu’s name, which will become
underlined, to be used as a keyboard shortcut, that allows you to select that menu when you press
Alt+ that letter. Existing submenus can be edited to change the letter which is used to select them
from the keyboard once the menu is open.
1) Select a custom menu or a submenu in the Menu drop-down list.
2) Click the Menu button and select Rename.
3) Add a tilde (~) in front of the letter that you want to use as an accelerator. For example, to
select the Send submenu command by pressing S (after opening the File menu using
Alt+F), enter ~Send. This changes it from the default d.

Caution

When allocating a shortcut to custom menus, be careful to not use an existing
shortcut letter.

Adding a command to a menu
You can add commands to the supplied menus and to menus you have created. On the Customize
dialog, select the menu in the Menu list and click the Add button in the Menu Content section of
the dialog.
On the Add Commands dialog (Figure 349), select a category and then the command, and click
Add. The dialog remains open, so you can select several commands. When you have finished
adding commands, click Close. Back on the Customize dialog, you can use the up and down
arrow buttons to arrange the commands in your preferred sequence.

Figure 349: Adding a command to a menu
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Modifying menu entries
In addition to changing the sequence of entries on a menu or submenu, you can add submenus,
rename or delete the entries, and add group separators.
To begin, select the menu or submenu to be modified, from the Menu list near the top of the
Customize page, then select the entry in the Entries list under Menu Content. Click the Modify
button and choose the required action from the drop-down list of actions.
Most of the actions should be self-explanatory. Begin a group adds a separator line after the
highlighted entry.

Customizing toolbars
You can customize toolbars in several ways, including choosing which icons are visible and locking
the position of a docked toolbar (as described in Chapter 1, Introducing LibreOffice), and adding or
deleting icons (commands) in the list of those available on a toolbar. You can also create new
toolbars. This section describes how to create new toolbars and add or delete icons on existing
ones.
To get to the toolbar customization dialog, do any of the following:

• On the toolbar, click the arrow at the end of the toolbar and choose Customize Toolbar.
• Choose View > Toolbars > Customize from the menu bar.
• Choose Tools > Customize from the menu bar and go to the Toolbars page.

Figure 350. The Toolbars page of the Customize dialog
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Modifying existing toolbars
To modify an existing toolbar:
1) In the Save In drop-down list, choose whether to save this changed toolbar for the
application (for example, Writer) or for a selected document.
2) In the section LibreOffice [name of the program (example: Writer)] > Toolbars, select
from the Toolbar drop-down list the toolbar that you want to customize.
3) You can create a new toolbar by clicking on the New button, or customize existing toolbars
by clicking on the Toolbar or Modify buttons, and add commands to a toolbar by clicking
on the Add button. These actions are described below.
4) When you have finished making all your changes, click OK to save them.

Creating a new toolbar
To create a new toolbar:
1) Choose Tools > Customize from the menu bar and go to the Toolbars tab.
2) Click New. On the Name dialog, type the new toolbar's name and choose from the Save In
drop-down list where to save this changed menu: for the application (for example, Writer) or
for a selected document. Click OK.

The new toolbar now appears on the list of toolbars in the Customize dialog. After creating a new
toolbar, you need to add some commands to it, as described below.

Adding a command to a toolbar
If the list of available buttons for a toolbar does not include all the commands you want on that
toolbar, you can add commands. When you create a new toolbar, you need to add commands to it.
1) On the Toolbars page of the Customize dialog, select the toolbar in the Toolbar list and click
the Add button in the Toolbar Content section of the dialog.
2) The Add Commands dialog is the same as for adding commands to menus (Figure 349).
Select a category and then the command, and click Add. The dialog remains open, so you
can select several commands. When you have finished adding commands, click Close. If
you insert an item which does not have an associated icon, the toolbar will display the full
name of the item: the next section describes how to choose an icon for a toolbar command.
3) Back on the Customize dialog, you can use the up and down arrow buttons to arrange the
commands in your preferred sequence.
4) When you are done making changes, click OK to save.

Choosing icons for toolbar commands
Toolbar buttons usually have icons, not words, on them, but not all of the commands have
associated icons.
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To choose an icon for a command, select the command and click Modify > Change icon. On the
Change Icon dialog, you can scroll through the available icons, select one, and click OK to assign
it to the command.

Figure 351: Change Icon dialog
To use a custom icon, create it in a graphics program and import it into LibreOffice by clicking the
Import button on the Change Icon dialog. Custom icons should be 16 x 16 pixels in size to achive
the best quality and should not contain more than 256 colors.

Example: Adding a Fax icon to a toolbar
You can customize LibreOffice so that a single click on an icon automatically sends the current
document as a fax.
1) Be sure the fax driver is installed. Consult the documentation for your fax modem for more
information.
2) Choose Tools > Options > LibreOffice Writer > Print. The dialog shown in Figure 352
opens.
3) Select the fax driver from the Fax list and click OK.
4) Click the arrow icon at the end of the Standard toolbar. In the drop-down menu, choose
Customize Toolbar. The Toolbars page of the Customize dialog appears (Figure 350).
Click Add.
5) On the Add Commands dialog (Figure 349), select Documents in the Category list, then
select Send Default Fax in the Commands list. Click Add. Now you can see the new icon
in the Commands list.
6) In the Commands list, click the up or down arrow button to position the new icon where you
want it. Click OK and then click Close.
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Figure 352: Setting up LibreOffice for sending faxes
Your toolbar now has a new icon to send the current document as a fax.

Figure 353: Adding a Send Fax command to a toolbar

Assigning shortcut keys
In addition to using the built-in keyboard shortcuts (listed in Appendix A), you can define your own.
You can assign shortcuts to standard LibreOffice functions or your own macros and save them for
use with the entire LibreOffice suite.

Caution

Be careful when reassigning your operating system’s or LibreOffice’s predefined
shortcut keys. Many key assignments are universally understood shortcuts, such as
F1 for Help, and are always expected to provide certain results. Although you can
easily reset the shortcut key assignments to the LibreOffice defaults, changing some
common shortcut keys can cause confusion, especially if other users share your
computer.

To adapt shortcut keys to your needs, use the Customize dialog, as described below.
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1) Select Tools > Customize > Keyboard. The Customize dialog opens.
2) To have the shortcut key assignment available in all components of LibreOffice select the
LibreOffice radio button.
3) Next select the required function from the Category and Function lists.
4) Now select the desired shortcut keys in the Shortcut keys list and click the Modify button at
the upper right.
5) Click OK to accept the change. Now the chosen shortcut keys will execute the function
chosen in step 3 above whenever they are pressed.

Note

All existing shortcut keys for the currently selected Function are listed in the Keys
selection box. If the Keys list is empty, it indicates that the chosen key combination is
free for use. If it were not, and you wanted to reassign a shortcut key combination
that is already in use, you must first delete the existing key.
Shortcut keys that are greyed-out in the listing on the Customize dialog, such as F1
and F10, are not available for reassignment.

Example: Assigning styles to shortcut keys
You can configure shortcut keys to quickly assign styles in your document. Some shortcuts are
predefined, such as Ctrl+0 for the Text body paragraph style, Ctrl+1 for the Heading 1 style, and
Ctrl+2 for Heading 2. You can modify these shortcuts and create your own.
1) Click Tools > Customize > Keyboard. The Keyboard page of the Customize dialog opens.

Figure 354. Defining keyboard shortcuts for applying styles
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2) To have the shortcut key assignment available only with one component (for example,
Writer), select that component’s name in the upper right corner of the page; otherwise
select LibreOffice to make it available to every component.
3) Choose the shortcut keys you want to assign a style to. In this example, we have chosen
Ctrl+9. This enables the Modify button.
4) In the Functions section at the bottom of the dialog, scroll down in the Category list to
Styles. Click the expansion symbol (usually a + sign or triangle) to expand the list of styles.
5) Choose the category of style. (This example uses a paragraph style, but you can also
choose character styles and others.) The Function list will display the names of the
available styles for the selected category. The example shows some of LibreOffice’s
predefined styles.
6) To assign Ctrl+9 to be the shortcut key combination for the List 1 style, select List 1 in the
Function list, and then click Modify. Ctrl+9 now appears in the Keys list on the right, and
List 1 appears next to Ctrl+9 in the Shortcut keys box at the top.
7) Make any other required changes, and then click OK to save these settings and close the
dialog.

Saving changes to a file
Changes to the shortcut key assignments can be saved in a keyboard configuration file for use at a
later time, thus permitting you to create and apply different configurations as the need arises. To
save keyboard shortcuts to a file:
1) After making your keyboard shortcut assignments, click the Save button at the right of the
Customize dialog (Figure 354).
2) In the Save Keyboard Configuration dialog, select All files from the Save as Type list.
3) Next enter a name for the keyboard configuration file in the File name box, or select an
existing file from the list. If you need to, browse to find a file from another location.
4) Click Save. A confirmation dialog appears if you are about to overwrite an existing file,
otherwise there will be no feedback and the file will be saved.

Loading a saved keyboard configuration
To load a saved keyboard configuration file and replace your existing configuration, click the Load
button at the right of the Customize dialog, and then select the configuration file from the Load
Keyboard Configuration dialog.

Resetting the shortcut keys
To reset all of the keyboard shortcuts to their default values, click the Reset button near the bottom
right of the Customize dialog. Use this feature with care as no confirmation dialog will be displayed;
the defaults will be set without any further notice or user input.

Assigning macros to events
In LibreOffice, when something happens, we say that an event occured. For example, a document
was opened, a key was pressed, or the mouse moved. You can associate a macro with an event,
so the macro is run when the event occurs. A common use is to assign the “open document” event
to run a macro that performs certain setup tasks for the document.
To associate a macro with an event, use the Events page of the Customize dialog. For more
information, see Chapter 13, Getting Started with Macros.
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Adding functionality with extensions
An extension is a package that can be installed into LibreOffice to add new functionality.
Several popular extensions are shipped bundled with LibreOffice and are installed with the
program. Others can be downloaded from various websites. The official extension repository is
located at http://extensions.libreoffice.org/. These extensions are free of charge.
Some extensions from other sources are free of charge; others are available for a fee. Check the
descriptions to see what licenses and fees apply to the ones that interest you.

Installing extensions
To install an extension, follow these steps:
1) Download an extension and save it anywhere on your computer.
2) In LibreOffice, select Tools > Extension Manager from the menu bar. In the Extension
Manager dialog (Figure 355), click Add.
3) A file browser window opens. Find and select the extension you want to install and click
Open. The extension begins installing. You may be asked to accept a license agreement.
4) When the installation is complete, the extension is listed in the Extension Manager dialog.

Tip

Note

To download extensions that are listed in the repository, you can open the Extension
Manager and click the Get more extensions online... link.
To install a shared extension, you will need write access to the LibreOffice
installation directory.

Figure 355: Using the Extension Manager
Chapter 14 Customizing LibreOffice
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Appendix A
Keyboard Shortcuts

Introduction
You can use LibreOffice without requiring a pointing device, such as a mouse or touchpad, by
using its built-in keyboard shortcuts.
This appendix lists some of the most common built-in keyboard shortcuts that apply to all
components of LibreOffice. For shortcuts specific to Writer, Calc, Impress, Draw, or Base, read the
relevant component guide or search the application Help.
Some of the shortcuts listed here may not work if your operating system uses the
same shortcuts for other tasks.

Note

To resolve any conflicts, assign different keys to these shortcuts by reconfiguring
either LibreOffice (see Chapter 14) or your operating system (see system
documentation).

Tip for Macintosh users
Some keystrokes are different on a Mac from those used in Windows and Linux. The following
table gives some common substitutions for the instructions in this chapter. For a more detailed list,
see the application Help.
Windows or Linux

Mac equivalent

Effect

Right-click

Control+click

Opens a context menu

Ctrl (Control)

z (Command)

Used with other keys

F5

Shift+z+F5

Opens the Navigator

F11

z+T

Opens the Styles and Formatting window
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General keyboard shortcuts
Opening menus and menu items
Shortcut Keys

Result

Alt+<?>

Opens a menu where <?> is the underlined character of the menu
you want to open. For example, Alt+T opens the menu Tools.

Alt+<?>+<*>

Opens a menu item where <?> is the underlined character of the
menu you want to open and <*> is the item within that menu. For
example, Alt+T+G opens the Gallery menu item in the menu Tools.

Esc

Closes an open menu.

Controlling dialogs
When you open any dialog, one element (such as a button, an option field, an entry in a list box, or
a checkbox) is highlighted or indicated by a dotted box around the field or button name. This
element is said to have the focus on it.
Shortcut Keys

Result

Enter

Activates selected button. In most cases where no button is
selected, Enter is equivalent to clicking OK.

Esc

Closes dialog without saving any changes made while it was open.
In most cases, Esc is equivalent to clicking Cancel. When an open
drop-down list is selected, Esc closes the list.

Spacebar

Checks an empty checkbox. Clears a checked checkbox.

Up, down arrow keys

Moves focus up and down a list. Increases or decreases value of a
variable. Moves focus vertically within a section of dialog.

Left, right arrow keys

Moves focus horizontally within a section of a dialog.

Tab

Advances focus to the next section or element of a dialog.

Shift+Tab

Returns focus to the previous section or element in a dialog.

Alt+Down Arrow

Shows items in a drop-down list.

Getting help
Shortcut Keys

Result

F1

Opens the LibreOffice Help dialog. In LibreOffice Help: jumps to the
first help page of the selected tab.

Shift+F1

Turns the cursor into the What’s This? question mark. Shows the tip
for an item underneath the cursor.

Shift+F2

Shows tip for a selected item.

Esc

In LibreOffice Help: goes up one level.
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Managing documents
Shortcut Keys

Result

Ctrl+F4 or Alt+F4

Closes the current document. Closes LibreOffice when the last
open document is closed.

Ctrl+O

Launches the Open dialog to open a document.

Ctrl+S

Saves the current document. If you are working on a previously
unsaved file, the shortcut launches the Save As dialog.

Ctrl+N

Creates a new document.

Shift+Ctrl+N

Opens the Templates and Documents dialog.

Ctrl+P

Opens the Print dialog to print the document.

Ctrl+Q

Closes the application.

Del

In the Save and Open dialogs, deletes the selected files or folders.
Items can be retrieved from the Recycle Bin (Trash).

Shift+Del

In the Save and Open dialogs, deletes the selected files or folders.
Items are permanently deleted: they can not be retrieved from the
Recycle Bin.

Backspace

In the Save and Open dialogs, shows contents of the current
directory's parent folder.

Navigating across LibreOffice
Shortcut Keys

Result

F6

Selects next subwindow (for example: Menu bar, Standard toolbar,
document view, and so on).

Shift+F6

Selects previous subwindow.

F10

Selects the first menu, typically the File menu.

Shift+F10

Opens the context menu.

Editing
Shortcut Keys

Result

Ctrl+X

Cuts selected items.

Ctrl+C

Copies selected items.

Ctrl+V

Pastes copied or cut items from the clipboard.

Ctrl+Shift+V

Opens the Paste Special dialog.

Ctrl+A

Selects all.

Ctrl+Z

Undoes last action.

Ctrl+Y

Redoes last action.

Ctrl+Shift+Y

Repeats last command.
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Shortcut Keys

Result

Ctrl+F

Opens the Find & Replace dialog.

Ctrl+Shift+F

Searches for the last entered search term.

Ctrl+Shift+R

Refreshes (redraws) the document view.

Ctrl+Shift+I

Shows or hides the cursor in read-only text.

Stopping macros
Shortcut Keys

Result

Shift+Ctrl+Q

Stops a running macro.

Defining keyboard shortcuts
In addition to using the built-in keyboard shortcuts listed in this Appendix, you can define your own.
See Chapter 14, Customizing LibreOffice, for instructions.

Further reading
For help with LibreOffice’s keyboard shortcuts, or using LibreOffice with a keyboard only, search
the application Help using the “shortcut keys” or “accessibility” keywords.
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Appendix B
Open Source,
Open Standards,
OpenDocument

Introduction
LibreOffice is a productivity suite that is compatible with other major office suites and available on a
variety of platforms. It is open source software and therefore free to download, use, and distribute.
If you are new to LibreOffice, this appendix will provide some information regarding its history, its
community and some of its technical specifications.

A short history of LibreOffice
The OpenOffice.org project began when Sun Microsystems released the source code (“blueprints”)
for its StarOffice® software to the open source community on October 13, 2000. OpenOffice.org
1.0, the product, was released on April 30, 2002. Major updates to OpenOffice.org included version
2.0 in October 2005 and version 3.0 in October 2008. On January 26, 2010, Oracle Corporation
acquired Sun Microsystems.
On September 28, 2010, the community of volunteers who develop and promote OpenOffice.org
announce a major change in the project’s structure. After ten years’ successful growth with Sun
Microsystems as founding and principle sponsor, the project launched an independent foundation
called The Document Foundation, to fulfil the promise of independence written in the original
charter. This foundation is the cornerstone of a new ecosystem where individuals and
organizations can contribute to and benefit from the availability of a truly free office suite.
Unable to acquire the trademarked OpenOffice.org name from Oracle Corporation, The Document
Foundation named its product LibreOffice. Continuing the version numbers from OpenOffice.org,
LibreOffice 3.3 was released in January 2011.
In February 2012, The Document Foundation was incorporated in Berlin as a German Stiftung. You
can read more about The Document Foundation at: http://www.documentfoundation.org/

The LibreOffice community
The Document Foundation's mission is:
“...to facilitate the evolution of the OpenOffice.org Community into a new open, independent,
and meritocratic organizational structure within the next few months. An independent
Foundation is a better match to the values of our contributors, users, and supporters, and will
enable a more effective, efficient, transparent, and inclusive Community. We will protect past
investments by building on the solid achievements of our first decade, encourage wide
participation in the Community, and co-ordinate activity across the Community.”
Some of our corporate supporters include Canonical, The GNOME Foundation, Google, Novell and
Red Hat. Additonally, over 450,000 people from nearly every part of the globe have joined this
project with the idea of creating the best possible office suite that all can use. This is the essence
of an “open source” community!
With its open source software licence, LibreOffice is key in the drive to provide an office suite that
is available to anyone, anywhere, for commercial or personal use. The software has been
translated into many languages and runs on all major operating systems. New functionality can be
added in the form of extensions.
The LibreOffice community invites contributors in all areas, including translators, software
developers, graphic artists, technical writers, editors, donors and end-user support. Whatever you
do best, you can make a difference in LibreOffice. The Community operates internationally in all
time zones and in many languages, linked through the internet at www.libreoffice.org and
www.documentfoundation.org.
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How is LibreOffice licensed?
LibreOffice is distributed under the Open Source Initiative (OSI) approved Lesser General Public
License (LGPL).
The LGPL license is available from the LibreOffice website:
http://www.libreoffice.org/download/license/

What is “open source”?
The four essential rights of open-source software are embodied within the Free Software
Foundation’s General Public License (GPL):

•
•
•
•

The right to use the software for any purpose.
Freedom to redistribute the software for free or for a fee.
Access to the complete source code of the program (that is, the “blueprints”).
The right to modify any part of the source, or use portions of it in other programs.

The basic idea behind open source is very simple: When programmers can read, redistribute, and
modify the source code for a piece of software, the software evolves. People improve it, people
adapt it, people fix bugs.
For more information on Free and Open Source software, visit these websites:
Open Source Initiative (OSI): http://www.opensource.org
Free Software Foundation (FSF): http://www.gnu.org

What are “open standards”?
An open standard provides a means of doing something that is independent of manufacturer or
vendor, thus enabling competing software programs to freely use the same file formats. HTML,
XML, and ODF are examples of open standards for documents.
An open standard meets the following requirements:

• It is well documented with the complete specification publically available, either free or at a
nominal charge.

• It can be freely copied, distributed and used. The intellectual property of the standard is
made irrevocably available on a royalty-free basis.

• It is standardized and maintained in an independent, open forum (also called "standards
organization") using an open process.

What is OpenDocument?
OpenDocument (ODF) is an XML-based file format for office documents (text documents,
spreadsheets, drawings, presentations and more), developed at OASIS (http://www.oasisopen.org/who/), an independent, international standards group.
Unlike other file formats, ODF is an open standard. It is publicly available, royalty-free, and without
legal or other restrictions; therefore ODF files are not tied to a specific office suite and anybody can
build a program that interprets these files. For this reason ODF is quickly becoming the preferred
file format for government agencies, schools and other companies who prefer not to be too
dependent on any one software supplier.
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Since version 2.0, OpenOffice.org has supported the open standard OASIS OpenDocument as its
default file format. LibreOffice saves documents in OpenDocument Format by default. LibreOffice 3
has adopted version 1.2 of the OpenDocument standard. LibreOffice can also open and save
many other file formats; see “File formats LibreOffice can open” on this page, “File formats
LibreOffice can save to” on page 374, and “Exporting to other formats” on page 375.

OpenDocument filename extensions
The most common filename extensions used for OpenDocument documents are:
*.odt for word processing (text) documents
*.ods for spreadsheets
*.odp for presentations
*.odb for databases
*.odg for graphics (vector drawings)
*.odf for formulas (mathematical equations)

File formats LibreOffice can open
LibreOffice can open a wide variety of file formats in addition to the OpenDocument formats,
including Portable Document Format (PDF), if an ODF file is embedded in the PDF (see Chapter
10 for more information).

Opening text documents
In addition to OpenDocument formats (.odt, .ott, .oth, .odm, and .fodt), Writer 3 can open the
formats used by OpenOffice.org 1.x (.sxw, .stw, and .sxg) and the following text document formats:
Microsoft Word 6.0/95/97/2000/XP) (.doc and .dot)
Microsoft Word 2003 XML (.xml)
Microsoft Word 2007/2010 XML (.docx, .docm, .dotx, .dotm)
Microsoft WinWord 5 (.doc)
WordPerfect Document (.wpd)
Microsoft Works (.wps)
Lotus WordPro (.lwp)
Rich Text Format (.rtf)
Text CSV (.csv and .txt)
StarWriter formats (.sdw, .sgl, .vor)
DocBook (.xml)
Unified Office Format text (.uot, .uof)
Ichitaro 8/9/10/11 (.jtd and .jtt)
Hangul WP 97 (.hwp)
T602 Document (.602, .txt)
AportisDoc (Palm) (.pdb)
Pocket Word (.psw)
HTML Document (.htm, .html)
Most of these file types are automatically detected by LibreOffice, so they can be opened without
explicitly selecting the document type in the file picker.
When opening .htm or .html files (used for web pages), LibreOffice customizes Writer for working
with these files.
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Opening spreadsheets
In addition to OpenDocument formats (.ods, .ots, and .fods), Calc 3 can open the formats used by
OpenOffice.org 1.x (.sxc and .stc) and the following spreadsheet formats:
Microsoft Excel 97/2000/XP (.xls, .xlw, and .xlt)
Microsoft Excel 4.x–5.0/95 (.xls, .xlw, and .xlt)
Microsoft Excel 2003 XML (.xml)
Microsoft Excel 2007/2010 XML (.xlsx, .xlsm, .xlts, .xltm)
Microsoft Excel 2007/2010 binary (.xlsb)
Lotus 1-2-3 (.wk1, .wks, and .123)
Data Interchange Format (.dif)
Rich Text Format (.rtf)
Text CSV (.csv and .txt)
StarCalc formats (.sdc and .vor)
dBASE (.dbf)
SYLK (.slk)
Unified Office Format spreadsheet (.uos, .uof)
HTML Document (.htm and .html files, including Web page queries)
Pocket Excel (pxl)
Quattro Pro 6.0 (.wb2)

Opening presentations
In addition to OpenDocument formats (.odp, .odg, .otp, and .fopd), Impress 3 can open the formats
used by OpenOffice.org 1.x (.sxi and .sti) and the following presentation formats:
Microsoft PowerPoint 97/2000/XP (.ppt and .pot)
Microsoft PowerPoint 2007/2010 (.pptx, .pptm, .potx, .potm)
StarDraw and StarImpress (.sda, .sdd, .sdp, and .vor)
Unified Office Format presentation (.uop, .uof)
CGM – Computer Graphics Metafile (.cgm)
Portable Document Format (.pdf)

Opening graphic files
In addition to OpenDocument formats (.odg and .otg), Draw 3 can open the formats used by
OpenOffice.org 1.x (.sxd and .std) and the following graphic formats:
BMP
DXF
EMF
EPS
GIF

JPEG, JPG
MET
PBM
PCD
PCT

PCX
PGM
PLT
PNG
PPM

PSD
RAS
SDA
SDD
SGF

SGV
SVM
TGA
TIF, TIFF
VOR

WMF
XBM
XPM

Opening formula files
In addition to OpenDocument Formula (.odf) files, Math 3 can open the format used by
OpenOffice.org 1.x (.sxm), StarMath, (.smf), and MathML (.mml) files.
When opening a Word document that contains an embedded equation editor object, if the option
for it (MathType to LibreOffice Math or reverse) is checked in Tools > Options > Load/Save >
Microsoft Office, the object will be automatically converted to an LibreOffice Math object.
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File formats LibreOffice can save to
Saving in an OpenDocument format guarantees the correct rendering of the file when it is
transferred to another person or when the file is re-opened with a later version of LibreOffice or
with another program. It is strongly recommended that you use OpenDocument as the default file
formats. However, you can save files in other formats, if you wish.

Tip

When sharing a document that you do not expect or want the recipient to modify, the
safest option is to convert the document to PDF. LibreOffice provides a very
straightforward way to convert documents to PDF. See Chapter 10, Printing,
Exporting, and E-Mailing, in this book.

Saving text documents
In addition to OpenDocument formats (.odt, .ott, and .fodt), Writer 3 can save in these formats:
OpenOffice.org 1.x Text Document (.sxw)
OpenOffice.org 1.x Text Document Template (.stw)
Microsoft Word 6.0, 95, and 97/2000/XP (.doc)
Microsoft Word 2003 XML (.xml)
Microsoft Word 2007/2010 XML (.docx)
Office Open XML Text (.docx)
Rich Text Format (.rtf)
StarWriter 3.0, 4.0, and 5.0 (.sdw)
StarWriter 3.0, 4.0, and 5.0 Template (.vor)
Text (.txt)
Text Encoded (.txt)
Unified Office Format text (.uot, .uof)
HTML Document (OpenOffice.org Writer) (.html and .htm)
DocBook (.xml)
AportisDoc (Palm) (.pdb)
Pocket Word (.psw)
Encryption support within the Microsoft Word 97/2000/XP filter allows password protected
Microsoft Word documents to be saved.

Note

The .rtf format is a common format for transferring text files between applications,
but you are likely to experience loss of formatting and images. For this reason, other
formats should be used.

Saving spreadsheet files
In addition to OpenDocument formats (.ods and .ots), Calc 3 can save in these formats:
OpenOffice.org 1.x Spreadsheet (.sxc)
OpenOffice.org 1.x Spreadsheet Template (.stc)
Microsoft Excel 97/2000/XP (.xls and .xlw)
Microsoft Excel 97/2000/XP Template (.xlt)
Microsoft Excel 5.0 and 95 (.xls and .xlw)
Microsoft Excel 2003 XML (.xml)
Microsoft Excel 2007/2010 XML (.xlsx)
Office Open XML Spreadsheet (.xlsx)
Data Interchange Format (.dif)
dBase (.dbf)
SYLK (.slk)
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Text CSV (.csv and .txt)
StarCalc 3.0, 4.0, and 5.0 formats (.sdc and .vor)
Unified Office Format spreadsheet (.uos)
HTML Document (OpenOffice.org Calc) (.html and .htm)
Pocket Excel (.pxl)

Note

The Java Runtime Environment is required to use the mobile device filters for
AportisDoc (Palm), Pocket Word, and Pocket Excel.

Saving presentations
In addition to OpenDocument formats (.odp, .otp, .fodp, and .odg), Impress 3 can save in these
formats:
OpenOffice.org 1.x Presentation (.sxi)
OpenOffice.org 1.x Presentation Template (.sti)
Microsoft PowerPoint 97/2000/XP (.ppt)
Microsoft PowerPoint 97/2000/XP Template (.pot)
Microsoft PowerPoint 2007/2010 XML (.pptx, .potm)
Office Open XML Presentation (.pptx, .potm, .ppsx)
StarDraw, StarImpress (.sda, .sdd, and .vor)
Unified Office Format presentation (.uop)
Impress can also export to MacroMedia Flash (.swf) and any of the graphics formats listed for
Draw.

Saving drawings
Draw 3 can only save in the OpenDocument Drawing formats (.odg and .otg), the OpenOffice.org
1.x formats (.sxd and .std) and StarDraw format (.sda, .sdd, and .vor).
However, Draw can also export to BMP, EMF, EPS, GIF, JPEG, MET, PBM, PCT, PGM, PNG,
PPM, RAS, SVG, SVM, TIFF, WMF, and XPM.

Writer/Web can save in these formats
HTML document (.html and .htm), as HTML 4.0 Transitional
OpenOffice.org 1.0 HTML Template (.stw)
OpenOffice.org 2.x HTML Template (.oth)
StarWriter/Web 4.0 and 5.0 (.vor)
Text (LibreOffice Writer/Web) (.txt)
Text Encoded (LibreOffice Writer/Web) (.txt)

Exporting to other formats
LibreOffice uses the term “export” for some file operations involving a change of file type. If you
cannot find the file type you are looking for under Save As, look under Export for additional types.
LibreOffice can export files to XHTML. In addition, Draw and Impress can export to Adobe Flash
(.swf) and a range of image formats.
To export to one of these formats, choose File > Export. On the Export dialog, specify a file name
for the exported document, then select the desired format in the File format list and click the
Export button.
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Index
3
3D objects 209

A
accepting or rejecting changes 104
accessibility features 367
accessibility options 45
adding macros from other sources 330
advantages of LibreOffice 19
antialiasing screen font 38
appearance options 44
Apply Style list 60
Arrows 202
Asian language support 52
AutoCorrect 55, 91
AutoFormat, Calc 137
AutoInput 129
AutoLayout 165
automatic changes 129
automatic saving 28
AutoRecovery 28, 48
AutoUpdate styles 62

B
background images from Gallery 301
Basic 330
bitmaps 209
BitTorrent 20
book preview 286
booklet printing 284
bookmarks 106
brackets (Math) 262
brochure printing 284
Bullets and Numbering dialog 169

C
Calc
AutoFormat 137
editing data 132
Enter key, use of 117
features 110
filtering visible cells 140
formula bar 111
Function Wizard 111
hiding and showing data 139
Navigator 116
outline group controls 139
printing 142
sheet tabs 112
sorting records 141
splitting the screen 126
status bar 113
themes 138
viewing 125
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Calc macros 339
cells, in Calc
formatting 134
navigating 115
selecting 119
change tracking 104
changes, undo and redo 31
check for updates automatically 46
chemical formulas 276
clipboard 39
closing a document 32
closing LibreOffice 32
CMYK 186
Color bar 185
color options 41
color palette 186
color scheme 44
columns, in Calc
deleting 121
freezing 125
inserting 121
selecting 119
comma separated values (CSV) 113, 115
comments, adding 102
complex text layout (CTL) 19, 52
components of OpenOffice.org 18
conditional formatting 139
Context menu 201
context menus 24
conversion 209
copy and paste 86
copying object from Gallery 301
create document from template 66
creating a document 26
cross-references
inserting references 106
overview 106
CSV file
open 114
save 115
CSV files 113, 115
Ctrl-click required to follow hyperlinks 44
custom dictionary 53
Customize dialog 345
customizing
keyboard shortcuts 358
menus 352
toolbars 355
cut and paste 86

D
dashes 89
data editing, Calc
changing data in a cell 133
removing data from a cell 133
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replacing all data in a cell 133
data entry, Calc
dates and times 129
fill series 130
Fill tool 129
numbers 127
numbers as text 128
selection lists 131
sharing content 132
speeding up 129
text 128
validating cell contents 132
data source
description 212
editing 236
linking 234
registering 234
using in OOo documents 236
viewing 235
data validity 132
database
AutoValue 218
creating 214
creating tables 215
field types and formats 216
planning 213
primary key 215, 217
registering 235
Report Wizard 250
Table Wizard 215
tables 215
database form
activation order 233
background 232
creating in Design View 234
creating using a Wizard 223
entering data 239
modifying 226
tab order 233
database reports
creating 249
database table
create using wizard 215
joined fields 225
relationships 221
date conversion, automatic 129
default file format 48
default template 71
deleting files 29
derivative markup (Math) 265
Design View (Base)
creating a new table 218
creating forms 234
creating queries 243
dictionaries, installing 51
dictionary 90
different first page 76
digital rights management (DRM) 291
digital signature 296
Index

DIM 334
dispatch framework 338
dispatch helper 335
divide document into chapters 76
dockable window 24
document
closing 32
create from template 66
creating 26
opening 27
starting new 26
document status option 36
document views 82
Documentation 11
download updates automatically 46
drag and drop 298
Draw 210
toolbars 184
workspace 183
drawing
arrows 188
banners 195
block arrows 194
connectors 192
curve 190
HTML export 210
polygon 190
rectangles 189
Squares 189
Drawing Object Properties toolbar 307
drawing objects
3D objects 209
grouping 308
properties 307
Drawing toolbar 307
drawing tools 306
duplication 206
dynamic gradients 206

E
E-mail options 54
e-mailing
Mail Merge Wizard 293
several recipients 293
Writer document as attachment 292
edit document properties before saving 48
editing data, Calc 132
en-dash and em-dash 89
envelope
printing 285
envelope printing 285
EPS images in PDF 288
equation
numbering 271
equation editor 255
brackets 262
derivative markup 265
Elements window 257
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equations over more than one line 264
font size 268
formula layout 262
limits to sum/integral 265
markup 260
matrix markup 263
right-click menu 259
event handling 346
export directly as PDF 287
export HTML 51
exporting
Flash 292
PDF 287
XHTML 292
extended tips 35
extension
Report Builder 253
extensions 348, 361
extensions and addons
sources of 20

Gallery 309
grouping 312
line options 312
moving and resizing objects 313
positioning options 312
same letter heights 310
toolbar 308, 310
Form Wizard 223
formatting pages 97
Formatting toolbar 22
formatting, Calc
AutoFormat 137
conditional 139
themes 138
formula bar, Calc 111
formula files, opening 373
formula layout 262
Free Software Foundation (FSF) 371
function key shortcuts 367
Function Wizard, Calc 111

F

G

fax icon, adding to toolbar 357
FDF 289
features
Calc 110
Impress 150
Writer 80
fields
bookmarks 106
cross-reference 106
Fields dialog box
References tab 106
file locations 40
file sharing options 43
Fill Format 60
Fill tool, Calc 129
filtering visible cells, Calc 140
Flash export 324
floating toolbars 23, 24
floating window 24
font
history 38
ignore settings when importing HTML 51
options 42
preview 38
replacement table 43
replacements 42
sizes for HTML 50
Fontwork
alignment 311
anchoring 312
area options 312
attributes 311
character spacing 311
creating an object 309
editing an object 310
Formatting toolbar 311

Gallery
adding objects 302
creating a new theme 304
deleting images 304
deleting objects 304
hide/show 302
inserting object as background 301
location 304
opening 301
themes 302
views (icon/detailed) 302
general options 35
GNU/Linux
system requirements 20
gradients 206
grammar checker 91
graphic files
opening 373
saving 375
graphic styles
167
graphics
adding from file 298
linking 299
Grid points 203

378

H
header
different on right and left pages 77
headers and footers, Calc 146
Help Agent 35
Help system 10
Help Tips 35
hidden objects 195
hiding and showing data, Calc 139
history of LibreOffice 370
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HTML compatibility 50
HTML export 51
HTML Export Wizard 324
hyperlinks
absolute 316
editing 319
inserting 316
relative 316
removing 319
hyphenation
manual 97

I
icon size and style (user interface) 38
icons in menus 38
IDE 333
ignore font settings when importing HTML 51
image map 305
images
adding from file 298
linking 299
scanned 300
importing files 372
importing numbers from an HTML page 50
Impress
content boxes 163
font resizing 167
150, 151
indents 89
indexes and bibliographies 103
Insert Bookmark dialog 107
Insert Picture dialog 298
installing and setting up 20
International Support 11
Internet options 54

J
Java options 46
Java Runtime Environment (JRE) 212
JRE (Java Runtime Environment) 20, 46

K
keyboard shortcuts
assigning 358, 367
customizing 358
function keys 367
loading from a file 360
resetting to default values 360
saving to a file 360
keyboard shortcuts (macros) 345

L
landscape pages 76
language settings 51
language support 19
layout methods 97
LGPL 14
libraries of macros 339

Index

library containers 339
LibreOffice Basic 330
LibreOffice Basic Macros dialog 332
licensing of LibreOffice 13, 371
limits to sum/integral 265
Line and Filling toolbar 185
linking object from gallery 301
Linux
Quickstarter 22
system requirements 20
load Basic code to edit 49
load/save options 47
loading styles 65
locale settings 52

M
Mac OS X
system requirements 20
Macro Organizer dialog 332, 342
macro security options 43
Macro Selector dialog 344
Macromedia Flash 324
macros 330
assigning to events 360
Calc 339
comments 334
creating 335
DIM 334
dispatch framework 338
dispatch helper 335
downloading 343
editing 333
event handling 346
example 335
functions 339
IDE 333, 338
library container 332
library containers 339
menu items 345
module 332
modules 339
organization 339
recording 331
REM 334
resources 349
running 333, 344
storage 342
subroutines 334, 339
variables 334
viewing 333
writing 348
mail merge 104
Mail Merge Wizard
e-mailing Writer document 293
Mantovani, Paolo 339
margins (Writer) 101
Master Pages 173
mathematical and chemical equations 255
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mathematical markup 260
mathematical symbols 257
matrix markup (Math) 263
measurement unit 90
memory options 36
menu bar 22
menus
adding commands 354
creating 353
customizing 352
modifying 353
modifying entries 355
Microsoft Office file conversion 49
Microsoft Windows
file associations 21
Quickstarter 21
system requirements 20
middle mouse button function 39
mouse positioning 38
MySQL 212

N
navigation
cell to cell, in Calc 116
sheet to sheet, in Calc 118
Navigation icons 83
Navigation toolbar 31, 83
Navigator 30, 154
Calc 116
new document 26
non-breaking hyphen 89
non-breaking spaces 89
nonconsecutive items, selecting 85
numbering equations 271
numbering pages 100

O
OASIS 19
objects
framing 195
hidden 195
ODF format version, saving 48
Office Assistant (Microsoft) 35
Open and Save As dialogs 29
Open Source Initiative (OSI) 13, 371
Open/Save dialogs 36
OpenDocument Format 19, 48
opening a document 27
orientation of page 76
outline group controls, Calc 139
outline level 168
OXT files 70

P
page break, Calc 145
page layout
different first page 76
landscape page 76
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orientation 76
page layouts 97
page margins 101, 184
page numbering 100
parts of the main window 22
password protection 27
password-protect PDF 291
paste text 86
path options 40
PDF
blank page export 289
digital rights management (DRM) 291
embed standard fonts 289
encrypt 291
EPS image 288
export documents to 287
form 288
image compression and resolution 288
initial view selection 289
pages to export 287
password-protect 291
security settings 291
tagged 288
user interface settings 289
PDF Options dialog 287
PDF/A-1a 288
personal data, removing 296
pictures
adding from file 298
linking 299
pixels 182
Powerpoint
150
presentation
slide design 160
160
Presentation Wizard 159
presentations
saving 375
primary key 217
primary key (database) 217
Print dialog 278
print file directly 278
print options
general 39
print preview
Calc 287
Writer 286
print ranges, Calc 142
printer settings 48
printing
black and white on color printer 285
booklet 284
brochure 284
Calc 142, 282
envelopes, labels, business cards 285
general options 279
grayscale on color printer 286
handouts 284
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headers and footers, Calc 146
Impress and Draw 283
multiple pages per sheet 280
notes (Impress) 284
page break, Calc 145
page order, details, scale, in Calc 143
page orientation 279
rows or columns on every page 145
selecting what to print 281
Writer 281

Q
queries (database)
aliases 248
creating using a Wizard 241
creating using Design View 243
joined fields 225
search conditions 243
Query Wizard (database) 241
Quickstarter 21
enabling 37
quotation marks 129

R
raster graphics 209
rectangle, drawing 189
redlines 104
redo change 32
regular expressions 87
relationships (database) 221
REM 334
remove personal information on saving 44
removing personal data 296
renaming files 29
replacement table (font) 43
Report Wizard (database) 250
revision marks 104
RGB 186
right to left (RTL) layout 19
right-click (context) menus 24
rows, in Calc
deleting 121
freezing 125
inserting 121
selecting 119
rulers 183

S
save as
web page 320
save AutoRecovery information 48
save original Basic code 49
save relative URLs 48
saving files 27
scaling factor (user interface) 37
scanner 300
screen font antialiasing 38
security 27
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security options 43
selecting
nonconsecutive items 85
vertical block of text 86
selection clipboard 39
selection lists, Calc 131
selection, in Calc
cells 119
columns 119
rows 119
sheets 120
send document as e-mail 292
sequence of styles, automatic 77
setup options 34
shared extension 361
sheet tabs, Calc 112
sheets, in Calc
inserting 122
renaming 124
selecting 120
shortcut keys 364
size optimization 49
Slide Design dialog 174
slide master 164, 172
apply 174
author information 176
creat 173
slide show
automatically advance 178
transitions 178
150
slides
162, 164, 172
Snap function 203
Snap to grid 203
sort order (database fields) 242
sorting records, Calc 141
special characters 88, 92
spelling checker 90
spelling options 53
spreadsheet
using as data source 234
spreadsheets
cell reference 115
definition 110
navigate 115
opening 373
saving 374
saving as CSV 115
starting a new document 26
starting LibreOffice 20
status bar 25
Calc 113
Writer 81
Style dialog 61, 63
styles 203
Apply Style list 60
assigning to shortcut keys 359
AutoUpdate 62
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changing using Style dialog 61
creating by dragging and dropping 63
creating from selection 63
creating new 62
creating using Style dialog 63
custom 62
defining a sequence 77
deleting 66
description 58
Fill Format 60
linking 63
loading from template or document 65
modifying 61
types supported 58
updating from a selection 62
167, 172
Styles and Formatting window 59
SUB 334
subroutines 339
subroutines in macros 334
Sun Microsystems 370
support 10
system font (user interface) 38

toolbars 153
adding commands 356
block arrows 194
choosing icons for commands 356
connectors 192
creating 356
curve 190
customizing 24
displaying or hiding 23
Draw 184
Fontwork 308
Line and Filling toolbar 185
lines and arrows 188
moving 23
overview 22
show or hide icons 24
tooltips 35, 162
track changes 104
transparency 206
two-digit years 36
typing errors, autocorrect 129

T

undo change 31
Ungrouping 208
unsaved changes flag 81
URL Recognition 316
user data options 34
User guides 11
user interface options 37
user interface, parts of 12
user-specific settings 47

tab stops 89
table of contents, automated 102
tear-off toolbars 23
template
associate with document 72
create document from 66
create from document 67
create using wizard 68
deleting 74
description 58
editing 69
exporting 75
folders 73
update document styles from 69
Template Management dialog 64
templates
importing 74
text
bulleted or numbered list 167
outline level 168
pasting 167
text boundaries (show/hide) 44
text box
AutoLayout 165, 168
text documents
opening 372
Text Formatting toolbar 167
text tool 165
theme
deleting 304
themes 302
themes (Gallery) 304
toolbar icons (macros) 345
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U

V
validating cell contents, Calc 132
variables in macros 334
VBA properties load/save options 49
vector graphics 182
vertical block of text, select 86
view options 37

W
Web Layout 320
web page export
Calc spreadsheets 323
Impress presentations 324
Web wizard (Writer) 321
Writer documents 320, 321
wildcards 87
windows, dockable/floating 24
wizard
query (database) 241
report (database) 250
table (database) 215
web 321
159
workspace
Draw 183
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Writer
document views 82
features 80
Navigation icons 83
Navigation toolbar 83
status bar 81
workspace 80
zoom 82, 83

X

Y
year (two digits) 36

Z
zoom 82, 83
163, 164, 167, 172
and distributing objects 209

XML 49

Index
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